summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2014-04-17 18:05:45 +0200
committerRemi Collet <fedora@famillecollet.com>2014-04-17 18:05:45 +0200
commit6f3e7a06474a915153575a0f690d1ea44db7cc82 (patch)
treecbb4c077637a97d98b7bae53ddfd5b3369d17b6f
parent5328c4a496a633ccc824933ecd4762a328c2ccce (diff)
php-pecl: add numerical prefix to extension configuration file (all done !)
-rw-r--r--php-pecl-yar.spec26
1 files changed, 18 insertions, 8 deletions
diff --git a/php-pecl-yar.spec b/php-pecl-yar.spec
index 2264d9f..11113fb 100644
--- a/php-pecl-yar.spec
+++ b/php-pecl-yar.spec
@@ -11,13 +11,20 @@
%{!?__pecl: %global __pecl %{_bindir}/pecl}
%{!?__php: %global __php %{_bindir}/php}
-%global with_zts 0%{?__ztsphp:1}
-%global pecl_name yar
+%global with_zts 0%{?__ztsphp:1}
+%global pecl_name yar
+%if "%{php_version}" < "5.6"
+# After json, msgpack
+%global ini_name %{pecl_name}.ini
+%else
+# After 40-json, 40-msgpack
+%global ini_name 50-%{pecl_name}.ini
+%endif
Summary: Light, concurrent RPC framework
Name: %{?scl_prefix}php-pecl-%{pecl_name}
Version: 1.2.3
-Release: 1%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
+Release: 2%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
License: BSD
Group: Development/Languages
URL: http://pecl.php.net/package/%{pecl_name}
@@ -88,7 +95,7 @@ cp -pr NTS ZTS
%endif
# Create configuration file
-cat > %{pecl_name}.ini << 'EOF'
+cat > %{ini_name} << 'EOF'
; Enable %{pecl_name} extension module
extension=%{pecl_name}.so
@@ -129,7 +136,7 @@ make -C NTS \
install INSTALL_ROOT=%{buildroot}
# install config file
-install -D -m 644 %{pecl_name}.ini %{buildroot}%{php_inidir}/%{pecl_name}.ini
+install -D -m 644 %{ini_name} %{buildroot}%{php_inidir}/%{ini_name}
# Install XML package description
install -D -m 644 package2.xml %{buildroot}%{pecl_xmldir}/%{name}.xml
@@ -138,7 +145,7 @@ install -D -m 644 package2.xml %{buildroot}%{pecl_xmldir}/%{name}.xml
make -C ZTS \
install INSTALL_ROOT=%{buildroot}
-install -D -m 644 %{pecl_name}.ini %{buildroot}%{php_ztsinidir}/%{pecl_name}.ini
+install -D -m 644 %{ini_name} %{buildroot}%{php_ztsinidir}/%{ini_name}
%endif
# Tools
@@ -193,18 +200,21 @@ rm -rf %{buildroot}
%doc %{pecl_docdir}/%{pecl_name}
%doc %{pecl_testdir}/%{pecl_name}
%{pecl_xmldir}/%{name}.xml
-%config(noreplace) %{php_inidir}/%{pecl_name}.ini
+%config(noreplace) %{php_inidir}/%{ini_name}
%{php_extdir}/%{pecl_name}.so
%{_bindir}/yar_debug
%{pear_phpdir}/yar_debug.inc
%if %{with_zts}
-%config(noreplace) %{php_ztsinidir}/%{pecl_name}.ini
+%config(noreplace) %{php_ztsinidir}/%{ini_name}
%{php_ztsextdir}/%{pecl_name}.so
%endif
%changelog
+* Thu Apr 17 2014 Remi Collet <remi@fedoraproject.org> - 1.2.3-2
+- add numerical prefix to extension configuration file (php 5.6)
+
* Thu Jan 02 2014 Remi Collet <remi@fedoraproject.org> - 1.2.3-1
- Update to 1.2.3 (stable)
- provides yar_debug command