summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2015-10-27 13:13:15 +0100
committerRemi Collet <fedora@famillecollet.com>2015-10-27 13:13:15 +0100
commit6a391261731188e04d02dd1ac8c53a9544bfdde9 (patch)
tree1f98e6cba22ade1abff7328fcb64f27a16c070b2
parentf22b35dd68f3c21be03b9b693d6c52b749259512 (diff)
php-pecl-yar: 1.2.5 (stable, php 5)
-rw-r--r--REFLECTION49
-rw-r--r--php-pecl-yar.spec10
2 files changed, 45 insertions, 14 deletions
diff --git a/REFLECTION b/REFLECTION
index 44f6739..cdec474 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #176 yar version 1.2.4 ] {
+Extension [ <persistent> extension #198 yar version 1.2.5 ] {
- Dependencies {
Dependency [ json (Required) ]
@@ -33,7 +33,7 @@ Extension [ <persistent> extension #176 yar version 1.2.4 ] {
}
- Constants [18] {
- Constant [ string YAR_VERSION ] { 1.2.4 }
+ Constant [ string YAR_VERSION ] { 1.2.5 }
Constant [ integer YAR_OPT_PACKAGER ] { 1 }
Constant [ integer YAR_OPT_PERSISTENT ] { 2 }
Constant [ integer YAR_OPT_TIMEOUT ] { 4 }
@@ -207,7 +207,7 @@ Extension [ <persistent> extension #176 yar version 1.2.4 ] {
Property [ <default> protected $_type ]
}
- - Methods [10] {
+ - Methods [11] {
Method [ <internal:yar> public method getType ] {
}
@@ -220,6 +220,9 @@ Extension [ <persistent> extension #176 yar version 1.2.4 ] {
}
}
+ Method [ <internal:Core, inherits Exception> public method __wakeup ] {
+ }
+
Method [ <internal:Core, inherits Exception> final public method getMessage ] {
}
@@ -264,7 +267,7 @@ Extension [ <persistent> extension #176 yar version 1.2.4 ] {
Property [ <default> protected $line ]
}
- - Methods [10] {
+ - Methods [11] {
Method [ <internal:yar, inherits Yar_Server_Exception> public method getType ] {
}
@@ -277,6 +280,9 @@ Extension [ <persistent> extension #176 yar version 1.2.4 ] {
}
}
+ Method [ <internal:Core, inherits Exception> public method __wakeup ] {
+ }
+
Method [ <internal:Core, inherits Exception> final public method getMessage ] {
}
@@ -321,7 +327,7 @@ Extension [ <persistent> extension #176 yar version 1.2.4 ] {
Property [ <default> protected $line ]
}
- - Methods [10] {
+ - Methods [11] {
Method [ <internal:yar, inherits Yar_Server_Exception> public method getType ] {
}
@@ -334,6 +340,9 @@ Extension [ <persistent> extension #176 yar version 1.2.4 ] {
}
}
+ Method [ <internal:Core, inherits Exception> public method __wakeup ] {
+ }
+
Method [ <internal:Core, inherits Exception> final public method getMessage ] {
}
@@ -378,7 +387,7 @@ Extension [ <persistent> extension #176 yar version 1.2.4 ] {
Property [ <default> protected $line ]
}
- - Methods [10] {
+ - Methods [11] {
Method [ <internal:yar, inherits Yar_Server_Exception> public method getType ] {
}
@@ -391,6 +400,9 @@ Extension [ <persistent> extension #176 yar version 1.2.4 ] {
}
}
+ Method [ <internal:Core, inherits Exception> public method __wakeup ] {
+ }
+
Method [ <internal:Core, inherits Exception> final public method getMessage ] {
}
@@ -435,7 +447,7 @@ Extension [ <persistent> extension #176 yar version 1.2.4 ] {
Property [ <default> protected $line ]
}
- - Methods [10] {
+ - Methods [11] {
Method [ <internal:yar, inherits Yar_Server_Exception> public method getType ] {
}
@@ -448,6 +460,9 @@ Extension [ <persistent> extension #176 yar version 1.2.4 ] {
}
}
+ Method [ <internal:Core, inherits Exception> public method __wakeup ] {
+ }
+
Method [ <internal:Core, inherits Exception> final public method getMessage ] {
}
@@ -492,7 +507,7 @@ Extension [ <persistent> extension #176 yar version 1.2.4 ] {
Property [ <default> protected $line ]
}
- - Methods [10] {
+ - Methods [11] {
Method [ <internal:yar> public method getType ] {
}
@@ -505,6 +520,9 @@ Extension [ <persistent> extension #176 yar version 1.2.4 ] {
}
}
+ Method [ <internal:Core, inherits Exception> public method __wakeup ] {
+ }
+
Method [ <internal:Core, inherits Exception> final public method getMessage ] {
}
@@ -549,7 +567,7 @@ Extension [ <persistent> extension #176 yar version 1.2.4 ] {
Property [ <default> protected $line ]
}
- - Methods [10] {
+ - Methods [11] {
Method [ <internal:yar, inherits Yar_Client_Exception> public method getType ] {
}
@@ -562,6 +580,9 @@ Extension [ <persistent> extension #176 yar version 1.2.4 ] {
}
}
+ Method [ <internal:Core, inherits Exception> public method __wakeup ] {
+ }
+
Method [ <internal:Core, inherits Exception> final public method getMessage ] {
}
@@ -606,7 +627,7 @@ Extension [ <persistent> extension #176 yar version 1.2.4 ] {
Property [ <default> protected $line ]
}
- - Methods [10] {
+ - Methods [11] {
Method [ <internal:yar, inherits Yar_Client_Exception> public method getType ] {
}
@@ -619,6 +640,9 @@ Extension [ <persistent> extension #176 yar version 1.2.4 ] {
}
}
+ Method [ <internal:Core, inherits Exception> public method __wakeup ] {
+ }
+
Method [ <internal:Core, inherits Exception> final public method getMessage ] {
}
@@ -663,7 +687,7 @@ Extension [ <persistent> extension #176 yar version 1.2.4 ] {
Property [ <default> protected $line ]
}
- - Methods [10] {
+ - Methods [11] {
Method [ <internal:yar, inherits Yar_Client_Exception> public method getType ] {
}
@@ -676,6 +700,9 @@ Extension [ <persistent> extension #176 yar version 1.2.4 ] {
}
}
+ Method [ <internal:Core, inherits Exception> public method __wakeup ] {
+ }
+
Method [ <internal:Core, inherits Exception> final public method getMessage ] {
}
diff --git a/php-pecl-yar.spec b/php-pecl-yar.spec
index c93137b..e45af52 100644
--- a/php-pecl-yar.spec
+++ b/php-pecl-yar.spec
@@ -31,8 +31,8 @@
Summary: Light, concurrent RPC framework
Name: %{?sub_prefix}php-pecl-%{pecl_name}
-Version: 1.2.4
-Release: 2%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Version: 1.2.5
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: BSD
Group: Development/Languages
URL: http://pecl.php.net/package/%{pecl_name}
@@ -91,7 +91,7 @@ Obsoletes: php56w-pecl-%{pecl_name} <= %{version}
Yar (Yet another RPC framework) is a light, concurrent RPC framework,
supports multi package protocols (json, msgpack).
-Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')%{?scl: as Software Collection (%{scl})}.
+Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')%{?scl: as Software Collection (%{scl} by %{?scl_vendor}%{!?scl_vendor:rh})}.
%prep
@@ -234,6 +234,7 @@ rm -rf %{buildroot}
%defattr(-,root,root,-)
%doc %{pecl_docdir}/%{pecl_name}
%{pecl_xmldir}/%{name}.xml
+
%config(noreplace) %{php_inidir}/%{ini_name}
%{php_extdir}/%{pecl_name}.so
%{_bindir}/yar_debug
@@ -246,6 +247,9 @@ rm -rf %{buildroot}
%changelog
+* Tue Oct 27 2015 Remi Collet <remi@fedoraproject.org> - 1.2.5-1
+- update to 1.2.5 (stable, php 5)
+
* Wed Jun 24 2015 Remi Collet <remi@fedoraproject.org> - 1.2.4-2
- allow build against rh-php56 (as more-php56)
- drop runtime dependency on pear, new scriptlets