summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-03-16 10:28:18 +0100
committerRemi Collet <remi@remirepo.net>2020-03-16 10:28:18 +0100
commit6638370fe5fb4a5e571a6c9468c0e393204ec5c1 (patch)
tree52a518869caa6b4d983689c0b589f1bcd077578f
parent422b2ff6f1437043483cf3f304ddf47e9f15a70e (diff)
update to 2.1.1
drop patches merged upstream
-rw-r--r--151.patch22
-rw-r--r--PHPINFO2
-rw-r--r--REFLECTION8
-rw-r--r--internal.php7
-rw-r--r--php-pecl-yar.spec18
5 files changed, 10 insertions, 47 deletions
diff --git a/151.patch b/151.patch
deleted file mode 100644
index 008bc95..0000000
--- a/151.patch
+++ /dev/null
@@ -1,22 +0,0 @@
-From ffe62a8793fcee61368a09e017b400a64d9db709 Mon Sep 17 00:00:00 2001
-From: Remi Collet <remi@remirepo.net>
-Date: Mon, 16 Mar 2020 07:05:37 +0100
-Subject: [PATCH] fix build, undefined variable
-
----
- packagers/msgpack.c | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/packagers/msgpack.c b/packagers/msgpack.c
-index 2050f4e..e1b078d 100644
---- a/packagers/msgpack.c
-+++ b/packagers/msgpack.c
-@@ -39,7 +39,7 @@ int php_yar_packager_msgpack_pack(const yar_packager_t *self, zval *pzval, smart
-
- zval * php_yar_packager_msgpack_unpack(const yar_packager_t *self, char *content, size_t len, char **msg, zval *ret) /* {{{ */ {
- ZVAL_NULL(ret);
-- php_msgpack_unserialize(rret, content, len);
-+ php_msgpack_unserialize(ret, content, len);
- return ret;
- } /* }}} */
-
diff --git a/PHPINFO b/PHPINFO
index 23993bb..9717705 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,7 +2,7 @@
yar
yar support => enabled
-Version => 2.1.0
+Version => 2.1.1
Directive => Local Value => Master Value
yar.packager => msgpack => msgpack
diff --git a/REFLECTION b/REFLECTION
index 5fbf954..f6dba11 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,8 +1,8 @@
-Extension [ <persistent> extension #112 yar version 2.1.0 ] {
+Extension [ <persistent> extension #112 yar version 2.1.1 ] {
- Dependencies {
- Dependency [ json (Optional) ]
- Dependency [ msgpack (Optional) ]
+ Dependency [ json (Required) ]
+ Dependency [ msgpack (Required) ]
}
- INI {
@@ -30,7 +30,7 @@ Extension [ <persistent> extension #112 yar version 2.1.0 ] {
}
- Constants [20] {
- Constant [ string YAR_VERSION ] { 2.1.0 }
+ Constant [ string YAR_VERSION ] { 2.1.1 }
Constant [ int YAR_OPT_PACKAGER ] { 1 }
Constant [ int YAR_OPT_PERSISTENT ] { 2 }
Constant [ int YAR_OPT_TIMEOUT ] { 4 }
diff --git a/internal.php b/internal.php
deleted file mode 100644
index fe7fc38..0000000
--- a/internal.php
+++ /dev/null
@@ -1,7 +0,0 @@
-<?php
-error_reporting(-1);
-class Service_Provider Extends SplFixedArray {
-}
-
-$yar = new Yar_Server(new Service_Provider());
-$yar->handle();
diff --git a/php-pecl-yar.spec b/php-pecl-yar.spec
index 22ac9f5..d661529 100644
--- a/php-pecl-yar.spec
+++ b/php-pecl-yar.spec
@@ -29,7 +29,7 @@
Summary: Light, concurrent RPC framework
Name: %{?sub_prefix}php-pecl-%{pecl_name}
-Version: 2.1.0
+Version: 2.1.1
%if 0%{?gh_date:1}
Release: 0.14.%{gh_date}git%{gh_short}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{pecl_name}-%{version}-%{gh_short}.tar.gz
@@ -40,9 +40,6 @@ Source0: https://pecl.php.net/get/%{pecl_name}-%{version}.tgz
License: PHP
URL: https://pecl.php.net/package/%{pecl_name}
-Source1: https://raw.githubusercontent.com/laruence/yar/yar-2.1.0/tests/htdocs/internal.php
-Patch0: https://patch-diff.githubusercontent.com/raw/laruence/yar/pull/151.patch
-
BuildRequires: %{?dtsprefix}gcc
BuildRequires: curl-devel
BuildRequires: %{?scl_prefix}php-devel > 7
@@ -52,14 +49,8 @@ BuildRequires: %{?sub_prefix}php-pecl-msgpack-devel
Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
Requires: %{?scl_prefix}php(api) = %{php_core_api}
-%if "%{php_version}" < "5.4"
-# php 5.3.3 in EL-6 don't use arched virtual provides
-# so only requires real packages instead
-Requires: %{?scl_prefix}php-common%{?_isa}
-%else
Requires: %{?scl_prefix}php-curl%{?_isa}
Requires: %{?scl_prefix}php-json%{?_isa}
-%endif
Requires: %{?scl_prefix}php-pecl(msgpack)%{?_isa}
%{?_sclreq:Requires: %{?scl_prefix}runtime%{?_sclreq}%{?_isa}}
@@ -117,9 +108,6 @@ sed -e 's/role="test"/role="src"/' \
-i package.xml
cd NTS
-cp %{SOURCE1} tests/htdocs/internal.php
-%patch0 -p1
-
# Sanity check, really often broken
extver=$(sed -n '/#define PHP_YAR_VERSION/{s/.* "//;s/".*$//;p}' php_yar.h)
if test "x${extver}" != "x%{version}%{?prever:-%{prever}}%{?gh_date:-dev}"; then
@@ -275,6 +263,10 @@ export YAR_API_PORT=$(%{__php} -r 'echo 8960 + PHP_MAJOR_VERSION*100 + PHP_MINOR
%changelog
+* Mon Mar 16 2020 Remi Collet <remi@remirepo.net> - 2.1.1-1
+- update to 2.1.1
+- drop patches merged upstream
+
* Mon Mar 16 2020 Remi Collet <remi@remirepo.net> - 2.1.0-1
- update to 2.1.0
- fix build with msgpack using patch from