summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-12-20 07:21:08 +0100
committerRemi Collet <remi@php.net>2021-12-20 07:21:08 +0100
commit2f254d4583b61a51482ce8d8b53bd09ea144cd3f (patch)
treebdc8c3344b9659a1cfb95cb2db29b8f34da73493
parent584a9feb90e940500e144104c7f06ae795dacfb5 (diff)
update to 2.2.1
-rw-r--r--PHPINFO2
-rw-r--r--REFLECTION63
-rw-r--r--php-pecl-yar.spec14
3 files changed, 50 insertions, 29 deletions
diff --git a/PHPINFO b/PHPINFO
index b17dbe6..8667a7e 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,7 +2,7 @@
yar
yar support => enabled
-Version => 2.2.0
+Version => 2.2.1
Directive => Local Value => Master Value
yar.packager => msgpack => msgpack
diff --git a/REFLECTION b/REFLECTION
index 7e9076c..40a6613 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #120 yar version 2.2.0 ] {
+Extension [ <persistent> extension #120 yar version 2.2.1 ] {
- Dependencies {
Dependency [ json (Required) ]
@@ -29,14 +29,15 @@ Extension [ <persistent> extension #120 yar version 2.2.0 ] {
}
}
- - Constants [20] {
- Constant [ string YAR_VERSION ] { 2.2.0 }
+ - Constants [21] {
+ Constant [ string YAR_VERSION ] { 2.2.1 }
Constant [ int YAR_OPT_PACKAGER ] { 1 }
Constant [ int YAR_OPT_PERSISTENT ] { 2 }
Constant [ int YAR_OPT_TIMEOUT ] { 4 }
Constant [ int YAR_OPT_CONNECT_TIMEOUT ] { 8 }
Constant [ int YAR_OPT_HEADER ] { 16 }
Constant [ int YAR_OPT_RESOLVE ] { 32 }
+ Constant [ int YAR_OPT_PROXY ] { 64 }
Constant [ int YAR_CLIENT_PROTOCOL_HTTP ] { 1 }
Constant [ int YAR_CLIENT_PROTOCOL_TCP ] { 2 }
Constant [ int YAR_CLIENT_PROTOCOL_UNIX ] { 4 }
@@ -71,9 +72,8 @@ Extension [ <persistent> extension #120 yar version 2.2.0 ] {
- Methods [2] {
Method [ <internal:yar, ctor> final public method __construct ] {
- - Parameters [2] {
- Parameter #0 [ <required> $obj ]
- Parameter #1 [ <optional> $protocol = <default> ]
+ - Parameters [1] {
+ Parameter #0 [ <required> object $executor ]
}
}
@@ -81,6 +81,7 @@ Extension [ <persistent> extension #120 yar version 2.2.0 ] {
- Parameters [0] {
}
+ - Return [ bool ]
}
}
}
@@ -107,40 +108,44 @@ Extension [ <persistent> extension #120 yar version 2.2.0 ] {
Method [ <internal:yar, ctor> final public method __construct ] {
- Parameters [2] {
- Parameter #0 [ <required> $url ]
- Parameter #1 [ <optional> $async = <default> ]
+ Parameter #0 [ <required> string $uri ]
+ Parameter #1 [ <optional> array $options = NULL ]
}
}
Method [ <internal:yar> public method call ] {
- Parameters [2] {
- Parameter #0 [ <required> $method ]
- Parameter #1 [ <required> $parameters ]
+ Parameter #0 [ <required> string $method ]
+ Parameter #1 [ <required> array $arguments ]
}
+ - Return [ mixed ]
}
Method [ <internal:yar> public method __call ] {
- Parameters [2] {
- Parameter #0 [ <required> $method ]
- Parameter #1 [ <required> $parameters ]
+ Parameter #0 [ <required> string $method ]
+ Parameter #1 [ <required> array $arguments ]
}
+ - Return [ mixed ]
}
Method [ <internal:yar> public method getOpt ] {
- Parameters [1] {
- Parameter #0 [ <required> $type ]
+ Parameter #0 [ <required> int $type ]
}
+ - Return [ mixed ]
}
Method [ <internal:yar> public method setOpt ] {
- Parameters [2] {
- Parameter #0 [ <required> $type ]
- Parameter #1 [ <required> $value ]
+ Parameter #0 [ <required> int $type ]
+ Parameter #1 [ <required> mixed $value ]
}
+ - Return [ Yar_Client|bool ]
}
}
}
@@ -160,26 +165,31 @@ Extension [ <persistent> extension #120 yar version 2.2.0 ] {
- Static methods [3] {
Method [ <internal:yar> static public method call ] {
- - Parameters [4] {
- Parameter #0 [ <required> $uri ]
- Parameter #1 [ <required> $method ]
- Parameter #2 [ <required> $parameters ]
- Parameter #3 [ <optional> $callback = <default> ]
+ - Parameters [6] {
+ Parameter #0 [ <required> string $uri ]
+ Parameter #1 [ <required> string $method ]
+ Parameter #2 [ <optional> array $arguments = NULL ]
+ Parameter #3 [ <optional> callable $callback = NULL ]
+ Parameter #4 [ <optional> callable $error_callback = NULL ]
+ Parameter #5 [ <optional> array $options = NULL ]
}
+ - Return [ int|bool|null ]
}
Method [ <internal:yar> static public method loop ] {
- Parameters [2] {
- Parameter #0 [ <optional> $callback = <default> ]
- Parameter #1 [ <optional> $error_callback = <default> ]
+ Parameter #0 [ <optional> callable $callback = NULL ]
+ Parameter #1 [ <optional> callable $error_callback = NULL ]
}
+ - Return [ ?bool ]
}
Method [ <internal:yar> static public method reset ] {
- Parameters [0] {
}
+ - Return [ bool ]
}
}
@@ -214,6 +224,7 @@ Extension [ <persistent> extension #120 yar version 2.2.0 ] {
- Parameters [0] {
}
+ - Return [ string|int ]
}
Method [ <internal:Core, inherits Exception, ctor> public method __construct ] {
@@ -311,6 +322,7 @@ Extension [ <persistent> extension #120 yar version 2.2.0 ] {
- Parameters [0] {
}
+ - Return [ string|int ]
}
Method [ <internal:Core, inherits Exception, ctor> public method __construct ] {
@@ -408,6 +420,7 @@ Extension [ <persistent> extension #120 yar version 2.2.0 ] {
- Parameters [0] {
}
+ - Return [ string|int ]
}
Method [ <internal:Core, inherits Exception, ctor> public method __construct ] {
@@ -505,6 +518,7 @@ Extension [ <persistent> extension #120 yar version 2.2.0 ] {
- Parameters [0] {
}
+ - Return [ string|int ]
}
Method [ <internal:Core, inherits Exception, ctor> public method __construct ] {
@@ -602,6 +616,7 @@ Extension [ <persistent> extension #120 yar version 2.2.0 ] {
- Parameters [0] {
}
+ - Return [ string|int ]
}
Method [ <internal:Core, inherits Exception, ctor> public method __construct ] {
@@ -699,6 +714,7 @@ Extension [ <persistent> extension #120 yar version 2.2.0 ] {
- Parameters [0] {
}
+ - Return [ string ]
}
Method [ <internal:Core, inherits Exception, ctor> public method __construct ] {
@@ -796,6 +812,7 @@ Extension [ <persistent> extension #120 yar version 2.2.0 ] {
- Parameters [0] {
}
+ - Return [ string ]
}
Method [ <internal:Core, inherits Exception, ctor> public method __construct ] {
@@ -893,6 +910,7 @@ Extension [ <persistent> extension #120 yar version 2.2.0 ] {
- Parameters [0] {
}
+ - Return [ string ]
}
Method [ <internal:Core, inherits Exception, ctor> public method __construct ] {
@@ -990,6 +1008,7 @@ Extension [ <persistent> extension #120 yar version 2.2.0 ] {
- Parameters [0] {
}
+ - Return [ string ]
}
Method [ <internal:Core, inherits Exception, ctor> public method __construct ] {
diff --git a/php-pecl-yar.spec b/php-pecl-yar.spec
index 7aedc98..3a00c7c 100644
--- a/php-pecl-yar.spec
+++ b/php-pecl-yar.spec
@@ -25,7 +25,7 @@
Summary: Light, concurrent RPC framework
Name: %{?sub_prefix}php-pecl-%{pecl_name}
-Version: 2.2.0
+Version: 2.2.1
%if 0%{?gh_date:1}
Release: 0.14.%{gh_date}git%{gh_short}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{pecl_name}-%{version}-%{gh_short}.tar.gz
@@ -62,15 +62,15 @@ Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}-%{rele
%if "%{?packager}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
# Other third party repo stuff
-%if "%{php_version}" > "7.3"
-Obsoletes: php73-pecl-%{pecl_name} <= %{version}
-%endif
%if "%{php_version}" > "7.4"
Obsoletes: php74-pecl-%{pecl_name} <= %{version}
%endif
%if "%{php_version}" > "8.0"
Obsoletes: php80-pecl-%{pecl_name} <= %{version}
%endif
+%if "%{php_version}" > "8.1"
+Obsoletes: php81-pecl-%{pecl_name} <= %{version}
+%endif
%endif
@@ -227,12 +227,11 @@ cd NTS
: Create test configuration
export TEST_PHP_EXECUTABLE=%{__php}
export TEST_PHP_ARGS="$DEPS -d extension=$PWD/modules/%{pecl_name}.so"
-export NO_INTERACTION=1
export REPORT_EXIT_STATUS=1
export YAR_API_PORT=$(%{__php} -r 'echo 8960 + PHP_MAJOR_VERSION*100 + PHP_MINOR_VERSION*10 + PHP_INT_SIZE + 0%{?scl:1};')
: Run the upstream test suite
-%{__php} -n run-tests.php --show-diff
+%{__php} -n run-tests.php -q --show-diff
%else
: upstream test suite disabled
%endif
@@ -255,6 +254,9 @@ export YAR_API_PORT=$(%{__php} -r 'echo 8960 + PHP_MAJOR_VERSION*100 + PHP_MINOR
%changelog
+* Mon Dec 20 2021 Remi Collet <remi@remirepo.net> - 2.2.1-1
+- update to 2.2.1
+
* Tue Jan 5 2021 Remi Collet <remi@remirepo.net> - 2.2.0-1
- update to 2.2.0