summaryrefslogtreecommitdiffstats
path: root/php-pecl-yaml.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-pecl-yaml.spec')
-rw-r--r--php-pecl-yaml.spec28
1 files changed, 18 insertions, 10 deletions
diff --git a/php-pecl-yaml.spec b/php-pecl-yaml.spec
index d724e77..3a88b6b 100644
--- a/php-pecl-yaml.spec
+++ b/php-pecl-yaml.spec
@@ -17,7 +17,7 @@
%global pecl_name yaml
%global ini_name 40-%{pecl_name}.ini
-%global upstream_version 2.2.3
+%global upstream_version 2.2.4
#global upstream_prever b2
%global sources %{pecl_name}-%{upstream_version}%{?upstream_prever}
%global _configure ../%{sources}/configure
@@ -25,14 +25,12 @@
Summary: PHP Bindings for yaml
Name: %{?scl_prefix}php-pecl-yaml
Version: %{upstream_version}%{?upstream_prever:~%{upstream_prever}}
-Release: 4%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: MIT
URL: https://pecl.php.net/package/yaml
Source0: https://pecl.php.net/get/%{pecl_name}-%{upstream_version}%{?upstream_prever}.tgz
-Patch0: %{pecl_name}-build.patch
-
ExcludeArch: %{ix86}
BuildRequires: make
@@ -68,8 +66,6 @@ sed -e 's/role="test"/role="src"/' \
-i package.xml
cd %{sources}
-%patch -P0 -p1
-
# Check upstream version (often broken)
extver=$(sed -n '/#define PHP_YAML_VERSION/{s/.* "//;s/".*$//;p}' php_yaml.h)
if test "x${extver}" != "x%{upstream_version}%{?upstream_prever}"; then
@@ -113,26 +109,30 @@ mkdir NTS ZTS
cd %{sources}
%{__phpize}
+[ -f Makefile.global ] && GLOBAL=Makefile.global || GLOBAL=build/Makefile.global
+sed -e 's/INSTALL_ROOT/DESTDIR/' -i $GLOBAL
cd ../NTS
%configure \
--with-libdir=%{_lib} \
--with-php-config=%{__phpconfig}
-make %{?_smp_mflags}
+
+%make_build
%if %{with_zts}
cd ../ZTS
%configure \
--with-libdir=%{_lib} \
--with-php-config=%{__ztsphpconfig}
-make %{?_smp_mflags}
+
+%make_build
%endif
%install
%{?dtsenable}
-make -C NTS install INSTALL_ROOT=%{buildroot}
+%make_install -C NTS
# Install XML package description
install -Dpm 644 package.xml %{buildroot}%{pecl_xmldir}/%{name}.xml
@@ -141,7 +141,7 @@ install -Dpm 644 package.xml %{buildroot}%{pecl_xmldir}/%{name}.xml
install -Dpm644 %{ini_name} %{buildroot}%{php_inidir}/%{ini_name}
%if %{with_zts}
-make -C ZTS install INSTALL_ROOT=%{buildroot}
+%make_install -C ZTS
install -Dpm644 %{ini_name} %{buildroot}%{php_ztsinidir}/%{ini_name}
%endif
@@ -197,6 +197,14 @@ REPORT_EXIT_STATUS=1 \
%changelog
+* Mon Oct 7 2024 Remi Collet <remi@remirepo.net> - 2.2.4-1
+- update to 2.2.4
+- drop patches merged upstream
+
+* Mon Sep 30 2024 Remi Collet <remi@remirepo.net> - 2.2.3-5
+- fix test suite with 8.4 using patch from
+ https://github.com/php/pecl-file_formats-yaml/pull/86
+
* Mon Feb 19 2024 Remi Collet <remi@remirepo.net> - 2.2.3-4
- fix incompatible-pointer-types using patch from
https://github.com/php/pecl-file_formats-yaml/pull/74