summaryrefslogtreecommitdiffstats
path: root/php-pecl-yaml.spec
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2017-03-29 12:16:47 +0200
committerRemi Collet <fedora@famillecollet.com>2017-03-29 12:16:47 +0200
commitd681eb3b7396c1f31116bdac21f57f051566ac30 (patch)
treee5ace4e2b01df5d6ce65938cec13bf7f5500eabb /php-pecl-yaml.spec
parent8a7f36b4cd52df9ba637e231ce770d033e52603e (diff)
switch the specs
Diffstat (limited to 'php-pecl-yaml.spec')
-rw-r--r--php-pecl-yaml.spec84
1 files changed, 47 insertions, 37 deletions
diff --git a/php-pecl-yaml.spec b/php-pecl-yaml.spec
index 15efaa9..b498b05 100644
--- a/php-pecl-yaml.spec
+++ b/php-pecl-yaml.spec
@@ -10,35 +10,26 @@
# Please, preserve the changelog entries
#
%if 0%{?scl:1}
-%if "%{scl}" == "rh-php56"
-%global sub_prefix more-php56-
-%else
%global sub_prefix %{scl_prefix}
-%endif
%scl_package php-pecl-yaml
%endif
%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
%global pecl_name yaml
-%if "%{php_version}" < "5.6"
-%global ini_name %{pecl_name}.ini
-%else
%global ini_name 40-%{pecl_name}.ini
-%endif
-#global prever b1
+#global prever RC8
Summary: PHP Bindings for yaml
Name: %{?sub_prefix}php-pecl-yaml
-Version: 1.3.0
-Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Version: 2.0.0
+Release: 2%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: MIT
Group: Development/Languages
URL: http://pecl.php.net/package/yaml
Source: http://pecl.php.net/get/%{pecl_name}-%{version}%{?prever}.tgz
-BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
-BuildRequires: %{?scl_prefix}php-devel >= 5.2.0
+BuildRequires: %{?scl_prefix}php-devel >= 7
BuildRequires: %{?scl_prefix}php-pear
BuildRequires: libyaml-devel
@@ -61,13 +52,15 @@ Obsoletes: php53-pecl-%{pecl_name} <= %{version}
Obsoletes: php53u-pecl-%{pecl_name} <= %{version}
Obsoletes: php54-pecl-%{pecl_name} <= %{version}
Obsoletes: php54w-pecl-%{pecl_name} <= %{version}
-%if "%{php_version}" > "5.5"
Obsoletes: php55u-pecl-%{pecl_name} <= %{version}
Obsoletes: php55w-pecl-%{pecl_name} <= %{version}
-%endif
-%if "%{php_version}" > "5.6"
Obsoletes: php56u-pecl-%{pecl_name} <= %{version}
Obsoletes: php56w-pecl-%{pecl_name} <= %{version}
+Obsoletes: php70u-pecl-%{pecl_name} <= %{version}
+Obsoletes: php70w-pecl-%{pecl_name} <= %{version}
+%if "%{php_version}" > "7.1"
+Obsoletes: php71u-pecl-%{pecl_name} <= %{version}
+Obsoletes: php71w-pecl-%{pecl_name} <= %{version}
%endif
%endif
@@ -97,10 +90,6 @@ sed -e 's/role="test"/role="src"/' \
-i package.xml
cd NTS
-# honour --with-libdir option
-# http://git.php.net/?p=pecl/file_formats/yaml.git;a=commitdiff;h=e1b40c36a8f0ba42a90c655ab3fc21bf4fb7d163
-sed -e 's:/lib:/$PHP_LIBDIR:' -i config.m4
-
# Check upstream version (often broken)
extver=$(sed -n '/#define PHP_YAML_VERSION/{s/.* "//;s/".*$//;p}' php_yaml.h)
if test "x${extver}" != "x%{version}%{?prever}"; then
@@ -133,7 +122,7 @@ extension=%{pecl_name}.so
;yaml.output_width = 80
; Enable/disable serialized php object processing.
-;yaml.decode_php = 1
+;yaml.decode_php = 0
EOF
cp -pr NTS ZTS
@@ -180,9 +169,6 @@ done
%check
-# See https://bugs.php.net/71696
-rm ?TS/tests/yaml_002.phpt
-
cd NTS
: Minimal load test for NTS extension
%{__php} --no-php-ini \
@@ -194,7 +180,7 @@ TEST_PHP_EXECUTABLE=%{__php} \
TEST_PHP_ARGS="-n -d extension=$PWD/modules/%{pecl_name}.so" \
NO_INTERACTION=1 \
REPORT_EXIT_STATUS=1 \
-%{__php} -n run-tests.php
+%{__php} -n run-tests.php --show-diff
%if %{with_zts}
cd ../ZTS
@@ -208,15 +194,11 @@ TEST_PHP_EXECUTABLE=%{__ztsphp} \
TEST_PHP_ARGS="-n -d extension=$PWD/modules/%{pecl_name}.so" \
NO_INTERACTION=1 \
REPORT_EXIT_STATUS=1 \
-%{__ztsphp} -n run-tests.php
+%{__ztsphp} -n run-tests.php --show-diff
%endif
-%clean
-rm -rf %{buildroot}
-
-
%if 0%{?fedora} < 24
# when pear installed alone, after us
%triggerin -- %{?scl_prefix}php-pear
@@ -238,7 +220,6 @@ fi
%files
-%defattr(-, root, root, -)
%{?_licensedir:%license NTS/LICENSE}
%doc %{pecl_docdir}/%{pecl_name}
%{pecl_xmldir}/%{name}.xml
@@ -253,18 +234,46 @@ fi
%changelog
-* Mon Sep 26 2016 Remi Collet <remi@fedoraproject.org> - 1.3.0-1
-- Update to 1.3.0 (php 5)
+* Thu Dec 1 2016 Remi Collet <remi@fedoraproject.org> - 2.0.0-2
+- rebuild with PHP 7.1.0 GA
+
+* Mon Sep 26 2016 Remi Collet <remi@fedoraproject.org> - 2.0.0-1
+- update to 2.0.0 (php 7)
+
+* Wed Sep 14 2016 Remi Collet <remi@fedoraproject.org> - 2.0.0-0.10.RC8
+- rebuild for PHP 7.1 new API version
-* Mon Jun 6 2016 Remi Collet <remi@fedoraproject.org> - 1.3.0-0.1.b1
-- Update to 1.3.0b1 (beta)
+* Mon Jun 6 2016 Remi Collet <remi@fedoraproject.org> - 2.0.0-0.9.RC8
+- update to 2.0.0RC8
-* Wed Mar 9 2016 Remi Collet <remi@fedoraproject.org> - 1.2.0-4
+* Sun Mar 6 2016 Remi Collet <remi@fedoraproject.org> - 2.0.0-0.8.RC7
- adapt for F24
-* Tue Mar 1 2016 Remi Collet <remi@fedoraproject.org> - 1.2.0-3
+* Tue Mar 1 2016 Remi Collet <remi@fedoraproject.org> - 2.0.0-0.7.RC7
- skip yaml_002.phpt, see https://bugs.php.net/71696
+* Thu Dec 31 2015 Remi Collet <remi@fedoraproject.org> - 2.0.0-0.6.RC7
+- update to 2.0.0RC7
+
+* Tue Dec 8 2015 Remi Collet <remi@fedoraproject.org> - 2.0.0-0.5.RC6
+- update to 2.0.0RC6
+
+* Sun Oct 18 2015 Remi Collet <remi@fedoraproject.org> - 2.0.0-0.4.RC5
+- update to 2.0.0RC5
+
+* Sat Oct 17 2015 Remi Collet <remi@fedoraproject.org> - 2.0.0-0.3.RC4
+- update to 2.0.0RC4
+
+* Sat Oct 17 2015 Remi Collet <remi@fedoraproject.org> - 2.0.0-0.2.RC2
+- add uptream patches, fix segfault and test suite
+
+* Sat Oct 17 2015 Remi Collet <remi@fedoraproject.org> - 2.0.0-0.1.RC2
+- update to 2.0.0RC2 for PHP 7
+- 2 failed tests, so ignore test suite results for now
+
+* Sat Oct 17 2015 Remi Collet <remi@fedoraproject.org> - 2.0.0-0.1.RC1
+- update to 2.0.0RC1 for PHP 7
+
* Tue Jun 23 2015 Remi Collet <remi@fedoraproject.org> - 1.2.0-2
- allow build against rh-php56 (as more-php56)
@@ -321,3 +330,4 @@ fi
* Thu May 05 2011 Thomas Morse <tmorse@empowercampaigns.com> 1.0.1-1
- Version 1.0.1
- initial RPM
+