summaryrefslogtreecommitdiffstats
path: root/php-pecl-yaml.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-08-16 08:34:45 +0200
committerRemi Collet <remi@remirepo.net>2020-08-16 08:34:45 +0200
commit5f7225f95b650f16e6682ab7057c1f486c397afa (patch)
tree394a618e4be400c666f2cbaeec925c0bd41dfe4e /php-pecl-yaml.spec
parent02d6f45f5111af3e73c7d906a6d9ca2fa641b4d3 (diff)
update to 2.2.0b1
drop patches merged upstream
Diffstat (limited to 'php-pecl-yaml.spec')
-rw-r--r--php-pecl-yaml.spec30
1 files changed, 13 insertions, 17 deletions
diff --git a/php-pecl-yaml.spec b/php-pecl-yaml.spec
index ed6c0b0..b9eab7a 100644
--- a/php-pecl-yaml.spec
+++ b/php-pecl-yaml.spec
@@ -17,19 +17,18 @@
%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
%global pecl_name yaml
%global ini_name 40-%{pecl_name}.ini
-#global prever RC8
+
+%global upstream_version 2.2.0
+%global upstream_prever b1
Summary: PHP Bindings for yaml
Name: %{?sub_prefix}php-pecl-yaml
-Version: 2.1.0
-Release: 3%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Version: %{upstream_version}%{?upstream_prever:~%{upstream_prever}}
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: MIT
URL: https://pecl.php.net/package/yaml
-Source: https://pecl.php.net/get/%{pecl_name}-%{version}%{?prever}.tgz
-
-Patch0: https://patch-diff.githubusercontent.com/raw/php/pecl-file_formats-yaml/pull/45.patch
-Patch1: https://patch-diff.githubusercontent.com/raw/php/pecl-file_formats-yaml/pull/53.patch
+Source0: https://pecl.php.net/get/%{pecl_name}-%{upstream_version}%{?upstream_prever}.tgz
BuildRequires: %{?dtsprefix}gcc
BuildRequires: %{?scl_prefix}php-devel >= 7.1
@@ -92,7 +91,7 @@ Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSIO
%prep
%setup -c -q
-mv %{pecl_name}-%{version}%{?prever} NTS
+mv %{pecl_name}-%{upstream_version}%{?upstream_prever} NTS
# Remove test file to avoid regsitration
sed -e 's/role="test"/role="src"/' \
@@ -100,13 +99,10 @@ sed -e 's/role="test"/role="src"/' \
-i package.xml
cd NTS
-%patch0 -p1 -b .pr45
-%patch1 -p1 -b .pr52
-
# Check upstream version (often broken)
extver=$(sed -n '/#define PHP_YAML_VERSION/{s/.* "//;s/".*$//;p}' php_yaml.h)
-if test "x${extver}" != "x%{version}%{?prever}"; then
- : Error: Upstream version is ${extver}, expecting %{version}%{?prever}.
+if test "x${extver}" != "x%{upstream_version}%{?upstream_prever}"; then
+ : Error: Upstream extension version is ${extver}, expecting %{upstream_version}%{?upstream_prever}.
exit 1
fi
cd ..
@@ -185,10 +181,6 @@ done
%check
-%if "%{php_version}" > "8.0"
-# warnings promoted to exception
-rm ?TS/tests/yaml_parse_file_002.phpt
-%endif
cd NTS
: Minimal load test for NTS extension
%{__php} --no-php-ini \
@@ -254,6 +246,10 @@ fi
%changelog
+* Sun Aug 16 2020 Remi Collet <remi@remirepo.net> - 2.2.0~b1-1
+- update to 2.2.0b1
+- drop patches merged upstream
+
* Wed Aug 5 2020 Remi Collet <remi@remirepo.net> - 2.1.0-3
- rebuild for 8.0.0beta1