summaryrefslogtreecommitdiffstats
path: root/php-pecl-yaml.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2023-03-06 08:02:32 +0100
committerRemi Collet <remi@php.net>2023-03-06 08:02:32 +0100
commit022f4fefbd0349af535f7e2c36317025cc0210cb (patch)
tree09224594d96c30f025a03d2de7a0429f3b4b7bf6 /php-pecl-yaml.spec
parent27a1303c7f72b767a6bda6a2df4b76e2dcec5ade (diff)
update to 2.2.3
drop patch merged upstream
Diffstat (limited to 'php-pecl-yaml.spec')
-rw-r--r--php-pecl-yaml.spec38
1 files changed, 15 insertions, 23 deletions
diff --git a/php-pecl-yaml.spec b/php-pecl-yaml.spec
index 7db8acc..93b9e89 100644
--- a/php-pecl-yaml.spec
+++ b/php-pecl-yaml.spec
@@ -1,6 +1,6 @@
# remirepo spec file for php-pecl-yaml
#
-# Copyright (c) 2012-2022 Remi Collet
+# Copyright (c) 2012-2023 Remi Collet
# Fedora spec file for php-pecl-yaml
#
@@ -10,29 +10,27 @@
# Please, preserve the changelog entries
#
%if 0%{?scl:1}
-%global sub_prefix %{scl_prefix}
%scl_package php-pecl-yaml
%endif
+%bcond_without tests
+
%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
%global pecl_name yaml
%global ini_name 40-%{pecl_name}.ini
-%global upstream_version 2.2.2
+%global upstream_version 2.2.3
#global upstream_prever b2
Summary: PHP Bindings for yaml
-Name: %{?sub_prefix}php-pecl-yaml
+Name: %{?scl_prefix}php-pecl-yaml
Version: %{upstream_version}%{?upstream_prever:~%{upstream_prever}}
-Release: 3%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: MIT
URL: https://pecl.php.net/package/yaml
Source0: https://pecl.php.net/get/%{pecl_name}-%{upstream_version}%{?upstream_prever}.tgz
-Patch0: %{pecl_name}-pr66.patch
-Patch1: %{pecl_name}-upstream.patch
-
BuildRequires: make
BuildRequires: %{?dtsprefix}gcc
BuildRequires: %{?scl_prefix}php-devel >= 7.1
@@ -47,12 +45,8 @@ Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
-%if "%{?scl_prefix}" != "%{?sub_prefix}"
-Provides: %{?scl_prefix}php-pecl-%{pecl_name} = %{version}-%{release}
-Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}-%{release}
-%endif
-%if "%{?packager}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
+%if "%{?packager}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel} == 7
# Other third party repo stuff
Obsoletes: php56u-pecl-%{pecl_name} <= %{version}
Obsoletes: php71u-pecl-%{pecl_name} <= %{version}
@@ -65,12 +59,6 @@ Obsoletes: php73-pecl-%{pecl_name} <= %{version}
%if "%{php_version}" > "7.4"
Obsoletes: php74-pecl-%{pecl_name} <= %{version}
%endif
-%if "%{php_version}" > "8.0"
-Obsoletes: php80-pecl-%{pecl_name} <= %{version}
-%endif
-%if "%{php_version}" > "8.1"
-Obsoletes: php81-pecl-%{pecl_name} <= %{version}
-%endif
%endif
@@ -93,9 +81,6 @@ sed -e 's/role="test"/role="src"/' \
-i package.xml
cd NTS
-%patch0 -p1 -b .pr66
-%patch1 -p1 -b .up
-
# Check upstream version (often broken)
extver=$(sed -n '/#define PHP_YAML_VERSION/{s/.* "//;s/".*$//;p}' php_yaml.h)
if test "x${extver}" != "x%{upstream_version}%{?upstream_prever}"; then
@@ -184,10 +169,12 @@ cd NTS
--define extension=modules/%{pecl_name}.so \
--modules | grep '^%{pecl_name}$'
+%if %{with tests}
: Upstream test suite for NTS extension
TEST_PHP_ARGS="-n -d extension=$PWD/modules/%{pecl_name}.so" \
REPORT_EXIT_STATUS=1 \
%{__php} -n run-tests.php -q -P --show-diff
+%endif
%if %{with_zts}
cd ../ZTS
@@ -196,11 +183,12 @@ cd ../ZTS
--define extension=modules/%{pecl_name}.so \
--modules | grep '^%{pecl_name}$'
+%if %{with tests}
: Upstream test suite for ZTS extension
TEST_PHP_ARGS="-n -d extension=$PWD/modules/%{pecl_name}.so" \
REPORT_EXIT_STATUS=1 \
%{__ztsphp} -n run-tests.php -q -P --show-diff
-
+%endif
%endif
@@ -239,6 +227,10 @@ fi
%changelog
+* Mon Mar 6 2023 Remi Collet <remi@remirepo.net> - 2.2.3-1
+- update to 2.2.3
+- drop patch merged upstream
+
* Fri Sep 9 2022 Remi Collet <remi@remirepo.net> - 2.2.2-3
- add upstream patch for test suite with PHP 8.2