summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-08-01 12:09:28 +0200
committerRemi Collet <remi@remirepo.net>2017-08-01 12:09:28 +0200
commite135fbbc964385fd3787bf3b6201deae050f297a (patch)
treea0b9b6fc6e567042b031b944c1416ad52e9031f2
parenta268c09223bfeecfab940a168b96a2417d575c0c (diff)
v2.0.2
-rw-r--r--.gitignore5
-rw-r--r--REFLECTION2
-rw-r--r--f220c0400bd1875879da58788187774a04430ecb.patch68
-rw-r--r--php-pecl-yaml.spec15
4 files changed, 15 insertions, 75 deletions
diff --git a/.gitignore b/.gitignore
index 68787b5..1ab5c4f 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,2 +1,7 @@
+package-*.xml
*.tgz
+*.tar.gz
+*.tar.xz
+*.tar.xz.asc
*.src.rpm
+*/*rpm
diff --git a/REFLECTION b/REFLECTION
index 6ff493a..4f9d59d 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #137 yaml version 2.0.0 ] {
+Extension [ <persistent> extension #162 yaml version 2.0.2 ] {
- Dependencies {
Dependency [ date (Optional) ]
diff --git a/f220c0400bd1875879da58788187774a04430ecb.patch b/f220c0400bd1875879da58788187774a04430ecb.patch
deleted file mode 100644
index 7e93b43..0000000
--- a/f220c0400bd1875879da58788187774a04430ecb.patch
+++ /dev/null
@@ -1,68 +0,0 @@
-From f220c0400bd1875879da58788187774a04430ecb Mon Sep 17 00:00:00 2001
-From: Remi Collet <remi@php.net>
-Date: Wed, 29 Mar 2017 10:45:07 +0200
-Subject: [PATCH] relax test to pass with 7.1.4RC1
-
----
- tests/yaml_parse_003.phpt | 4 ++--
- tests/yaml_parse_004.phpt | 2 +-
- tests/yaml_parse_006.phpt | 8 ++++----
- 3 files changed, 7 insertions(+), 7 deletions(-)
-
-diff --git a/tests/yaml_parse_003.phpt b/tests/yaml_parse_003.phpt
-index a7197ce..5ffab2c 100644
---- a/tests/yaml_parse_003.phpt
-+++ b/tests/yaml_parse_003.phpt
-@@ -12,8 +12,8 @@ grave-accent: `text
- '));
- ?>
- --EXPECTF--
--Warning: yaml_parse(): scanning error encountered during parsing: found character that cannot start any token (line 2, column 16), context while scanning for the next token (line 2, column 16) in %syaml_parse_003.php on line 4
-+Warning: yaml_parse(): scanning error encountered during parsing: found character that cannot start any token (line 2, column 16), context while scanning for the next token (line 2, column 16) in %syaml_parse_003.php on line %d
- bool(false)
-
--Warning: yaml_parse(): scanning error encountered during parsing: found character that cannot start any token (line 2, column 15), context while scanning for the next token (line 2, column 15) in %syaml_parse_003.php on line 7
-+Warning: yaml_parse(): scanning error encountered during parsing: found character that cannot start any token (line 2, column 15), context while scanning for the next token (line 2, column 15) in %syaml_parse_003.php on line %d
- bool(false)
-diff --git a/tests/yaml_parse_004.phpt b/tests/yaml_parse_004.phpt
-index ea7c08f..5c97721 100644
---- a/tests/yaml_parse_004.phpt
-+++ b/tests/yaml_parse_004.phpt
-@@ -16,5 +16,5 @@ reference: *broken_pointer_to_define
- '));
- ?>
- --EXPECTF--
--Warning: yaml_parse(): alias broken_pointer_to_define is not registered (line 6, column 37) in %syaml_parse_004.php on line 8
-+Warning: yaml_parse(): alias broken_pointer_to_define is not registered (line 6, column 37) in %syaml_parse_004.php on line %d
- bool(false)
-diff --git a/tests/yaml_parse_006.phpt b/tests/yaml_parse_006.phpt
-index dc24955..f82d58c 100644
---- a/tests/yaml_parse_006.phpt
-+++ b/tests/yaml_parse_006.phpt
-@@ -33,10 +33,10 @@ var_dump(yaml_parse('---
- '));
- ?>
- --EXPECTF--
--Warning: yaml_parse(): scanning error encountered during parsing: found character that cannot start any token (line 2, column 1), context while scanning for the next token (line 2, column 1) in %syaml_parse_006.php on line 5
-+Warning: yaml_parse(): scanning error encountered during parsing: found character that cannot start any token (line 2, column 1), context while scanning for the next token (line 2, column 1) in %syaml_parse_006.php on line %d
- bool(false)
-
--Warning: yaml_parse(): scanning error encountered during parsing: found character that cannot start any token (line 2, column 3), context while scanning for the next token (line 2, column 3) in %syaml_parse_006.php on line 9
-+Warning: yaml_parse(): scanning error encountered during parsing: found character that cannot start any token (line 2, column 3), context while scanning for the next token (line 2, column 3) in %syaml_parse_006.php on line %d
- bool(false)
- array(1) {
- ["key"]=>
-@@ -47,8 +47,8 @@ array(1) {
- string(26) "space and tab before value"
- }
-
--Warning: yaml_parse(): scanning error encountered during parsing: found character that cannot start any token (line 2, column 2), context while scanning for the next token (line 2, column 2) in %syaml_parse_006.php on line 21
-+Warning: yaml_parse(): scanning error encountered during parsing: found character that cannot start any token (line 2, column 2), context while scanning for the next token (line 2, column 2) in %syaml_parse_006.php on line %d
- bool(false)
-
--Warning: yaml_parse(): scanning error encountered during parsing: found character that cannot start any token (line 2, column 4), context while scanning for the next token (line 2, column 4) in %syaml_parse_006.php on line 25
-+Warning: yaml_parse(): scanning error encountered during parsing: found character that cannot start any token (line 2, column 4), context while scanning for the next token (line 2, column 4) in %syaml_parse_006.php on line %d
- bool(false)
---
-2.1.4
-
diff --git a/php-pecl-yaml.spec b/php-pecl-yaml.spec
index c07e6a0..9fe7e6e 100644
--- a/php-pecl-yaml.spec
+++ b/php-pecl-yaml.spec
@@ -21,16 +21,14 @@
Summary: PHP Bindings for yaml
Name: %{?sub_prefix}php-pecl-yaml
-Version: 2.0.0
-Release: 4%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Version: 2.0.2
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: MIT
Group: Development/Languages
URL: http://pecl.php.net/package/yaml
Source: http://pecl.php.net/get/%{pecl_name}-%{version}%{?prever}.tgz
-Patch0: f220c0400bd1875879da58788187774a04430ecb.patch
-
BuildRequires: %{?scl_prefix}php-devel >= 7
BuildRequires: %{?scl_prefix}php-pear
BuildRequires: libyaml-devel
@@ -96,7 +94,6 @@ sed -e 's/role="test"/role="src"/' \
-i package.xml
cd NTS
-%patch0 -p1 -b .upstream
# Check upstream version (often broken)
extver=$(sed -n '/#define PHP_YAML_VERSION/{s/.* "//;s/".*$//;p}' php_yaml.h)
@@ -137,8 +134,9 @@ cp -pr NTS ZTS
%build
-cd NTS
+%{?dtsenable}
+cd NTS
%{_bindir}/phpize
%configure \
--with-libdir=%{_lib} \
@@ -156,6 +154,8 @@ make %{?_smp_mflags}
%install
+%{?dtsenable}
+
make -C NTS install INSTALL_ROOT=%{buildroot}
# Install XML package description
@@ -242,6 +242,9 @@ fi
%changelog
+* Tue Aug 1 2017 Remi Collet <remi@remirepo.net> - 2.0.2-1
+- Update to 2.0.2
+
* Tue Jul 18 2017 Remi Collet <remi@remirepo.net> - 2.0.0-4
- rebuild for PHP 7.2.0beta1 new API