summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-03-09 10:53:56 +0100
committerRemi Collet <fedora@famillecollet.com>2016-03-09 10:53:56 +0100
commitd2651e937f18676af4fb777acae78dfe9688f16f (patch)
treec6f3ebd9a18feedfd8b3b3b5cab3a30ca43ec314
parent26761f37d4ead19c024926e83e49dd3388d9fb88 (diff)
php-pecl-yaml: F24
-rw-r--r--php-pecl-yaml.spec22
1 files changed, 14 insertions, 8 deletions
diff --git a/php-pecl-yaml.spec b/php-pecl-yaml.spec
index 52ae3b4..e2bb3c2 100644
--- a/php-pecl-yaml.spec
+++ b/php-pecl-yaml.spec
@@ -18,9 +18,6 @@
%endif
%{?scl: %scl_package php-pecl-yaml}
-%{!?php_inidir: %global php_inidir %{_sysconfdir}/php.d}
-%{!?__pecl: %global __pecl %{_bindir}/pecl}
-%{!?__php: %global __php %{_bindir}/php}
%global with_zts 0%{?__ztsphp:1}
%global pecl_name yaml
@@ -33,7 +30,7 @@
Summary: PHP Bindings for yaml
Name: %{?sub_prefix}php-pecl-yaml
Version: 1.2.0
-Release: 3%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 4%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: MIT
Group: Development/Languages
URL: http://pecl.php.net/package/yaml
@@ -49,10 +46,12 @@ Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
Requires: %{?scl_prefix}php(api) = %{php_core_api}
%{?_sclreq:Requires: %{?scl_prefix}runtime%{?_sclreq}%{?_isa}}
-Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
-Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
-Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
+Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
+Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
+Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
+Provides: %{?scl_prefix}php-pecl-%{pecl_name} = %{version}-%{release}
+Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}-%{release}
%if "%{?vendor}" == "Remi Collet" && 0%{!?scl:1}
# Other third party repo stuff
@@ -95,7 +94,9 @@ Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSIO
mv %{pecl_name}-%{version} NTS
# Remove test file to avoid regsitration
-sed -e '/role="test"/d' -i package.xml
+sed -e 's/role="test"/role="src"/' \
+ %{?_licensedir:-e '/LICENSE/s/role="doc"/role="src"/' } \
+ -i package.xml
cd NTS
# honour --with-libdir option
@@ -218,6 +219,7 @@ REPORT_EXIT_STATUS=1 \
rm -rf %{buildroot}
+%if 0%{?fedora} < 24
# when pear installed alone, after us
%triggerin -- %{?scl_prefix}php-pear
if [ -x %{__pecl} ] ; then
@@ -234,6 +236,7 @@ fi
if [ $1 -eq 0 -a -x %{__pecl} ] ; then
%{pecl_uninstall} %{pecl_name} >/dev/null || :
fi
+%endif
%files
@@ -252,6 +255,9 @@ fi
%changelog
+* Wed Mar 9 2016 Remi Collet <remi@fedoraproject.org> - 1.2.0-4
+- adapt for F24
+
* Tue Mar 1 2016 Remi Collet <remi@fedoraproject.org> - 1.2.0-3
- skip yaml_002.phpt, see https://bugs.php.net/71696