summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2014-03-19 16:14:11 +0100
committerRemi Collet <fedora@famillecollet.com>2014-03-19 16:14:11 +0100
commit2b45f37872d1b137d36e7253fa01f49746923374 (patch)
treec7535dc10fd0750d623c4c2da49b01b67a77884e
parent8c06a4a805ccafd7b5d94a55cc5eda942cc114dc (diff)
php-pecl-yaml: allow SCL BUILD
-rw-r--r--php-pecl-yaml.spec40
1 files changed, 30 insertions, 10 deletions
diff --git a/php-pecl-yaml.spec b/php-pecl-yaml.spec
index 97e707e..662f943 100644
--- a/php-pecl-yaml.spec
+++ b/php-pecl-yaml.spec
@@ -1,3 +1,15 @@
+# spec file for php-pecl-yaml
+#
+# Copyright (c) 2012-2014 Remi Collet
+# Copyright (c) 2011-2012 Theodore Lee
+# Copyright (c) 2011 Thomas Morse
+#
+# License: MIT
+# http://opensource.org/licenses/MIT
+#
+# Please, preserve the changelog entries
+#
+%{?scl: %scl_package php-pecl-yaml}
%{!?php_inidir: %global php_inidir %{_sysconfdir}/php.d}
%{!?__pecl: %global __pecl %{_bindir}/pecl}
%{!?__php: %global __php %{_bindir}/php}
@@ -6,9 +18,9 @@
%global pecl_name yaml
Summary: PHP Bindings for yaml
-Name: php-pecl-yaml
+Name: %{?scl_prefix}php-pecl-yaml
Version: 1.1.1
-Release: 1%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
+Release: 2%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
License: MIT
Group: Development/Languages
URL: http://pecl.php.net/package/yaml
@@ -16,20 +28,21 @@ URL: http://pecl.php.net/package/yaml
Source: http://pecl.php.net/get/%{pecl_name}-%{version}.tgz
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
-BuildRequires: php-devel >= 5.2.0
-BuildRequires: php-pear
+BuildRequires: %{?scl_prefix}php-devel >= 5.2.0
+BuildRequires: %{?scl_prefix}php-pear
BuildRequires: libyaml-devel
Requires(post): %{__pecl}
Requires(postun): %{__pecl}
-Requires: php(zend-abi) = %{php_zend_api}
-Requires: php(api) = %{php_core_api}
+Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
+Requires: %{?scl_prefix}php(api) = %{php_core_api}
-Provides: php-%{pecl_name} = %{version}
-Provides: php-%{pecl_name}%{?_isa} = %{version}
-Provides: php-pecl(%{pecl_name}) = %{version}
-Provides: php-pecl(%{pecl_name})%{?_isa} = %{version}
+Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
+Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
+Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
+Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
+%if "%{?vendor}" == "Remi Collet"
# Other third party repo stuff
Obsoletes: php53-pecl-%{pecl_name}
Obsoletes: php53u-pecl-%{pecl_name}
@@ -37,6 +50,10 @@ Obsoletes: php54-pecl-%{pecl_name}
%if "%{php_version}" > "5.5"
Obsoletes: php55u-pecl-%{pecl_name}
%endif
+%if "%{php_version}" > "5.6"
+Obsoletes: php56u-pecl-%{pecl_name}
+%endif
+%endif
%if 0%{?fedora} < 20 && 0%{?rhel} < 7
# Filter private shared
@@ -199,6 +216,9 @@ fi
%changelog
+* Wed Mar 19 2014 Remi Collet <rcollet@redhat.com> - 1.1.1-2
+- allow SCL build
+
* Tue Nov 19 2013 Remi Collet <remi@fedoraproject.org> - 1.1.1-1
- Update to 1.1.1 (stable)
- install doc in pecl doc_dir