summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2015-10-17 19:50:14 +0200
committerRemi Collet <fedora@famillecollet.com>2015-10-17 19:50:14 +0200
commit25721e053f9c4c73f2a2dc97804a181d07928505 (patch)
tree5c42bb81c61ef0b7e0cb1e8a9d151f1acb11b9c8
parent5b64eca514d9a8d7ed305e9bfdb9ab0d65185772 (diff)
php-pecl-yaml: 2.0.0RC4
-rw-r--r--REFLECTION-DEV2
-rw-r--r--php-pecl-yaml-dev.spec12
-rw-r--r--yaml-upstream.patch56
3 files changed, 6 insertions, 64 deletions
diff --git a/REFLECTION-DEV b/REFLECTION-DEV
index 753248c..134d207 100644
--- a/REFLECTION-DEV
+++ b/REFLECTION-DEV
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #99 yaml version 2.0.0RC2 ] {
+Extension [ <persistent> extension #99 yaml version 2.0.0RC4 ] {
- Dependencies {
Dependency [ date (Optional) ]
diff --git a/php-pecl-yaml-dev.spec b/php-pecl-yaml-dev.spec
index 89901f2..6c0e641 100644
--- a/php-pecl-yaml-dev.spec
+++ b/php-pecl-yaml-dev.spec
@@ -29,21 +29,18 @@
%else
%global ini_name 40-%{pecl_name}.ini
%endif
-%global prever RC2
+%global prever RC4
Summary: PHP Bindings for yaml
Name: %{?sub_prefix}php-pecl-yaml
Version: 2.0.0
-Release: 0.2.%{prever}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 0.3.%{prever}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: MIT
Group: Development/Languages
URL: http://pecl.php.net/package/yaml
Source: http://pecl.php.net/get/%{pecl_name}-%{version}%{?prever}.tgz
-# Upstream patch
-Patch0: %{pecl_name}-upstream.patch
-
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildRequires: %{?scl_prefix}php-devel >= 7
BuildRequires: %{?scl_prefix}php-pear
@@ -102,8 +99,6 @@ mv %{pecl_name}-%{version}%{?prever} NTS
sed -e '/role="test"/d' -i package.xml
cd NTS
-%patch0 -p1 -b .upstream
-
# Check upstream version (often broken)
extver=$(sed -n '/#define PHP_YAML_VERSION/{s/.* "//;s/".*$//;p}' php_yaml.h)
if test "x${extver}" != "x%{version}%{?prever}"; then
@@ -251,6 +246,9 @@ fi
%changelog
+* Sat Oct 17 2015 Remi Collet <remi@fedoraproject.org> - 2.0.0-0.3.RC4
+- update to 2.0.0RC4
+
* Sat Oct 17 2015 Remi Collet <remi@fedoraproject.org> - 2.0.0-0.2.RC2
- add uptream patches, fix segfault and test suite
diff --git a/yaml-upstream.patch b/yaml-upstream.patch
deleted file mode 100644
index c2bf423..0000000
--- a/yaml-upstream.patch
+++ /dev/null
@@ -1,56 +0,0 @@
-From b015af52451b90bc38463ea4915c150de4a1b9d9 Mon Sep 17 00:00:00 2001
-From: Remi Collet <remi@php.net>
-Date: Sat, 17 Oct 2015 09:42:29 +0200
-Subject: [PATCH] free later, fix tests/yaml_emit_005.phpt failure
-
----
- emit.c | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/emit.c b/emit.c
-index faa4d07..d210acc 100644
---- a/emit.c
-+++ b/emit.c
-@@ -668,13 +668,13 @@ static int y_write_object(
- NULL, (yaml_char_t *) YAML_PHP_TAG, (yaml_char_t *) buf.s->val, buf.s->len,
- 0, 0, YAML_DOUBLE_QUOTED_SCALAR_STYLE);
-
-- smart_string_free(&buf);
- if (!status) {
- y_event_init_failed(&event);
- status = FAILURE;
- } else {
- status = y_event_emit(state, &event TSRMLS_CC);
- }
-+ smart_string_free(&buf);
- }
-
- return status;
---
-2.1.4
-
-From 2538b42347d1fc390ebd88ef1c1ca4164c2faecf Mon Sep 17 00:00:00 2001
-From: Remi Collet <remi@php.net>
-Date: Sat, 17 Oct 2015 09:46:19 +0200
-Subject: [PATCH] missing init value, fix segfault in tests/bug_64694.phpt
-
----
- parse.c | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/parse.c b/parse.c
-index d52753a..dbd8cd5 100644
---- a/parse.c
-+++ b/parse.c
-@@ -880,7 +880,7 @@ static char *convert_to_char(zval *zv TSRMLS_DC)
- default:
- {
- php_serialize_data_t var_hash;
-- smart_str buf;
-+ smart_str buf = {0};
-
- PHP_VAR_SERIALIZE_INIT(var_hash);
- php_var_serialize(&buf, zv, &var_hash TSRMLS_CC);
---
-2.1.4
-