summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PHPINFO2
-rw-r--r--REFLECTION12
-rw-r--r--php-pecl-yaf.spec8
3 files changed, 14 insertions, 8 deletions
diff --git a/PHPINFO b/PHPINFO
index 5a2543c..ea46cee 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,7 +2,7 @@
yaf
yaf support => enabled
-Version => 3.2.0
+Version => 3.2.1
Supports => http://pecl.php.net/package/yaf
Directive => Local Value => Master Value
diff --git a/REFLECTION b/REFLECTION
index a99df31..8c33b92 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #113 yaf version 3.2.0 ] {
+Extension [ <persistent> extension #113 yaf version 3.2.1 ] {
- Dependencies {
Dependency [ spl (Required) ]
@@ -37,7 +37,7 @@ Extension [ <persistent> extension #113 yaf version 3.2.0 ] {
}
- Constants [13] {
- Constant [ string YAF_VERSION ] { 3.2.0 }
+ Constant [ string YAF_VERSION ] { 3.2.1 }
Constant [ string YAF_ENVIRON ] { product }
Constant [ int YAF_ERR_STARTUP_FAILED ] { 512 }
Constant [ int YAF_ERR_ROUTE_FAILED ] { 513 }
@@ -202,7 +202,7 @@ Extension [ <persistent> extension #113 yaf version 3.2.0 ] {
- Properties [0] {
}
- - Methods [23] {
+ - Methods [24] {
Method [ <internal:yaf, ctor> private method __construct ] {
}
@@ -252,6 +252,12 @@ Extension [ <persistent> extension #113 yaf version 3.2.0 ] {
}
}
+ Method [ <internal:yaf> public method getResponse ] {
+
+ - Parameters [0] {
+ }
+ }
+
Method [ <internal:yaf> public method getRequest ] {
- Parameters [0] {
diff --git a/php-pecl-yaf.spec b/php-pecl-yaf.spec
index 6177924..c7002a3 100644
--- a/php-pecl-yaf.spec
+++ b/php-pecl-yaf.spec
@@ -26,7 +26,7 @@
Summary: Yet Another Framework
Name: %{?sub_prefix}php-pecl-yaf
-Version: 3.2.0
+Version: 3.2.1
%if 0%{?gh_date:1}
Release: 0.12.%{gh_date}git%{gh_short}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{pecl_name}-%{version}-%{gh_short}.tar.gz
@@ -155,9 +155,6 @@ done
%check
-# fix path
-sed -e '/base_uri:protected/s/syaf/s/' -i ?TS/tests/issue231.phpt
-
cd NTS
: Minimal load test for NTS extension
%{__php} --no-php-ini \
@@ -223,6 +220,9 @@ fi
%changelog
+* Mon Apr 20 2020 Remi Collet <remi@remirepo.net> - 3.2.1-1
+- update to 3.2.1
+
* Sun Apr 19 2020 Remi Collet <remi@remirepo.net> - 3.2.0-1
- update to 3.2.0 (beta)
- open https://github.com/laruence/yaf/pull/474