summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PHPINFO14
-rw-r--r--REFLECTION759
-rw-r--r--php-pecl-yaf.spec10
3 files changed, 407 insertions, 376 deletions
diff --git a/PHPINFO b/PHPINFO
index 7204614..5a2543c 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,16 +2,16 @@
yaf
yaf support => enabled
-Version => 3.1.4
+Version => 3.2.0
Supports => http://pecl.php.net/package/yaf
Directive => Local Value => Master Value
yaf.library => no value => no value
-yaf.action_prefer => Off => Off
-yaf.lowcase_path => Off => Off
-yaf.use_spl_autoload => Off => Off
+yaf.environ => product => product
yaf.forward_limit => 5 => 5
-yaf.name_suffix => On => On
+yaf.use_namespace => 0 => 0
+yaf.action_prefer => 0 => 0
+yaf.lowcase_path => 0 => 0
+yaf.use_spl_autoload => 0 => 0
+yaf.name_suffix => 1 => 1
yaf.name_separator => no value => no value
-yaf.environ => product => product
-yaf.use_namespace => Off => Off
diff --git a/REFLECTION b/REFLECTION
index 6452d6a..a99df31 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #113 yaf version 3.1.4 ] {
+Extension [ <persistent> extension #113 yaf version 3.2.0 ] {
- Dependencies {
Dependency [ spl (Required) ]
@@ -10,6 +10,15 @@ Extension [ <persistent> extension #113 yaf version 3.1.4 ] {
Entry [ yaf.library <ALL> ]
Current = ''
}
+ Entry [ yaf.environ <SYSTEM> ]
+ Current = 'product'
+ }
+ Entry [ yaf.forward_limit <ALL> ]
+ Current = '5'
+ }
+ Entry [ yaf.use_namespace <ALL> ]
+ Current = '0'
+ }
Entry [ yaf.action_prefer <ALL> ]
Current = '0'
}
@@ -19,25 +28,16 @@ Extension [ <persistent> extension #113 yaf version 3.1.4 ] {
Entry [ yaf.use_spl_autoload <ALL> ]
Current = '0'
}
- Entry [ yaf.forward_limit <ALL> ]
- Current = '5'
- }
Entry [ yaf.name_suffix <ALL> ]
Current = '1'
}
Entry [ yaf.name_separator <ALL> ]
Current = ''
}
- Entry [ yaf.environ <SYSTEM> ]
- Current = 'product'
- }
- Entry [ yaf.use_namespace <SYSTEM> ]
- Current = '0'
- }
}
- - Constants [12] {
- Constant [ string YAF_VERSION ] { 3.1.4 }
+ - Constants [13] {
+ Constant [ string YAF_VERSION ] { 3.2.0 }
Constant [ string YAF_ENVIRON ] { product }
Constant [ int YAF_ERR_STARTUP_FAILED ] { 512 }
Constant [ int YAF_ERR_ROUTE_FAILED ] { 513 }
@@ -49,6 +49,7 @@ Extension [ <persistent> extension #113 yaf version 3.1.4 ] {
Constant [ int YAF_ERR_NOTFOUND_VIEW ] { 518 }
Constant [ int YAF_ERR_CALL_FAILED ] { 519 }
Constant [ int YAF_ERR_TYPE_ERROR ] { 521 }
+ Constant [ int YAF_ERR_ACCESS_ERROR ] { 522 }
}
- Classes [38] {
@@ -57,8 +58,7 @@ Extension [ <persistent> extension #113 yaf version 3.1.4 ] {
- Constants [0] {
}
- - Static properties [1] {
- Property [ protected static $_app ]
+ - Static properties [0] {
}
- Static methods [1] {
@@ -69,17 +69,10 @@ Extension [ <persistent> extension #113 yaf version 3.1.4 ] {
}
}
- - Properties [7] {
- Property [ <default> protected $config ]
- Property [ <default> protected $dispatcher ]
- Property [ <default> protected $_modules ]
- Property [ <default> protected $_running ]
- Property [ <default> protected $_environ ]
- Property [ <default> protected $_err_no ]
- Property [ <default> protected $_err_msg ]
+ - Properties [0] {
}
- - Methods [17] {
+ - Methods [14] {
Method [ <internal:yaf, ctor> public method __construct ] {
- Parameters [2] {
@@ -164,16 +157,10 @@ Extension [ <persistent> extension #113 yaf version 3.1.4 ] {
}
}
- Method [ <internal:yaf, dtor> public method __destruct ] {
- }
-
- Method [ <internal:yaf> private method __clone ] {
- }
-
- Method [ <internal:yaf> private method __sleep ] {
- }
+ Method [ <internal:yaf> public method getInstance ] {
- Method [ <internal:yaf> private method __wakeup ] {
+ - Parameters [0] {
+ }
}
}
}
@@ -201,8 +188,7 @@ Extension [ <persistent> extension #113 yaf version 3.1.4 ] {
- Constants [0] {
}
- - Static properties [1] {
- Property [ protected static $_instance ]
+ - Static properties [0] {
}
- Static methods [1] {
@@ -213,32 +199,13 @@ Extension [ <persistent> extension #113 yaf version 3.1.4 ] {
}
}
- - Properties [10] {
- Property [ <default> protected $_router ]
- Property [ <default> protected $_view ]
- Property [ <default> protected $_request ]
- Property [ <default> protected $_plugins ]
- Property [ <default> protected $_auto_render ]
- Property [ <default> protected $_return_response ]
- Property [ <default> protected $_instantly_flush ]
- Property [ <default> protected $_default_module ]
- Property [ <default> protected $_default_controller ]
- Property [ <default> protected $_default_action ]
+ - Properties [0] {
}
- Methods [23] {
Method [ <internal:yaf, ctor> private method __construct ] {
}
- Method [ <internal:yaf> private method __clone ] {
- }
-
- Method [ <internal:yaf> private method __sleep ] {
- }
-
- Method [ <internal:yaf> private method __wakeup ] {
- }
-
Method [ <internal:yaf> public method enableView ] {
- Parameters [0] {
@@ -291,6 +258,24 @@ Extension [ <persistent> extension #113 yaf version 3.1.4 ] {
}
}
+ Method [ <internal:yaf> public method getDefaultModule ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:yaf> public method getDefaultController ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:yaf> public method getDefaultAction ] {
+
+ - Parameters [0] {
+ }
+ }
+
Method [ <internal:yaf> public method setErrorHandler ] {
- Parameters [2] {
@@ -376,8 +361,7 @@ Extension [ <persistent> extension #113 yaf version 3.1.4 ] {
- Constants [0] {
}
- - Static properties [1] {
- Property [ protected static $_instance ]
+ - Static properties [0] {
}
- Static methods [2] {
@@ -397,9 +381,7 @@ Extension [ <persistent> extension #113 yaf version 3.1.4 ] {
}
}
- - Properties [2] {
- Property [ <default> protected $_library ]
- Property [ <default> protected $_global_library ]
+ - Properties [0] {
}
- Methods [11] {
@@ -409,15 +391,6 @@ Extension [ <persistent> extension #113 yaf version 3.1.4 ] {
}
}
- Method [ <internal:yaf> private method __clone ] {
- }
-
- Method [ <internal:yaf> private method __sleep ] {
- }
-
- Method [ <internal:yaf> private method __wakeup ] {
- }
-
Method [ <internal:yaf> public method autoload ] {
- Parameters [1] {
@@ -427,8 +400,9 @@ Extension [ <persistent> extension #113 yaf version 3.1.4 ] {
Method [ <internal:yaf> public method registerLocalNamespace ] {
- - Parameters [1] {
- Parameter #0 [ <required> $name_prefix ]
+ - Parameters [2] {
+ Parameter #0 [ <required> $namespace ]
+ Parameter #1 [ <optional> $path ]
}
}
@@ -451,6 +425,13 @@ Extension [ <persistent> extension #113 yaf version 3.1.4 ] {
}
}
+ Method [ <internal:yaf> public method getNamespacePath ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $class_name ]
+ }
+ }
+
Method [ <internal:yaf> public method setLibraryPath ] {
- Parameters [2] {
@@ -465,6 +446,20 @@ Extension [ <persistent> extension #113 yaf version 3.1.4 ] {
Parameter #0 [ <optional> $is_global ]
}
}
+
+ Method [ <internal:yaf> public method registerNamespace ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $namespace ]
+ Parameter #1 [ <optional> $path ]
+ }
+ }
+
+ Method [ <internal:yaf> public method getNamespaces ] {
+
+ - Parameters [0] {
+ }
+ }
}
}
@@ -481,21 +476,10 @@ Extension [ <persistent> extension #113 yaf version 3.1.4 ] {
- Static methods [0] {
}
- - Properties [11] {
- Property [ <default> public $module ]
- Property [ <default> public $controller ]
- Property [ <default> public $action ]
- Property [ <default> public $method ]
- Property [ <default> protected $params ]
- Property [ <default> protected $language ]
- Property [ <default> protected $_exception ]
- Property [ <default> protected $_base_uri ]
- Property [ <default> protected $uri ]
- Property [ <default> protected $dispatched ]
- Property [ <default> protected $routed ]
+ - Properties [0] {
}
- - Methods [31] {
+ - Methods [32] {
Method [ <internal:yaf> public method isGet ] {
- Parameters [0] {
@@ -588,6 +572,12 @@ Extension [ <persistent> extension #113 yaf version 3.1.4 ] {
}
}
+ Method [ <internal:yaf> public method clearParams ] {
+
+ - Parameters [0] {
+ }
+ }
+
Method [ <internal:yaf> public method getException ] {
- Parameters [0] {
@@ -614,22 +604,25 @@ Extension [ <persistent> extension #113 yaf version 3.1.4 ] {
Method [ <internal:yaf> public method setModuleName ] {
- - Parameters [1] {
+ - Parameters [2] {
Parameter #0 [ <required> $module ]
+ Parameter #1 [ <optional> $format_name ]
}
}
Method [ <internal:yaf> public method setControllerName ] {
- - Parameters [1] {
+ - Parameters [2] {
Parameter #0 [ <required> $controller ]
+ Parameter #1 [ <optional> $format_name ]
}
}
Method [ <internal:yaf> public method setActionName ] {
- - Parameters [1] {
+ - Parameters [2] {
Parameter #0 [ <required> $action ]
+ Parameter #1 [ <optional> $format_name ]
}
}
@@ -699,7 +692,7 @@ Extension [ <persistent> extension #113 yaf version 3.1.4 ] {
}
}
- Class [ <internal:yaf> class Yaf_Request_Http extends Yaf_Request_Abstract ] {
+ Class [ <internal:yaf> final class Yaf_Request_Http extends Yaf_Request_Abstract ] {
- Constants [0] {
}
@@ -710,18 +703,7 @@ Extension [ <persistent> extension #113 yaf version 3.1.4 ] {
- Static methods [0] {
}
- - Properties [11] {
- Property [ <default> public $module ]
- Property [ <default> public $controller ]
- Property [ <default> public $action ]
- Property [ <default> public $method ]
- Property [ <default> protected $params ]
- Property [ <default> protected $language ]
- Property [ <default> protected $_exception ]
- Property [ <default> protected $_base_uri ]
- Property [ <default> protected $uri ]
- Property [ <default> protected $dispatched ]
- Property [ <default> protected $routed ]
+ - Properties [0] {
}
- Methods [40] {
@@ -752,9 +734,6 @@ Extension [ <persistent> extension #113 yaf version 3.1.4 ] {
Method [ <internal:yaf, ctor> public method __construct ] {
}
- Method [ <internal:yaf> private method __clone ] {
- }
-
Method [ <internal:yaf, inherits Yaf_Request_Abstract> public method isGet ] {
- Parameters [0] {
@@ -841,6 +820,12 @@ Extension [ <persistent> extension #113 yaf version 3.1.4 ] {
}
}
+ Method [ <internal:yaf, inherits Yaf_Request_Abstract> public method clearParams ] {
+
+ - Parameters [0] {
+ }
+ }
+
Method [ <internal:yaf, inherits Yaf_Request_Abstract> public method getException ] {
- Parameters [0] {
@@ -867,22 +852,25 @@ Extension [ <persistent> extension #113 yaf version 3.1.4 ] {
Method [ <internal:yaf, inherits Yaf_Request_Abstract> public method setModuleName ] {
- - Parameters [1] {
+ - Parameters [2] {
Parameter #0 [ <required> $module ]
+ Parameter #1 [ <optional> $format_name ]
}
}
Method [ <internal:yaf, inherits Yaf_Request_Abstract> public method setControllerName ] {
- - Parameters [1] {
+ - Parameters [2] {
Parameter #0 [ <required> $controller ]
+ Parameter #1 [ <optional> $format_name ]
}
}
Method [ <internal:yaf, inherits Yaf_Request_Abstract> public method setActionName ] {
- - Parameters [1] {
+ - Parameters [2] {
Parameter #0 [ <required> $action ]
+ Parameter #1 [ <optional> $format_name ]
}
}
@@ -965,27 +953,13 @@ Extension [ <persistent> extension #113 yaf version 3.1.4 ] {
- Static methods [0] {
}
- - Properties [11] {
- Property [ <default> public $module ]
- Property [ <default> public $controller ]
- Property [ <default> public $action ]
- Property [ <default> public $method ]
- Property [ <default> protected $params ]
- Property [ <default> protected $language ]
- Property [ <default> protected $_exception ]
- Property [ <default> protected $_base_uri ]
- Property [ <default> protected $uri ]
- Property [ <default> protected $dispatched ]
- Property [ <default> protected $routed ]
+ - Properties [0] {
}
- Methods [39] {
Method [ <internal:yaf, ctor> public method __construct ] {
}
- Method [ <internal:yaf> private method __clone ] {
- }
-
Method [ <internal:yaf> public method getQuery ] {
}
@@ -1093,6 +1067,12 @@ Extension [ <persistent> extension #113 yaf version 3.1.4 ] {
}
}
+ Method [ <internal:yaf, inherits Yaf_Request_Abstract> public method clearParams ] {
+
+ - Parameters [0] {
+ }
+ }
+
Method [ <internal:yaf, inherits Yaf_Request_Abstract> public method getException ] {
- Parameters [0] {
@@ -1119,22 +1099,25 @@ Extension [ <persistent> extension #113 yaf version 3.1.4 ] {
Method [ <internal:yaf, inherits Yaf_Request_Abstract> public method setModuleName ] {
- - Parameters [1] {
+ - Parameters [2] {
Parameter #0 [ <required> $module ]
+ Parameter #1 [ <optional> $format_name ]
}
}
Method [ <internal:yaf, inherits Yaf_Request_Abstract> public method setControllerName ] {
- - Parameters [1] {
+ - Parameters [2] {
Parameter #0 [ <required> $controller ]
+ Parameter #1 [ <optional> $format_name ]
}
}
Method [ <internal:yaf, inherits Yaf_Request_Abstract> public method setActionName ] {
- - Parameters [1] {
+ - Parameters [2] {
Parameter #0 [ <required> $action ]
+ Parameter #1 [ <optional> $format_name ]
}
}
@@ -1216,28 +1199,16 @@ Extension [ <persistent> extension #113 yaf version 3.1.4 ] {
- Static methods [0] {
}
- - Properties [3] {
- Property [ <default> protected $_header ]
- Property [ <default> protected $_body ]
- Property [ <default> protected $_sendheader ]
+ - Properties [0] {
}
- - Methods [10] {
+ - Methods [8] {
Method [ <internal:yaf, ctor> public method __construct ] {
- Parameters [0] {
}
}
- Method [ <internal:yaf, dtor> public method __destruct ] {
-
- - Parameters [0] {
- }
- }
-
- Method [ <internal:yaf> private method __clone ] {
- }
-
Method [ <internal:yaf> public method __toString ] {
}
@@ -1287,7 +1258,7 @@ Extension [ <persistent> extension #113 yaf version 3.1.4 ] {
}
}
- Class [ <internal:yaf> class Yaf_Response_Http extends Yaf_Response_Abstract ] {
+ Class [ <internal:yaf> final class Yaf_Response_Http extends Yaf_Response_Abstract ] {
- Constants [1] {
Constant [ public string DEFAULT_BODY ] { content }
@@ -1299,14 +1270,10 @@ Extension [ <persistent> extension #113 yaf version 3.1.4 ] {
- Static methods [0] {
}
- - Properties [4] {
- Property [ <default> protected $_header ]
- Property [ <default> protected $_body ]
- Property [ <default> protected $_sendheader ]
- Property [ <default> protected $_response_code ]
+ - Properties [0] {
}
- - Methods [14] {
+ - Methods [13] {
Method [ <internal:yaf> public method setHeader ] {
- Parameters [4] {
@@ -1356,12 +1323,6 @@ Extension [ <persistent> extension #113 yaf version 3.1.4 ] {
}
}
- Method [ <internal:yaf, inherits Yaf_Response_Abstract, dtor> public method __destruct ] {
-
- - Parameters [0] {
- }
- }
-
Method [ <internal:yaf, inherits Yaf_Response_Abstract> public method __toString ] {
}
@@ -1417,25 +1378,16 @@ Extension [ <persistent> extension #113 yaf version 3.1.4 ] {
- Static methods [0] {
}
- - Properties [3] {
- Property [ <default> protected $_header ]
- Property [ <default> protected $_body ]
- Property [ <default> protected $_sendheader ]
+ - Properties [0] {
}
- - Methods [9] {
+ - Methods [8] {
Method [ <internal:yaf, inherits Yaf_Response_Abstract, ctor> public method __construct ] {
- Parameters [0] {
}
}
- Method [ <internal:yaf, inherits Yaf_Response_Abstract, dtor> public method __destruct ] {
-
- - Parameters [0] {
- }
- }
-
Method [ <internal:yaf, inherits Yaf_Response_Abstract> public method __toString ] {
}
@@ -1496,17 +1448,20 @@ Extension [ <persistent> extension #113 yaf version 3.1.4 ] {
- Static methods [0] {
}
- - Properties [7] {
- Property [ <default> public $actions ]
- Property [ <default> protected $_module ]
- Property [ <default> protected $_name ]
- Property [ <default> protected $_request ]
- Property [ <default> protected $_response ]
- Property [ <default> protected $_invoke_args ]
- Property [ <default> protected $_view ]
+ - Properties [0] {
}
- Methods [15] {
+ Method [ <internal:yaf, ctor> public method __construct ] {
+
+ - Parameters [4] {
+ Parameter #0 [ <required> $request ]
+ Parameter #1 [ <required> $response ]
+ Parameter #2 [ <required> $view ]
+ Parameter #3 [ <optional> array or NULL $args ]
+ }
+ }
+
Method [ <internal:yaf> protected method render ] {
- Parameters [2] {
@@ -1535,13 +1490,19 @@ Extension [ <persistent> extension #113 yaf version 3.1.4 ] {
}
}
- Method [ <internal:yaf> public method getModuleName ] {
+ Method [ <internal:yaf> public method getView ] {
- Parameters [0] {
}
}
- Method [ <internal:yaf> public method getView ] {
+ Method [ <internal:yaf> public method getName ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:yaf> public method getModuleName ] {
- Parameters [0] {
}
@@ -1596,12 +1557,6 @@ Extension [ <persistent> extension #113 yaf version 3.1.4 ] {
Parameter #0 [ <required> $name ]
}
}
-
- Method [ <internal:yaf, ctor> final public method __construct ] {
- }
-
- Method [ <internal:yaf> final private method __clone ] {
- }
}
}
@@ -1616,24 +1571,30 @@ Extension [ <persistent> extension #113 yaf version 3.1.4 ] {
- Static methods [0] {
}
- - Properties [8] {
- Property [ <default> public $actions ]
- Property [ <default> protected $_module ]
- Property [ <default> protected $_name ]
- Property [ <default> protected $_request ]
- Property [ <default> protected $_response ]
- Property [ <default> protected $_invoke_args ]
- Property [ <default> protected $_view ]
+ - Properties [1] {
Property [ <default> protected $_controller ]
}
- - Methods [16] {
+ - Methods [18] {
Method [ <internal:yaf> abstract public method execute ] {
}
Method [ <internal:yaf> public method getController ] {
}
+ Method [ <internal:yaf> public method getControllerName ] {
+ }
+
+ Method [ <internal:yaf, inherits Yaf_Controller_Abstract, ctor> public method __construct ] {
+
+ - Parameters [4] {
+ Parameter #0 [ <required> $request ]
+ Parameter #1 [ <required> $response ]
+ Parameter #2 [ <required> $view ]
+ Parameter #3 [ <optional> array or NULL $args ]
+ }
+ }
+
Method [ <internal:yaf, inherits Yaf_Controller_Abstract> protected method render ] {
- Parameters [2] {
@@ -1662,13 +1623,19 @@ Extension [ <persistent> extension #113 yaf version 3.1.4 ] {
}
}
- Method [ <internal:yaf, inherits Yaf_Controller_Abstract> public method getModuleName ] {
+ Method [ <internal:yaf, inherits Yaf_Controller_Abstract> public method getView ] {
- Parameters [0] {
}
}
- Method [ <internal:yaf, inherits Yaf_Controller_Abstract> public method getView ] {
+ Method [ <internal:yaf, inherits Yaf_Controller_Abstract> public method getName ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:yaf, inherits Yaf_Controller_Abstract> public method getModuleName ] {
- Parameters [0] {
}
@@ -1723,13 +1690,10 @@ Extension [ <persistent> extension #113 yaf version 3.1.4 ] {
Parameter #0 [ <required> $name ]
}
}
-
- Method [ <internal:yaf, inherits Yaf_Controller_Abstract, ctor> final public method __construct ] {
- }
}
}
- Class [ <internal:yaf> abstract class Yaf_Config_Abstract ] {
+ Class [ <internal:yaf> <iterateable> abstract class Yaf_Config_Abstract implements Iterator, Traversable, ArrayAccess, Countable ] {
- Constants [0] {
}
@@ -1740,27 +1704,119 @@ Extension [ <persistent> extension #113 yaf version 3.1.4 ] {
- Static methods [0] {
}
- - Properties [2] {
- Property [ <default> protected $_config ]
- Property [ <default> protected $_readonly ]
+ - Properties [0] {
}
- - Methods [4] {
- Method [ <internal:yaf> abstract public method get ] {
+ - Methods [16] {
+ Method [ <internal:yaf> public method get ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <optional> $name ]
+ }
+ }
+
+ Method [ <internal:yaf, prototype Countable> public method count ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:yaf> public method toArray ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:yaf, prototype ArrayAccess> public method offsetUnset ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $name ]
+ }
+ }
+
+ Method [ <internal:yaf, prototype Iterator> public method rewind ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:yaf, prototype Iterator> public method current ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:yaf, prototype Iterator> public method key ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:yaf, prototype Iterator> public method next ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:yaf, prototype Iterator> public method valid ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:yaf> public method __isset ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $name ]
+ }
+ }
+
+ Method [ <internal:yaf> public method __get ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <optional> $name ]
+ }
+ }
+
+ Method [ <internal:yaf, prototype ArrayAccess> public method offsetGet ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <optional> $name ]
+ }
+ }
+
+ Method [ <internal:yaf, prototype ArrayAccess> public method offsetExists ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $name ]
+ }
+ }
+
+ Method [ <internal:yaf, prototype ArrayAccess> abstract public method offsetSet ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $name ]
+ Parameter #1 [ <required> $value ]
+ }
}
Method [ <internal:yaf> abstract public method set ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $name ]
+ Parameter #1 [ <required> $value ]
+ }
}
Method [ <internal:yaf> abstract public method readonly ] {
- }
- Method [ <internal:yaf> abstract public method toArray ] {
+ - Parameters [0] {
+ }
}
}
}
- Class [ <internal:yaf> <iterateable> final class Yaf_Config_Ini extends Yaf_Config_Abstract implements Iterator, Traversable, ArrayAccess, Countable ] {
+ Class [ <internal:yaf> <iterateable> final class Yaf_Config_Ini extends Yaf_Config_Abstract implements Countable, ArrayAccess, Traversable, Iterator ] {
- Constants [0] {
}
@@ -1771,9 +1827,7 @@ Extension [ <persistent> extension #113 yaf version 3.1.4 ] {
- Static methods [0] {
}
- - Properties [2] {
- Property [ <default> protected $_config ]
- Property [ <default> protected $_readonly ]
+ - Properties [0] {
}
- Methods [18] {
@@ -1785,13 +1839,6 @@ Extension [ <persistent> extension #113 yaf version 3.1.4 ] {
}
}
- Method [ <internal:yaf> public method __isset ] {
-
- - Parameters [1] {
- Parameter #0 [ <required> $name ]
- }
- }
-
Method [ <internal:yaf, overwrites Yaf_Config_Abstract, prototype Yaf_Config_Abstract> public method get ] {
- Parameters [1] {
@@ -1807,101 +1854,108 @@ Extension [ <persistent> extension #113 yaf version 3.1.4 ] {
}
}
- Method [ <internal:yaf, prototype Countable> public method count ] {
+ Method [ <internal:yaf, overwrites Yaf_Config_Abstract, prototype Yaf_Config_Abstract> public method readonly ] {
- Parameters [0] {
}
}
- Method [ <internal:yaf, prototype Iterator> public method rewind ] {
+ Method [ <internal:yaf, overwrites Yaf_Config_Abstract, prototype ArrayAccess> public method offsetGet ] {
- - Parameters [0] {
+ - Parameters [1] {
+ Parameter #0 [ <optional> $name ]
}
}
- Method [ <internal:yaf, prototype Iterator> public method current ] {
+ Method [ <internal:yaf, overwrites Yaf_Config_Abstract, prototype Yaf_Config_Abstract> public method offsetSet ] {
- - Parameters [0] {
+ - Parameters [2] {
+ Parameter #0 [ <required> $name ]
+ Parameter #1 [ <required> $value ]
}
}
- Method [ <internal:yaf, prototype Iterator> public method next ] {
+ Method [ <internal:yaf> public method __set ] {
- - Parameters [0] {
+ - Parameters [2] {
+ Parameter #0 [ <required> $name ]
+ Parameter #1 [ <required> $value ]
}
}
- Method [ <internal:yaf, prototype Iterator> public method valid ] {
+ Method [ <internal:yaf, inherits Yaf_Config_Abstract, prototype Countable> public method count ] {
- Parameters [0] {
}
}
- Method [ <internal:yaf, prototype Iterator> public method key ] {
+ Method [ <internal:yaf, inherits Yaf_Config_Abstract> public method toArray ] {
- Parameters [0] {
}
}
- Method [ <internal:yaf, overwrites Yaf_Config_Abstract, prototype Yaf_Config_Abstract> public method toArray ] {
+ Method [ <internal:yaf, inherits Yaf_Config_Abstract, prototype ArrayAccess> public method offsetUnset ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $name ]
+ }
+ }
+
+ Method [ <internal:yaf, inherits Yaf_Config_Abstract, prototype Iterator> public method rewind ] {
- Parameters [0] {
}
}
- Method [ <internal:yaf, overwrites Yaf_Config_Abstract, prototype Yaf_Config_Abstract> public method readonly ] {
+ Method [ <internal:yaf, inherits Yaf_Config_Abstract, prototype Iterator> public method current ] {
- Parameters [0] {
}
}
- Method [ <internal:yaf, prototype ArrayAccess> public method offsetUnset ] {
+ Method [ <internal:yaf, inherits Yaf_Config_Abstract, prototype Iterator> public method key ] {
- - Parameters [1] {
- Parameter #0 [ <required> $name ]
+ - Parameters [0] {
}
}
- Method [ <internal:yaf, prototype ArrayAccess> public method offsetGet ] {
+ Method [ <internal:yaf, inherits Yaf_Config_Abstract, prototype Iterator> public method next ] {
- - Parameters [1] {
- Parameter #0 [ <required> $name ]
+ - Parameters [0] {
}
}
- Method [ <internal:yaf, prototype ArrayAccess> public method offsetExists ] {
+ Method [ <internal:yaf, inherits Yaf_Config_Abstract, prototype Iterator> public method valid ] {
- - Parameters [1] {
- Parameter #0 [ <required> $name ]
+ - Parameters [0] {
}
}
- Method [ <internal:yaf, prototype ArrayAccess> public method offsetSet ] {
+ Method [ <internal:yaf, inherits Yaf_Config_Abstract> public method __isset ] {
- - Parameters [2] {
+ - Parameters [1] {
Parameter #0 [ <required> $name ]
- Parameter #1 [ <required> $value ]
}
}
- Method [ <internal:yaf> public method __get ] {
+ Method [ <internal:yaf, inherits Yaf_Config_Abstract> public method __get ] {
- Parameters [1] {
Parameter #0 [ <optional> $name ]
}
}
- Method [ <internal:yaf> public method __set ] {
+ Method [ <internal:yaf, inherits Yaf_Config_Abstract, prototype ArrayAccess> public method offsetExists ] {
- - Parameters [2] {
+ - Parameters [1] {
Parameter #0 [ <required> $name ]
- Parameter #1 [ <required> $value ]
}
}
}
}
- Class [ <internal:yaf> <iterateable> final class Yaf_Config_Simple extends Yaf_Config_Abstract implements Iterator, Traversable, ArrayAccess, Countable ] {
+ Class [ <internal:yaf> <iterateable> final class Yaf_Config_Simple extends Yaf_Config_Abstract implements Countable, ArrayAccess, Traversable, Iterator ] {
- Constants [0] {
}
@@ -1912,35 +1966,40 @@ Extension [ <persistent> extension #113 yaf version 3.1.4 ] {
- Static methods [0] {
}
- - Properties [2] {
- Property [ <default> protected $_config ]
- Property [ <default> protected $_readonly ]
+ - Properties [0] {
}
- Methods [18] {
Method [ <internal:yaf, ctor> public method __construct ] {
- Parameters [2] {
- Parameter #0 [ <required> $config_file ]
- Parameter #1 [ <optional> $section ]
+ Parameter #0 [ <required> $config ]
+ Parameter #1 [ <optional> $readonly ]
}
}
- Method [ <internal:yaf> public method __isset ] {
+ Method [ <internal:yaf, overwrites Yaf_Config_Abstract, prototype Yaf_Config_Abstract> public method set ] {
- - Parameters [1] {
+ - Parameters [2] {
Parameter #0 [ <required> $name ]
+ Parameter #1 [ <required> $value ]
}
}
- Method [ <internal:yaf, overwrites Yaf_Config_Abstract, prototype Yaf_Config_Abstract> public method get ] {
+ Method [ <internal:yaf, overwrites Yaf_Config_Abstract, prototype Yaf_Config_Abstract> public method readonly ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:yaf, overwrites Yaf_Config_Abstract, prototype ArrayAccess> public method offsetUnset ] {
- Parameters [1] {
- Parameter #0 [ <optional> $name ]
+ Parameter #0 [ <required> $name ]
}
}
- Method [ <internal:yaf, overwrites Yaf_Config_Abstract, prototype Yaf_Config_Abstract> public method set ] {
+ Method [ <internal:yaf> public method __set ] {
- Parameters [2] {
Parameter #0 [ <required> $name ]
@@ -1948,97 +2007,90 @@ Extension [ <persistent> extension #113 yaf version 3.1.4 ] {
}
}
- Method [ <internal:yaf, prototype Countable> public method count ] {
+ Method [ <internal:yaf, overwrites Yaf_Config_Abstract, prototype Yaf_Config_Abstract> public method offsetSet ] {
- - Parameters [0] {
+ - Parameters [2] {
+ Parameter #0 [ <required> $name ]
+ Parameter #1 [ <required> $value ]
}
}
- Method [ <internal:yaf, prototype ArrayAccess> public method offsetUnset ] {
+ Method [ <internal:yaf, inherits Yaf_Config_Abstract> public method get ] {
- Parameters [1] {
- Parameter #0 [ <required> $name ]
+ Parameter #0 [ <optional> $name ]
}
}
- Method [ <internal:yaf, prototype Iterator> public method rewind ] {
+ Method [ <internal:yaf, inherits Yaf_Config_Abstract, prototype Countable> public method count ] {
- Parameters [0] {
}
}
- Method [ <internal:yaf, prototype Iterator> public method current ] {
+ Method [ <internal:yaf, inherits Yaf_Config_Abstract> public method toArray ] {
- Parameters [0] {
}
}
- Method [ <internal:yaf, prototype Iterator> public method next ] {
+ Method [ <internal:yaf, inherits Yaf_Config_Abstract, prototype Iterator> public method rewind ] {
- Parameters [0] {
}
}
- Method [ <internal:yaf, prototype Iterator> public method valid ] {
+ Method [ <internal:yaf, inherits Yaf_Config_Abstract, prototype Iterator> public method current ] {
- Parameters [0] {
}
}
- Method [ <internal:yaf, prototype Iterator> public method key ] {
+ Method [ <internal:yaf, inherits Yaf_Config_Abstract, prototype Iterator> public method key ] {
- Parameters [0] {
}
}
- Method [ <internal:yaf, overwrites Yaf_Config_Abstract, prototype Yaf_Config_Abstract> public method readonly ] {
+ Method [ <internal:yaf, inherits Yaf_Config_Abstract, prototype Iterator> public method next ] {
- Parameters [0] {
}
}
- Method [ <internal:yaf, overwrites Yaf_Config_Abstract, prototype Yaf_Config_Abstract> public method toArray ] {
+ Method [ <internal:yaf, inherits Yaf_Config_Abstract, prototype Iterator> public method valid ] {
- Parameters [0] {
}
}
- Method [ <internal:yaf> public method __set ] {
+ Method [ <internal:yaf, inherits Yaf_Config_Abstract> public method __isset ] {
- - Parameters [2] {
+ - Parameters [1] {
Parameter #0 [ <required> $name ]
- Parameter #1 [ <required> $value ]
}
}
- Method [ <internal:yaf> public method __get ] {
+ Method [ <internal:yaf, inherits Yaf_Config_Abstract> public method __get ] {
- Parameters [1] {
Parameter #0 [ <optional> $name ]
}
}
- Method [ <internal:yaf, prototype ArrayAccess> public method offsetGet ] {
+ Method [ <internal:yaf, inherits Yaf_Config_Abstract, prototype ArrayAccess> public method offsetGet ] {
- Parameters [1] {
- Parameter #0 [ <required> $name ]
+ Parameter #0 [ <optional> $name ]
}
}
- Method [ <internal:yaf, prototype ArrayAccess> public method offsetExists ] {
+ Method [ <internal:yaf, inherits Yaf_Config_Abstract, prototype ArrayAccess> public method offsetExists ] {
- Parameters [1] {
Parameter #0 [ <required> $name ]
}
}
-
- Method [ <internal:yaf, prototype ArrayAccess> public method offsetSet ] {
-
- - Parameters [2] {
- Parameter #0 [ <required> $name ]
- Parameter #1 [ <required> $value ]
- }
- }
}
}
@@ -2090,13 +2142,14 @@ Extension [ <persistent> extension #113 yaf version 3.1.4 ] {
Method [ <internal:yaf> abstract public method getScriptPath ] {
- - Parameters [0] {
+ - Parameters [1] {
+ Parameter #0 [ <optional> $request ]
}
}
}
}
- Class [ <internal:yaf> class Yaf_View_Simple implements Yaf_View_Interface ] {
+ Class [ <internal:yaf> final class Yaf_View_Simple implements Yaf_View_Interface ] {
- Constants [0] {
}
@@ -2107,13 +2160,10 @@ Extension [ <persistent> extension #113 yaf version 3.1.4 ] {
- Static methods [0] {
}
- - Properties [3] {
- Property [ <default> protected $_tpl_vars ]
- Property [ <default> protected $_tpl_dir ]
- Property [ <default> protected $_options ]
+ - Properties [0] {
}
- - Methods [13] {
+ - Methods [12] {
Method [ <internal:yaf, ctor> final public method __construct ] {
- Parameters [2] {
@@ -2122,13 +2172,6 @@ Extension [ <persistent> extension #113 yaf version 3.1.4 ] {
}
}
- Method [ <internal:yaf> public method __isset ] {
-
- - Parameters [1] {
- Parameter #0 [ <required> $name ]
- }
- }
-
Method [ <internal:yaf> public method get ] {
- Parameters [1] {
@@ -2192,7 +2235,8 @@ Extension [ <persistent> extension #113 yaf version 3.1.4 ] {
Method [ <internal:yaf, prototype Yaf_View_Interface> public method getScriptPath ] {
- - Parameters [0] {
+ - Parameters [1] {
+ Parameter #0 [ <optional> $request ]
}
}
@@ -2224,13 +2268,14 @@ Extension [ <persistent> extension #113 yaf version 3.1.4 ] {
- Static methods [0] {
}
- - Properties [2] {
- Property [ <default> protected $_routes ]
- Property [ <default> protected $_current ]
+ - Properties [0] {
}
- Methods [7] {
Method [ <internal:yaf, ctor> public method __construct ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:yaf> public method addRoute ] {
@@ -2243,12 +2288,22 @@ Extension [ <persistent> extension #113 yaf version 3.1.4 ] {
}
Method [ <internal:yaf> public method getRoute ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $name ]
+ }
}
Method [ <internal:yaf> public method getRoutes ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:yaf> public method getCurrentRoute ] {
+
+ - Parameters [0] {
+ }
}
}
}
@@ -2285,7 +2340,7 @@ Extension [ <persistent> extension #113 yaf version 3.1.4 ] {
}
}
- Class [ <internal:yaf> class Yaf_Route_Static implements Yaf_Route_Interface ] {
+ Class [ <internal:yaf> final class Yaf_Route_Static implements Yaf_Route_Interface ] {
- Constants [0] {
}
@@ -2335,10 +2390,7 @@ Extension [ <persistent> extension #113 yaf version 3.1.4 ] {
- Static methods [0] {
}
- - Properties [3] {
- Property [ <default> protected $controller ]
- Property [ <default> protected $module ]
- Property [ <default> protected $action ]
+ - Properties [0] {
}
- Methods [3] {
@@ -2379,8 +2431,7 @@ Extension [ <persistent> extension #113 yaf version 3.1.4 ] {
- Static methods [0] {
}
- - Properties [1] {
- Property [ <default> protected $_var_name ]
+ - Properties [0] {
}
- Methods [3] {
@@ -2419,13 +2470,10 @@ Extension [ <persistent> extension #113 yaf version 3.1.4 ] {
- Static methods [0] {
}
- - Properties [3] {
- Property [ <default> protected $_route ]
- Property [ <default> protected $_default ]
- Property [ <default> protected $_verify ]
+ - Properties [0] {
}
- - Methods [3] {
+ - Methods [4] {
Method [ <internal:yaf, ctor> public method __construct ] {
- Parameters [3] {
@@ -2435,6 +2483,13 @@ Extension [ <persistent> extension #113 yaf version 3.1.4 ] {
}
}
+ Method [ <internal:yaf> public method match ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $uri ]
+ }
+ }
+
Method [ <internal:yaf, prototype Yaf_Route_Interface> public method route ] {
- Parameters [1] {
@@ -2463,15 +2518,10 @@ Extension [ <persistent> extension #113 yaf version 3.1.4 ] {
- Static methods [0] {
}
- - Properties [5] {
- Property [ <default> protected $_route ]
- Property [ <default> protected $_default ]
- Property [ <default> protected $_maps ]
- Property [ <default> protected $_verify ]
- Property [ <default> protected $_reverse ]
+ - Properties [0] {
}
- - Methods [3] {
+ - Methods [4] {
Method [ <internal:yaf, ctor> public method __construct ] {
- Parameters [5] {
@@ -2483,6 +2533,13 @@ Extension [ <persistent> extension #113 yaf version 3.1.4 ] {
}
}
+ Method [ <internal:yaf> public method match ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $uri ]
+ }
+ }
+
Method [ <internal:yaf, prototype Yaf_Route_Interface> public method route ] {
- Parameters [1] {
@@ -2511,9 +2568,7 @@ Extension [ <persistent> extension #113 yaf version 3.1.4 ] {
- Static methods [0] {
}
- - Properties [2] {
- Property [ <default> protected $_ctl_router ]
- Property [ <default> protected $_delimiter ]
+ - Properties [0] {
}
- Methods [3] {
@@ -2620,8 +2675,7 @@ Extension [ <persistent> extension #113 yaf version 3.1.4 ] {
- Constants [0] {
}
- - Static properties [1] {
- Property [ protected static $_instance ]
+ - Static properties [0] {
}
- Static methods [4] {
@@ -2655,26 +2709,21 @@ Extension [ <persistent> extension #113 yaf version 3.1.4 ] {
}
}
- - Properties [1] {
- Property [ <default> protected $_entries ]
+ - Properties [0] {
}
- - Methods [2] {
+ - Methods [1] {
Method [ <internal:yaf, ctor> private method __construct ] {
}
-
- Method [ <internal:yaf> private method __clone ] {
- }
}
}
- Class [ <internal:yaf> <iterateable> final class Yaf_Session implements Iterator, Traversable, ArrayAccess, Countable ] {
+ Class [ <internal:yaf> <iterateable> abstract final class Yaf_Session implements Iterator, Traversable, ArrayAccess, Countable ] {
- Constants [0] {
}
- - Static properties [1] {
- Property [ protected static $_instance ]
+ - Static properties [0] {
}
- Static methods [1] {
@@ -2685,24 +2734,13 @@ Extension [ <persistent> extension #113 yaf version 3.1.4 ] {
}
}
- - Properties [2] {
- Property [ <default> protected $_session ]
- Property [ <default> protected $_started ]
+ - Properties [0] {
}
- - Methods [24] {
+ - Methods [21] {
Method [ <internal:yaf, ctor> private method __construct ] {
}
- Method [ <internal:yaf> private method __clone ] {
- }
-
- Method [ <internal:yaf> private method __sleep ] {
- }
-
- Method [ <internal:yaf> private method __wakeup ] {
- }
-
Method [ <internal:yaf> public method start ] {
- Parameters [0] {
@@ -2744,36 +2782,6 @@ Extension [ <persistent> extension #113 yaf version 3.1.4 ] {
}
}
- Method [ <internal:yaf, prototype Iterator> public method rewind ] {
-
- - Parameters [0] {
- }
- }
-
- Method [ <internal:yaf, prototype Iterator> public method next ] {
-
- - Parameters [0] {
- }
- }
-
- Method [ <internal:yaf, prototype Iterator> public method current ] {
-
- - Parameters [0] {
- }
- }
-
- Method [ <internal:yaf, prototype Iterator> public method key ] {
-
- - Parameters [0] {
- }
- }
-
- Method [ <internal:yaf, prototype Iterator> public method valid ] {
-
- - Parameters [0] {
- }
- }
-
Method [ <internal:yaf> public method clear ] {
- Parameters [0] {
@@ -2837,6 +2845,21 @@ Extension [ <persistent> extension #113 yaf version 3.1.4 ] {
Parameter #0 [ <required> $name ]
}
}
+
+ Method [ <internal:Core, inherits Iterator> abstract public method current ] {
+ }
+
+ Method [ <internal:Core, inherits Iterator> abstract public method next ] {
+ }
+
+ Method [ <internal:Core, inherits Iterator> abstract public method key ] {
+ }
+
+ Method [ <internal:Core, inherits Iterator> abstract public method valid ] {
+ }
+
+ Method [ <internal:Core, inherits Iterator> abstract public method rewind ] {
+ }
}
}
diff --git a/php-pecl-yaf.spec b/php-pecl-yaf.spec
index 9f27fdd..6177924 100644
--- a/php-pecl-yaf.spec
+++ b/php-pecl-yaf.spec
@@ -26,7 +26,7 @@
Summary: Yet Another Framework
Name: %{?sub_prefix}php-pecl-yaf
-Version: 3.1.4
+Version: 3.2.0
%if 0%{?gh_date:1}
Release: 0.12.%{gh_date}git%{gh_short}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{pecl_name}-%{version}-%{gh_short}.tar.gz
@@ -155,6 +155,9 @@ done
%check
+# fix path
+sed -e '/base_uri:protected/s/syaf/s/' -i ?TS/tests/issue231.phpt
+
cd NTS
: Minimal load test for NTS extension
%{__php} --no-php-ini \
@@ -220,6 +223,11 @@ fi
%changelog
+* Sun Apr 19 2020 Remi Collet <remi@remirepo.net> - 3.2.0-1
+- update to 3.2.0 (beta)
+- open https://github.com/laruence/yaf/pull/474
+ relax test, don't rely on sources path
+
* Wed Apr 1 2020 Remi Collet <remi@remirepo.net> - 3.1.4-1
- update to 3.1.4