summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-03-16 06:40:46 +0100
committerRemi Collet <remi@remirepo.net>2020-03-16 06:40:46 +0100
commitf65c6a9a9614bafd5035c2f6d0e340d675c83e43 (patch)
tree6f16f9d55d6dace718e05489646d03d4f0ddcdc7
parentdc7a4ff9020d347079b13009b75bbd1398ac9288 (diff)
v3.1.1
-rw-r--r--PHPINFO3
-rw-r--r--REFLECTION22
-rw-r--r--php-pecl-yaf.spec16
-rw-r--r--yaf.ini5
4 files changed, 23 insertions, 23 deletions
diff --git a/PHPINFO b/PHPINFO
index 5a23a2a..842eb10 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,7 +2,7 @@
yaf
yaf support => enabled
-Version => 3.0.9
+Version => 3.1.1
Supports => http://pecl.php.net/package/yaf
Directive => Local Value => Master Value
@@ -13,6 +13,5 @@ yaf.use_spl_autoload => Off => Off
yaf.forward_limit => 5 => 5
yaf.name_suffix => On => On
yaf.name_separator => no value => no value
-yaf.st_compatible => Off => Off
yaf.environ => product => product
yaf.use_namespace => Off => Off
diff --git a/REFLECTION b/REFLECTION
index 40847bd..50538a3 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #107 yaf version 3.0.9 ] {
+Extension [ <persistent> extension #112 yaf version 3.1.1 ] {
- Dependencies {
Dependency [ spl (Required) ]
@@ -28,9 +28,6 @@ Extension [ <persistent> extension #107 yaf version 3.0.9 ] {
Entry [ yaf.name_separator <ALL> ]
Current = ''
}
- Entry [ yaf.st_compatible <ALL> ]
- Current = '0'
- }
Entry [ yaf.environ <SYSTEM> ]
Current = 'product'
}
@@ -40,7 +37,7 @@ Extension [ <persistent> extension #107 yaf version 3.0.9 ] {
}
- Constants [12] {
- Constant [ string YAF_VERSION ] { 3.0.9 }
+ Constant [ string YAF_VERSION ] { 3.1.1 }
Constant [ string YAF_ENVIRON ] { product }
Constant [ int YAF_ERR_STARTUP_FAILED ] { 512 }
Constant [ int YAF_ERR_ROUTE_FAILED ] { 513 }
@@ -682,7 +679,8 @@ Extension [ <persistent> extension #107 yaf version 3.0.9 ] {
Method [ <internal:yaf> public method setDispatched ] {
- - Parameters [0] {
+ - Parameters [1] {
+ Parameter #0 [ <required> $dispatched ]
}
}
@@ -695,7 +693,7 @@ Extension [ <persistent> extension #107 yaf version 3.0.9 ] {
Method [ <internal:yaf> public method setRouted ] {
- Parameters [1] {
- Parameter #0 [ <optional> $flag ]
+ Parameter #0 [ <required> $flag ]
}
}
}
@@ -934,7 +932,8 @@ Extension [ <persistent> extension #107 yaf version 3.0.9 ] {
Method [ <internal:yaf, inherits Yaf_Request_Abstract> public method setDispatched ] {
- - Parameters [0] {
+ - Parameters [1] {
+ Parameter #0 [ <required> $dispatched ]
}
}
@@ -947,7 +946,7 @@ Extension [ <persistent> extension #107 yaf version 3.0.9 ] {
Method [ <internal:yaf, inherits Yaf_Request_Abstract> public method setRouted ] {
- Parameters [1] {
- Parameter #0 [ <optional> $flag ]
+ Parameter #0 [ <required> $flag ]
}
}
}
@@ -1185,7 +1184,8 @@ Extension [ <persistent> extension #107 yaf version 3.0.9 ] {
Method [ <internal:yaf, inherits Yaf_Request_Abstract> public method setDispatched ] {
- - Parameters [0] {
+ - Parameters [1] {
+ Parameter #0 [ <required> $dispatched ]
}
}
@@ -1198,7 +1198,7 @@ Extension [ <persistent> extension #107 yaf version 3.0.9 ] {
Method [ <internal:yaf, inherits Yaf_Request_Abstract> public method setRouted ] {
- Parameters [1] {
- Parameter #0 [ <optional> $flag ]
+ Parameter #0 [ <required> $flag ]
}
}
}
diff --git a/php-pecl-yaf.spec b/php-pecl-yaf.spec
index 7787004..fdf4362 100644
--- a/php-pecl-yaf.spec
+++ b/php-pecl-yaf.spec
@@ -1,6 +1,6 @@
# remirepo spec file for php-pecl-yaf
#
-# Copyright (c) 2012-2019 Remi Collet
+# Copyright (c) 2012-2020 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
@@ -26,16 +26,16 @@
Summary: Yet Another Framework
Name: %{?sub_prefix}php-pecl-yaf
-Version: 3.0.9
+Version: 3.1.1
%if 0%{?gh_date:1}
Release: 0.12.%{gh_date}git%{gh_short}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{pecl_name}-%{version}-%{gh_short}.tar.gz
%else
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
-Source: http://pecl.php.net/get/%{pecl_name}-%{version}%{?prever}.tgz
+Source: https://pecl.php.net/get/%{pecl_name}-%{version}%{?prever}.tgz
%endif
License: PHP
-URL: http://pecl.php.net/package/yaf
+URL: https://pecl.php.net/package/yaf
Source1: %{pecl_name}.ini
BuildRequires: %{?dtsprefix}gcc
@@ -155,8 +155,6 @@ done
%check
-sed -e 's/Catchable/%s/' -i ?TS/tests/022.phpt
-
cd NTS
: Minimal load test for NTS extension
%{__php} --no-php-ini \
@@ -222,6 +220,12 @@ fi
%changelog
+* Mon Mar 16 2020 Remi Collet <remi@remirepo.net> - 3.1.1-1
+- update to 3.1.1
+
+* Sun Mar 15 2020 Remi Collet <remi@remirepo.net> - 3.1.0-1
+- update to 3.1.0
+
* Thu Dec 19 2019 Remi Collet <remi@remirepo.net> - 3.0.9-1
- update to 3.0.9
diff --git a/yaf.ini b/yaf.ini
index 83c7591..1b8827c 100644
--- a/yaf.ini
+++ b/yaf.ini
@@ -18,7 +18,6 @@ extension = yaf.so
; When this value is Off(default), Yaf_Loader::autoload() will always return TRUE.
;yaf.use_spl_autoload = 0
-
; The max forward count, default is 5.
; That means you can have a max value of 5 in the forward stack.
; This is a protection for prevent recursive Yaf_Controller_Abstract::forward().
@@ -26,14 +25,13 @@ extension = yaf.so
; When this On, Yaf_Loader will identify a class by it's suffix to decide whether it is a MVC Class.
; When this Off, Yaf_Loader will look at the prefix of the class name.
-;yaf.name_suffix = 1
+;yaf.name_suffix = On
; When this is not empty, Yaf_Loader will identify the class suffix and string value of this.
; For example, when this value is "_", Yaf_Loader will take Index_Controller as a Controller Class,
; IndexController as a normal class.
;yaf.name_separator = ""
-
; If this is On, and in the meantime you are using ini config file as the parameter of Yaf_Application(),
; the compiling result of the ini config file will be cached in the PHP process.
;yaf.cache_config = 0
@@ -48,4 +46,3 @@ extension = yaf.so
; Yaf_Controller_Abstract => \Yaf\Controller_Abstract
; (Abstract is the keyword, can not used as a class name)
;yaf.use_namespace = 0
-