summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-05-11 12:13:37 +0200
committerRemi Collet <remi@remirepo.net>2020-05-11 12:13:37 +0200
commit5a6b77fef71ac1a2963f4c7cd113f976f295cdb8 (patch)
tree1be682c2afe7afa4a1235999f03abdc4b568db35
parent50ba9c1188ef4906e4d45fb043fc8205d0a986f3 (diff)
v3.2.2
-rw-r--r--PHPINFO2
-rw-r--r--REFLECTION265
-rw-r--r--php-pecl-yaf.spec10
3 files changed, 210 insertions, 67 deletions
diff --git a/PHPINFO b/PHPINFO
index ea46cee..166b431 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,7 +2,7 @@
yaf
yaf support => enabled
-Version => 3.2.1
+Version => 3.2.2
Supports => http://pecl.php.net/package/yaf
Directive => Local Value => Master Value
diff --git a/REFLECTION b/REFLECTION
index 8c33b92..fb5f152 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #113 yaf version 3.2.1 ] {
+Extension [ <persistent> extension #114 yaf version 3.2.2 ] {
- Dependencies {
Dependency [ spl (Required) ]
@@ -37,7 +37,7 @@ Extension [ <persistent> extension #113 yaf version 3.2.1 ] {
}
- Constants [13] {
- Constant [ string YAF_VERSION ] { 3.2.1 }
+ Constant [ string YAF_VERSION ] { 3.2.2 }
Constant [ string YAF_ENVIRON ] { product }
Constant [ int YAF_ERR_STARTUP_FAILED ] { 512 }
Constant [ int YAF_ERR_ROUTE_FAILED ] { 513 }
@@ -202,7 +202,7 @@ Extension [ <persistent> extension #113 yaf version 3.2.1 ] {
- Properties [0] {
}
- - Methods [24] {
+ - Methods [25] {
Method [ <internal:yaf, ctor> private method __construct ] {
}
@@ -240,6 +240,13 @@ Extension [ <persistent> extension #113 yaf version 3.2.1 ] {
}
}
+ Method [ <internal:yaf> public method setResponse ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $response ]
+ }
+ }
+
Method [ <internal:yaf> public method getApplication ] {
- Parameters [0] {
@@ -485,7 +492,7 @@ Extension [ <persistent> extension #113 yaf version 3.2.1 ] {
- Properties [0] {
}
- - Methods [32] {
+ - Methods [39] {
Method [ <internal:yaf> public method isGet ] {
- Parameters [0] {
@@ -540,6 +547,62 @@ Extension [ <persistent> extension #113 yaf version 3.2.1 ] {
}
}
+ Method [ <internal:yaf> public method getQuery ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $name ]
+ Parameter #1 [ <optional> $default ]
+ }
+ }
+
+ Method [ <internal:yaf> public method getRequest ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $name ]
+ Parameter #1 [ <optional> $default ]
+ }
+ }
+
+ Method [ <internal:yaf> public method getPost ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $name ]
+ Parameter #1 [ <optional> $default ]
+ }
+ }
+
+ Method [ <internal:yaf> public method getCookie ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $name ]
+ Parameter #1 [ <optional> $default ]
+ }
+ }
+
+ Method [ <internal:yaf> public method getRaw ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $name ]
+ Parameter #1 [ <optional> $default ]
+ }
+ }
+
+ Method [ <internal:yaf> public method getFiles ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $name ]
+ Parameter #1 [ <optional> $default ]
+ }
+ }
+
+ Method [ <internal:yaf> public method get ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $name ]
+ Parameter #1 [ <optional> $default ]
+ }
+ }
+
Method [ <internal:yaf> public method getServer ] {
- Parameters [2] {
@@ -670,26 +733,26 @@ Extension [ <persistent> extension #113 yaf version 3.2.1 ] {
}
}
- Method [ <internal:yaf> public method isDispatched ] {
+ Method [ <internal:yaf> final public method isDispatched ] {
- Parameters [0] {
}
}
- Method [ <internal:yaf> public method setDispatched ] {
+ Method [ <internal:yaf> final public method setDispatched ] {
- Parameters [1] {
Parameter #0 [ <required> $dispatched ]
}
}
- Method [ <internal:yaf> public method isRouted ] {
+ Method [ <internal:yaf> final public method isRouted ] {
- Parameters [0] {
}
}
- Method [ <internal:yaf> public method setRouted ] {
+ Method [ <internal:yaf> final public method setRouted ] {
- Parameters [1] {
Parameter #0 [ <required> $flag ]
@@ -698,7 +761,7 @@ Extension [ <persistent> extension #113 yaf version 3.2.1 ] {
}
}
- Class [ <internal:yaf> final class Yaf_Request_Http extends Yaf_Request_Abstract ] {
+ Class [ <internal:yaf> class Yaf_Request_Http extends Yaf_Request_Abstract ] {
- Constants [0] {
}
@@ -713,30 +776,6 @@ Extension [ <persistent> extension #113 yaf version 3.2.1 ] {
}
- Methods [40] {
- Method [ <internal:yaf> public method getQuery ] {
- }
-
- Method [ <internal:yaf> public method getRequest ] {
- }
-
- Method [ <internal:yaf> public method getPost ] {
- }
-
- Method [ <internal:yaf> public method getCookie ] {
- }
-
- Method [ <internal:yaf> public method getRaw ] {
- }
-
- Method [ <internal:yaf> public method getFiles ] {
- }
-
- Method [ <internal:yaf> public method get ] {
- }
-
- Method [ <internal:yaf, overwrites Yaf_Request_Abstract, prototype Yaf_Request_Abstract> public method isXmlHttpRequest ] {
- }
-
Method [ <internal:yaf, ctor> public method __construct ] {
}
@@ -788,6 +827,68 @@ Extension [ <persistent> extension #113 yaf version 3.2.1 ] {
}
}
+ Method [ <internal:yaf, inherits Yaf_Request_Abstract> public method isXmlHttpRequest ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:yaf, inherits Yaf_Request_Abstract> public method getQuery ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $name ]
+ Parameter #1 [ <optional> $default ]
+ }
+ }
+
+ Method [ <internal:yaf, inherits Yaf_Request_Abstract> public method getRequest ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $name ]
+ Parameter #1 [ <optional> $default ]
+ }
+ }
+
+ Method [ <internal:yaf, inherits Yaf_Request_Abstract> public method getPost ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $name ]
+ Parameter #1 [ <optional> $default ]
+ }
+ }
+
+ Method [ <internal:yaf, inherits Yaf_Request_Abstract> public method getCookie ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $name ]
+ Parameter #1 [ <optional> $default ]
+ }
+ }
+
+ Method [ <internal:yaf, inherits Yaf_Request_Abstract> public method getRaw ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $name ]
+ Parameter #1 [ <optional> $default ]
+ }
+ }
+
+ Method [ <internal:yaf, inherits Yaf_Request_Abstract> public method getFiles ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $name ]
+ Parameter #1 [ <optional> $default ]
+ }
+ }
+
+ Method [ <internal:yaf, inherits Yaf_Request_Abstract> public method get ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $name ]
+ Parameter #1 [ <optional> $default ]
+ }
+ }
+
Method [ <internal:yaf, inherits Yaf_Request_Abstract> public method getServer ] {
- Parameters [2] {
@@ -918,26 +1019,26 @@ Extension [ <persistent> extension #113 yaf version 3.2.1 ] {
}
}
- Method [ <internal:yaf, inherits Yaf_Request_Abstract> public method isDispatched ] {
+ Method [ <internal:yaf, inherits Yaf_Request_Abstract> final public method isDispatched ] {
- Parameters [0] {
}
}
- Method [ <internal:yaf, inherits Yaf_Request_Abstract> public method setDispatched ] {
+ Method [ <internal:yaf, inherits Yaf_Request_Abstract> final public method setDispatched ] {
- Parameters [1] {
Parameter #0 [ <required> $dispatched ]
}
}
- Method [ <internal:yaf, inherits Yaf_Request_Abstract> public method isRouted ] {
+ Method [ <internal:yaf, inherits Yaf_Request_Abstract> final public method isRouted ] {
- Parameters [0] {
}
}
- Method [ <internal:yaf, inherits Yaf_Request_Abstract> public method setRouted ] {
+ Method [ <internal:yaf, inherits Yaf_Request_Abstract> final public method setRouted ] {
- Parameters [1] {
Parameter #0 [ <required> $flag ]
@@ -946,7 +1047,7 @@ Extension [ <persistent> extension #113 yaf version 3.2.1 ] {
}
}
- Class [ <internal:yaf> final class Yaf_Request_Simple extends Yaf_Request_Abstract ] {
+ Class [ <internal:yaf> class Yaf_Request_Simple extends Yaf_Request_Abstract ] {
- Constants [2] {
Constant [ public string SCHEME_HTTP ] { http }
@@ -962,28 +1063,10 @@ Extension [ <persistent> extension #113 yaf version 3.2.1 ] {
- Properties [0] {
}
- - Methods [39] {
+ - Methods [40] {
Method [ <internal:yaf, ctor> public method __construct ] {
}
- Method [ <internal:yaf> public method getQuery ] {
- }
-
- Method [ <internal:yaf> public method getRequest ] {
- }
-
- Method [ <internal:yaf> public method getPost ] {
- }
-
- Method [ <internal:yaf> public method getCookie ] {
- }
-
- Method [ <internal:yaf> public method getFiles ] {
- }
-
- Method [ <internal:yaf> public method get ] {
- }
-
Method [ <internal:yaf, overwrites Yaf_Request_Abstract, prototype Yaf_Request_Abstract> public method isXmlHttpRequest ] {
}
@@ -1035,6 +1118,62 @@ Extension [ <persistent> extension #113 yaf version 3.2.1 ] {
}
}
+ Method [ <internal:yaf, inherits Yaf_Request_Abstract> public method getQuery ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $name ]
+ Parameter #1 [ <optional> $default ]
+ }
+ }
+
+ Method [ <internal:yaf, inherits Yaf_Request_Abstract> public method getRequest ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $name ]
+ Parameter #1 [ <optional> $default ]
+ }
+ }
+
+ Method [ <internal:yaf, inherits Yaf_Request_Abstract> public method getPost ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $name ]
+ Parameter #1 [ <optional> $default ]
+ }
+ }
+
+ Method [ <internal:yaf, inherits Yaf_Request_Abstract> public method getCookie ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $name ]
+ Parameter #1 [ <optional> $default ]
+ }
+ }
+
+ Method [ <internal:yaf, inherits Yaf_Request_Abstract> public method getRaw ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $name ]
+ Parameter #1 [ <optional> $default ]
+ }
+ }
+
+ Method [ <internal:yaf, inherits Yaf_Request_Abstract> public method getFiles ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $name ]
+ Parameter #1 [ <optional> $default ]
+ }
+ }
+
+ Method [ <internal:yaf, inherits Yaf_Request_Abstract> public method get ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $name ]
+ Parameter #1 [ <optional> $default ]
+ }
+ }
+
Method [ <internal:yaf, inherits Yaf_Request_Abstract> public method getServer ] {
- Parameters [2] {
@@ -1165,26 +1304,26 @@ Extension [ <persistent> extension #113 yaf version 3.2.1 ] {
}
}
- Method [ <internal:yaf, inherits Yaf_Request_Abstract> public method isDispatched ] {
+ Method [ <internal:yaf, inherits Yaf_Request_Abstract> final public method isDispatched ] {
- Parameters [0] {
}
}
- Method [ <internal:yaf, inherits Yaf_Request_Abstract> public method setDispatched ] {
+ Method [ <internal:yaf, inherits Yaf_Request_Abstract> final public method setDispatched ] {
- Parameters [1] {
Parameter #0 [ <required> $dispatched ]
}
}
- Method [ <internal:yaf, inherits Yaf_Request_Abstract> public method isRouted ] {
+ Method [ <internal:yaf, inherits Yaf_Request_Abstract> final public method isRouted ] {
- Parameters [0] {
}
}
- Method [ <internal:yaf, inherits Yaf_Request_Abstract> public method setRouted ] {
+ Method [ <internal:yaf, inherits Yaf_Request_Abstract> final public method setRouted ] {
- Parameters [1] {
Parameter #0 [ <required> $flag ]
@@ -1264,7 +1403,7 @@ Extension [ <persistent> extension #113 yaf version 3.2.1 ] {
}
}
- Class [ <internal:yaf> final class Yaf_Response_Http extends Yaf_Response_Abstract ] {
+ Class [ <internal:yaf> class Yaf_Response_Http extends Yaf_Response_Abstract ] {
- Constants [1] {
Constant [ public string DEFAULT_BODY ] { content }
@@ -2155,7 +2294,7 @@ Extension [ <persistent> extension #113 yaf version 3.2.1 ] {
}
}
- Class [ <internal:yaf> final class Yaf_View_Simple implements Yaf_View_Interface ] {
+ Class [ <internal:yaf> class Yaf_View_Simple implements Yaf_View_Interface ] {
- Constants [0] {
}
diff --git a/php-pecl-yaf.spec b/php-pecl-yaf.spec
index c7002a3..4aaa8e4 100644
--- a/php-pecl-yaf.spec
+++ b/php-pecl-yaf.spec
@@ -26,7 +26,7 @@
Summary: Yet Another Framework
Name: %{?sub_prefix}php-pecl-yaf
-Version: 3.2.1
+Version: 3.2.2
%if 0%{?gh_date:1}
Release: 0.12.%{gh_date}git%{gh_short}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{pecl_name}-%{version}-%{gh_short}.tar.gz
@@ -41,6 +41,7 @@ Source1: %{pecl_name}.ini
BuildRequires: %{?dtsprefix}gcc
BuildRequires: %{?scl_prefix}php-devel >= 7
BuildRequires: %{?scl_prefix}php-pear
+BuildRequires: %{?scl_prefix}php-json
BuildRequires: pcre-devel
Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
@@ -163,7 +164,7 @@ cd NTS
: Upstream test suite for NTS extension
TEST_PHP_EXECUTABLE=%{__php} \
-TEST_PHP_ARGS="-n -d extension_dir=$PWD/modules -d extension=%{pecl_name}.so" \
+TEST_PHP_ARGS="-n -d extension=json.so -d extension=$PWD/modules/%{pecl_name}.so" \
NO_INTERACTION=1 \
REPORT_EXIT_STATUS=1 \
%{__php} -n run-tests.php --show-diff
@@ -178,7 +179,7 @@ cd ../ZTS
: Upstream test suite for NTS extension
TEST_PHP_EXECUTABLE=%{__ztsphp} \
-TEST_PHP_ARGS="-n -d extension_dir=$PWD/modules -d extension=%{pecl_name}.so" \
+TEST_PHP_ARGS="-n -d extension=json.so -d extension=$PWD/modules/%{pecl_name}.so" \
NO_INTERACTION=1 \
REPORT_EXIT_STATUS=1 \
%{__ztsphp} -n run-tests.php --show-diff
@@ -220,6 +221,9 @@ fi
%changelog
+* Mon May 11 2020 Remi Collet <remi@remirepo.net> - 3.2.2-1
+- update to 3.2.2
+
* Mon Apr 20 2020 Remi Collet <remi@remirepo.net> - 3.2.1-1
- update to 3.2.1