summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2018-01-01 17:58:21 +0100
committerRemi Collet <remi@remirepo.net>2018-01-01 17:58:21 +0100
commit01335d75ff561c613932741210a759df4898b5ff (patch)
treebe735c61a096bfb578824b186329490d2f626fb5
parent4cbce24b7f2b4c14448129603a5ee9642afd3e97 (diff)
v3.0.6
-rw-r--r--REFLECTION18
-rw-r--r--php-pecl-yaf.spec11
2 files changed, 15 insertions, 14 deletions
diff --git a/REFLECTION b/REFLECTION
index b2271a1..fe80bd1 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #159 yaf version 3.0.5 ] {
+Extension [ <persistent> extension #169 yaf version 3.0.6 ] {
- Dependencies {
Dependency [ spl (Required) ]
@@ -40,7 +40,7 @@ Extension [ <persistent> extension #159 yaf version 3.0.5 ] {
}
- Constants [12] {
- Constant [ string YAF_VERSION ] { 3.0.5 }
+ Constant [ string YAF_VERSION ] { 3.0.6 }
Constant [ string YAF_ENVIRON ] { product }
Constant [ integer YAF_ERR_STARTUP_FAILED ] { 512 }
Constant [ integer YAF_ERR_ROUTE_FAILED ] { 513 }
@@ -474,8 +474,8 @@ Extension [ <persistent> extension #159 yaf version 3.0.5 ] {
Class [ <internal:yaf> abstract class Yaf_Request_Abstract ] {
- Constants [2] {
- Constant [ string SCHEME_HTTP ] { http }
- Constant [ string SCHEME_HTTPS ] { https }
+ Constant [ public string SCHEME_HTTP ] { http }
+ Constant [ public string SCHEME_HTTPS ] { https }
}
- Static properties [0] {
@@ -953,8 +953,8 @@ Extension [ <persistent> extension #159 yaf version 3.0.5 ] {
Class [ <internal:yaf> final class Yaf_Request_Simple extends Yaf_Request_Abstract ] {
- Constants [2] {
- Constant [ string SCHEME_HTTP ] { http }
- Constant [ string SCHEME_HTTPS ] { https }
+ Constant [ public string SCHEME_HTTP ] { http }
+ Constant [ public string SCHEME_HTTPS ] { https }
}
- Static properties [0] {
@@ -1204,7 +1204,7 @@ Extension [ <persistent> extension #159 yaf version 3.0.5 ] {
Class [ <internal:yaf> abstract class Yaf_Response_Abstract ] {
- Constants [1] {
- Constant [ string DEFAULT_BODY ] { content }
+ Constant [ public string DEFAULT_BODY ] { content }
}
- Static properties [0] {
@@ -1287,7 +1287,7 @@ Extension [ <persistent> extension #159 yaf version 3.0.5 ] {
Class [ <internal:yaf> class Yaf_Response_Http extends Yaf_Response_Abstract ] {
- Constants [1] {
- Constant [ string DEFAULT_BODY ] { content }
+ Constant [ public string DEFAULT_BODY ] { content }
}
- Static properties [0] {
@@ -1405,7 +1405,7 @@ Extension [ <persistent> extension #159 yaf version 3.0.5 ] {
Class [ <internal:yaf> class Yaf_Response_Cli extends Yaf_Response_Abstract ] {
- Constants [1] {
- Constant [ string DEFAULT_BODY ] { content }
+ Constant [ public string DEFAULT_BODY ] { content }
}
- Static properties [0] {
diff --git a/php-pecl-yaf.spec b/php-pecl-yaf.spec
index 54d27c8..cce396f 100644
--- a/php-pecl-yaf.spec
+++ b/php-pecl-yaf.spec
@@ -1,6 +1,6 @@
# remirepo spec file for php-pecl-yaf
#
-# Copyright (c) 2012-2017 Remi Collet
+# Copyright (c) 2012-2018 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
@@ -22,12 +22,12 @@
Summary: Yet Another Framework
Name: %{?sub_prefix}php-pecl-yaf
-Version: 3.0.5
+Version: 3.0.6
%if 0%{?gh_date:1}
Release: 0.10.%{gh_date}git%{gh_short}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{pecl_name}-%{version}-%{gh_short}.tar.gz
%else
-Release: 2%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
Source: http://pecl.php.net/get/%{pecl_name}-%{version}%{?prever}.tgz
%endif
License: PHP
@@ -174,8 +174,6 @@ REPORT_EXIT_STATUS=1 \
%if %{with_zts}
cd ../ZTS
-# https://github.com/laruence/php-yaf/issues/180
-rm tests/016.phpt
: Minimal load test for ZTS extension
%{__ztsphp} --no-php-ini \
@@ -226,6 +224,9 @@ fi
%changelog
+* Mon Jan 1 2018 Remi Collet <remi@remirepo.net> - 3.0.6-1
+- Update to 3.0.6
+
* Tue Jul 18 2017 Remi Collet <remi@remirepo.net> - 3.0.5-2
- rebuild for PHP 7.2.0beta1 new API