summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--52.patch27
-rw-r--r--php-pecl-yaconf.spec17
2 files changed, 41 insertions, 3 deletions
diff --git a/52.patch b/52.patch
new file mode 100644
index 0000000..afaefbf
--- /dev/null
+++ b/52.patch
@@ -0,0 +1,27 @@
+From 7ba54422a5f37fddf0088d3e3c0c82ec1640d220 Mon Sep 17 00:00:00 2001
+From: Remi Collet <remi@remirepo.net>
+Date: Thu, 6 Jun 2019 10:43:12 +0200
+Subject: [PATCH 1/2] fix for 7.4
+
+---
+ yaconf.c | 4 ++++
+ 1 file changed, 4 insertions(+)
+
+diff --git a/yaconf.c b/yaconf.c
+index dea7652..99e1265 100644
+--- a/yaconf.c
++++ b/yaconf.c
+@@ -121,7 +121,11 @@ static void php_yaconf_hash_destroy(HashTable *ht) /* {{{ */ {
+ zend_string *key;
+ zval *element;
+
++#if PHP_VERSION_ID < 70400
+ if (((ht)->u.flags & HASH_FLAG_INITIALIZED)) {
++#else
++ if (HT_IS_INITIALIZED(ht)) {
++#endif
+ ZEND_HASH_FOREACH_STR_KEY_VAL(ht, key, element) {
+ if (key) {
+ free(key);
+
+
diff --git a/php-pecl-yaconf.spec b/php-pecl-yaconf.spec
index 93c9892..0f864dd 100644
--- a/php-pecl-yaconf.spec
+++ b/php-pecl-yaconf.spec
@@ -1,6 +1,6 @@
# remirepo spec file for php-pecl-yaconf
#
-# Copyright (c) 2015-2018 Remi Collet
+# Copyright (c) 2015-2019 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
@@ -24,12 +24,14 @@ Version: 1.0.8
Release: 0.3.%{gh_date}.%{gh_short}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{gh_project}-%{version}-%{gh_short}.tar.gz
%else
-Release: 3%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 4%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
Source0: http://pecl.php.net/get/%{pecl_name}-%{version}.tgz
%endif
License: PHP
URL: https://github.com/%{gh_owner}/%{gh_project}
+Patch0: https://patch-diff.githubusercontent.com/raw/laruence/yaconf/pull/52.patch
+
BuildRequires: %{?dtsprefix}gcc
BuildRequires: %{?scl_prefix}php-devel > 7
BuildRequires: %{?scl_prefix}php-pear
@@ -50,9 +52,13 @@ Obsoletes: php72u-pecl-%{pecl_name} <= %{version}
Obsoletes: php72w-pecl-%{pecl_name} <= %{version}
%endif
%if "%{php_version}" > "7.3"
-Obsoletes: php73u-pecl-%{pecl_name} <= %{version}
+Obsoletes: php73-pecl-%{pecl_name} <= %{version}
Obsoletes: php73w-pecl-%{pecl_name} <= %{version}
%endif
+%if "%{php_version}" > "7.4"
+Obsoletes: php74-pecl-%{pecl_name} <= %{version}
+Obsoletes: php74w-pecl-%{pecl_name} <= %{version}
+%endif
%endif
# Package have be renamed
@@ -101,6 +107,7 @@ mv %{pecl_name}-%{version} NTS
%{?_licensedir:sed -e '/LICENSE/s/role="doc"/role="src"/' -i package.xml}
cd NTS
+%patch0 -p1 -b .pr52
# Sanity check, really often broken
extver=$(sed -n '/#define PHP_YACONF_VERSION/{s/.* "//;s/".*$//;p}' php_yaconf.h)
@@ -245,6 +252,10 @@ fi
%changelog
+* Fri Jun 7 2019 Remi Collet <remi@remirepo.net> - 1.0.8-0.4.20180622.d5f267a
+- add patch for 7.4 from
+ https://github.com/laruence/yaconf/pull/52
+
* Thu Aug 16 2018 Remi Collet <remi@remirepo.net> - 1.0.8-0.3.20180622.d5f267a
- rebuild for 7.3.0beta2 new ABI