summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2019-12-24 08:12:11 +0100
committerRemi Collet <remi@remirepo.net>2019-12-24 08:12:11 +0100
commit8a2bfdb87178355241629873acc56879290e2ed7 (patch)
tree20ddc7f6ced01681c070430e045b9b440816e019
parentbade08a9f81862cecd186ade8051abe16dc03562 (diff)
v1.0.8
-rw-r--r--52.patch27
-rw-r--r--PHPINFO4
-rw-r--r--REFLECTION14
-rw-r--r--php-pecl-yaconf.spec27
4 files changed, 24 insertions, 48 deletions
diff --git a/52.patch b/52.patch
deleted file mode 100644
index afaefbf..0000000
--- a/52.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-From 7ba54422a5f37fddf0088d3e3c0c82ec1640d220 Mon Sep 17 00:00:00 2001
-From: Remi Collet <remi@remirepo.net>
-Date: Thu, 6 Jun 2019 10:43:12 +0200
-Subject: [PATCH 1/2] fix for 7.4
-
----
- yaconf.c | 4 ++++
- 1 file changed, 4 insertions(+)
-
-diff --git a/yaconf.c b/yaconf.c
-index dea7652..99e1265 100644
---- a/yaconf.c
-+++ b/yaconf.c
-@@ -121,7 +121,11 @@ static void php_yaconf_hash_destroy(HashTable *ht) /* {{{ */ {
- zend_string *key;
- zval *element;
-
-+#if PHP_VERSION_ID < 70400
- if (((ht)->u.flags & HASH_FLAG_INITIALIZED)) {
-+#else
-+ if (HT_IS_INITIALIZED(ht)) {
-+#endif
- ZEND_HASH_FOREACH_STR_KEY_VAL(ht, key, element) {
- if (key) {
- free(key);
-
-
diff --git a/PHPINFO b/PHPINFO
index 40304bb..5922bf0 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,8 +2,8 @@
yaconf
yaconf support => enabled
-version => 1.0.7
-yaconf config last check time => Thu Jun 28 14:05:57 2018
+version => 1.0.8
+yaconf config last check time => Tue Dec 24 08:11:48 2019
parsed filename => mtime
diff --git a/REFLECTION b/REFLECTION
index d891b59..f287ef7 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #173 yaconf version 1.0.7 ] {
+Extension [ <persistent> extension #108 yaconf version 1.0.8 ] {
- INI {
Entry [ yaconf.directory <SYSTEM> ]
@@ -18,11 +18,12 @@ Extension [ <persistent> extension #173 yaconf version 1.0.7 ] {
- Static properties [0] {
}
- - Static methods [2] {
+ - Static methods [3] {
Method [ <internal:yaconf> static public method get ] {
- - Parameters [1] {
+ - Parameters [2] {
Parameter #0 [ <required> $name ]
+ Parameter #1 [ <optional> $default ]
}
}
@@ -32,6 +33,13 @@ Extension [ <persistent> extension #173 yaconf version 1.0.7 ] {
Parameter #0 [ <required> $name ]
}
}
+
+ Method [ <internal:yaconf> static public method __debug_info ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $name ]
+ }
+ }
}
- Properties [0] {
diff --git a/php-pecl-yaconf.spec b/php-pecl-yaconf.spec
index aeee5ab..73088b9 100644
--- a/php-pecl-yaconf.spec
+++ b/php-pecl-yaconf.spec
@@ -12,7 +12,7 @@
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner laruence
%global gh_project yaconf
-%global gh_date 20180622
+#global gh_date 20180622
%global pecl_name yaconf
%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
%global ini_name 40-%{pecl_name}.ini
@@ -24,14 +24,12 @@ Version: 1.0.8
Release: 0.4.%{gh_date}.%{gh_short}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{gh_project}-%{version}-%{gh_short}.tar.gz
%else
-Release: 5%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
-Source0: http://pecl.php.net/get/%{pecl_name}-%{version}.tgz
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Source0: https://pecl.php.net/get/%{pecl_name}-%{version}.tgz
%endif
License: PHP
URL: https://github.com/%{gh_owner}/%{gh_project}
-Patch0: https://patch-diff.githubusercontent.com/raw/laruence/yaconf/pull/52.patch
-
BuildRequires: %{?dtsprefix}gcc
BuildRequires: %{?scl_prefix}php-devel > 7
BuildRequires: %{?scl_prefix}php-pear
@@ -41,22 +39,16 @@ Requires: %{?scl_prefix}php(api) = %{php_core_api}
%{?_sclreq:Requires: %{?scl_prefix}runtime%{?_sclreq}%{?_isa}}
%if "%{?vendor}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
-Obsoletes: php70u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php70w-pecl-%{pecl_name} <= %{version}
-%if "%{php_version}" > "7.1"
-Obsoletes: php71u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php71w-pecl-%{pecl_name} <= %{version}
-%endif
%if "%{php_version}" > "7.2"
Obsoletes: php72u-pecl-%{pecl_name} <= %{version}
Obsoletes: php72w-pecl-%{pecl_name} <= %{version}
%endif
%if "%{php_version}" > "7.3"
-Obsoletes: php73-pecl-%{pecl_name} <= %{version}
+Obsoletes: php73-pecl-%{pecl_name} <= %{version}
Obsoletes: php73w-pecl-%{pecl_name} <= %{version}
%endif
%if "%{php_version}" > "7.4"
-Obsoletes: php74-pecl-%{pecl_name} <= %{version}
+Obsoletes: php74-pecl-%{pecl_name} <= %{version}
Obsoletes: php74w-pecl-%{pecl_name} <= %{version}
%endif
%endif
@@ -107,8 +99,6 @@ mv %{pecl_name}-%{version} NTS
%{?_licensedir:sed -e '/LICENSE/s/role="doc"/role="src"/' -i package.xml}
cd NTS
-%patch0 -p1 -b .pr52
-
# Sanity check, really often broken
extver=$(sed -n '/#define PHP_YACONF_VERSION/{s/.* "//;s/".*$//;p}' php_yaconf.h)
if test "x${extver}" != "x%{version}%{?gh_date:-dev}"; then
@@ -178,6 +168,9 @@ cp -pr NTS/tests %{buildroot}%{pecl_testdir}/%{pecl_name}/tests
%check
+# ignore bad test
+rm ?TS/tests/010.phpt
+
cd NTS
: Minimal load test for NTS extension
%{__php} --no-php-ini \
@@ -193,7 +186,6 @@ REPORT_EXIT_STATUS=1 \
%if %{with_zts}
cd ../ZTS
-rm tests/004.phpt
: Minimal load test for ZTS extension
%{__ztsphp} --no-php-ini \
--define extension=%{buildroot}%{php_ztsextdir}/%{pecl_name}.so \
@@ -252,6 +244,9 @@ fi
%changelog
+* Tue Dec 24 2019 Remi Collet <remi@remirepo.net> - 1.0.8-1
+- Update to 1.0.8
+
* Tue Sep 03 2019 Remi Collet <remi@remirepo.net> - 1.0.8-0.4.20180622.d5f267a
- rebuild for 7.4.0RC1