summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--php-pecl-yac.spec30
1 files changed, 18 insertions, 12 deletions
diff --git a/php-pecl-yac.spec b/php-pecl-yac.spec
index 40b1c46..94ea294 100644
--- a/php-pecl-yac.spec
+++ b/php-pecl-yac.spec
@@ -18,9 +18,6 @@
%endif
%{?scl: %scl_package php-yac}
-%{!?php_inidir: %global php_inidir %{_sysconfdir}/php.d}
-%{!?__pecl: %global __pecl %{_bindir}/pecl}
-%{!?__php: %global __php %{_bindir}/php}
%global with_zts 0%{?__ztsphp:1}
%global pecl_name yac
@@ -35,7 +32,7 @@
Summary: Lockless user data cache
Name: %{?sub_prefix}php-pecl-%{pecl_name}
Version: 0.9.2
-Release: 3%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 4%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: PHP
Group: Development/Languages
@@ -54,11 +51,13 @@ Requires: %{?scl_prefix}php(api) = %{php_core_api}
%{?_sclreq:Requires: %{?scl_prefix}runtime%{?_sclreq}%{?_isa}}
# Package have be renamed
-Obsoletes: %{?scl_prefix}php-%{pecl_name} < %{version}
-Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
-Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
-Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
+Obsoletes: %{?scl_prefix}php-%{pecl_name} < %{version}
+Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
+Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
+Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
+Provides: %{?scl_prefix}php-pecl-%{pecl_name} = %{version}-%{release}
+Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}-%{release}
%if "%{?vendor}" == "Remi Collet" && 0%{!?scl:1}
# Other third party repo stuff
@@ -101,7 +100,9 @@ Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSIO
mv %{pecl_name}-%{version} NTS
# Don't install (register) the tests
-sed -e 's/role="test"/role="src"/' -i package.xml
+sed -e 's/role="test"/role="src"/' \
+ %{?_licensedir:-e '/LICENSE/s/role="doc"/role="src"/' } \
+ -i package.xml
cd NTS
%if %{with_fastlz}
@@ -174,7 +175,7 @@ make -C ZTS install INSTALL_ROOT=%{buildroot}
install -D -m 644 %{ini_name} %{buildroot}%{php_ztsinidir}/%{ini_name}
%endif
-# Test & Documentation
+# Documentation
for i in $(grep 'role="doc"' package.xml | sed -e 's/^.*name="//;s/".*$//')
do install -Dpm 644 NTS/$i %{buildroot}%{pecl_docdir}/%{pecl_name}/$i
done
@@ -220,6 +221,7 @@ REPORT_EXIT_STATUS=1 \
%endif
+%if 0%{?fedora} < 24
# when pear installed alone, after us
%triggerin -- %{?scl_prefix}php-pear
if [ -x %{__pecl} ] ; then
@@ -236,6 +238,7 @@ fi
if [ $1 -eq 0 -a -x %{__pecl} ] ; then
%{pecl_uninstall} %{pecl_name} >/dev/null || :
fi
+%endif
%clean
@@ -243,7 +246,7 @@ rm -rf %{buildroot}
%files
-%defattr(-, root, root, 0755)
+%defattr(-,root,root,-)
%{?_licensedir:%license NTS/LICENSE}
%doc %{pecl_docdir}/%{pecl_name}
%{pecl_xmldir}/%{name}.xml
@@ -258,6 +261,9 @@ rm -rf %{buildroot}
%changelog
+* Wed Mar 9 2016 Remi Collet <remi@fedoraproject.org> - 0.9.2-4
+- adapt for F24
+
* Tue Jun 23 2015 Remi Collet <remi@fedoraproject.org> - 0.9.2-3
- allow build against rh-php56 (as more-php56)
@@ -295,4 +301,4 @@ rm -rf %{buildroot}
- version 0.1.1
* Sat Mar 23 2013 Remi Collet <remi@fedoraproject.org> - 0.1.0-0.1.git57fe00d
-- initial package, version 0.1.0 (experimental) \ No newline at end of file
+- initial package, version 0.1.0 (experimental)