summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-12-20 07:37:24 +0100
committerRemi Collet <remi@php.net>2021-12-20 07:37:24 +0100
commite8b2d76741e1a90b6cb46c74ec5680420a3e12eb (patch)
treebc96c70c2771cadfd2ec82e13bd7b4241889c66d
parentf12234c1b855631ed349d8814914fa45f78f7488 (diff)
update to 2.3.1
drop patch merged upstream
-rw-r--r--PHPINFO2
-rw-r--r--REFLECTION36
-rw-r--r--php-pecl-yac.spec19
-rw-r--r--yac-php81.patch19
4 files changed, 30 insertions, 46 deletions
diff --git a/PHPINFO b/PHPINFO
index 69fb80d..449f54b 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,7 +2,7 @@
yac
yac support => enabled
-Version => 2.3.0
+Version => 2.3.1
Shared Memory => mmap
Serializer => php, msgpack, igbinary, json
diff --git a/REFLECTION b/REFLECTION
index cfb4747..c6ce10c 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #119 yac version 2.3.0 ] {
+Extension [ <persistent> extension #119 yac version 2.3.1 ] {
- Dependencies {
Dependency [ msgpack (Required) ]
@@ -31,7 +31,7 @@ Extension [ <persistent> extension #119 yac version 2.3.0 ] {
}
- Constants [9] {
- Constant [ string YAC_VERSION ] { 2.3.0 }
+ Constant [ string YAC_VERSION ] { 2.3.1 }
Constant [ int YAC_MAX_KEY_LEN ] { 48 }
Constant [ int YAC_MAX_VALUE_RAW_LEN ] { 67108863 }
Constant [ int YAC_MAX_RAW_COMPRESSED_LEN ] { 1048576 }
@@ -61,60 +61,68 @@ Extension [ <persistent> extension #119 yac version 2.3.0 ] {
Method [ <internal:yac, ctor> public method __construct ] {
- Parameters [1] {
- Parameter #0 [ <optional> $prefix = <default> ]
+ Parameter #0 [ <optional> string $prefix = "" ]
}
}
Method [ <internal:yac> public method add ] {
- Parameters [3] {
- Parameter #0 [ <required> $keys ]
- Parameter #1 [ <optional> $value = <default> ]
- Parameter #2 [ <optional> $ttl = <default> ]
+ Parameter #0 [ <required> array|string $key ]
+ Parameter #1 [ <required> mixed $value ]
+ Parameter #2 [ <optional> int $ttl = 0 ]
}
+ - Return [ ?bool ]
}
Method [ <internal:yac> public method set ] {
- Parameters [3] {
- Parameter #0 [ <required> $keys ]
- Parameter #1 [ <optional> $value = <default> ]
- Parameter #2 [ <optional> $ttl = <default> ]
+ Parameter #0 [ <required> array|string $key ]
+ Parameter #1 [ <required> mixed $value ]
+ Parameter #2 [ <optional> int $ttl = 0 ]
}
+ - Return [ ?bool ]
}
Method [ <internal:yac> public method get ] {
- - Parameters [1] {
- Parameter #0 [ <required> $keys ]
+ - Parameters [2] {
+ Parameter #0 [ <required> array|string $key ]
+ Parameter #1 [ <optional> mixed &$cas = NULL ]
}
+ - Return [ ?bool ]
}
Method [ <internal:yac> public method delete ] {
- Parameters [2] {
- Parameter #0 [ <required> $keys ]
- Parameter #1 [ <optional> $ttl = <default> ]
+ Parameter #0 [ <required> array|string $key ]
+ Parameter #1 [ <optional> int $delay = 0 ]
}
+ - Return [ ?bool ]
}
Method [ <internal:yac> public method flush ] {
- Parameters [0] {
}
+ - Return [ bool ]
}
Method [ <internal:yac> public method info ] {
- Parameters [0] {
}
+ - Return [ array ]
}
Method [ <internal:yac> public method dump ] {
- Parameters [1] {
- Parameter #0 [ <optional> $limit = <default> ]
+ Parameter #0 [ <optional> int $limit = 0 ]
}
+ - Return [ ?array ]
}
}
}
diff --git a/php-pecl-yac.spec b/php-pecl-yac.spec
index c4788bd..b8e8feb 100644
--- a/php-pecl-yac.spec
+++ b/php-pecl-yac.spec
@@ -28,7 +28,7 @@
Summary: Lockless user data cache
Name: %{?sub_prefix}php-pecl-%{pecl_name}
-Version: 2.3.0
+Version: 2.3.1
License: PHP
URL: https://pecl.php.net/package/%{pecl_name}
%if 0%{?gh_date:1}
@@ -39,8 +39,6 @@ Release: 5%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_
Source0: https://pecl.php.net/get/%{pecl_name}-%{version}.tgz
%endif
-Patch0: %{pecl_name}-php81.patch
-
BuildRequires: make
BuildRequires: %{?dtsprefix}gcc
BuildRequires: %{?scl_prefix}php-devel >= 7.0
@@ -72,9 +70,6 @@ Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}-%{rele
%if "%{?packager}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
# Other third party repo stuff
-%if "%{php_version}" > "7.3"
-Obsoletes: php73-pecl-%{pecl_name} <= %{version}
-%endif
%if "%{php_version}" > "7.4"
Obsoletes: php74-pecl-%{pecl_name} <= %{version}
%endif
@@ -115,8 +110,6 @@ sed -e 's/role="test"/role="src"/' \
-i package.xml
cd NTS
-%patch0 -p1
-
%if %{with_fastlz}
sed -e '\:name="compressor/fastlz:d' -i ../package.xml
rm -r compressor/fastlz
@@ -216,9 +209,8 @@ OPTS="-n"
: Upstream test suite for NTS extension
TEST_PHP_EXECUTABLE=%{__php} \
TEST_PHP_ARGS="$OPTS -d extension=$PWD/modules/%{pecl_name}.so" \
-NO_INTERACTION=1 \
REPORT_EXIT_STATUS=1 \
-%{__php} -n run-tests.php --show-diff
+%{__php} -n run-tests.php -q --show-diff
%else
: Upstream test suite disabled
%endif
@@ -235,9 +227,8 @@ cd ../ZTS
: Upstream test suite for ZTS extension
TEST_PHP_EXECUTABLE=%{__ztsphp} \
TEST_PHP_ARGS="$OPTS -d extension=$PWD/modules/%{pecl_name}.so" \
-NO_INTERACTION=1 \
REPORT_EXIT_STATUS=1 \
-%{__ztsphp} -n run-tests.php --show-diff
+%{__ztsphp} -n run-tests.php -q --show-diff
%else
: Upstream test suite disabled
%endif
@@ -279,6 +270,10 @@ fi
%changelog
+* Mon Dec 20 2021 Remi Collet <remi@remirepo.net> - 2.3.1-1
+- update to 2.3.1
+- drop patch merged upstream
+
* Wed Sep 01 2021 Remi Collet <remi@remirepo.net> - 2.3.0-5
- rebuild for 8.1.0RC1
diff --git a/yac-php81.patch b/yac-php81.patch
deleted file mode 100644
index e4d4c45..0000000
--- a/yac-php81.patch
+++ /dev/null
@@ -1,19 +0,0 @@
-From 14fd1ecb6d95b9eecf3356fb2b3f01d937d2e4b5 Mon Sep 17 00:00:00 2001
-From: Remi Collet <remi@remirepo.net>
-Date: Wed, 4 Aug 2021 14:05:13 +0200
-Subject: [PATCH] relax test for 8.1.0beta2
-
----
- tests/023.phpt | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/tests/023.phpt b/tests/023.phpt
-index 0dce792..1fc658a 100644
---- a/tests/023.phpt
-+++ b/tests/023.phpt
-@@ -9,4 +9,4 @@ yac.enable=0
- class Sub extends Yac {};
- ?>
- --EXPECTF--
--Fatal error: Class Sub may not inherit from final class (Yac) in %s023.php on line %d
-+Fatal error: Class Sub %s final class %s