summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-08-01 10:32:12 +0200
committerRemi Collet <remi@remirepo.net>2017-08-01 10:32:12 +0200
commit7af4d1712fd145a4a4fa96ee22b2dbc27ecefca5 (patch)
tree7704aa10eac015d17ccb77b2f64bea2b42e0a16a
parentb22d8fe8ce8a85af038013546839fc37039b37f2 (diff)
switch
-rw-r--r--.gitignore7
-rw-r--r--REFLECTION21
-rw-r--r--REFLECTION-PHP7125
-rw-r--r--php-pecl-yac-php7.spec351
-rw-r--r--php-pecl-yac.spec101
5 files changed, 99 insertions, 506 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 0000000..1ab5c4f
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+package-*.xml
+*.tgz
+*.tar.gz
+*.tar.xz
+*.tar.xz.asc
+*.src.rpm
+*/*rpm
diff --git a/REFLECTION b/REFLECTION
index 024874a..561f7ef 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #159 yac version 0.9.2 ] {
+Extension [ <persistent> extension #124 yac version 2.0.1 ] {
- INI {
Entry [ yac.enable <SYSTEM> ]
@@ -22,7 +22,7 @@ Extension [ <persistent> extension #159 yac version 0.9.2 ] {
}
- Constants [5] {
- Constant [ string YAC_VERSION ] { 0.9.2 }
+ Constant [ string YAC_VERSION ] { 2.0.1 }
Constant [ integer YAC_MAX_KEY_LEN ] { 48 }
Constant [ integer YAC_MAX_VALUE_RAW_LEN ] { 67108863 }
Constant [ integer YAC_MAX_RAW_COMPRESSED_LEN ] { 1048576 }
@@ -45,7 +45,7 @@ Extension [ <persistent> extension #159 yac version 0.9.2 ] {
Property [ <default> protected $_prefix ]
}
- - Methods [8] {
+ - Methods [10] {
Method [ <internal:yac, ctor> public method __construct ] {
- Parameters [1] {
@@ -71,6 +71,14 @@ Extension [ <persistent> extension #159 yac version 0.9.2 ] {
}
}
+ Method [ <internal:yac> public method __set ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $key ]
+ Parameter #1 [ <required> $value ]
+ }
+ }
+
Method [ <internal:yac> public method get ] {
- Parameters [1] {
@@ -78,6 +86,13 @@ Extension [ <persistent> extension #159 yac version 0.9.2 ] {
}
}
+ Method [ <internal:yac> public method __get ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $key ]
+ }
+ }
+
Method [ <internal:yac> public method delete ] {
- Parameters [2] {
diff --git a/REFLECTION-PHP7 b/REFLECTION-PHP7
deleted file mode 100644
index 561f7ef..0000000
--- a/REFLECTION-PHP7
+++ /dev/null
@@ -1,125 +0,0 @@
-Extension [ <persistent> extension #124 yac version 2.0.1 ] {
-
- - INI {
- Entry [ yac.enable <SYSTEM> ]
- Current = '1'
- }
- Entry [ yac.debug <ALL> ]
- Current = '0'
- }
- Entry [ yac.keys_memory_size <SYSTEM> ]
- Current = '4M'
- }
- Entry [ yac.values_memory_size <SYSTEM> ]
- Current = '64M'
- }
- Entry [ yac.compress_threshold <SYSTEM> ]
- Current = '-1'
- }
- Entry [ yac.enable_cli <SYSTEM> ]
- Current = '0'
- }
- }
-
- - Constants [5] {
- Constant [ string YAC_VERSION ] { 2.0.1 }
- Constant [ integer YAC_MAX_KEY_LEN ] { 48 }
- Constant [ integer YAC_MAX_VALUE_RAW_LEN ] { 67108863 }
- Constant [ integer YAC_MAX_RAW_COMPRESSED_LEN ] { 1048576 }
- Constant [ string YAC_SERIALIZER ] { PHP }
- }
-
- - Classes [1] {
- Class [ <internal:yac> class Yac ] {
-
- - Constants [0] {
- }
-
- - Static properties [0] {
- }
-
- - Static methods [0] {
- }
-
- - Properties [1] {
- Property [ <default> protected $_prefix ]
- }
-
- - Methods [10] {
- Method [ <internal:yac, ctor> public method __construct ] {
-
- - Parameters [1] {
- Parameter #0 [ <optional> $prefix ]
- }
- }
-
- Method [ <internal:yac> public method add ] {
-
- - Parameters [3] {
- Parameter #0 [ <required> $keys ]
- Parameter #1 [ <optional> $value ]
- Parameter #2 [ <optional> $ttl ]
- }
- }
-
- Method [ <internal:yac> public method set ] {
-
- - Parameters [3] {
- Parameter #0 [ <required> $keys ]
- Parameter #1 [ <optional> $value ]
- Parameter #2 [ <optional> $ttl ]
- }
- }
-
- Method [ <internal:yac> public method __set ] {
-
- - Parameters [2] {
- Parameter #0 [ <required> $key ]
- Parameter #1 [ <required> $value ]
- }
- }
-
- Method [ <internal:yac> public method get ] {
-
- - Parameters [1] {
- Parameter #0 [ <required> $keys ]
- }
- }
-
- Method [ <internal:yac> public method __get ] {
-
- - Parameters [1] {
- Parameter #0 [ <required> $key ]
- }
- }
-
- Method [ <internal:yac> public method delete ] {
-
- - Parameters [2] {
- Parameter #0 [ <required> $keys ]
- Parameter #1 [ <optional> $ttl ]
- }
- }
-
- Method [ <internal:yac> public method flush ] {
-
- - Parameters [0] {
- }
- }
-
- Method [ <internal:yac> public method info ] {
-
- - Parameters [0] {
- }
- }
-
- Method [ <internal:yac> public method dump ] {
-
- - Parameters [0] {
- }
- }
- }
- }
- }
-}
-
diff --git a/php-pecl-yac-php7.spec b/php-pecl-yac-php7.spec
deleted file mode 100644
index b3a70e0..0000000
--- a/php-pecl-yac-php7.spec
+++ /dev/null
@@ -1,351 +0,0 @@
-# remirepo spec file for php-pecl-yac
-# with SCL compatibility, from:
-#
-# Fedora spec file for php-pecl-yac (previously php-yac)
-#
-# Copyright (c) 2013-2017 Remi Collet
-# License: CC-BY-SA
-# http://creativecommons.org/licenses/by-sa/4.0/
-#
-# Please, preserve the changelog entries
-#
-%if 0%{?scl:1}
-%global sub_prefix %{scl_prefix}
-%scl_package php-pecl-yac
-%endif
-
-%global gh_commit 7e5a9edfcfb6ad064c165a0b6abf8d11218fe4b5
-%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
-%global gh_owner laruence
-%global gh_project yac
-#global gh_date 20150908
-%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
-%global pecl_name yac
-%global with_tests %{!?_without_tests:1}%{?_without_tests:0}
-%if "%{php_version}" < "5.6"
-%global ini_name %{pecl_name}.ini
-%else
-%global ini_name 40-%{pecl_name}.ini
-%endif
-%global with_fastlz 1
-
-Summary: Lockless user data cache
-Name: %{?sub_prefix}php-pecl-%{pecl_name}
-Version: 2.0.1
-%if 0%{?gh_date:1}
-Release: 0.8.%{gh_date}git%{gh_short}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
-Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{pecl_name}-%{version}-%{gh_short}.tar.gz
-%else
-Release: 4%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
-Source0: http://pecl.php.net/get/%{pecl_name}-%{version}.tgz
-%endif
-
-License: PHP
-Group: Development/Languages
-URL: http://pecl.php.net/package/%{pecl_name}
-
-BuildRequires: %{?scl_prefix}php-devel > 7
-BuildRequires: %{?scl_prefix}php-pear
-%if %{with_fastlz}
-BuildRequires: fastlz-devel
-%endif
-
-Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
-Requires: %{?scl_prefix}php(api) = %{php_core_api}
-%{?_sclreq:Requires: %{?scl_prefix}runtime%{?_sclreq}%{?_isa}}
-
-# Package have be renamed
-Obsoletes: %{?scl_prefix}php-%{pecl_name} < %{version}
-Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
-Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
-Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
-Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
-%if "%{?scl_prefix}" != "%{?sub_prefix}"
-Provides: %{?scl_prefix}php-pecl-%{pecl_name} = %{version}-%{release}
-Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}-%{release}
-%endif
-
-%if "%{?vendor}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
-# Other third party repo stuff
-Obsoletes: php53-pecl-%{pecl_name} <= %{version}
-Obsoletes: php53u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php54-pecl-%{pecl_name} <= %{version}
-Obsoletes: php54w-pecl-%{pecl_name} <= %{version}
-Obsoletes: php55u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php55w-pecl-%{pecl_name} <= %{version}
-Obsoletes: php56u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php56w-pecl-%{pecl_name} <= %{version}
-Obsoletes: php70u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php70w-pecl-%{pecl_name} <= %{version}
-%if "%{php_version}" > "7.1"
-Obsoletes: php71u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php71w-pecl-%{pecl_name} <= %{version}
-%endif
-%if "%{php_version}" > "7.2"
-Obsoletes: php72u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php72w-pecl-%{pecl_name} <= %{version}
-%endif
-%endif
-
-%if 0%{?fedora} < 20 && 0%{?rhel} < 7
-# Filter private shared object
-%{?filter_provides_in: %filter_provides_in %{_libdir}/.*\.so$}
-%{?filter_setup}
-%endif
-
-
-%description
-Yac (Yet Another Cache) is a shared memory user data cache for PHP.
-
-It can be used to replace APC or local memcached.
-
-Yac is lockless, that means, it is very fast, but there could be a
-chance you will get a wrong data(depends on how many key slots are
-allocated and how many keys are stored), so you'd better make sure
-that your product is not very sensitive to that.
-
-Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')%{?scl: as Software Collection (%{scl} by %{?scl_vendor}%{!?scl_vendor:rh})}.
-
-
-%prep
-%setup -qc
-%if 0%{?gh_date:1}
-mv %{gh_project}-%{gh_commit} NTS
-mv NTS/package.xml .
-%else
-mv %{pecl_name}-%{version} NTS
-%endif
-
-# Don't install (register) the tests
-sed -e 's/role="test"/role="src"/' \
- %{?_licensedir:-e '/LICENSE/s/role="doc"/role="src"/' } \
- -i package.xml
-
-cd NTS
-%if %{with_fastlz}
-sed -e '\:name="compressor/fastlz:d' -i ../package.xml
-rm -r compressor/fastlz
-%endif
-
-# Check version as upstream often forget to update this
-extver=$(sed -n '/#define PHP_YAC_VERSION/{s/.* "//;s/".*$//;p}' php_yac.h)
-if test "x${extver}" != "x%{version}%{?prever}%{?gh_date:-dev}"; then
- : Error: Upstream YAC version is ${extver}, expecting %{version}%{?prever}%{?gh_date:-dev}.
- exit 1
-fi
-cd ..
-
-# Drop in the bit of configuration
-cat > %{ini_name} << 'EOF'
-; Enable Yet Another Cache extension module
-extension = %{pecl_name}.so
-
-;yac.enable=1
-;yac.enable_cli=0
-;yac.debug=0
-;yac.keys_memory_size=4M
-;yac.values_memory_size=64M
-;yac.compress_threshold=-1
-EOF
-
-
-%if %{with_zts}
-# duplicate for ZTS build
-cp -pr NTS ZTS
-%endif
-
-
-%build
-peclconf() {
-%configure \
-%if %{with_fastlz}
- --with-system-fastlz \
-%endif
- --with-php-config=$1
-}
-
-cd NTS
-%{_bindir}/phpize
-peclconf %{_bindir}/php-config
-make %{?_smp_mflags}
-
-%if %{with_zts}
-cd ../ZTS
-%{_bindir}/zts-phpize
-peclconf %{_bindir}/zts-php-config
-make %{?_smp_mflags}
-%endif
-
-
-%install
-# Install the NTS stuff
-make -C NTS install INSTALL_ROOT=%{buildroot}
-install -D -m 644 %{ini_name} %{buildroot}%{php_inidir}/%{ini_name}
-
-# Install XML package description
-install -D -m 644 package.xml %{buildroot}%{pecl_xmldir}/%{name}.xml
-
-# Install the ZTS stuff
-%if %{with_zts}
-make -C ZTS install INSTALL_ROOT=%{buildroot}
-install -D -m 644 %{ini_name} %{buildroot}%{php_ztsinidir}/%{ini_name}
-%endif
-
-# Documentation
-for i in README.md $(grep 'role="doc"' package.xml | sed -e 's/^.*name="//;s/".*$//')
-do [ -f NTS/$i ] && install -Dpm 644 NTS/$i %{buildroot}%{pecl_docdir}/%{pecl_name}/$i
-done
-
-
-%check
-sed -e 's/Catchable/%s/' -i ?TS/tests/005.phpt
-
-cd NTS
-
-: Minimal load test for NTS extension
-%{_bindir}/php --no-php-ini \
- --define extension=%{buildroot}%{php_extdir}/%{pecl_name}.so \
- --modules | grep %{pecl_name}
-
-%if %{with_tests}
-: Upstream test suite for NTS extension
-TEST_PHP_EXECUTABLE=%{__php} \
-TEST_PHP_ARGS="-n -d extension_dir=$PWD/modules -d extension=%{pecl_name}.so" \
-NO_INTERACTION=1 \
-REPORT_EXIT_STATUS=1 \
-%{__php} -n run-tests.php --show-diff
-%else
-: Upstream test suite disabled
-%endif
-
-%if %{with_zts}
-cd ../ZTS
-
-: Minimal load test for ZTS extension
-%{__ztsphp} --no-php-ini \
- --define extension=%{buildroot}%{php_ztsextdir}/%{pecl_name}.so \
- --modules | grep %{pecl_name}
-
-%if %{with_tests}
-: Upstream test suite for ZTS extension
-TEST_PHP_EXECUTABLE=%{__ztsphp} \
-TEST_PHP_ARGS="-n -d extension_dir=$PWD/modules -d extension=%{pecl_name}.so" \
-NO_INTERACTION=1 \
-REPORT_EXIT_STATUS=1 \
-%{__ztsphp} -n run-tests.php --show-diff
-%else
-: Upstream test suite disabled
-%endif
-%endif
-
-
-%if 0%{?fedora} < 24
-# when pear installed alone, after us
-%triggerin -- %{?scl_prefix}php-pear
-if [ -x %{__pecl} ] ; then
- %{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || :
-fi
-
-# posttrans as pear can be installed after us
-%posttrans
-if [ -x %{__pecl} ] ; then
- %{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || :
-fi
-
-%postun
-if [ $1 -eq 0 -a -x %{__pecl} ] ; then
- %{pecl_uninstall} %{pecl_name} >/dev/null || :
-fi
-%endif
-
-
-%files
-%{?_licensedir:%license NTS/LICENSE}
-%doc %{pecl_docdir}/%{pecl_name}
-%{pecl_xmldir}/%{name}.xml
-
-%config(noreplace) %{php_inidir}/%{ini_name}
-%{php_extdir}/%{pecl_name}.so
-
-%if %{with_zts}
-%{php_ztsextdir}/%{pecl_name}.so
-%config(noreplace) %{php_ztsinidir}/%{ini_name}
-%endif
-
-
-%changelog
-* Tue Jul 18 2017 Remi Collet <remi@remirepo.net> - 2.0.1-4
-- rebuild for PHP 7.2.0beta1 new API
-
-* Thu Dec 1 2016 Remi Collet <remi@fedoraproject.org> - 2.0.1-3
-- rebuild with PHP 7.1.0 GA
-
-* Wed Sep 14 2016 Remi Collet <remi@fedoraproject.org> - 2.0.1-2
-- rebuild for PHP 7.1 new API version
-
-* Sat Jul 2 2016 Remi Collet <remi@fedoraproject.org> - 2.0.1-1
-- update to 2.0.1 (php 7)
-- sources from pecl
-
-* Sun Mar 6 2016 Remi Collet <remi@fedoraproject.org> - 2.0.0-2
-- adapt for F24
-
-* Tue Oct 27 2015 Remi Collet <remi@fedoraproject.org> - 2.0.0-1
-- update to 2.0.0 (php 7)
-
-* Tue Oct 13 2015 Remi Collet <remi@fedoraproject.org> - 0.9.3-0.6.20150908gita406e46
-- rebuild for PHP 7.0.0RC5 new API version
-- new snapshot
-
-* Fri Sep 18 2015 Remi Collet <remi@fedoraproject.org> - 0.9.3-0.5.20150717git74fa8e2
-- F23 rebuild with rh_layout
-
-* Wed Jul 22 2015 Remi Collet <remi@fedoraproject.org> - 0.9.3-0.4.20150717git74fa8e2
-- rebuild against php 7.0.0beta2
-
-* Wed Jul 8 2015 Remi Collet <remi@fedoraproject.org> - 0.9.3-0.3.20150701git85f6e35
-- rebuild against php 7.0.0beta1
-
-* Wed Jun 24 2015 Remi Collet <remi@fedoraproject.org> - 0.9.3-0.2.20150616git1d26cd4
-- rebuild for "rh_layout" (php70)
-
-* Tue Jun 16 2015 Remi Collet <remi@fedoraproject.org> - 0.9.3-0.1.20150616git1d26cd4
-- update to 0.9.3-dev for PHP 7
-- sources from github
-
-* Sun Mar 1 2015 Remi Collet <remi@fedoraproject.org> - 0.9.2-2
-- drop runtime dependency on pear, new scriplets
-
-* Wed Dec 24 2014 Remi Collet <remi@fedoraproject.org> - 0.9.2-1.1
-- Fedora 21 SCL mass rebuild
-
-* Sat Oct 25 2014 Remi Collet <remi@fedoraproject.org> - 0.9.2-1
-- Update to 0.9.2
-
-* Sat Sep 6 2014 Remi Collet <remi@fedoraproject.org> - 0.9.1-3
-- test build with system fastlz
-- don't install the tests
-
-* Tue Aug 26 2014 Remi Collet <rcollet@redhat.com> - 0.9.1-2
-- improve SCL build
-
-* Fri Jul 25 2014 Remi Collet <remi@fedoraproject.org> - 0.9.1-1
-- Update to 0.9.1 (beta)
-
-* Thu Jul 24 2014 Remi Collet <remi@fedoraproject.org> - 0.9.0-1
-- upstream move to pecl
-- rename from php-yac to php-pecl-yac
-- update to 0.9.0 (beta)
-
-* Thu Apr 17 2014 Remi Collet <remi@fedoraproject.org> - 0.1.1-3
-- add numerical prefix to extension configuration file (php 5.6)
-
-* Tue Mar 25 2014 Remi Collet <remi@fedoraproject.org> - 0.1.1-2
-- allow SCL build
-
-* Sun Mar 16 2014 Remi Collet <remi@fedoraproject.org> - 0.1.1-1
-- version 0.1.1
-
-* Sat Mar 23 2013 Remi Collet <remi@fedoraproject.org> - 0.1.0-0.1.git57fe00d
-- initial package, version 0.1.0 (experimental)
-
diff --git a/php-pecl-yac.spec b/php-pecl-yac.spec
index 4a148af..b3a70e0 100644
--- a/php-pecl-yac.spec
+++ b/php-pecl-yac.spec
@@ -10,16 +10,16 @@
# Please, preserve the changelog entries
#
%if 0%{?scl:1}
-%if "%{scl}" == "rh-php56"
-%global sub_prefix more-php56-
-%else
%global sub_prefix %{scl_prefix}
-%endif
+%scl_package php-pecl-yac
%endif
-%{?scl: %scl_package php-yac}
-
-%global with_zts 0%{?__ztsphp:1}
+%global gh_commit 7e5a9edfcfb6ad064c165a0b6abf8d11218fe4b5
+%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
+%global gh_owner laruence
+%global gh_project yac
+#global gh_date 20150908
+%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
%global pecl_name yac
%global with_tests %{!?_without_tests:1}%{?_without_tests:0}
%if "%{php_version}" < "5.6"
@@ -31,16 +31,20 @@
Summary: Lockless user data cache
Name: %{?sub_prefix}php-pecl-%{pecl_name}
-Version: 0.9.2
+Version: 2.0.1
+%if 0%{?gh_date:1}
+Release: 0.8.%{gh_date}git%{gh_short}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{pecl_name}-%{version}-%{gh_short}.tar.gz
+%else
Release: 4%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Source0: http://pecl.php.net/get/%{pecl_name}-%{version}.tgz
+%endif
License: PHP
Group: Development/Languages
URL: http://pecl.php.net/package/%{pecl_name}
-Source0: http://pecl.php.net/get/%{pecl_name}-%{version}.tgz
-BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
-BuildRequires: %{?scl_prefix}php-devel > 5.2
+BuildRequires: %{?scl_prefix}php-devel > 7
BuildRequires: %{?scl_prefix}php-pear
%if %{with_fastlz}
BuildRequires: fastlz-devel
@@ -56,8 +60,10 @@ Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
+%if "%{?scl_prefix}" != "%{?sub_prefix}"
Provides: %{?scl_prefix}php-pecl-%{pecl_name} = %{version}-%{release}
Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}-%{release}
+%endif
%if "%{?vendor}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
# Other third party repo stuff
@@ -65,13 +71,19 @@ Obsoletes: php53-pecl-%{pecl_name} <= %{version}
Obsoletes: php53u-pecl-%{pecl_name} <= %{version}
Obsoletes: php54-pecl-%{pecl_name} <= %{version}
Obsoletes: php54w-pecl-%{pecl_name} <= %{version}
-%if "%{php_version}" > "5.5"
Obsoletes: php55u-pecl-%{pecl_name} <= %{version}
Obsoletes: php55w-pecl-%{pecl_name} <= %{version}
-%endif
-%if "%{php_version}" > "5.6"
Obsoletes: php56u-pecl-%{pecl_name} <= %{version}
Obsoletes: php56w-pecl-%{pecl_name} <= %{version}
+Obsoletes: php70u-pecl-%{pecl_name} <= %{version}
+Obsoletes: php70w-pecl-%{pecl_name} <= %{version}
+%if "%{php_version}" > "7.1"
+Obsoletes: php71u-pecl-%{pecl_name} <= %{version}
+Obsoletes: php71w-pecl-%{pecl_name} <= %{version}
+%endif
+%if "%{php_version}" > "7.2"
+Obsoletes: php72u-pecl-%{pecl_name} <= %{version}
+Obsoletes: php72w-pecl-%{pecl_name} <= %{version}
%endif
%endif
@@ -97,7 +109,12 @@ Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSIO
%prep
%setup -qc
+%if 0%{?gh_date:1}
+mv %{gh_project}-%{gh_commit} NTS
+mv NTS/package.xml .
+%else
mv %{pecl_name}-%{version} NTS
+%endif
# Don't install (register) the tests
sed -e 's/role="test"/role="src"/' \
@@ -112,8 +129,8 @@ rm -r compressor/fastlz
# Check version as upstream often forget to update this
extver=$(sed -n '/#define PHP_YAC_VERSION/{s/.* "//;s/".*$//;p}' php_yac.h)
-if test "x${extver}" != "x%{version}%{?prever}"; then
- : Error: Upstream YAC version is ${extver}, expecting %{version}%{?prever}.
+if test "x${extver}" != "x%{version}%{?prever}%{?gh_date:-dev}"; then
+ : Error: Upstream YAC version is ${extver}, expecting %{version}%{?prever}%{?gh_date:-dev}.
exit 1
fi
cd ..
@@ -161,7 +178,6 @@ make %{?_smp_mflags}
%install
-rm -rf %{buildroot}
# Install the NTS stuff
make -C NTS install INSTALL_ROOT=%{buildroot}
install -D -m 644 %{ini_name} %{buildroot}%{php_inidir}/%{ini_name}
@@ -176,12 +192,14 @@ install -D -m 644 %{ini_name} %{buildroot}%{php_ztsinidir}/%{ini_name}
%endif
# Documentation
-for i in $(grep 'role="doc"' package.xml | sed -e 's/^.*name="//;s/".*$//')
-do install -Dpm 644 NTS/$i %{buildroot}%{pecl_docdir}/%{pecl_name}/$i
+for i in README.md $(grep 'role="doc"' package.xml | sed -e 's/^.*name="//;s/".*$//')
+do [ -f NTS/$i ] && install -Dpm 644 NTS/$i %{buildroot}%{pecl_docdir}/%{pecl_name}/$i
done
%check
+sed -e 's/Catchable/%s/' -i ?TS/tests/005.phpt
+
cd NTS
: Minimal load test for NTS extension
@@ -241,12 +259,7 @@ fi
%endif
-%clean
-rm -rf %{buildroot}
-
-
%files
-%defattr(-,root,root,-)
%{?_licensedir:%license NTS/LICENSE}
%doc %{pecl_docdir}/%{pecl_name}
%{pecl_xmldir}/%{name}.xml
@@ -261,11 +274,44 @@ rm -rf %{buildroot}
%changelog
-* Wed Mar 9 2016 Remi Collet <remi@fedoraproject.org> - 0.9.2-4
+* Tue Jul 18 2017 Remi Collet <remi@remirepo.net> - 2.0.1-4
+- rebuild for PHP 7.2.0beta1 new API
+
+* Thu Dec 1 2016 Remi Collet <remi@fedoraproject.org> - 2.0.1-3
+- rebuild with PHP 7.1.0 GA
+
+* Wed Sep 14 2016 Remi Collet <remi@fedoraproject.org> - 2.0.1-2
+- rebuild for PHP 7.1 new API version
+
+* Sat Jul 2 2016 Remi Collet <remi@fedoraproject.org> - 2.0.1-1
+- update to 2.0.1 (php 7)
+- sources from pecl
+
+* Sun Mar 6 2016 Remi Collet <remi@fedoraproject.org> - 2.0.0-2
- adapt for F24
-* Tue Jun 23 2015 Remi Collet <remi@fedoraproject.org> - 0.9.2-3
-- allow build against rh-php56 (as more-php56)
+* Tue Oct 27 2015 Remi Collet <remi@fedoraproject.org> - 2.0.0-1
+- update to 2.0.0 (php 7)
+
+* Tue Oct 13 2015 Remi Collet <remi@fedoraproject.org> - 0.9.3-0.6.20150908gita406e46
+- rebuild for PHP 7.0.0RC5 new API version
+- new snapshot
+
+* Fri Sep 18 2015 Remi Collet <remi@fedoraproject.org> - 0.9.3-0.5.20150717git74fa8e2
+- F23 rebuild with rh_layout
+
+* Wed Jul 22 2015 Remi Collet <remi@fedoraproject.org> - 0.9.3-0.4.20150717git74fa8e2
+- rebuild against php 7.0.0beta2
+
+* Wed Jul 8 2015 Remi Collet <remi@fedoraproject.org> - 0.9.3-0.3.20150701git85f6e35
+- rebuild against php 7.0.0beta1
+
+* Wed Jun 24 2015 Remi Collet <remi@fedoraproject.org> - 0.9.3-0.2.20150616git1d26cd4
+- rebuild for "rh_layout" (php70)
+
+* Tue Jun 16 2015 Remi Collet <remi@fedoraproject.org> - 0.9.3-0.1.20150616git1d26cd4
+- update to 0.9.3-dev for PHP 7
+- sources from github
* Sun Mar 1 2015 Remi Collet <remi@fedoraproject.org> - 0.9.2-2
- drop runtime dependency on pear, new scriplets
@@ -302,3 +348,4 @@ rm -rf %{buildroot}
* Sat Mar 23 2013 Remi Collet <remi@fedoraproject.org> - 0.1.0-0.1.git57fe00d
- initial package, version 0.1.0 (experimental)
+