summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2014-07-24 11:45:31 +0200
committerRemi Collet <fedora@famillecollet.com>2014-07-24 11:45:31 +0200
commit4a7c863f2b1cb287987dad67b85452d94ebd0dd9 (patch)
tree9a97f8fb8964f1a28dc67e217decf6246c884bbe
rename php-yac to php-pecl-yac
-rw-r--r--Makefile4
-rw-r--r--php-pecl-yac.spec178
2 files changed, 182 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..91b0fd5
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,4 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../common/Makefile
+
diff --git a/php-pecl-yac.spec b/php-pecl-yac.spec
new file mode 100644
index 0000000..f896a9a
--- /dev/null
+++ b/php-pecl-yac.spec
@@ -0,0 +1,178 @@
+# spec file for php-yac
+#
+# Copyright (c) 2014 Remi Collet
+# License: CC-BY-SA
+# http://creativecommons.org/licenses/by-sa/3.0/
+#
+# Please, preserve the changelog entries
+#
+%{?scl: %scl_package php-yac}
+%{!?php_inidir: %global php_inidir %{_sysconfdir}/php.d}
+%{!?__pecl: %global __pecl %{_bindir}/pecl}
+%{!?__php: %global __php %{_bindir}/php}
+
+%global pecl_name yac
+%global commit 9271a83f029c9e4309c7669ba85bbb0fa2e8f585
+%global gitver %(c=%{commit}; echo ${c:0:7})
+%global with_zts 0%{?__ztsphp:1}
+%if "%{php_version}" < "5.6"
+%global ini_name %{pecl_name}.ini
+%else
+%global ini_name 40-%{pecl_name}.ini
+%endif
+
+Summary: Shared memory user data cache for PHP
+Name: %{?scl_prefix}php-yac
+Version: 0.1.1
+Release: 3%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
+Source0: https://github.com/laruence/%{pecl_name}/archive/%{commit}/%{pecl_name}-%{version}-%{gitver}.tar.gz
+
+License: PHP
+Group: Development/Languages
+URL: https://github.com/laruence/yac
+
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
+BuildRequires: %{?scl_prefix}php-devel >= 5.2
+
+Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
+Requires: %{?scl_prefix}php(api) = %{php_core_api}
+
+%if "%{?vendor}" == "Remi Collet"
+# Other third party repo stuff
+Obsoletes: php53-%{pecl_name}
+Obsoletes: php53u-%{pecl_name}
+Obsoletes: php54-%{pecl_name}
+%if "%{php_version}" > "5.5"
+Obsoletes: php55u-%{pecl_name}
+%endif
+%if "%{php_version}" > "5.6"
+Obsoletes: php56u-%{pecl_name}
+%endif
+%endif
+
+%if 0%{?fedora} < 20
+# Filter private shared object
+%{?filter_provides_in: %filter_provides_in %{_libdir}/.*\.so$}
+%{?filter_setup}
+%endif
+
+
+%description
+Yac (Yet Another Cache) is a shared memory user data cache for PHP.
+
+It can be used to replace APC or local memcached.
+
+This extension is still EXPERIMENTAL.
+
+
+%prep
+%setup -qc
+mv %{pecl_name}-%{commit} NTS
+
+# Drop in the bit of configuration
+cat > %{ini_name} << 'EOF'
+; Enable Yet Another Cache extension module
+extension = %{pecl_name}.so
+
+yac.enable=1
+;yac.debug=0
+;yac.keys_memory_size=4M
+;yac.values_memory_size=64M
+;yac.compress_threshold=-1
+EOF
+
+# When this file will be removed, clean the description.
+[ -f NTS/EXPERIMENTAL ] || exit 1
+
+%if %{with_zts}
+# duplicate for ZTS build
+cp -pr NTS ZTS
+%endif
+
+
+%build
+cd NTS
+%{_bindir}/phpize
+%configure --with-php-config=%{_bindir}/php-config
+make %{?_smp_mflags}
+
+%if %{with_zts}
+cd ../ZTS
+%{_bindir}/zts-phpize
+%configure --with-php-config=%{_bindir}/zts-php-config
+make %{?_smp_mflags}
+%endif
+
+
+%install
+rm -rf %{buildroot}
+# Install the NTS stuff
+make -C NTS install INSTALL_ROOT=%{buildroot}
+install -D -m 644 %{ini_name} %{buildroot}%{php_inidir}/%{ini_name}
+
+# Install the ZTS stuff
+%if %{with_zts}
+make -C ZTS install INSTALL_ROOT=%{buildroot}
+install -D -m 644 %{ini_name} %{buildroot}%{php_ztsinidir}/%{ini_name}
+%endif
+
+
+%check
+cd NTS
+
+: Minimal load test for NTS extension
+%{_bindir}/php --no-php-ini \
+ --define extension=%{buildroot}%{php_extdir}/%{pecl_name}.so \
+ --modules | grep %{pecl_name}
+
+TEST_PHP_EXECUTABLE=%{__php} \
+TEST_PHP_ARGS="-n -d extension_dir=$PWD/modules -d extension=%{pecl_name}.so" \
+NO_INTERACTION=1 \
+REPORT_EXIT_STATUS=1 \
+%{__php} -n run-tests.php
+
+%if %{with_zts}
+cd ../ZTS
+
+: Minimal load test for ZTS extension
+%{__ztsphp} --no-php-ini \
+ --define extension=%{buildroot}%{php_ztsextdir}/%{pecl_name}.so \
+ --modules | grep %{pecl_name}
+
+TEST_PHP_EXECUTABLE=%{__ztsphp} \
+TEST_PHP_ARGS="-n -d extension_dir=$PWD/modules -d extension=%{pecl_name}.so" \
+NO_INTERACTION=1 \
+REPORT_EXIT_STATUS=1 \
+%{__ztsphp} -n run-tests.php
+%endif
+
+
+%clean
+rm -rf %{buildroot}
+
+
+%files
+%defattr(-, root, root, 0755)
+%doc NTS/{CREDITS,LICENSE,README.md}
+
+%config(noreplace) %{php_inidir}/%{ini_name}
+%{php_extdir}/%{pecl_name}.so
+
+%if %{with_zts}
+%{php_ztsextdir}/%{pecl_name}.so
+%config(noreplace) %{php_ztsinidir}/%{ini_name}
+%endif
+
+
+%changelog
+* Thu Apr 17 2014 Remi Collet <remi@fedoraproject.org> - 0.1.1-3
+- add numerical prefix to extension configuration file (php 5.6)
+
+* Tue Mar 25 2014 Remi Collet <remi@fedoraproject.org> - 0.1.1-2
+- allow SCL build
+
+* Sun Mar 16 2014 Remi Collet <remi@fedoraproject.org> - 0.1.1-1
+- version 0.1.1
+
+* Sat Mar 23 2013 Remi Collet <remi@fedoraproject.org> - 0.1.0-0.1.git57fe00d
+- initial package, version 0.1.0 (experimental)