summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2014-07-25 10:31:21 +0200
committerRemi Collet <fedora@famillecollet.com>2014-07-25 10:31:21 +0200
commit31a1b608d8aa3f1e32bb609833d828c1462ba839 (patch)
treed7650f1521f5cf73078cde78e23f0337bfc38f11
parent3b0577edf87b5deaeaea8f67bcfc06a470e8e2b1 (diff)
php-pecl-yac: 0.9.1
-rw-r--r--REFLECTION110
-rw-r--r--php-pecl-yac.spec8
2 files changed, 116 insertions, 2 deletions
diff --git a/REFLECTION b/REFLECTION
new file mode 100644
index 0000000..8400971
--- /dev/null
+++ b/REFLECTION
@@ -0,0 +1,110 @@
+Extension [ <persistent> extension #155 yac version 0.9.1 ] {
+
+ - INI {
+ Entry [ yac.enable <SYSTEM> ]
+ Current = '1'
+ }
+ Entry [ yac.debug <ALL> ]
+ Current = '0'
+ }
+ Entry [ yac.keys_memory_size <SYSTEM> ]
+ Current = '4M'
+ }
+ Entry [ yac.values_memory_size <SYSTEM> ]
+ Current = '64M'
+ }
+ Entry [ yac.compress_threshold <SYSTEM> ]
+ Current = '-1'
+ }
+ Entry [ yac.enable_cli <SYSTEM> ]
+ Current = '0'
+ }
+ }
+
+ - Constants [5] {
+ Constant [ string YAC_VERSION ] { 0.9.1 }
+ Constant [ integer YAC_MAX_KEY_LEN ] { 48 }
+ Constant [ integer YAC_MAX_VALUE_RAW_LEN ] { 67108863 }
+ Constant [ integer YAC_MAX_RAW_COMPRESSED_LEN ] { 1048576 }
+ Constant [ string YAC_SERIALIZER ] { PHP }
+ }
+
+ - Classes [1] {
+ Class [ <internal:yac> class Yac ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [1] {
+ Property [ <default> protected $_prefix ]
+ }
+
+ - Methods [8] {
+ Method [ <internal:yac, ctor> public method __construct ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <optional> $prefix ]
+ }
+ }
+
+ Method [ <internal:yac> public method add ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $keys ]
+ Parameter #1 [ <optional> $value ]
+ Parameter #2 [ <optional> $ttl ]
+ }
+ }
+
+ Method [ <internal:yac> public method set ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $keys ]
+ Parameter #1 [ <optional> $value ]
+ Parameter #2 [ <optional> $ttl ]
+ }
+ }
+
+ Method [ <internal:yac> public method get ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $keys ]
+ }
+ }
+
+ Method [ <internal:yac> public method delete ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $keys ]
+ Parameter #1 [ <optional> $ttl ]
+ }
+ }
+
+ Method [ <internal:yac> public method flush ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:yac> public method info ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:yac> public method dump ] {
+
+ - Parameters [0] {
+ }
+ }
+ }
+ }
+ }
+}
+
diff --git a/php-pecl-yac.spec b/php-pecl-yac.spec
index d1dcff3..cd05a6c 100644
--- a/php-pecl-yac.spec
+++ b/php-pecl-yac.spec
@@ -22,7 +22,7 @@
Summary: Lockless user data cache
Name: %{?scl_prefix}php-pecl-%{pecl_name}
-Version: 0.9.0
+Version: 0.9.1
Release: 1%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
License: PHP
@@ -89,7 +89,8 @@ cat > %{ini_name} << 'EOF'
; Enable Yet Another Cache extension module
extension = %{pecl_name}.so
-yac.enable=1
+;yac.enable=1
+;yac.enable_cli=0
;yac.debug=0
;yac.keys_memory_size=4M
;yac.values_memory_size=64M
@@ -211,6 +212,9 @@ rm -rf %{buildroot}
%changelog
+* Fri Jul 25 2014 Remi Collet <remi@fedoraproject.org> - 0.9.1-1
+- Update to 0.9.1 (beta)
+
* Thu Jul 24 2014 Remi Collet <remi@fedoraproject.org> - 0.9.0-1
- upstream move to pecl
- rename from php-yac to php-pecl-yac