summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2014-03-15 08:01:44 +0100
committerRemi Collet <fedora@famillecollet.com>2014-03-15 08:01:44 +0100
commitc240aa5ac029a7b6d425ff6270d8549813adaed7 (patch)
tree1a85299cf52a94526360c66536a3fe9121026588
parent2b9fa44485b7fcb15885b3b353e500bd9cf3c314 (diff)
php-pecl-xslcache: cleanups
-rw-r--r--php-pecl-xslcache.spec43
1 files changed, 25 insertions, 18 deletions
diff --git a/php-pecl-xslcache.spec b/php-pecl-xslcache.spec
index 3595f92..e052b80 100644
--- a/php-pecl-xslcache.spec
+++ b/php-pecl-xslcache.spec
@@ -16,7 +16,7 @@
Summary: XSL extension that caches the parsed XSL style sheet
Name: php-pecl-%{pecl_name}
Version: 0.7.2
-Release: 1%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
+Release: 2%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
License: PHP
Group: Development/Languages
URL: http://pecl.php.net/package/%{pecl_name}
@@ -50,8 +50,21 @@ Provides: php-%{pecl_name}%{?_isa} = %{version}
Provides: php-pecl(%{pecl_name}) = %{version}
Provides: php-pecl(%{pecl_name})%{?_isa} = %{version}
+%if "%{?vendor}" == "Remi Collet"
+# Other third party repo stuff
+Obsoletes: php53-pecl-%{pecl_name}
+Obsoletes: php53u-pecl-%{pecl_name}
+Obsoletes: php54-pecl-%{pecl_name}
+%if "%{php_version}" > "5.5"
+Obsoletes: php55u-pecl-%{pecl_name}
+%endif
+%if "%{php_version}" > "5.6"
+Obsoletes: php56u-pecl-%{pecl_name}
+%endif
+%endif
+
%if 0%{?fedora} < 20
-# Filter shared private
+# Filter private shared object
%{?filter_provides_in: %filter_provides_in %{_libdir}/.*\.so$}
%{?filter_setup}
%endif
@@ -134,6 +147,12 @@ make -C ZTS install INSTALL_ROOT=%{buildroot}
install -D -m 644 %{pecl_name}.ini %{buildroot}%{php_ztsinidir}/%{pecl_name}.ini
%endif
+# Test & Documentation
+cd NTS
+for i in LICENSE $(grep 'role="doc"' ../package.xml | sed -e 's/^.*name="//;s/".*$//')
+do install -Dpm 644 $i %{buildroot}%{pecl_docdir}/%{pecl_name}/$i
+done
+
%post
%{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || :
@@ -153,14 +172,6 @@ cd NTS
--define extension=modules/%{pecl_name}.so \
--modules | grep %{pecl_name}
-: Upstream test suite for NTS extension
-TEST_PHP_EXECUTABLE=%{__php} \
-TEST_PHP_ARGS="-n -d extension=dom.so -d extension=$PWD/modules/%{pecl_name}.so" \
-NO_INTERACTION=1 \
-REPORT_EXIT_STATUS=1 \
-%{__php} -n run-tests.php
-
-
%if %{with_zts}
: Minimal load test for ZTS extension
cd ../ZTS
@@ -168,13 +179,6 @@ cd ../ZTS
--define extension=dom.so \
--define extension=modules/%{pecl_name}.so \
--modules | grep %{pecl_name}
-
-: Upstream test suite for ZTS extension
-TEST_PHP_EXECUTABLE=%{__ztsphp} \
-TEST_PHP_ARGS="-n -d extension=dom.so -d extension=$PWD/modules/%{pecl_name}.so" \
-NO_INTERACTION=1 \
-REPORT_EXIT_STATUS=1 \
-%{__ztsphp} -n run-tests.php
%endif
@@ -184,7 +188,7 @@ rm -rf %{buildroot}
%files
%defattr(-,root,root,-)
-%doc NTS/{LICENSE,CREDITS}
+%doc %{pecl_docdir}/%{pecl_name}
%{pecl_xmldir}/%{name}.xml
%config(noreplace) %{php_inidir}/%{pecl_name}.ini
%{php_extdir}/%{pecl_name}.so
@@ -196,5 +200,8 @@ rm -rf %{buildroot}
%changelog
+* Sat Mar 15 2014 Remi Collet <remi@fedoraproject.org> - 0.7.2-2
+- install doc in pecl_docdir
+
* Mon Oct 7 2013 Remi Collet <remi@fedoraproject.org> - 0.7.2-1
- initial package, version 0.7.2 (beta)