summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2014-03-24 17:47:25 +0100
committerRemi Collet <fedora@famillecollet.com>2014-03-24 17:47:25 +0100
commit51f4174163793df8a72c599e23b74bae3bd9ff65 (patch)
treefd781b55ae83e14c65a27f210885bcc0bb1bd1e2
parentde44ced08b4cb96a0f38eb278c12de5ce8bf37d4 (diff)
php-pecl-xslcache: allow SCL build
-rw-r--r--php-pecl-xslcache.spec30
1 files changed, 17 insertions, 13 deletions
diff --git a/php-pecl-xslcache.spec b/php-pecl-xslcache.spec
index dcc949d..37a429a 100644
--- a/php-pecl-xslcache.spec
+++ b/php-pecl-xslcache.spec
@@ -6,6 +6,7 @@
#
# Please, preserve the changelog entries
#
+%{?scl: %scl_package php-pecl-xslcache}
%{!?php_inidir: %global php_inidir %{_sysconfdir}/php.d}
%{!?__pecl: %global __pecl %{_bindir}/pecl}
%{!?__php: %global __php %{_bindir}/php}
@@ -14,9 +15,9 @@
%global pecl_name xslcache
Summary: XSL extension that caches the parsed XSL style sheet
-Name: php-pecl-%{pecl_name}
+Name: %{?scl_prefix}php-pecl-%{pecl_name}
Version: 0.7.2
-Release: 2%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
+Release: 3%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
License: PHP
Group: Development/Languages
URL: http://pecl.php.net/package/%{pecl_name}
@@ -27,28 +28,28 @@ Source0: http://pecl.php.net/get/%{pecl_name}-%{version}.tgz
Source1: http://www.php.net/license/3_01.txt
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
-BuildRequires: php-devel
-BuildRequires: php-pear
-BuildRequires: php-dom
+BuildRequires: %{?scl_prefix}php-devel
+BuildRequires: %{?scl_prefix}php-pear
+BuildRequires: %{?scl_prefix}php-dom
BuildRequires: libattr-devel
BuildRequires: libxslt-devel
Requires(post): %{__pecl}
Requires(postun): %{__pecl}
-Requires: php(zend-abi) = %{php_zend_api}
-Requires: php(api) = %{php_core_api}
+Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
+Requires: %{?scl_prefix}php(api) = %{php_core_api}
%if "%{php_version}" < "5.4"
# php 5.3.3 in EL-6 don't use arched virtual provides
# so only requires real packages instead
-Requires: php-xml%{?_isa}
+Requires: %{?scl_prefix}php-xml%{?_isa}
%else
-Requires: php-dom%{?_isa}
+Requires: %{?scl_prefix}php-dom%{?_isa}
%endif
-Provides: php-%{pecl_name} = %{version}
-Provides: php-%{pecl_name}%{?_isa} = %{version}
-Provides: php-pecl(%{pecl_name}) = %{version}
-Provides: php-pecl(%{pecl_name})%{?_isa} = %{version}
+Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
+Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
+Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
+Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
%if "%{?vendor}" == "Remi Collet"
# Other third party repo stuff
@@ -200,6 +201,9 @@ rm -rf %{buildroot}
%changelog
+* Mon Mar 24 2014 Remi Collet <remi@fedoraproject.org> - 0.7.2-3
+- allow SCL build
+
* Sat Mar 15 2014 Remi Collet <remi@fedoraproject.org> - 0.7.2-2
- install doc in pecl_docdir