summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2014-03-24 17:48:40 +0100
committerRemi Collet <fedora@famillecollet.com>2014-03-24 17:48:40 +0100
commitab809a0cb2220a7397977b9ac69a4607eb2fcc91 (patch)
tree627ff018af43116d3a4142ac75af4050a80df62d
parent8b858888fc93d6576f496335cd9b07efc9af4112 (diff)
php-pecl-xrange: allow SCL build
-rw-r--r--php-pecl-xrange.spec41
1 files changed, 29 insertions, 12 deletions
diff --git a/php-pecl-xrange.spec b/php-pecl-xrange.spec
index 31f902d..a86e81d 100644
--- a/php-pecl-xrange.spec
+++ b/php-pecl-xrange.spec
@@ -6,6 +6,7 @@
#
# Please, preserve the changelog entries
#
+%{?scl: %scl_package php-pecl-xrange}
%{!?php_inidir: %global php_inidir %{_sysconfdir}/php.d}
%{!?__pecl: %global __pecl %{_bindir}/pecl}
%{!?__php: %global __php %{_bindir}/php}
@@ -14,9 +15,9 @@
%global pecl_name xrange
Summary: Numeric iterator primitives
-Name: php-pecl-%{pecl_name}
+Name: %{?scl_prefix}php-pecl-%{pecl_name}
Version: 1.3.2
-Release: 2%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
+Release: 3%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
License: PHP
Group: Development/Languages
URL: http://pecl.php.net/package/%{pecl_name}
@@ -32,26 +33,39 @@ Source1: http://www.php.net/license/3_01.txt
Patch0: %{pecl_name}-svn.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
-BuildRequires: php-devel
-BuildRequires: php-pear
+BuildRequires: %{?scl_prefix}php-devel
+BuildRequires: %{?scl_prefix}php-pear
BuildRequires: pcre-devel
Requires(post): %{__pecl}
Requires(postun): %{__pecl}
-Requires: php(zend-abi) = %{php_zend_api}
-Requires: php(api) = %{php_core_api}
+Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
+Requires: %{?scl_prefix}php(api) = %{php_core_api}
%if "%{php_version}" < "5.4"
# php 5.3.3 in EL-6 don't use arched virtual provides
# so only requires real packages instead
-Requires: php-common%{?_isa}
+Requires: %{?scl_prefix}php-common%{?_isa}
%else
-Requires: php-spl%{?_isa}
+Requires: %{?scl_prefix}php-spl%{?_isa}
%endif
-Provides: php-%{pecl_name} = %{version}
-Provides: php-%{pecl_name}%{?_isa} = %{version}
-Provides: php-pecl(%{pecl_name}) = %{version}
-Provides: php-pecl(%{pecl_name})%{?_isa} = %{version}
+Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
+Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
+Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
+Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
+
+%if "%{?vendor}" == "Remi Collet"
+# Other third party repo stuff
+Obsoletes: php53-pecl-%{pecl_name}
+Obsoletes: php53u-pecl-%{pecl_name}
+Obsoletes: php54-pecl-%{pecl_name}
+%if "%{php_version}" > "5.5"
+Obsoletes: php55u-pecl-%{pecl_name}
+%endif
+%if "%{php_version}" > "5.6"
+Obsoletes: php56u-pecl-%{pecl_name}
+%endif
+%endif
%if 0%{?fedora} < 20 && 0%{?rhel} < 7
# Filter shared private
@@ -202,6 +216,9 @@ rm -rf %{buildroot}
%changelog
+* Mon Mar 24 2014 Remi Collet <remi@fedoraproject.org> - 1.3.2-3
+- allow SCL build
+
* Sat Nov 9 2013 Remi Collet <remi@fedoraproject.org> - 1.3.2-2
- cleanups for Copr
- install doc in pecl doc_dir