summaryrefslogtreecommitdiffstats
path: root/php-pecl-xmlrpc.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-06-02 10:22:30 +0200
committerRemi Collet <remi@remirepo.net>2020-06-02 10:22:30 +0200
commit1e06613a75635011ab3a709dc912bcd7ec47bb44 (patch)
tree18b1cc11e3642c208adcc1eb38899cb6f67bae91 /php-pecl-xmlrpc.spec
new package
Diffstat (limited to 'php-pecl-xmlrpc.spec')
-rw-r--r--php-pecl-xmlrpc.spec197
1 files changed, 197 insertions, 0 deletions
diff --git a/php-pecl-xmlrpc.spec b/php-pecl-xmlrpc.spec
new file mode 100644
index 0000000..d11a4ad
--- /dev/null
+++ b/php-pecl-xmlrpc.spec
@@ -0,0 +1,197 @@
+# remirepo spec file for php-pecl-xmlrpc
+#
+# Copyright (c) 2020 Remi Collet
+# License: CC-BY-SA
+# http://creativecommons.org/licenses/by-sa/4.0/
+#
+# Please, preserve the changelog entries
+#
+
+# we don't want -z defs linker flag
+%undefine _strict_symbol_defs_build
+
+%if 0%{?scl:1}
+%global sub_prefix %{scl_prefix}
+%scl_package php-pecl-xmlrpc
+%endif
+
+# https://github.com/php/pecl-networking-xmlrpc/commits/master
+%global gh_commit e71da6ad6f86fd149de14e42b54019edf3e629b7
+%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
+%global gh_owner php
+%global gh_project pecl-networking-xmlrpc
+%global gh_date 20200602
+%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
+%global pecl_name xmlrpc
+%global with_tests 0%{!?_without_tests:1}
+%global upver 1.0.0
+%global lower DEV
+# After 20-xml
+%global ini_name 30-%{pecl_name}.ini
+
+Summary: Functions to write XML-RPC servers and clients
+Name: %{?sub_prefix}php-pecl-%{pecl_name}
+Version: %{upver}%{?lower:~%{lower}}%{?gh_date:.%{gh_date}}
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+
+# Extension is PHP
+# Library is BSD
+License: PHP and BSD
+URL: https://pecl.php.net/package/%{pecl_name}
+Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{pecl_name}-%{upver}-%{gh_short}.tar.gz
+
+BuildRequires: %{?dtsprefix}gcc
+BuildRequires: %{?scl_prefix}php-devel > 8.0
+BuildRequires: %{?scl_prefix}php-pear
+BuildRequires: %{?scl_prefix}php-xml
+
+Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
+Requires: %{?scl_prefix}php(api) = %{php_core_api}
+Requires: %{?scl_prefix}php-xml%{?_isa}
+%{?_sclreq:Requires: %{?scl_prefix}runtime%{?_sclreq}%{?_isa}}
+
+# Set epoch so provides is > 0:8.0
+Obsoletes: %{?scl_prefix}php-%{pecl_name} < 8.0.0
+Provides: %{?scl_prefix}php-%{pecl_name} = 1:%{version}
+Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = 1:%{version}
+Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
+Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
+%if "%{?scl_prefix}" != "%{?sub_prefix}"
+Provides: %{?scl_prefix}php-pecl-%{pecl_name} = %{version}-%{release}
+Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}-%{release}
+%endif
+
+%if "%{?vendor}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
+# Other third party repo stuff
+%if "%{php_version}" > "8.0"
+Obsoletes: php80-pecl-%{pecl_name} <= %{version}
+Obsoletes: php80w-pecl-%{pecl_name} <= %{version}
+%endif
+%endif
+
+
+%description
+These functions can be used to write XML-RPC servers and clients.
+You can find more information about XML-RPC at http://www.xmlrpc.com/,
+and more documentation on this extension and its functions at
+http://xmlrpc-epi.sourceforge.net/.
+
+This extension which was previously part of the PHP distribution.
+
+This package is only provided for legacy applications.
+
+Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')%{?scl: as Software Collection (%{scl} by %{?scl_vendor}%{!?scl_vendor:rh})}.
+
+
+%prep
+%setup -qc
+mv %{gh_project}-%{gh_commit} NTS
+
+cd NTS
+# Check version as upstream often forget to update this
+extver=$(sed -n '/#define PHP_XMLRPC_VERSION/{s/.* "//;s/".*$//;p}' php_xmlrpc.h)
+if test "x${extver}" != "x%{upver}%{?rcver}%{?gh_date:-dev}"; then
+ : Error: Upstream RECODE version is ${extver}, expecting %{upver}%{?rcver}%{?gh_date:-dev}.
+ exit 1
+fi
+cd ..
+
+# Create configuration file
+cat << 'EOF' | tee %{ini_name}
+; Enable "%{pecl_name}" extension module
+extension=%{pecl_name}
+EOF
+
+
+%if %{with_zts}
+# duplicate for ZTS build
+cp -pr NTS ZTS
+%endif
+
+
+%build
+%{?dtsenable}
+
+peclconf() {
+%configure \
+ --with-xmlrpc \
+ --with-php-config=$1
+}
+
+cd NTS
+%{_bindir}/phpize
+peclconf %{_bindir}/php-config
+make %{?_smp_mflags}
+
+%if %{with_zts}
+cd ../ZTS
+%{_bindir}/zts-phpize
+peclconf %{_bindir}/zts-php-config
+make %{?_smp_mflags}
+%endif
+
+
+%install
+%{?dtsenable}
+
+# Install the NTS stuff
+make -C NTS install INSTALL_ROOT=%{buildroot}
+install -D -m 644 %{ini_name} %{buildroot}%{php_inidir}/%{ini_name}
+
+# Install the ZTS stuff
+%if %{with_zts}
+make -C ZTS install INSTALL_ROOT=%{buildroot}
+install -D -m 644 %{ini_name} %{buildroot}%{php_ztsinidir}/%{ini_name}
+%endif
+
+
+%check
+cd NTS
+
+: Minimal load test for NTS extension
+%{_bindir}/php --no-php-ini \
+ --define extension=xml \
+ --define extension=%{buildroot}%{php_extdir}/%{pecl_name}.so \
+ --modules | grep '^%{pecl_name}$'
+
+%if %{with_zts}
+cd ../ZTS
+
+: Minimal load test for ZTS extension
+%{__ztsphp} --no-php-ini \
+ --define extension=xml \
+ --define extension=%{buildroot}%{php_ztsextdir}/%{pecl_name}.so \
+ --modules | grep '^%{pecl_name}$'
+
+%endif
+
+%if %{with_tests}
+cd ../NTS
+
+: Run upstream test suite
+TEST_PHP_EXECUTABLE=%{__php} \
+TEST_PHP_ARGS="-n -d extension=xml -d extension=%{buildroot}%{php_extdir}/%{pecl_name}.so" \
+NO_INTERACTION=1 \
+REPORT_EXIT_STATUS=1 \
+%{__php} -n run-tests.php -q --show-diff
+%endif
+
+
+
+%files
+%{!?_licensedir:%global license %%doc}
+%license NTS/LICENSE
+%license NTS/libxmlrpc/COPYING
+
+%config(noreplace) %{php_inidir}/%{ini_name}
+%{php_extdir}/%{pecl_name}.so
+
+%if %{with_zts}
+%{php_ztsextdir}/%{pecl_name}.so
+%config(noreplace) %{php_ztsinidir}/%{ini_name}
+%endif
+
+
+%changelog
+* Tue Jun 2 2020 Remi Collet <remi@remirepo.net> - 1.0.0~DEV.20200202-1
+- initial package, version 1.0.0-dev