summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--Makefile4
-rw-r--r--php-pecl-xmldiff.spec205
-rw-r--r--xmldiff-system-diffmark.patch142
3 files changed, 351 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..13af741
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,4 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../../common/Makefile
+
diff --git a/php-pecl-xmldiff.spec b/php-pecl-xmldiff.spec
new file mode 100644
index 0000000..08f29e8
--- /dev/null
+++ b/php-pecl-xmldiff.spec
@@ -0,0 +1,205 @@
+# spec file for php-pecl-xmldiff
+#
+# Copyright (c) 2013 Remi Collet
+# License: CC-BY-SA
+# http://creativecommons.org/licenses/by-sa/3.0/
+#
+# Please, preserve the changelog entries
+#
+%{!?php_inidir: %{expand: %%global php_inidir %{_sysconfdir}/php.d}}
+%{!?php_incldir: %{expand: %%global php_incldir %{_includedir}/php}}
+%{!?__pecl: %{expand: %%global __pecl %{_bindir}/pecl}}
+
+%global with_zts 0%{?__ztsphp:1}
+%global pecl_name xmldiff
+
+Summary: XML diff and merge
+Name: php-pecl-%{pecl_name}
+Version: 0.8.0
+Release: 1%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
+License: BSD
+Group: Development/Languages
+URL: http://pecl.php.net/package/%{pecl_name}
+Source0: http://pecl.php.net/get/%{pecl_name}-%{version}.tgz
+
+# use syste diffmark library instead of bundled copy
+Patch0: xmldiff-system-diffmark.patch
+
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
+BuildRequires: php-devel > 5.3
+BuildRequires: php-pear
+BuildRequires: php-dom
+BuildRequires: php-libxml
+BuildRequires: diffmark-devel
+
+Requires(post): %{__pecl}
+Requires(postun): %{__pecl}
+Requires: php(zend-abi) = %{php_zend_api}
+Requires: php(api) = %{php_core_api}
+Requires: php-dom%{?_isa}
+Requires: php-libxml%{?_isa}
+
+Provides: php-%{pecl_name} = %{version}
+Provides: php-%{pecl_name}%{?_isa} = %{version}
+Provides: php-pecl(%{pecl_name}) = %{version}
+Provides: php-pecl(%{pecl_name})%{?_isa} = %{version}
+
+# Filter shared private
+%{?filter_provides_in: %filter_provides_in %{_libdir}/.*\.so$}
+%{?filter_setup}
+
+%description
+The extension is able to produce diffs of two XML documents and then to apply
+the difference to the source document. The diff is a XML document containing
+copy/insert/delete instruction nodes in human readable format. DOMDocument
+objects, local files and strings in memory can be processed.
+
+
+%package devel
+Summary: %{name} developer files (header)
+Group: Development/Libraries
+Requires: %{name}%{?_isa} = %{version}-%{release}
+Requires: php-devel%{?_isa}
+
+%description devel
+These are the files needed to compile programs using %{name}.
+
+
+%prep
+%setup -q -c
+mv %{pecl_name}-%{version} NTS
+
+cd NTS
+%patch0 -p0
+
+# drop bundled library to ensure it is not used
+rm -rf diffmark
+
+# Sanity check, really often broken
+extver=$(sed -n '/#define PHP_XMLDIFF_VERSION/{s/.* "//;s/".*$//;p}' php_xmldiff.h)
+if test "x${extver}" != "x%{version}%{?prever:-%{prever}}"; then
+ : Error: Upstream extension version is ${extver}, expecting %{version}%{?prever:-%{prever}}.
+ exit 1
+fi
+cd ..
+
+%if %{with_zts}
+# Duplicate source tree for NTS / ZTS build
+cp -pr NTS ZTS
+%endif
+
+# Create configuration file
+cat > %{pecl_name}.ini << 'EOF'
+; Enable %{pecl_name} extension module
+extension=%{pecl_name}.so
+EOF
+
+
+%build
+cd NTS
+%{_bindir}/phpize
+%configure \
+ --with-libdiffmark \
+ --with-php-config=%{_bindir}/php-config
+make %{?_smp_mflags}
+
+%if %{with_zts}
+cd ../ZTS
+%{_bindir}/zts-phpize
+%configure \
+ --with-libdiffmark \
+ --with-php-config=%{_bindir}/zts-php-config
+make %{?_smp_mflags}
+%endif
+
+
+%install
+rm -rf %{buildroot}
+
+make -C NTS \
+ install INSTALL_ROOT=%{buildroot}
+
+# install config file
+install -D -m 644 %{pecl_name}.ini %{buildroot}%{php_inidir}/%{pecl_name}.ini
+
+# Install XML package description
+install -D -m 644 package.xml %{buildroot}%{pecl_xmldir}/%{name}.xml
+
+%if %{with_zts}
+make -C ZTS \
+ install INSTALL_ROOT=%{buildroot}
+
+install -D -m 644 %{pecl_name}.ini %{buildroot}%{php_ztsinidir}/%{pecl_name}.ini
+%endif
+
+
+%post
+%{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || :
+
+
+%postun
+if [ $1 -eq 0 ] ; then
+ %{pecl_uninstall} %{pecl_name} >/dev/null || :
+fi
+
+
+%check
+cd NTS
+# Minimal load test for NTS extension
+php --no-php-ini \
+ --define extension=dom.so \
+ --define extension=modules/%{pecl_name}.so \
+ --modules | grep %{pecl_name}
+
+# Upstream test suite for NTS extension
+TEST_PHP_EXECUTABLE=%{_bindir}/php \
+TEST_PHP_ARGS="-n -d extension=dom.so -d extension=$PWD/modules/%{pecl_name}.so" \
+NO_INTERACTION=1 \
+REPORT_EXIT_STATUS=1 \
+%{_bindir}/php -n run-tests.php
+
+%if %{with_zts}
+cd ../ZTS
+# Minimal load test for ZTS extension
+%{__ztsphp} --no-php-ini \
+ --define extension=dom.so \
+ --define extension=modules/%{pecl_name}.so \
+ --modules | grep %{pecl_name}
+
+# Upstream test suite for ZTS extension
+TEST_PHP_EXECUTABLE=%{__ztsphp} \
+TEST_PHP_ARGS="-n -d extension=dom.so -d extension=$PWD/modules/%{pecl_name}.so" \
+NO_INTERACTION=1 \
+REPORT_EXIT_STATUS=1 \
+%{__ztsphp} -n run-tests.php
+%endif
+
+
+%clean
+rm -rf %{buildroot}
+
+
+%files
+%defattr(-,root,root,-)
+%doc NTS/CREDITS
+%{pecl_xmldir}/%{name}.xml
+%config(noreplace) %{php_inidir}/%{pecl_name}.ini
+%{php_extdir}/%{pecl_name}.so
+
+%if %{with_zts}
+%config(noreplace) %{php_ztsinidir}/%{pecl_name}.ini
+%{php_ztsextdir}/%{pecl_name}.so
+%endif
+
+%files devel
+%defattr(-,root,root,-)
+%{php_incldir}/ext/%{pecl_name}
+
+%if %{with_zts}
+%{php_ztsincldir}/ext/%{pecl_name}
+%endif
+
+
+%changelog
+* Sun Sep 29 2013 Remi Collet <remi@fedoraproject.org> - 0.8.0-1
+- initial package
diff --git a/xmldiff-system-diffmark.patch b/xmldiff-system-diffmark.patch
new file mode 100644
index 0000000..7443064
--- /dev/null
+++ b/xmldiff-system-diffmark.patch
@@ -0,0 +1,142 @@
+Index: config.m4
+===================================================================
+--- config.m4 (révision 331572)
++++ config.m4 (copie de travail)
+@@ -2,11 +2,13 @@
+ dnl config.m4 for extension xmldiff
+
+ PHP_ARG_ENABLE(xmldiff, whether to enable xmldiff support,
+-[ --enable-xmldiff Enable xmldiff support])
++[ --enable-xmldiff Enable xmldiff support])
++PHP_ARG_WITH(libdiffmark, whether to use system diffmark library,
++[ --with-libdiffmark=DIR XMLDiff: diffmark install prefix], no, no)
+
+ if test -z "$PHP_LIBXML_DIR"; then
+ PHP_ARG_WITH(libxml-dir, libxml2 install dir,
+- [ --with-libxml-dir=DIR XMLDiff: libxml2 install prefix], no, no)
++ [ --with-libxml-dir=DIR XMLDiff: libxml2 install prefix], no, no)
+ fi
+
+ if test "$PHP_XMLDIFF" != "no"; then
+@@ -21,45 +23,83 @@
+ AC_MSG_ERROR([XMLDiff extension requires DOM extension])
+ fi
+
+- PHP_DIFFMARK_SOURCES="diffmark/lib/compare.cc \
+- diffmark/lib/diff.cc \
+- diffmark/lib/link.cc \
+- diffmark/lib/merge.cc \
+- diffmark/lib/namespacecollector.cc \
+- diffmark/lib/nspace.cc \
+- diffmark/lib/target.cc \
+- diffmark/lib/xbuffer.cc \
+- diffmark/lib/xdoc.cc \
+- diffmark/lib/xutil.cc"
++ if test "$PHP_LIBDIFFMARK" != "no"; then
++ SEARCH_PATH="/usr /usr/local"
++ SEARCH_FOR="/include/diffmark/diff.hh"
++ AC_MSG_CHECKING([for diffmark headers])
++ if test -r $PHP_LIBDIFFMARK/$SEARCH_FOR; then # path given as parameter
++ LIBDIFFMARK_DIR=$PHP_LIBDIFFMARK
++ else
++ for i in $SEARCH_PATH ; do
++ if test -r $i/$SEARCH_FOR; then
++ LIBDIFFMARK_DIR=$i
++ fi
++ done
++ fi
++
++ if test -z "$LIBDIFFMARK_DIR"; then
++ AC_MSG_RESULT([not found])
++ AC_MSG_ERROR([The required diffmark library was not found.])
++ else
++ AC_MSG_RESULT(found in $LIBDIFFMARK_DIR)
++ fi
+
++ PHP_ADD_INCLUDE($LIBDIFFMARK_DIR/include/diffmark)
++ AC_DEFINE(HAVE_LIBDIFFMARK,1,[Use system diffmark library])
++ PHP_ADD_LIBRARY_WITH_PATH(diffmark, $LIBDIFFMARK_DIR/lib, XMLDIFF_SHARED_LIBADD)
+
+- PHP_SETUP_LIBXML(XMLDIFF_SHARED_LIBADD, [
+- AC_DEFINE(HAVE_XMLDIFF,1,[ ])
+- PHP_SUBST(XMLDIFF_SHARED_LIBADD)
+- PHP_NEW_EXTENSION(xmldiff, $PHP_DIFFMARK_SOURCES xmldiff.cpp, $ext_shared)
+- PHP_ADD_EXTENSION_DEP(xmldiff, dom, true)
+- PHP_ADD_EXTENSION_DEP(xmldiff, libxml, true)
+- PHP_ADD_BUILD_DIR($ext_builddir/diffmark/lib)
+- PHP_ADD_INCLUDE($ext_srcdir/diffmark/lib)
+- PHP_ADD_INCLUDE($ext_builddir/diffmark/lib)
+- PHP_ADD_INCLUDE($ext_srcdir/simplexml_compat)
+- PHP_ADD_INCLUDE($ext_builddir/simplexml_compat)
+- PHP_INSTALL_HEADERS([ext/xmldiff/php_xmldiff.h])
+- PHP_INSTALL_HEADERS([diffmark/lib/compare.hh])
+- PHP_INSTALL_HEADERS([diffmark/lib/compareimpl.hh])
+- PHP_INSTALL_HEADERS([diffmark/lib/diff.hh])
+- PHP_INSTALL_HEADERS([diffmark/lib/lcs.hh])
+- PHP_INSTALL_HEADERS([diffmark/lib/lcsimpl.hh])
+- PHP_INSTALL_HEADERS([diffmark/lib/link.hh])
+- PHP_INSTALL_HEADERS([diffmark/lib/merge.hh])
+- PHP_INSTALL_HEADERS([diffmark/lib/namespacecollector.hh])
+- PHP_INSTALL_HEADERS([diffmark/lib/nspace.hh])
+- PHP_INSTALL_HEADERS([diffmark/lib/target.hh])
+- PHP_INSTALL_HEADERS([diffmark/lib/xbuffer.hh])
+- PHP_INSTALL_HEADERS([diffmark/lib/xdoc.hh])
+- PHP_INSTALL_HEADERS([diffmark/lib/xutil.hh])
+- ], [
+- AC_MSG_ERROR([xml2-config not found. Please check your libxml2 installation.])
+- ])
++ PHP_SETUP_LIBXML(XMLDIFF_SHARED_LIBADD, [
++ AC_DEFINE(HAVE_XMLDIFF,1,[ ])
++ PHP_SUBST(XMLDIFF_SHARED_LIBADD)
++ PHP_NEW_EXTENSION(xmldiff, xmldiff.cpp, $ext_shared)
++ PHP_ADD_EXTENSION_DEP(xmldiff, dom, true)
++ PHP_ADD_EXTENSION_DEP(xmldiff, libxml, true)
++ PHP_ADD_INCLUDE($ext_srcdir/simplexml_compat)
++ PHP_ADD_INCLUDE($ext_builddir/simplexml_compat)
++ PHP_INSTALL_HEADERS([ext/xmldiff/php_xmldiff.h])
++ ], [
++ AC_MSG_ERROR([xml2-config not found. Please check your libxml2 installation.])
++ ])
++ else
++ PHP_DIFFMARK_SOURCES="diffmark/lib/compare.cc \
++ diffmark/lib/diff.cc \
++ diffmark/lib/link.cc \
++ diffmark/lib/merge.cc \
++ diffmark/lib/namespacecollector.cc \
++ diffmark/lib/nspace.cc \
++ diffmark/lib/target.cc \
++ diffmark/lib/xbuffer.cc \
++ diffmark/lib/xdoc.cc \
++ diffmark/lib/xutil.cc"
+
++ PHP_SETUP_LIBXML(XMLDIFF_SHARED_LIBADD, [
++ AC_DEFINE(HAVE_XMLDIFF,1,[ ])
++ PHP_SUBST(XMLDIFF_SHARED_LIBADD)
++ PHP_NEW_EXTENSION(xmldiff, $PHP_DIFFMARK_SOURCES xmldiff.cpp, $ext_shared)
++ PHP_ADD_EXTENSION_DEP(xmldiff, dom, true)
++ PHP_ADD_EXTENSION_DEP(xmldiff, libxml, true)
++ PHP_ADD_BUILD_DIR($ext_builddir/diffmark/lib)
++ PHP_ADD_INCLUDE($ext_srcdir/diffmark/lib)
++ PHP_ADD_INCLUDE($ext_builddir/diffmark/lib)
++ PHP_ADD_INCLUDE($ext_srcdir/simplexml_compat)
++ PHP_ADD_INCLUDE($ext_builddir/simplexml_compat)
++ PHP_INSTALL_HEADERS([ext/xmldiff/php_xmldiff.h])
++ PHP_INSTALL_HEADERS([diffmark/lib/compare.hh])
++ PHP_INSTALL_HEADERS([diffmark/lib/compareimpl.hh])
++ PHP_INSTALL_HEADERS([diffmark/lib/diff.hh])
++ PHP_INSTALL_HEADERS([diffmark/lib/lcs.hh])
++ PHP_INSTALL_HEADERS([diffmark/lib/lcsimpl.hh])
++ PHP_INSTALL_HEADERS([diffmark/lib/link.hh])
++ PHP_INSTALL_HEADERS([diffmark/lib/merge.hh])
++ PHP_INSTALL_HEADERS([diffmark/lib/namespacecollector.hh])
++ PHP_INSTALL_HEADERS([diffmark/lib/nspace.hh])
++ PHP_INSTALL_HEADERS([diffmark/lib/target.hh])
++ PHP_INSTALL_HEADERS([diffmark/lib/xbuffer.hh])
++ PHP_INSTALL_HEADERS([diffmark/lib/xdoc.hh])
++ PHP_INSTALL_HEADERS([diffmark/lib/xutil.hh])
++ ], [
++ AC_MSG_ERROR([xml2-config not found. Please check your libxml2 installation.])
++ ])
++ fi
++
+ fi