summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-01-18 09:42:12 +0100
committerRemi Collet <remi@remirepo.net>2021-01-18 09:42:12 +0100
commitfb7e80b10a95c2b06ef9f9e155f7299017b9555e (patch)
tree19eff33d0301db37a06f0b58baaad1fbb56e8438
parent1170a612ee396d698e4dd821efcd3cabb912dedd (diff)
update to 1.1.3
-rw-r--r--.gitignore2
-rw-r--r--PHPINFO4
-rw-r--r--REFLECTION18
-rw-r--r--php-pecl-xmldiff.spec22
-rw-r--r--xmldiff-php8.patch43
5 files changed, 29 insertions, 60 deletions
diff --git a/.gitignore b/.gitignore
index 1ab5c4f..01f0400 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,5 +1,7 @@
+clog
package-*.xml
*.tgz
+*.tar.bz2
*.tar.gz
*.tar.xz
*.tar.xz.asc
diff --git a/PHPINFO b/PHPINFO
index 80a0cd4..3f4f558 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,6 +2,6 @@
xmldiff
xmldiff support => enabled
-xmldiff version => 1.1.2
+xmldiff version => 1.1.3
diffmark library => system
-Revision => $Id: xmldiff.cpp 335872 2015-02-03 17:21:38Z ab $
+Revision => $Id: xmldiff.cpp 350542 2020-09-10 12:08:03Z remi $
diff --git a/REFLECTION b/REFLECTION
index db2e8ac..2977a01 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #117 xmldiff version 1.1.2 ] {
+Extension [ <persistent> extension #119 xmldiff version 1.1.3 ] {
- Dependencies {
Dependency [ dom (Required) ]
@@ -22,6 +22,10 @@ Extension [ <persistent> extension #117 xmldiff version 1.1.2 ] {
- Methods [3] {
Method [ <internal:xmldiff, ctor> public method __construct ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <optional> $nsurl ]
+ }
}
Method [ <internal:xmldiff> abstract public method diff ] {
@@ -74,6 +78,10 @@ Extension [ <persistent> extension #117 xmldiff version 1.1.2 ] {
}
Method [ <internal:xmldiff, inherits XMLDiff\Base, ctor> public method __construct ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <optional> $nsurl ]
+ }
}
}
}
@@ -110,6 +118,10 @@ Extension [ <persistent> extension #117 xmldiff version 1.1.2 ] {
}
Method [ <internal:xmldiff, inherits XMLDiff\Base, ctor> public method __construct ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <optional> $nsurl ]
+ }
}
}
}
@@ -146,6 +158,10 @@ Extension [ <persistent> extension #117 xmldiff version 1.1.2 ] {
}
Method [ <internal:xmldiff, inherits XMLDiff\Base, ctor> public method __construct ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <optional> $nsurl ]
+ }
}
}
}
diff --git a/php-pecl-xmldiff.spec b/php-pecl-xmldiff.spec
index 3ef491f..b20bed1 100644
--- a/php-pecl-xmldiff.spec
+++ b/php-pecl-xmldiff.spec
@@ -1,6 +1,6 @@
# remirepo spec file for php-pecl-xmldiff
#
-# Copyright (c) 2013-2020 Remi Collet
+# Copyright (c) 2013-2021 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
@@ -23,16 +23,15 @@
Summary: XML diff and merge
Name: %{?sub_prefix}php-pecl-%{pecl_name}
-Version: 1.1.2
-Release: 16%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Version: 1.1.3
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: BSD
URL: https://pecl.php.net/package/%{pecl_name}
Source0: https://pecl.php.net/get/%{pecl_name}-%{version}.tgz
-Patch0: %{pecl_name}-php8.patch
-
BuildRequires: %{?dtsprefix}gcc
-BuildRequires: %{?scl_prefix}php-devel > 5.3
+BuildRequires: make
+BuildRequires: %{?scl_prefix}php-devel
BuildRequires: %{?scl_prefix}php-pear
BuildRequires: %{?scl_prefix}php-dom
BuildRequires: %{?scl_prefix}php-libxml
@@ -66,12 +65,6 @@ Obsoletes: php80-pecl-%{pecl_name} <= %{version}
%endif
%endif
-%if 0%{?fedora} < 20 && 0%{?rhel} < 7
-# Filter shared private
-%{?filter_provides_in: %filter_provides_in %{_libdir}/.*\.so$}
-%{?filter_setup}
-%endif
-
%description
The extension is able to produce diffs of two XML documents and then to apply
@@ -103,8 +96,6 @@ sed -e '/name="diffmark/d' \
mv %{pecl_name}-%{version} NTS
cd NTS
-%patch0 -p0 -b .up
-
# drop bundled library to ensure it is not used
rm -rf diffmark
@@ -251,6 +242,9 @@ REPORT_EXIT_STATUS=1 \
%changelog
+* Mon Jan 18 2021 Remi Collet <remi@remirepo.net> - 1.1.3-1
+- update to 1.1.3
+
* Wed Sep 30 2020 Remi Collet <remi@remirepo.net> - 1.1.2-16
- rebuild for PHP 8.0.0RC1
diff --git a/xmldiff-php8.patch b/xmldiff-php8.patch
deleted file mode 100644
index 0d9cabb..0000000
--- a/xmldiff-php8.patch
+++ /dev/null
@@ -1,43 +0,0 @@
-Index: php_xmldiff.h
-===================================================================
---- php_xmldiff.h (révision 350541)
-+++ php_xmldiff.h (copie de travail)
-@@ -147,6 +147,14 @@
- examples in any other php module directory.
- */
-
-+#ifndef TSRMLS_DC
-+#define TSRMLS_D void
-+#define TSRMLS_DC
-+#define TSRMLS_C
-+#define TSRMLS_CC
-+#define TSRMLS_FETCH()
-+#endif
-+
- #ifdef ZTS
- #define XMLDIFF_G(v) TSRMG(xmldiff_globals_id, zend_xmldiff_globals *, v)
- #else
-Index: xmldiff.cpp
-===================================================================
---- xmldiff.cpp (révision 350541)
-+++ xmldiff.cpp (copie de travail)
-@@ -62,6 +62,10 @@
- /* }}} */
-
- /* {{{ arginfo */
-+ZEND_BEGIN_ARG_INFO_EX(XMLDiff_construct, 0, 0, 0)
-+ ZEND_ARG_INFO(0, nsurl)
-+ZEND_END_ARG_INFO()
-+
- ZEND_BEGIN_ARG_INFO_EX(XMLDiff_diff, 0, 0, 2)
- ZEND_ARG_INFO(0, from)
- ZEND_ARG_INFO(0, to)
-@@ -75,7 +79,7 @@
-
- /* {{{ xmldiff_methods[] */
- const zend_function_entry XMLDiffBase_methods[] = {
-- PHP_ME(XMLDiffBase, __construct, NULL, ZEND_ACC_PUBLIC)
-+ PHP_ME(XMLDiffBase, __construct, XMLDiff_construct, ZEND_ACC_PUBLIC)
- PHP_ME(XMLDiffBase, diff, XMLDiff_diff, ZEND_ACC_PUBLIC | ZEND_ACC_ABSTRACT)
- PHP_ME(XMLDiffBase, merge, XMLDiff_merge, ZEND_ACC_PUBLIC | ZEND_ACC_ABSTRACT)
- PHP_FE_END