summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2014-04-17 18:05:45 +0200
committerRemi Collet <fedora@famillecollet.com>2014-04-17 18:05:45 +0200
commit652bd697240bcbd85bd060fb7a8cbd7c6ac74415 (patch)
treeaa3957cafeca8a648917488c1aba51699017b824
parenta5fe599adeab535ef140d8b59b3243a807ce0637 (diff)
php-pecl: add numerical prefix to extension configuration file (all done !)
-rw-r--r--php-pecl-xmldiff.spec22
1 files changed, 16 insertions, 6 deletions
diff --git a/php-pecl-xmldiff.spec b/php-pecl-xmldiff.spec
index 631ad83..84c8792 100644
--- a/php-pecl-xmldiff.spec
+++ b/php-pecl-xmldiff.spec
@@ -14,11 +14,18 @@
%global with_zts 0%{?__ztsphp:1}
%global pecl_name xmldiff
+%if "%{php_version}" < "5.6"
+# After dom
+%global ini_name %{pecl_name}.ini
+%else
+# After 20-dom
+%global ini_name 40-%{pecl_name}.ini
+%endif
Summary: XML diff and merge
Name: %{?scl_prefix}php-pecl-%{pecl_name}
Version: 0.9.2
-Release: 2%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
+Release: 3%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
License: BSD
Group: Development/Languages
URL: http://pecl.php.net/package/%{pecl_name}
@@ -108,7 +115,7 @@ cp -pr NTS ZTS
%endif
# Create configuration file
-cat > %{pecl_name}.ini << 'EOF'
+cat > %{ini_name} << 'EOF'
; Enable %{pecl_name} extension module
extension=%{pecl_name}.so
EOF
@@ -138,7 +145,7 @@ rm -rf %{buildroot}
make -C NTS install INSTALL_ROOT=%{buildroot}
# install config file
-install -D -m 644 %{pecl_name}.ini %{buildroot}%{php_inidir}/%{pecl_name}.ini
+install -D -m 644 %{ini_name} %{buildroot}%{php_inidir}/%{ini_name}
# Install XML package description
install -D -m 644 package.xml %{buildroot}%{pecl_xmldir}/%{name}.xml
@@ -146,7 +153,7 @@ install -D -m 644 package.xml %{buildroot}%{pecl_xmldir}/%{name}.xml
%if %{with_zts}
make -C ZTS install INSTALL_ROOT=%{buildroot}
-install -D -m 644 %{pecl_name}.ini %{buildroot}%{php_ztsinidir}/%{pecl_name}.ini
+install -D -m 644 %{ini_name} %{buildroot}%{php_ztsinidir}/%{ini_name}
%endif
# Test & Documentation
@@ -208,11 +215,11 @@ rm -rf %{buildroot}
%defattr(-,root,root,-)
%doc %{pecl_docdir}/%{pecl_name}
%{pecl_xmldir}/%{name}.xml
-%config(noreplace) %{php_inidir}/%{pecl_name}.ini
+%config(noreplace) %{php_inidir}/%{ini_name}
%{php_extdir}/%{pecl_name}.so
%if %{with_zts}
-%config(noreplace) %{php_ztsinidir}/%{pecl_name}.ini
+%config(noreplace) %{php_ztsinidir}/%{ini_name}
%{php_ztsextdir}/%{pecl_name}.so
%endif
@@ -227,6 +234,9 @@ rm -rf %{buildroot}
%changelog
+* Thu Apr 17 2014 Remi Collet <remi@fedoraproject.org> - 0.9.2-3
+- add numerical prefix to extension configuration file (php 5.6)
+
* Thu Jan 2 2014 Remi Collet <remi@fedoraproject.org> - 0.9.2-2
- adapt for SCL
- doc in pecl_docdir