summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2013-11-02 18:37:45 +0100
committerRemi Collet <fedora@famillecollet.com>2013-11-02 18:37:45 +0100
commit64062aaed8ca7740a83a28547029f79c0b2074e6 (patch)
tree0ba7be39f802e8b5779ca52a01037f300ae689f2
parent3114c56daf9aa2c8cf187147528a318ad9e9c570 (diff)
php-pecl-xmldiff: 0.9.1 (stable)
-rw-r--r--php-pecl-xmldiff.spec18
-rw-r--r--xmldiff-php533.patch40
2 files changed, 9 insertions, 49 deletions
diff --git a/php-pecl-xmldiff.spec b/php-pecl-xmldiff.spec
index 5a7d156..e2f2519 100644
--- a/php-pecl-xmldiff.spec
+++ b/php-pecl-xmldiff.spec
@@ -16,17 +16,13 @@
Summary: XML diff and merge
Name: php-pecl-%{pecl_name}
-Version: 0.9.0
-Release: 2%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
+Version: 0.9.1
+Release: 1%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
License: BSD
Group: Development/Languages
URL: http://pecl.php.net/package/%{pecl_name}
Source0: http://pecl.php.net/get/%{pecl_name}-%{version}.tgz
-# Fix build with PHP <= 5.3.6
-# http://svn.php.net/viewvc?view=revision&revision=332040
-Patch0: %{pecl_name}-php533.patch
-
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildRequires: php-devel > 5.3
BuildRequires: php-pear
@@ -53,9 +49,11 @@ Provides: php-%{pecl_name}%{?_isa} = %{version}
Provides: php-pecl(%{pecl_name}) = %{version}
Provides: php-pecl(%{pecl_name})%{?_isa} = %{version}
+%if 0%{?fedora} < 20
# Filter shared private
%{?filter_provides_in: %filter_provides_in %{_libdir}/.*\.so$}
%{?filter_setup}
+%endif
%description
The extension is able to produce diffs of two XML documents and then to apply
@@ -80,8 +78,6 @@ These are the files needed to compile programs using %{name}.
mv %{pecl_name}-%{version} NTS
cd NTS
-%patch0 -p1
-
# drop bundled library to ensure it is not used
rm -rf diffmark
@@ -211,11 +207,15 @@ rm -rf %{buildroot}
%changelog
+* Sat Nov 02 2013 Remi Collet <remi@fedoraproject.org> - 0.9.1-1
+- Update to 0.9.1 (stable)
+- drop our patch merged upstream
+
* Fri Nov 01 2013 Remi Collet <remi@fedoraproject.org> - 0.9.0-2
- fix build with php 5.3.3 in RHEL-6
* Wed Oct 02 2013 Remi Collet <remi@fedoraproject.org> - 0.9.0-1
-- Update to 0.9.0
+- Update to 0.9.0 (stable)
- License now provided in upstream sources
- Drop merged patch for system libdiffmark
diff --git a/xmldiff-php533.patch b/xmldiff-php533.patch
deleted file mode 100644
index 8ef4434..0000000
--- a/xmldiff-php533.patch
+++ /dev/null
@@ -1,40 +0,0 @@
-diff -up xmldiff-0.9.0/php_xmldiff.h.old xmldiff-0.9.0/php_xmldiff.h
---- xmldiff-0.9.0/php_xmldiff.h.old 2013-11-01 07:13:21.917000281 +0100
-+++ xmldiff-0.9.0/php_xmldiff.h 2013-11-01 06:58:51.805999994 +0100
-@@ -162,7 +162,14 @@ PHP_XMLDIFF_API xmlChar *
- php_xmldiff_do_merge_memory(const char *src, int src_len, const char *diff, int diff_len, struct ze_xmldiff_obj *zxo TSRMLS_DC);
-
- #if PHP_MAJOR_VERSION == 5 && PHP_MINOR_VERSION > 3
--# define DOM_RET_OBJ_EX DOM_RET_OBJ
-+# define XMLDIFF_DOM_RET_OBJ DOM_RET_OBJ
-+#elif PHP_MAJOR_VERSION == 5 && PHP_MINOR_VERSION == 3 && PHP_RELEASE_VERSION > 6
-+# define XMLDIFF_DOM_RET_OBJ DOM_RET_OBJ_EX
-+#else
-+# define XMLDIFF_DOM_RET_OBJ(obj, ret, domobject); do { \
-+ zval *rv = NULL; \
-+ DOM_RET_OBJ(rv, obj, ret, domobject); \
-+ } while(0);
- #endif
-
- #endif /* PHP_XMLDIFF_H */
-diff -up xmldiff-0.9.0/xmldiff.cpp.old xmldiff-0.9.0/xmldiff.cpp
---- xmldiff-0.9.0/xmldiff.cpp.old 2013-11-01 07:13:36.941006721 +0100
-+++ xmldiff-0.9.0/xmldiff.cpp 2013-11-01 06:56:56.729005006 +0100
-@@ -577,7 +577,7 @@ PHP_METHOD(XMLDiffDOM, diff)
- retNode = (xmlNodePtr)retDoc;
-
- /* return the resulting dom object */
-- DOM_RET_OBJ_EX(retNode, &domRetStatus, NULL);
-+ XMLDIFF_DOM_RET_OBJ(retNode, &domRetStatus, NULL);
-
- /* set return object properties */
- php_xmldiff_set_out_dom_props(return_value TSRMLS_CC);
-@@ -626,7 +626,7 @@ PHP_METHOD(XMLDiffDOM, merge)
- retNode = (xmlNodePtr)retDoc;
-
- /* return the resulting dom object */
-- DOM_RET_OBJ_EX(retNode, &domRetStatus, NULL);
-+ XMLDIFF_DOM_RET_OBJ(retNode, &domRetStatus, NULL);
-
- /* set return object properties */
- php_xmldiff_set_out_dom_props(return_value TSRMLS_CC);