summaryrefslogtreecommitdiffstats
path: root/php-pecl-xlswriter.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-pecl-xlswriter.spec')
-rw-r--r--php-pecl-xlswriter.spec19
1 files changed, 17 insertions, 2 deletions
diff --git a/php-pecl-xlswriter.spec b/php-pecl-xlswriter.spec
index 65008bb..18459b3 100644
--- a/php-pecl-xlswriter.spec
+++ b/php-pecl-xlswriter.spec
@@ -7,6 +7,8 @@
# Please, preserve the changelog entries
#
+# TODO unbundle libxlsxio
+
# we don't want -z defs linker flag
%undefine _strict_symbol_defs_build
@@ -27,11 +29,13 @@
Summary: An efficient and fast xlsx file export extension
Name: %{?sub_prefix}php-pecl-%{pecl_name}
Version: 1.2.7
-Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 2%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: BSD
URL: http://pecl.php.net/package/%{pecl_name}
Source0: http://pecl.php.net/get/%{pecl_name}-%{version}.tgz
+Patch0: https://patch-diff.githubusercontent.com/raw/viest/php-ext-excel-export/pull/158.patch
+
BuildRequires: %{?dtsprefix}gcc
BuildRequires: %{?scl_prefix}php-devel >= 7
BuildRequires: %{?scl_prefix}php-pear
@@ -103,7 +107,8 @@ sed -e 's/role="test"/role="src"/' \
cd NTS
# we use the system library
-rm -r library
+rm -r library/libxlsxwriter/src
+%patch0 -p1 -b .pr158
# Sanity check, really often broken
extver=$(sed -n '/#define PHP_XLSWRITER_VERSION/{s/.* "//;s/".*$//;p}' php_xlswriter.h)
@@ -132,6 +137,11 @@ peclbuild() {
%configure \
--with-xlswriter \
--with-libxlsxwriter=%{_prefix} \
+%if 0%{?rhel} == 6
+ --disable-reader \
+%else
+ --enable-reader \
+%endif
--with-php-config=$1
make %{?_smp_mflags}
@@ -245,6 +255,11 @@ cd ..
%changelog
+* Fri Sep 6 2019 Remi Collet <remi@remirepo.net> - 1.2.7-2
+- enable the reader
+- add patch to fix config.m4 from
+ https://github.com/viest/php-ext-excel-export/pull/158
+
* Fri Sep 6 2019 Remi Collet <remi@remirepo.net> - 1.2.7-1
- update to 1.2.7