summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--php-pecl-xlswriter.spec12
1 files changed, 10 insertions, 2 deletions
diff --git a/php-pecl-xlswriter.spec b/php-pecl-xlswriter.spec
index c62416d..e9f0d11 100644
--- a/php-pecl-xlswriter.spec
+++ b/php-pecl-xlswriter.spec
@@ -25,16 +25,18 @@
%global ini_name 40-%{pecl_name}.ini
# No soname, so manage dependency on available version
-%global libxlsxwriter_version 0.7.8
+%global libxlsxwriter_version 0.8.0
Summary: An efficient and fast xlsx file export extension
Name: %{?sub_prefix}php-pecl-%{pecl_name}
Version: 1.2.2
-Release: 4%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 5%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: BSD
URL: http://pecl.php.net/package/%{pecl_name}
Source0: http://pecl.php.net/get/%{pecl_name}-%{version}.tgz
+Patch0: %{pecl_name}-build.patch
+
BuildRequires: %{?dtsprefix}gcc
BuildRequires: %{?scl_prefix}php-devel >= 7
BuildRequires: %{?scl_prefix}php-pear
@@ -102,6 +104,8 @@ sed -e 's/role="test"/role="src"/' \
-i package.xml
cd NTS
+%patch0 -p1 -b .fixbuild
+
# Sanity check, really often broken
extver=$(sed -n '/#define PHP_XLSWRITER_VERSION/{s/.* "//;s/".*$//;p}' php_xls_writer.h)
if test "x${extver}" != "x%{version}%{?prever:-%{prever}}"; then
@@ -241,6 +245,10 @@ cd ..
%changelog
+* Wed Sep 12 2018 Remi Collet <remi@remirepo.net> - 1.2.2-5
+- rebuild with libxlsxwriter 0.8.0
+- open https://github.com/viest/php-ext-excel-export/pull/84
+
* Fri Aug 31 2018 Remi Collet <remi@remirepo.net> - 1.2.2-4
- rebuild with libxlsxwriter 0.7.8
- open https://github.com/viest/php-ext-excel-export/pull/81