summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PHPINFO4
-rw-r--r--REFLECTION18
-rw-r--r--php-pecl-xlswriter.spec7
3 files changed, 16 insertions, 13 deletions
diff --git a/PHPINFO b/PHPINFO
index e514acb..fa6affb 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -3,7 +3,7 @@ xlswriter
xlswriter support => enabled
Version => 1.3.5
-libxlsxwriter headers version => 0.9.4
-libxlsxwriter library version => 0.9.4
+libxlsxwriter headers version => 0.9.5
+libxlsxwriter library version => 0.9.5
libxlsxio headers version => 0.2.26
libxlsxio library version => 0.2.26
diff --git a/REFLECTION b/REFLECTION
index c353ad4..35eeaae 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -564,15 +564,15 @@ Extension [ <persistent> extension #101 xlswriter version 1.3.5 ] {
Constant [ public int CHART_COLUMN_STACKED ] { 8 }
Constant [ public int CHART_COLUMN_STACKED_PERCENT ] { 9 }
Constant [ public int CHART_DOUGHNUT ] { 10 }
- Constant [ public int CHART_PIE ] { 12 }
- Constant [ public int CHART_SCATTER ] { 13 }
- Constant [ public int CHART_SCATTER_STRAIGHT ] { 14 }
- Constant [ public int CHART_SCATTER_STRAIGHT_WITH_MARKERS ] { 15 }
- Constant [ public int CHART_SCATTER_SMOOTH ] { 16 }
- Constant [ public int CHART_SCATTER_SMOOTH_WITH_MARKERS ] { 17 }
- Constant [ public int CHART_RADAR ] { 18 }
- Constant [ public int CHART_RADAR_WITH_MARKERS ] { 19 }
- Constant [ public int CHART_RADAR_FILLED ] { 20 }
+ Constant [ public int CHART_PIE ] { 14 }
+ Constant [ public int CHART_SCATTER ] { 15 }
+ Constant [ public int CHART_SCATTER_STRAIGHT ] { 16 }
+ Constant [ public int CHART_SCATTER_STRAIGHT_WITH_MARKERS ] { 17 }
+ Constant [ public int CHART_SCATTER_SMOOTH ] { 18 }
+ Constant [ public int CHART_SCATTER_SMOOTH_WITH_MARKERS ] { 19 }
+ Constant [ public int CHART_RADAR ] { 20 }
+ Constant [ public int CHART_RADAR_WITH_MARKERS ] { 21 }
+ Constant [ public int CHART_RADAR_FILLED ] { 22 }
Constant [ public int CHART_LEGEND_NONE ] { 0 }
Constant [ public int CHART_LEGEND_RIGHT ] { 1 }
Constant [ public int CHART_LEGEND_LEFT ] { 2 }
diff --git a/php-pecl-xlswriter.spec b/php-pecl-xlswriter.spec
index 3da20d6..74d1eb3 100644
--- a/php-pecl-xlswriter.spec
+++ b/php-pecl-xlswriter.spec
@@ -22,13 +22,13 @@
%global ini_name 40-%{pecl_name}.ini
# No soname, so manage dependency on available version
-%global libxlsxwriter_version 0.9.4
+%global libxlsxwriter_version 0.9.5
%global libxlsxio_version 0.2.26
Summary: An efficient and fast xlsx file export extension
Name: %{?sub_prefix}php-pecl-%{pecl_name}
Version: 1.3.5
-Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 2%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: BSD
URL: https://pecl.php.net/package/%{pecl_name}
Source0: https://pecl.php.net/get/%{pecl_name}-%{version}.tgz
@@ -251,6 +251,9 @@ cd ..
%changelog
+* Mon Jun 1 2020 Remi Collet <remi@remirepo.net> - 1.3.5-2
+- build using libxlsxwriter version 0.9.5
+
* Tue May 26 2020 Remi Collet <remi@remirepo.net> - 1.3.5-1
- update to 1.3.5
- drop patch merged upstream