summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PHPINFO2
-rw-r--r--REFLECTION2
-rw-r--r--php-pecl-xlswriter.spec47
3 files changed, 31 insertions, 20 deletions
diff --git a/PHPINFO b/PHPINFO
index 2df9aee..9826b3e 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,6 +2,6 @@
xlswriter
xlswriter support => enabled
-Version => 1.5.4
+Version => 1.5.5
bundled libxlsxwriter version => 1.1.3
bundled libxlsxio version => 0.2.27
diff --git a/REFLECTION b/REFLECTION
index fa4fcb4..c3d3e93 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #103 xlswriter version 1.5.4 ] {
+Extension [ <persistent> extension #103 xlswriter version 1.5.5 ] {
- Functions {
Function [ <internal:xlswriter> function xlswriter_get_version ] {
diff --git a/php-pecl-xlswriter.spec b/php-pecl-xlswriter.spec
index b31e174..4ad7998 100644
--- a/php-pecl-xlswriter.spec
+++ b/php-pecl-xlswriter.spec
@@ -13,13 +13,18 @@
%bcond_with syslib
%bcond_without tests
-%if 0%{?scl:1}
-%scl_package php-pecl-xlswriter
-%endif
+%{?scl:%scl_package php-pecl-xlswriter}
+
+# Defined in Fedora >= 37 and RHEL >= 10, in PHP >= 7.4 for remirepo
+%{!?__phpize: %global __phpize %{_bindir}/phpize}
+%{!?__ztsphpize: %global __ztsphpize %{_bindir}/zts-phpize}
+%{!?__phpconfig: %global __phpconfig %{_bindir}/php-config}
+%{!?__ztsphpconfig:%global __ztsphpconfig %{_bindir}/zts-php-config}
%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
%global pecl_name xlswriter
%global ini_name 40-%{pecl_name}.ini
+%global sources %{pecl_name}-%{version}
%if %{with syslib}
# No soname, so manage dependency on available version
@@ -29,7 +34,7 @@
Summary: An efficient and fast xlsx file extension
Name: %{?scl_prefix}php-pecl-%{pecl_name}
-Version: 1.5.4
+Version: 1.5.5
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: BSD-2-Clause
URL: https://pecl.php.net/package/%{pecl_name}
@@ -96,15 +101,13 @@ Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSIO
%prep
%setup -q -c
-mv %{pecl_name}-%{version} NTS
-
# Don't install tests
sed -e 's/role="test"/role="src"/' \
%{?_licensedir:-e '/LICENSE/s/role="doc"/role="src"/' } \
-e '/name="library/d' \
-i package.xml
-cd NTS
+pushd %{sources}
%if %{with syslib}
# we use the system libraries
rm -r library
@@ -116,11 +119,12 @@ if test "x${extver}" != "x%{version}%{?prever:-%{prever}}"; then
: Error: Upstream extension version is ${extver}, expecting %{version}%{?prever:-%{prever}}.
exit 1
fi
-cd ..
+popd
+mkdir NTS
%if %{with_zts}
# Duplicate source tree for NTS / ZTS build
-cp -pr NTS ZTS
+mkdir ZTS
%endif
# Create configuration file
@@ -130,11 +134,14 @@ extension=%{pecl_name}.so
EOF
+%global _configure ../%{sources}/configure
+
%build
%{?dtsenable}
peclbuild() {
%configure \
+ --without-openssl \
--with-xlswriter \
%if %{with syslib}
--with-libxlsxwriter=%{_prefix} \
@@ -146,14 +153,15 @@ peclbuild() {
make %{?_smp_mflags}
}
-cd NTS
-%{_bindir}/phpize
-peclbuild %{_bindir}/php-config
+cd %{sources}
+%{__phpize}
+
+cd ../NTS
+peclbuild %{__phpconfig}
%if %{with_zts}
cd ../ZTS
-%{_bindir}/zts-phpize
-peclbuild %{_bindir}/zts-php-config
+peclbuild %{__ztsphpconfig}
%endif
@@ -176,7 +184,7 @@ install -D -m 644 %{ini_name} %{buildroot}%{php_ztsinidir}/%{ini_name}
# Documentation
for i in $(grep 'role="doc"' package.xml | sed -e 's/^.*name="//;s/".*$//')
-do install -Dpm 644 NTS/$i %{buildroot}%{pecl_docdir}/%{pecl_name}/$i
+do install -Dpm 644 %{sources}/$i %{buildroot}%{pecl_docdir}/%{pecl_name}/$i
done
@@ -206,7 +214,7 @@ OPT="-q -P --show-diff"
OPT="$OPT %{?_smp_mflags}"
%endif
-cd NTS
+cd %{sources}
: Minimal load test for NTS extension
%{__php} --no-php-ini \
--define extension=%{buildroot}%{php_extdir}/%{pecl_name}.so \
@@ -220,7 +228,6 @@ REPORT_EXIT_STATUS=1 \
%endif
%if %{with_zts}
-cd ../ZTS
: Minimal load test for ZTS extension
%{__ztsphp} --no-php-ini \
--define extension=%{buildroot}%{php_ztsextdir}/%{pecl_name}.so \
@@ -237,7 +244,7 @@ cd ..
%files
-%{?_licensedir:%license NTS/LICENSE}
+%{?_licensedir:%license %{sources}/LICENSE}
%doc %{pecl_docdir}/%{pecl_name}
%{pecl_xmldir}/%{name}.xml
@@ -251,6 +258,10 @@ cd ..
%changelog
+* Tue May 16 2023 Remi Collet <remi@remirepo.net> - 1.5.5-1
+- update to 1.5.5
+- build out of sources tree
+
* Thu Mar 2 2023 Remi Collet <remi@remirepo.net> - 1.5.4-1
- update to 1.5.4
- drop patch merged upstream