summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--226.patch25
-rw-r--r--PHPINFO8
-rw-r--r--REFLECTION602
-rw-r--r--php-pecl-xlswriter.spec240
4 files changed, 704 insertions, 171 deletions
diff --git a/226.patch b/226.patch
deleted file mode 100644
index b5a99eb..0000000
--- a/226.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-From c190802563372c2394f94cb9df3ee563ec701e63 Mon Sep 17 00:00:00 2001
-From: Remi Collet <remi@remirepo.net>
-Date: Tue, 14 Jan 2020 11:37:29 +0100
-Subject: [PATCH] fix build with libxlsxwriter-0.9.3
-
----
- kernel/write.c | 4 ++++
- 1 file changed, 4 insertions(+)
-
-diff --git a/kernel/write.c b/kernel/write.c
-index 0467c61..cd7042b 100644
---- a/kernel/write.c
-+++ b/kernel/write.c
-@@ -915,7 +915,11 @@ _populate_range_data_cache(lxw_workbook *self, lxw_series_range *range)
- return;
- }
-
-+#if defined(LXW_VERSION_ID) && LXW_VERSION_ID >= 93
-+ cell_obj = lxw_worksheet_find_cell_in_row(row_obj, col_num);
-+#else
- cell_obj = lxw_worksheet_find_cell(row_obj, col_num);
-+#endif
-
- if (cell_obj) {
- if (cell_obj->type == NUMBER_CELL) {
diff --git a/PHPINFO b/PHPINFO
index 250f560..9826b3e 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,8 +2,6 @@
xlswriter
xlswriter support => enabled
-Version => 1.3.4.1
-libxlsxwriter headers version => 0.9.4
-libxlsxwriter library version => 0.9.4
-libxlsxio headers version => 0.2.26
-libxlsxio library version => 0.2.26
+Version => 1.5.5
+bundled libxlsxwriter version => 1.1.3
+bundled libxlsxio version => 0.2.27
diff --git a/REFLECTION b/REFLECTION
index d643fe8..c3d3e93 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,7 +1,20 @@
-Extension [ <persistent> extension #100 xlswriter version 1.3.4.1 ] {
+Extension [ <persistent> extension #103 xlswriter version 1.5.5 ] {
- - Classes [4] {
- Class [ <internal:xlswriter> class Vtiful\Kernel\Exception extends Exception implements Throwable ] {
+ - Functions {
+ Function [ <internal:xlswriter> function xlswriter_get_version ] {
+
+ - Parameters [0] {
+ }
+ }
+ Function [ <internal:xlswriter> function xlswriter_get_author ] {
+
+ - Parameters [0] {
+ }
+ }
+ }
+
+ - Classes [6] {
+ Class [ <internal:xlswriter> class Vtiful\Kernel\Exception extends Exception implements Throwable, Stringable ] {
- Constants [0] {
}
@@ -13,62 +26,138 @@ Extension [ <persistent> extension #100 xlswriter version 1.3.4.1 ] {
}
- Properties [4] {
- Property [ <default> protected $message ]
- Property [ <default> protected $code ]
- Property [ <default> protected $file ]
- Property [ <default> protected $line ]
+ Property [ protected $message = '' ]
+ Property [ protected $code = 0 ]
+ Property [ protected string $file = '' ]
+ Property [ protected int $line = 0 ]
}
- Methods [10] {
Method [ <internal:Core, inherits Exception, ctor> public method __construct ] {
- Parameters [3] {
- Parameter #0 [ <optional> $message ]
- Parameter #1 [ <optional> $code ]
- Parameter #2 [ <optional> $previous ]
+ Parameter #0 [ <optional> string $message = "" ]
+ Parameter #1 [ <optional> int $code = 0 ]
+ Parameter #2 [ <optional> ?Throwable $previous = null ]
}
}
Method [ <internal:Core, inherits Exception> public method __wakeup ] {
+
+ - Parameters [0] {
+ }
+ - Tentative return [ void ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getMessage ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getCode ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getFile ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getLine ] {
+
+ - Parameters [0] {
+ }
+ - Return [ int ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTrace ] {
+
+ - Parameters [0] {
+ }
+ - Return [ array ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getPrevious ] {
+
+ - Parameters [0] {
+ }
+ - Return [ ?Throwable ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTraceAsString ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
}
- Method [ <internal:Core, inherits Exception, prototype Throwable> public method __toString ] {
+ Method [ <internal:Core, inherits Exception, prototype Stringable> public method __toString ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
}
}
}
Class [ <internal:xlswriter> class Vtiful\Kernel\Excel ] {
- - Constants [12] {
+ - Constants [53] {
Constant [ public int SKIP_NONE ] { 0 }
Constant [ public int SKIP_EMPTY_ROW ] { 1 }
+ Constant [ public int SKIP_HIDDEN_ROW ] { 8 }
Constant [ public int SKIP_EMPTY_CELLS ] { 2 }
Constant [ public int SKIP_EMPTY_VALUE ] { 256 }
Constant [ public int GRIDLINES_HIDE_ALL ] { 0 }
Constant [ public int GRIDLINES_SHOW_ALL ] { 3 }
Constant [ public int GRIDLINES_SHOW_PRINT ] { 2 }
Constant [ public int GRIDLINES_SHOW_SCREEN ] { 1 }
+ Constant [ public int PAPER_DEFAULT ] { 0 }
+ Constant [ public int PAPER_LETTER ] { 1 }
+ Constant [ public int PAPER_LETTER_SMALL ] { 2 }
+ Constant [ public int PAPER_TABLOID ] { 3 }
+ Constant [ public int PAPER_LEDGER ] { 4 }
+ Constant [ public int PAPER_LEGAL ] { 5 }
+ Constant [ public int PAPER_STATEMENT ] { 6 }
+ Constant [ public int PAPER_EXECUTIVE ] { 7 }
+ Constant [ public int PAPER_A3 ] { 8 }
+ Constant [ public int PAPER_A4 ] { 9 }
+ Constant [ public int PAPER_A4_SMALL ] { 10 }
+ Constant [ public int PAPER_A5 ] { 11 }
+ Constant [ public int PAPER_B4 ] { 12 }
+ Constant [ public int PAPER_B5 ] { 13 }
+ Constant [ public int PAPER_FOLIO ] { 14 }
+ Constant [ public int PAPER_QUARTO ] { 15 }
+ Constant [ public int PAPER_NOTE ] { 18 }
+ Constant [ public int PAPER_ENVELOPE_9 ] { 19 }
+ Constant [ public int PAPER_ENVELOPE_10 ] { 20 }
+ Constant [ public int PAPER_ENVELOPE_11 ] { 21 }
+ Constant [ public int PAPER_ENVELOPE_12 ] { 22 }
+ Constant [ public int PAPER_ENVELOPE_14 ] { 23 }
+ Constant [ public int PAPER_C_SIZE_SHEET ] { 24 }
+ Constant [ public int PAPER_D_SIZE_SHEET ] { 25 }
+ Constant [ public int PAPER_E_SIZE_SHEET ] { 26 }
+ Constant [ public int PAPER_ENVELOPE_DL ] { 27 }
+ Constant [ public int PAPER_ENVELOPE_C3 ] { 28 }
+ Constant [ public int PAPER_ENVELOPE_C4 ] { 29 }
+ Constant [ public int PAPER_ENVELOPE_C5 ] { 30 }
+ Constant [ public int PAPER_ENVELOPE_C6 ] { 31 }
+ Constant [ public int PAPER_ENVELOPE_C65 ] { 32 }
+ Constant [ public int PAPER_ENVELOPE_B4 ] { 33 }
+ Constant [ public int PAPER_ENVELOPE_B5 ] { 34 }
+ Constant [ public int PAPER_ENVELOPE_B6 ] { 35 }
+ Constant [ public int PAPER_ENVELOPE_1 ] { 36 }
+ Constant [ public int PAPER_MONARCH ] { 37 }
+ Constant [ public int PAPER_ENVELOPE_2 ] { 38 }
+ Constant [ public int PAPER_FANFOLD ] { 39 }
+ Constant [ public int PAPER_GERMAN_STD_FANFOLD ] { 40 }
+ Constant [ public int PAPER_GERMAN_LEGAL_FANFOLD ] { 41 }
Constant [ public int TYPE_INT ] { 2 }
Constant [ public int TYPE_DOUBLE ] { 4 }
Constant [ public int TYPE_STRING ] { 1 }
@@ -78,7 +167,7 @@ Extension [ <persistent> extension #100 xlswriter version 1.3.4.1 ] {
- Static properties [0] {
}
- - Static methods [2] {
+ - Static methods [3] {
Method [ <internal:xlswriter> static public method columnIndexFromString ] {
- Parameters [1] {
@@ -92,15 +181,22 @@ Extension [ <persistent> extension #100 xlswriter version 1.3.4.1 ] {
Parameter #0 [ <required> $index ]
}
}
+
+ Method [ <internal:xlswriter> static public method timestampFromDateDouble ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $index ]
+ }
+ }
}
- Properties [3] {
- Property [ <default> private $config ]
- Property [ <default> private $fileName ]
- Property [ <default> private $read_row_type ]
+ Property [ private $config = NULL ]
+ Property [ private $fileName = NULL ]
+ Property [ private $read_row_type = NULL ]
}
- - Methods [33] {
+ - Methods [51] {
Method [ <internal:xlswriter, ctor> public method __construct ] {
- Parameters [1] {
@@ -108,11 +204,17 @@ Extension [ <persistent> extension #100 xlswriter version 1.3.4.1 ] {
}
}
+ Method [ <internal:xlswriter> public method close ] {
+
+ - Parameters [0] {
+ }
+ }
+
Method [ <internal:xlswriter> public method fileName ] {
- Parameters [2] {
Parameter #0 [ <required> $file_name ]
- Parameter #1 [ <optional> $sheet_name ]
+ Parameter #1 [ <optional> $sheet_name = <default> ]
}
}
@@ -123,6 +225,13 @@ Extension [ <persistent> extension #100 xlswriter version 1.3.4.1 ] {
}
}
+ Method [ <internal:xlswriter> public method existSheet ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $sheet_name ]
+ }
+ }
+
Method [ <internal:xlswriter> public method checkoutSheet ] {
- Parameters [1] {
@@ -130,11 +239,19 @@ Extension [ <persistent> extension #100 xlswriter version 1.3.4.1 ] {
}
}
+ Method [ <internal:xlswriter> public method activateSheet ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $sheet_name ]
+ }
+ }
+
Method [ <internal:xlswriter> public method constMemory ] {
- - Parameters [2] {
+ - Parameters [3] {
Parameter #0 [ <required> $file_name ]
- Parameter #1 [ <optional> $sheet_name ]
+ Parameter #1 [ <optional> $sheet_name = <default> ]
+ Parameter #2 [ <optional> $use_zip64 = <default> ]
}
}
@@ -142,7 +259,7 @@ Extension [ <persistent> extension #100 xlswriter version 1.3.4.1 ] {
- Parameters [2] {
Parameter #0 [ <required> $header ]
- Parameter #1 [ <optional> $format_handle ]
+ Parameter #1 [ <optional> $format_handle = <default> ]
}
}
@@ -178,8 +295,18 @@ Extension [ <persistent> extension #100 xlswriter version 1.3.4.1 ] {
Parameter #0 [ <required> $row ]
Parameter #1 [ <required> $column ]
Parameter #2 [ <required> $data ]
- Parameter #3 [ <required> $format ]
- Parameter #4 [ <required> $format_handle ]
+ Parameter #3 [ <optional> $format = <default> ]
+ Parameter #4 [ <optional> $format_handle = <default> ]
+ }
+ }
+
+ Method [ <internal:xlswriter> public method insertRichText ] {
+
+ - Parameters [4] {
+ Parameter #0 [ <required> $row ]
+ Parameter #1 [ <required> $column ]
+ Parameter #2 [ <required> $rich_strings ]
+ Parameter #3 [ <optional> $format_handle = <default> ]
}
}
@@ -189,8 +316,8 @@ Extension [ <persistent> extension #100 xlswriter version 1.3.4.1 ] {
Parameter #0 [ <required> $row ]
Parameter #1 [ <required> $column ]
Parameter #2 [ <required> $timestamp ]
- Parameter #3 [ <required> $format ]
- Parameter #4 [ <required> $format_handle ]
+ Parameter #3 [ <optional> $format = <default> ]
+ Parameter #4 [ <optional> $format_handle = <default> ]
}
}
@@ -205,11 +332,13 @@ Extension [ <persistent> extension #100 xlswriter version 1.3.4.1 ] {
Method [ <internal:xlswriter> public method insertUrl ] {
- - Parameters [4] {
+ - Parameters [6] {
Parameter #0 [ <required> $row ]
Parameter #1 [ <required> $column ]
Parameter #2 [ <required> $url ]
- Parameter #3 [ <required> $format ]
+ Parameter #3 [ <optional> $text = <default> ]
+ Parameter #4 [ <optional> $tool_tip = <default> ]
+ Parameter #5 [ <optional> $format = <default> ]
}
}
@@ -219,8 +348,8 @@ Extension [ <persistent> extension #100 xlswriter version 1.3.4.1 ] {
Parameter #0 [ <required> $row ]
Parameter #1 [ <required> $column ]
Parameter #2 [ <required> $image ]
- Parameter #3 [ <optional> $width ]
- Parameter #4 [ <optional> $height ]
+ Parameter #3 [ <optional> $width = <default> ]
+ Parameter #4 [ <optional> $height = <default> ]
}
}
@@ -230,7 +359,22 @@ Extension [ <persistent> extension #100 xlswriter version 1.3.4.1 ] {
Parameter #0 [ <required> $row ]
Parameter #1 [ <required> $column ]
Parameter #2 [ <required> $formula ]
- Parameter #3 [ <optional> $format_handle ]
+ Parameter #3 [ <optional> $format_handle = <default> ]
+ }
+ }
+
+ Method [ <internal:xlswriter> public method insertComment ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $row ]
+ Parameter #1 [ <required> $column ]
+ Parameter #2 [ <required> $comment ]
+ }
+ }
+
+ Method [ <internal:xlswriter> public method showComment ] {
+
+ - Parameters [0] {
}
}
@@ -239,7 +383,7 @@ Extension [ <persistent> extension #100 xlswriter version 1.3.4.1 ] {
- Parameters [3] {
Parameter #0 [ <required> $range ]
Parameter #1 [ <required> $data ]
- Parameter #2 [ <optional> $format_handle ]
+ Parameter #2 [ <optional> $format_handle = <default> ]
}
}
@@ -261,6 +405,19 @@ Extension [ <persistent> extension #100 xlswriter version 1.3.4.1 ] {
}
}
+ Method [ <internal:xlswriter> public method getCurrentLine ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:xlswriter> public method setCurrentLine ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $row ]
+ }
+ }
+
Method [ <internal:xlswriter> public method defaultFormat ] {
- Parameters [1] {
@@ -276,6 +433,21 @@ Extension [ <persistent> extension #100 xlswriter version 1.3.4.1 ] {
}
}
+ Method [ <internal:xlswriter> public method protection ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <optional> $password = <default> ]
+ }
+ }
+
+ Method [ <internal:xlswriter> public method validation ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $range ]
+ Parameter #1 [ <required> $validation_resource ]
+ }
+ }
+
Method [ <internal:xlswriter> public method zoom ] {
- Parameters [1] {
@@ -290,6 +462,54 @@ Extension [ <persistent> extension #100 xlswriter version 1.3.4.1 ] {
}
}
+ Method [ <internal:xlswriter> public method setPaper ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $paper ]
+ }
+ }
+
+ Method [ <internal:xlswriter> public method setMargins ] {
+
+ - Parameters [4] {
+ Parameter #0 [ <required> $left ]
+ Parameter #1 [ <required> $right ]
+ Parameter #2 [ <required> $top ]
+ Parameter #3 [ <required> $bottom ]
+ }
+ }
+
+ Method [ <internal:xlswriter> public method setPortrait ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:xlswriter> public method setLandscape ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:xlswriter> public method setPrintScale ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <optional> $scale = <default> ]
+ }
+ }
+
+ Method [ <internal:xlswriter> public method setCurrentSheetHide ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:xlswriter> public method setCurrentSheetIsFirst ] {
+
+ - Parameters [0] {
+ }
+ }
+
Method [ <internal:xlswriter> public method openFile ] {
- Parameters [1] {
@@ -299,8 +519,9 @@ Extension [ <persistent> extension #100 xlswriter version 1.3.4.1 ] {
Method [ <internal:xlswriter> public method openSheet ] {
- - Parameters [1] {
- Parameter #0 [ <required> $zs_sheet_name ]
+ - Parameters [2] {
+ Parameter #0 [ <optional> $zs_sheet_name = <default> ]
+ Parameter #1 [ <optional> $zl_flag = <default> ]
}
}
@@ -308,9 +529,9 @@ Extension [ <persistent> extension #100 xlswriter version 1.3.4.1 ] {
- Parameters [4] {
Parameter #0 [ <required> $fp ]
- Parameter #1 [ <optional> $delimiter_str ]
- Parameter #2 [ <optional> $enclosure_str ]
- Parameter #3 [ <optional> $escape_str ]
+ Parameter #1 [ <optional> $delimiter_str = <default> ]
+ Parameter #2 [ <optional> $enclosure_str = <default> ]
+ Parameter #3 [ <optional> $escape_str = <default> ]
}
}
@@ -319,9 +540,9 @@ Extension [ <persistent> extension #100 xlswriter version 1.3.4.1 ] {
- Parameters [5] {
Parameter #0 [ <required> $callback ]
Parameter #1 [ <required> $fp ]
- Parameter #2 [ <optional> $delimiter_str ]
- Parameter #3 [ <optional> $enclosure_str ]
- Parameter #4 [ <optional> $escape_str ]
+ Parameter #2 [ <optional> $delimiter_str = <default> ]
+ Parameter #3 [ <optional> $enclosure_str = <default> ]
+ Parameter #4 [ <optional> $escape_str = <default> ]
}
}
@@ -338,6 +559,13 @@ Extension [ <persistent> extension #100 xlswriter version 1.3.4.1 ] {
}
}
+ Method [ <internal:xlswriter> public method setGlobalType ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $zv_type_t ]
+ }
+ }
+
Method [ <internal:xlswriter> public method setSkipRows ] {
- Parameters [1] {
@@ -354,7 +582,7 @@ Extension [ <persistent> extension #100 xlswriter version 1.3.4.1 ] {
Method [ <internal:xlswriter> public method nextRow ] {
- Parameters [1] {
- Parameter #0 [ <optional> $zv_type_t ]
+ Parameter #0 [ <optional> $zv_type_t = <default> ]
}
}
@@ -362,7 +590,7 @@ Extension [ <persistent> extension #100 xlswriter version 1.3.4.1 ] {
- Parameters [2] {
Parameter #0 [ <required> $fci ]
- Parameter #1 [ <required> $sheet_name ]
+ Parameter #1 [ <optional> $sheet_name = <default> ]
}
}
}
@@ -370,7 +598,7 @@ Extension [ <persistent> extension #100 xlswriter version 1.3.4.1 ] {
Class [ <internal:xlswriter> class Vtiful\Kernel\Format ] {
- - Constants [64] {
+ - Constants [65] {
Constant [ public int UNDERLINE_SINGLE ] { 1 }
Constant [ public int UNDERLINE_DOUBLE ] { 2 }
Constant [ public int UNDERLINE_SINGLE_ACCOUNTING ] { 3 }
@@ -422,6 +650,7 @@ Extension [ <persistent> extension #100 xlswriter version 1.3.4.1 ] {
Constant [ public int PATTERN_LIGHT_TRELLIS ] { 16 }
Constant [ public int PATTERN_GRAY_125 ] { 17 }
Constant [ public int PATTERN_GRAY_0625 ] { 18 }
+ Constant [ public int BORDER_NONE ] { 0 }
Constant [ public int BORDER_THIN ] { 1 }
Constant [ public int BORDER_MEDIUM ] { 2 }
Constant [ public int BORDER_DASHED ] { 3 }
@@ -446,7 +675,7 @@ Extension [ <persistent> extension #100 xlswriter version 1.3.4.1 ] {
- Properties [0] {
}
- - Methods [14] {
+ - Methods [18] {
Method [ <internal:xlswriter, ctor> public method __construct ] {
- Parameters [1] {
@@ -479,10 +708,37 @@ Extension [ <persistent> extension #100 xlswriter version 1.3.4.1 ] {
}
}
+ Method [ <internal:xlswriter> public method borderOfTheFourSides ] {
+
+ - Parameters [4] {
+ Parameter #0 [ <required> $top ]
+ Parameter #1 [ <required> $right ]
+ Parameter #2 [ <required> $bottom ]
+ Parameter #3 [ <required> $left ]
+ }
+ }
+
+ Method [ <internal:xlswriter> public method borderColor ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $color ]
+ }
+ }
+
+ Method [ <internal:xlswriter> public method borderColorOfTheFourSides ] {
+
+ - Parameters [4] {
+ Parameter #0 [ <required> $top_color ]
+ Parameter #1 [ <required> $right_color ]
+ Parameter #2 [ <required> $bottom_color ]
+ Parameter #3 [ <required> $left_color ]
+ }
+ }
+
Method [ <internal:xlswriter> public method align ] {
- Parameters [1] {
- Parameter #0 [ <required> $style ]
+ Parameter #0 [ <required> ...$style ]
}
}
@@ -527,6 +783,12 @@ Extension [ <persistent> extension #100 xlswriter version 1.3.4.1 ] {
}
}
+ Method [ <internal:xlswriter> public method unlocked ] {
+
+ - Parameters [0] {
+ }
+ }
+
Method [ <internal:xlswriter> public method toResource ] {
- Parameters [0] {
@@ -545,7 +807,7 @@ Extension [ <persistent> extension #100 xlswriter version 1.3.4.1 ] {
Class [ <internal:xlswriter> class Vtiful\Kernel\Chart ] {
- - Constants [27] {
+ - Constants [29] {
Constant [ public int CHART_BAR ] { 4 }
Constant [ public int CHART_BAR_STACKED ] { 5 }
Constant [ public int CHART_BAR_STACKED_PERCENT ] { 6 }
@@ -557,15 +819,15 @@ Extension [ <persistent> extension #100 xlswriter version 1.3.4.1 ] {
Constant [ public int CHART_COLUMN_STACKED ] { 8 }
Constant [ public int CHART_COLUMN_STACKED_PERCENT ] { 9 }
Constant [ public int CHART_DOUGHNUT ] { 10 }
- Constant [ public int CHART_PIE ] { 12 }
- Constant [ public int CHART_SCATTER ] { 13 }
- Constant [ public int CHART_SCATTER_STRAIGHT ] { 14 }
- Constant [ public int CHART_SCATTER_STRAIGHT_WITH_MARKERS ] { 15 }
- Constant [ public int CHART_SCATTER_SMOOTH ] { 16 }
- Constant [ public int CHART_SCATTER_SMOOTH_WITH_MARKERS ] { 17 }
- Constant [ public int CHART_RADAR ] { 18 }
- Constant [ public int CHART_RADAR_WITH_MARKERS ] { 19 }
- Constant [ public int CHART_RADAR_FILLED ] { 20 }
+ Constant [ public int CHART_PIE ] { 14 }
+ Constant [ public int CHART_SCATTER ] { 15 }
+ Constant [ public int CHART_SCATTER_STRAIGHT ] { 16 }
+ Constant [ public int CHART_SCATTER_STRAIGHT_WITH_MARKERS ] { 17 }
+ Constant [ public int CHART_SCATTER_SMOOTH ] { 18 }
+ Constant [ public int CHART_SCATTER_SMOOTH_WITH_MARKERS ] { 19 }
+ Constant [ public int CHART_RADAR ] { 20 }
+ Constant [ public int CHART_RADAR_WITH_MARKERS ] { 21 }
+ Constant [ public int CHART_RADAR_FILLED ] { 22 }
Constant [ public int CHART_LEGEND_NONE ] { 0 }
Constant [ public int CHART_LEGEND_RIGHT ] { 1 }
Constant [ public int CHART_LEGEND_LEFT ] { 2 }
@@ -573,6 +835,8 @@ Extension [ <persistent> extension #100 xlswriter version 1.3.4.1 ] {
Constant [ public int CHART_LEGEND_BOTTOM ] { 4 }
Constant [ public int CHART_LEGEND_OVERLAY_RIGHT ] { 6 }
Constant [ public int CHART_LEGEND_OVERLAY_LEFT ] { 7 }
+ Constant [ public int CHART_LINE_STACKED ] { 12 }
+ Constant [ public int CHART_LINE_STACKED_PERCENT ] { 13 }
}
- Static properties [0] {
@@ -597,7 +861,7 @@ Extension [ <persistent> extension #100 xlswriter version 1.3.4.1 ] {
- Parameters [2] {
Parameter #0 [ <required> $value ]
- Parameter #1 [ <optional> $categories ]
+ Parameter #1 [ <optional> $categories = <default> ]
}
}
@@ -650,6 +914,234 @@ Extension [ <persistent> extension #100 xlswriter version 1.3.4.1 ] {
}
}
}
+
+ Class [ <internal:xlswriter> class Vtiful\Kernel\Validation ] {
+
+ - Constants [27] {
+ Constant [ public int TYPE_INTEGER ] { 1 }
+ Constant [ public int TYPE_INTEGER_FORMULA ] { 2 }
+ Constant [ public int TYPE_DECIMAL ] { 3 }
+ Constant [ public int TYPE_DECIMAL_FORMULA ] { 4 }
+ Constant [ public int TYPE_LIST ] { 5 }
+ Constant [ public int TYPE_LIST_FORMULA ] { 6 }
+ Constant [ public int TYPE_DATE ] { 7 }
+ Constant [ public int TYPE_DATE_FORMULA ] { 8 }
+ Constant [ public int TYPE_DATE_NUMBER ] { 9 }
+ Constant [ public int TYPE_TIME ] { 10 }
+ Constant [ public int TYPE_TIME_FORMULA ] { 11 }
+ Constant [ public int TYPE_TIME_NUMBER ] { 12 }
+ Constant [ public int TYPE_LENGTH ] { 13 }
+ Constant [ public int TYPE_LENGTH_FORMULA ] { 14 }
+ Constant [ public int TYPE_CUSTOM_FORMULA ] { 15 }
+ Constant [ public int TYPE_ANY ] { 16 }
+ Constant [ public int CRITERIA_BETWEEN ] { 1 }
+ Constant [ public int CRITERIA_NOT_BETWEEN ] { 2 }
+ Constant [ public int CRITERIA_EQUAL_TO ] { 3 }
+ Constant [ public int CRITERIA_NOT_EQUAL_TO ] { 4 }
+ Constant [ public int CRITERIA_GREATER_THAN ] { 5 }
+ Constant [ public int CRITERIA_LESS_THAN ] { 6 }
+ Constant [ public int CRITERIA_GREATER_THAN_OR_EQUAL_TO ] { 7 }
+ Constant [ public int CRITERIA_LESS_THAN_OR_EQUAL_TO ] { 8 }
+ Constant [ public int ERROR_TYPE_STOP ] { 0 }
+ Constant [ public int ERROR_TYPE_WARNING ] { 1 }
+ Constant [ public int ERROR_TYPE_INFORMATION ] { 2 }
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [23] {
+ Method [ <internal:xlswriter, ctor> public method __construct ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:xlswriter> public method validationType ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $type ]
+ }
+ }
+
+ Method [ <internal:xlswriter> public method criteriaType ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $type ]
+ }
+ }
+
+ Method [ <internal:xlswriter> public method ignoreBlank ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $ignore_blank ]
+ }
+ }
+
+ Method [ <internal:xlswriter> public method showInput ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $show_input ]
+ }
+ }
+
+ Method [ <internal:xlswriter> public method showError ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $show_error ]
+ }
+ }
+
+ Method [ <internal:xlswriter> public method errorType ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $error_type ]
+ }
+ }
+
+ Method [ <internal:xlswriter> public method dropdown ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $dropdown ]
+ }
+ }
+
+ Method [ <internal:xlswriter> public method valueNumber ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $value_number ]
+ }
+ }
+
+ Method [ <internal:xlswriter> public method valueFormula ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $value_formula ]
+ }
+ }
+
+ Method [ <internal:xlswriter> public method valueList ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $value_list ]
+ }
+ }
+
+ Method [ <internal:xlswriter> public method valueDatetime ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $timestamp ]
+ }
+ }
+
+ Method [ <internal:xlswriter> public method minimumNumber ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $minimum_number ]
+ }
+ }
+
+ Method [ <internal:xlswriter> public method minimumFormula ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $minimum_formula ]
+ }
+ }
+
+ Method [ <internal:xlswriter> public method minimumDatetime ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $timestamp ]
+ }
+ }
+
+ Method [ <internal:xlswriter> public method maximumNumber ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $maximum_number ]
+ }
+ }
+
+ Method [ <internal:xlswriter> public method maximumFormula ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $maximum_formula ]
+ }
+ }
+
+ Method [ <internal:xlswriter> public method maximumDatetime ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $maximum_datetime ]
+ }
+ }
+
+ Method [ <internal:xlswriter> public method inputTitle ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $input_title ]
+ }
+ }
+
+ Method [ <internal:xlswriter> public method inputMessage ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $input_message ]
+ }
+ }
+
+ Method [ <internal:xlswriter> public method errorTitle ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $error_titile ]
+ }
+ }
+
+ Method [ <internal:xlswriter> public method errorMessage ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $error_message ]
+ }
+ }
+
+ Method [ <internal:xlswriter> public method toResource ] {
+
+ - Parameters [0] {
+ }
+ }
+ }
+ }
+
+ Class [ <internal:xlswriter> class Vtiful\Kernel\RichString ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [1] {
+ Method [ <internal:xlswriter, ctor> public method __construct ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $text ]
+ Parameter #1 [ <optional> $format_handle = <default> ]
+ }
+ }
+ }
+ }
}
}
diff --git a/php-pecl-xlswriter.spec b/php-pecl-xlswriter.spec
index a81090c..a333fa3 100644
--- a/php-pecl-xlswriter.spec
+++ b/php-pecl-xlswriter.spec
@@ -1,116 +1,108 @@
# remirepo spec file for php-pecl-xlswriter
#
-# Copyright (c) 2018-2020 Remi Collet
-# License: CC-BY-SA
+# Copyright (c) 2018-2023 Remi Collet
+# License: CC-BY-SA-4.0
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
-# we don't want -z defs linker flag
-%undefine _strict_symbol_defs_build
+%bcond_with syslib
+%bcond_without tests
-%if 0%{?scl:1}
-%scl_package php-pecl-xlswriter
-%global sub_prefix %{scl_prefix}
-%endif
+%{?scl:%scl_package php-pecl-xlswriter}
-%global with_tests 0%{!?_without_tests:1}
%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
%global pecl_name xlswriter
-# After json
%global ini_name 40-%{pecl_name}.ini
+%global sources %{pecl_name}-%{version}
+%global _configure ../%{sources}/configure
+%if %{with syslib}
# No soname, so manage dependency on available version
-%global libxlsxwriter_version 0.9.4
-%global libxlsxio_version 0.2.26
+%global libxlsxwriter_version 1.0.0
+%global libxlsxio_version 0.2.29
+%endif
-Summary: An efficient and fast xlsx file export extension
-Name: %{?sub_prefix}php-pecl-%{pecl_name}
-Version: 1.3.4.1
+Summary: An efficient and fast xlsx file extension
+Name: %{?scl_prefix}php-pecl-%{pecl_name}
+Version: 1.5.5
Release: 2%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
-License: BSD
+License: BSD-2-Clause
URL: https://pecl.php.net/package/%{pecl_name}
Source0: https://pecl.php.net/get/%{pecl_name}-%{version}.tgz
-Patch0: https://patch-diff.githubusercontent.com/raw/viest/php-ext-xlswriter/pull/226.patch
-
BuildRequires: %{?dtsprefix}gcc
-BuildRequires: %{?scl_prefix}php-devel >= 7
+BuildRequires: make
+BuildRequires: %{?scl_prefix}php-devel >= 7.0
BuildRequires: %{?scl_prefix}php-pear
+%if %{with syslib}
BuildRequires: libxlsxwriter-devel >= %{libxlsxwriter_version}
BuildRequires: libxlsxio-devel >= %{libxlsxio_version}
BuildRequires: zlib-devel
+%endif
Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
Requires: %{?scl_prefix}php(api) = %{php_core_api}
-Requires: %{?scl_prefix}php-json%{?_isa}
-%{?_sclreq:Requires: %{?scl_prefix}runtime%{?_sclreq}%{?_isa}}
+%if %{with syslib}
Requires: libxlsxwriter%{?_isa} >= %{libxlsxwriter_version}
Requires: libxlsxio%{?_isa} >= %{libxlsxio_version}
+%else
+# see library/libxlsxwriter/include/xlsxwriter.h
+Provides: bundled(libxlsxwriter) = 1.1.3
+# see library/libxlsxio/include/xlsxio_version.h
+Provides: bundled(libxlsxio) = 0.2.27
+%endif
Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
-%if "%{?scl_prefix}" != "%{?sub_prefix}"
-Provides: %{?scl_prefix}php-pecl-%{pecl_name} = %{version}-%{release}
-Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}-%{release}
-%endif
-
-%if "%{?vendor}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
-%if "%{php_version}" > "7.1"
-Obsoletes: php71u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php71w-pecl-%{pecl_name} <= %{version}
-%endif
-%if "%{php_version}" > "7.2"
-Obsoletes: php72u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php72w-pecl-%{pecl_name} <= %{version}
-%endif
-%if "%{php_version}" > "7.3"
-Obsoletes: php73-pecl-%{pecl_name} <= %{version}
-Obsoletes: php73w-pecl-%{pecl_name} <= %{version}
-%endif
-%if "%{php_version}" > "7.4"
-Obsoletes: php74-pecl-%{pecl_name} <= %{version}
-Obsoletes: php74w-pecl-%{pecl_name} <= %{version}
-%endif
-%endif
-
-%if 0%{?fedora} < 20 && 0%{?rhel} < 7
-# Filter shared private
-%{?filter_provides_in: %filter_provides_in %{_libdir}/.*\.so$}
-%{?filter_setup}
-%endif
%description
-An efficient and fast xlsx file export extension for PHP.
-
-- Quickly export xlsx files in php projects.
-- Export xlsx files under fixed memory.
-- Insert a calculation formula in an xlsx file.
-- Insert a local picture in an xlsx file.
-- Merging cells and cell styles.
+xlswriter is a PHP C Extension that can be used to write text, numbers,
+formulas and hyperlinks to multiple worksheets in an Excel 2007+ XLSX file.
+
+Writer
+
+- 100% compatible Excel XLSX files.
+- Full Excel formatting.
+- Merged cells.
+- Defined names.
+- Autofilters.
+- Charts.
+- Data validation and drop down lists.
+- Worksheet PNG/JPEG images.
+- Memory optimization mode for writing large files.
+- Works on Linux, FreeBSD, OpenBSD, OS X, Windows.
+- Compiles for 32 and 64 bit.
+- FreeBSD License.
+- The only dependency is on zlib.
+
+Reader
+
+- Full read data
+- Cursor read data
+- Read by data type
+- Xlsx to csv
Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')%{?scl: as Software Collection (%{scl} by %{?scl_vendor}%{!?scl_vendor:rh})}.
%prep
%setup -q -c
-mv %{pecl_name}-%{version} NTS
-
# Don't install tests
sed -e 's/role="test"/role="src"/' \
%{?_licensedir:-e '/LICENSE/s/role="doc"/role="src"/' } \
-e '/name="library/d' \
-i package.xml
-cd NTS
-%patch0 -p1 -b .pr226
-
+pushd %{sources}
+%if %{with syslib}
# we use the system libraries
rm -r library
+%endif
# Sanity check, really often broken
extver=$(sed -n '/#define PHP_XLSWRITER_VERSION/{s/.* "//;s/".*$//;p}' php_xlswriter.h)
@@ -118,11 +110,12 @@ if test "x${extver}" != "x%{version}%{?prever:-%{prever}}"; then
: Error: Upstream extension version is ${extver}, expecting %{version}%{?prever:-%{prever}}.
exit 1
fi
-cd ..
+popd
+mkdir NTS
%if %{with_zts}
# Duplicate source tree for NTS / ZTS build
-cp -pr NTS ZTS
+mkdir ZTS
%endif
# Create configuration file
@@ -137,23 +130,27 @@ EOF
peclbuild() {
%configure \
+ --without-openssl \
--with-xlswriter \
+%if %{with syslib}
--with-libxlsxwriter=%{_prefix} \
--with-libxlsxio=%{_prefix} \
+%endif
--enable-reader \
--with-php-config=$1
make %{?_smp_mflags}
}
-cd NTS
-%{_bindir}/phpize
-peclbuild %{_bindir}/php-config
+cd %{sources}
+%{__phpize}
+
+cd ../NTS
+peclbuild %{__phpconfig}
%if %{with_zts}
cd ../ZTS
-%{_bindir}/zts-phpize
-peclbuild %{_bindir}/zts-php-config
+peclbuild %{__ztsphpconfig}
%endif
@@ -176,7 +173,7 @@ install -D -m 644 %{ini_name} %{buildroot}%{php_ztsinidir}/%{ini_name}
# Documentation
for i in $(grep 'role="doc"' package.xml | sed -e 's/^.*name="//;s/".*$//')
-do install -Dpm 644 NTS/$i %{buildroot}%{pecl_docdir}/%{pecl_name}/$i
+do install -Dpm 644 %{sources}/$i %{buildroot}%{pecl_docdir}/%{pecl_name}/$i
done
@@ -201,46 +198,42 @@ fi
%check
-modules="-d extension=json.so"
+OPT="-q -P --show-diff"
+%if "%{php_version}" > "7.4"
+OPT="$OPT %{?_smp_mflags}"
+%endif
-cd NTS
+cd %{sources}
: Minimal load test for NTS extension
%{__php} --no-php-ini \
- $modules \
--define extension=%{buildroot}%{php_extdir}/%{pecl_name}.so \
- --modules | grep %{pecl_name}
+ --modules | grep '^%{pecl_name}$'
-%if %{with_tests}
+%if %{with tests}
: Upstream test suite for NTS extension
-TEST_PHP_EXECUTABLE=%{__php} \
TEST_PHP_ARGS="-n -d extension=%{buildroot}%{php_extdir}/%{pecl_name}.so" \
-NO_INTERACTION=1 \
REPORT_EXIT_STATUS=1 \
-%{__php} -n run-tests.php --show-diff
+%{__php} -n run-tests.php $OPT
%endif
%if %{with_zts}
-cd ../ZTS
: Minimal load test for ZTS extension
%{__ztsphp} --no-php-ini \
- $modules \
--define extension=%{buildroot}%{php_ztsextdir}/%{pecl_name}.so \
- --modules | grep %{pecl_name}
+ --modules | grep '^%{pecl_name}$'
-%if %{with_tests}
+%if %{with tests}
: Upstream test suite for ZTS extension
-TEST_PHP_EXECUTABLE=%{_bindir}/zts-php \
TEST_PHP_ARGS="-n -d extension=%{buildroot}%{php_ztsextdir}/%{pecl_name}.so" \
-NO_INTERACTION=1 \
REPORT_EXIT_STATUS=1 \
-%{_bindir}/zts-php -n run-tests.php --show-diff
+%{__ztsphp} -n run-tests.php $OPT
%endif
%endif
cd ..
%files
-%{?_licensedir:%license NTS/LICENSE}
+%{?_licensedir:%license %{sources}/LICENSE}
%doc %{pecl_docdir}/%{pecl_name}
%{pecl_xmldir}/%{name}.xml
@@ -254,6 +247,81 @@ cd ..
%changelog
+* Wed Aug 30 2023 Remi Collet <remi@remirepo.net> - 1.5.5-2
+- rebuild for PHP 8.3.0RC1
+
+* Tue May 16 2023 Remi Collet <remi@remirepo.net> - 1.5.5-1
+- update to 1.5.5
+- build out of sources tree
+
+* Thu Mar 2 2023 Remi Collet <remi@remirepo.net> - 1.5.4-1
+- update to 1.5.4
+- drop patch merged upstream
+
+* Wed Mar 1 2023 Remi Collet <remi@remirepo.net> - 1.5.3-1
+- update to 1.5.3
+- drop patch merged upstream
+- add another patch for PHP 8.2 from
+ https://github.com/viest/php-ext-xlswriter/pull/470
+
+* Fri Sep 16 2022 Remi Collet <remi@remirepo.net> - 1.5.2-2
+- add patch for PHP 8.2 from
+ https://github.com/viest/php-ext-xlswriter/pull/451
+
+* Thu Apr 28 2022 Remi Collet <remi@remirepo.net> - 1.5.2-1
+- update to 1.5.2
+
+* Tue Oct 26 2021 Remi Collet <remi@remirepo.net> - 1.5.1-1
+- update to 1.5.1
+
+* Thu Oct 7 2021 Remi Collet <remi@remirepo.net> - 1.5.0-1
+- update to 1.5.0
+
+* Wed Sep 01 2021 Remi Collet <remi@remirepo.net> - 1.4.0-2
+- rebuild for 8.1.0RC1
+
+* Mon Jul 19 2021 Remi Collet <remi@remirepo.net> - 1.4.0-1
+- update to 1.4.0
+
+* Sat Jan 2 2021 Remi Collet <remi@remirepo.net> - 1.3.7-1
+- update to 1.3.7
+- drop patch merged upstream
+
+* Wed Sep 30 2020 Remi Collet <remi@remirepo.net> - 1.3.6-9
+- rebuild using bundled libraries
+
+* Wed Sep 30 2020 Remi Collet <remi@remirepo.net> - 1.3.6-8
+- rebuild for PHP 8.0.0RC1
+
+* Tue Sep 8 2020 Remi Collet <remi@remirepo.net> - 1.3.6-7
+- build using libxlsxwriter version 1.0.0
+
+* Wed Sep 2 2020 Remi Collet <remi@remirepo.net> - 1.3.6-6
+- add patch for PHP 8.0.0beta3 from
+ https://github.com/viest/php-ext-xlswriter/pull/298
+
+* Tue Aug 18 2020 Remi Collet <remi@remirepo.net> - 1.3.6-5
+- build using libxlsxwriter version 0.9.9
+
+* Tue Aug 11 2020 Remi Collet <remi@remirepo.net> - 1.3.6-4
+- build using libxlsxwriter version 0.9.8
+
+* Fri Aug 7 2020 Remi Collet <remi@remirepo.net> - 1.3.6-3
+- build using libxlsxwriter version 0.9.7
+
+* Wed Aug 5 2020 Remi Collet <remi@remirepo.net> - 1.3.6-2
+- rebuild for 8.0.0beta1
+
+* Wed Jun 17 2020 Remi Collet <remi@remirepo.net> - 1.3.6-1
+- update to 1.3.6
+
+* Mon Jun 1 2020 Remi Collet <remi@remirepo.net> - 1.3.5-2
+- build using libxlsxwriter version 0.9.5
+
+* Tue May 26 2020 Remi Collet <remi@remirepo.net> - 1.3.5-1
+- update to 1.3.5
+- drop patch merged upstream
+
* Mon Apr 13 2020 Remi Collet <remi@remirepo.net> - 1.3.4.1-1
- update to 1.3.4.1