summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-10-26 16:34:26 +0200
committerRemi Collet <remi@php.net>2021-10-26 16:34:26 +0200
commitcfda1fff16405cb376cc0663fdbb0d74ff8e2c88 (patch)
tree372eef3d4ed52f7a265403a2688ee6e572a4b4df
parent23f4618bbfefabab2acb359f3e06e21fc7d10f79 (diff)
update to 1.5.1
-rw-r--r--PHPINFO4
-rw-r--r--REFLECTION57
-rw-r--r--php-pecl-xlswriter.spec28
3 files changed, 71 insertions, 18 deletions
diff --git a/PHPINFO b/PHPINFO
index 318c464..40b71b3 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,6 +2,6 @@
xlswriter
xlswriter support => enabled
-Version => 1.4.0
-bundled libxlsxwriter version => 1.0.0
+Version => 1.5.1
+bundled libxlsxwriter version => 1.1.3
bundled libxlsxio version => 0.2.27
diff --git a/REFLECTION b/REFLECTION
index 5c7744f..dc308f5 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #107 xlswriter version 1.4.0 ] {
+Extension [ <persistent> extension #111 xlswriter version 1.5.1 ] {
- Functions {
Function [ <internal:xlswriter> function xlswriter_get_version ] {
@@ -13,7 +13,7 @@ Extension [ <persistent> extension #107 xlswriter version 1.4.0 ] {
}
}
- - Classes [5] {
+ - Classes [6] {
Class [ <internal:xlswriter> class Vtiful\Kernel\Exception extends Exception implements Throwable ] {
- Constants [0] {
@@ -161,7 +161,7 @@ Extension [ <persistent> extension #107 xlswriter version 1.4.0 ] {
Property [ <default> private $read_row_type ]
}
- - Methods [47] {
+ - Methods [50] {
Method [ <internal:xlswriter, ctor> public method __construct ] {
- Parameters [1] {
@@ -213,9 +213,10 @@ Extension [ <persistent> extension #107 xlswriter version 1.4.0 ] {
Method [ <internal:xlswriter> public method constMemory ] {
- - Parameters [2] {
+ - Parameters [3] {
Parameter #0 [ <required> $file_name ]
Parameter #1 [ <optional> $sheet_name ]
+ Parameter #2 [ <optional> $use_zip64 ]
}
}
@@ -264,6 +265,16 @@ Extension [ <persistent> extension #107 xlswriter version 1.4.0 ] {
}
}
+ Method [ <internal:xlswriter> public method insertRichText ] {
+
+ - Parameters [4] {
+ Parameter #0 [ <required> $row ]
+ Parameter #1 [ <required> $column ]
+ Parameter #2 [ <required> $rich_strings ]
+ Parameter #3 [ <optional> $format_handle ]
+ }
+ }
+
Method [ <internal:xlswriter> public method insertDate ] {
- Parameters [5] {
@@ -359,6 +370,19 @@ Extension [ <persistent> extension #107 xlswriter version 1.4.0 ] {
}
}
+ Method [ <internal:xlswriter> public method getCurrentLine ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:xlswriter> public method setCurrentLine ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $row ]
+ }
+ }
+
Method [ <internal:xlswriter> public method defaultFormat ] {
- Parameters [1] {
@@ -1024,6 +1048,31 @@ Extension [ <persistent> extension #107 xlswriter version 1.4.0 ] {
}
}
}
+
+ Class [ <internal:xlswriter> class Vtiful\Kernel\RichString ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [1] {
+ Method [ <internal:xlswriter, ctor> public method __construct ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $text ]
+ Parameter #1 [ <optional> $format_handle ]
+ }
+ }
+ }
+ }
}
}
diff --git a/php-pecl-xlswriter.spec b/php-pecl-xlswriter.spec
index 4720185..4c9cfad 100644
--- a/php-pecl-xlswriter.spec
+++ b/php-pecl-xlswriter.spec
@@ -31,8 +31,8 @@
Summary: An efficient and fast xlsx file extension
Name: %{?sub_prefix}php-pecl-%{pecl_name}
-Version: 1.4.0
-Release: 2%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Version: 1.5.1
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: BSD
URL: https://pecl.php.net/package/%{pecl_name}
Source0: https://pecl.php.net/get/%{pecl_name}-%{version}.tgz
@@ -56,7 +56,7 @@ Requires: libxlsxwriter%{?_isa} >= %{libxlsxwriter_version}
Requires: libxlsxio%{?_isa} >= %{libxlsxio_version}
%else
# see library/libxlsxwriter/include/xlsxwriter.h
-Provides: bundled(libxlsxwriter) = 0.9.4
+Provides: bundled(libxlsxwriter) = 1.1.3
# see library/libxlsxio/include/xlsxio_version.h
Provides: bundled(libxlsxio) = 0.2.27
%endif
@@ -71,9 +71,6 @@ Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}-%{rele
%endif
%if "%{?packager}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
-%if "%{php_version}" > "7.3"
-Obsoletes: php73-pecl-%{pecl_name} <= %{version}
-%endif
%if "%{php_version}" > "7.4"
Obsoletes: php74-pecl-%{pecl_name} <= %{version}
%endif
@@ -223,6 +220,11 @@ fi
%check
+OPT="-q -P --show-diff"
+%if "%{php_version}" > "7.4"
+OPT="$OPT %{?_smp_mflags}"
+%endif
+
%if %{with syslib}
# https://github.com/brechtsanders/xlsxio/issues/75
rm ?TS/tests/open_xlsx_get_data_skip_empty.phpt
@@ -240,11 +242,9 @@ cd NTS
%if %{with tests}
: Upstream test suite for NTS extension
-TEST_PHP_EXECUTABLE=%{__php} \
TEST_PHP_ARGS="-n -d extension=%{buildroot}%{php_extdir}/%{pecl_name}.so" \
-NO_INTERACTION=1 \
REPORT_EXIT_STATUS=1 \
-%{__php} -n run-tests.php --show-diff
+%{__php} -n run-tests.php $OPT
%endif
%if %{with_zts}
@@ -257,11 +257,9 @@ cd ../ZTS
%if %{with tests}
: Upstream test suite for ZTS extension
-TEST_PHP_EXECUTABLE=%{_bindir}/zts-php \
TEST_PHP_ARGS="-n -d extension=%{buildroot}%{php_ztsextdir}/%{pecl_name}.so" \
-NO_INTERACTION=1 \
REPORT_EXIT_STATUS=1 \
-%{_bindir}/zts-php -n run-tests.php --show-diff
+%{_bindir}/zts-php -n run-tests.php $OPT
%endif
%endif
cd ..
@@ -282,6 +280,12 @@ cd ..
%changelog
+* Tue Oct 26 2021 Remi Collet <remi@remirepo.net> - 1.5.1-1
+- update to 1.5.1
+
+* Thu Oct 7 2021 Remi Collet <remi@remirepo.net> - 1.5.0-1
+- update to 1.5.0
+
* Wed Sep 01 2021 Remi Collet <remi@remirepo.net> - 1.4.0-2
- rebuild for 8.1.0RC1