summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-07-19 07:42:07 +0200
committerRemi Collet <remi@remirepo.net>2021-07-19 07:42:07 +0200
commitc94a13eb697186e39ac560bb7ebbde78b6f0eb20 (patch)
tree668e3cc775e74e31d16f6d475ca322bb42495a18
parent8edae9b46a6a059ebcf923da26597d5030038df0 (diff)
update to 1.4.0
-rw-r--r--PHPINFO4
-rw-r--r--REFLECTION315
-rw-r--r--php-pecl-xlswriter.spec44
3 files changed, 335 insertions, 28 deletions
diff --git a/PHPINFO b/PHPINFO
index d3268b8..318c464 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,6 +2,6 @@
xlswriter
xlswriter support => enabled
-Version => 1.3.7
-bundled libxlsxwriter version => 0.9.4
+Version => 1.4.0
+bundled libxlsxwriter version => 1.0.0
bundled libxlsxio version => 0.2.27
diff --git a/REFLECTION b/REFLECTION
index f4b9a13..5c7744f 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #106 xlswriter version 1.3.7 ] {
+Extension [ <persistent> extension #107 xlswriter version 1.4.0 ] {
- Functions {
Function [ <internal:xlswriter> function xlswriter_get_version ] {
@@ -13,7 +13,7 @@ Extension [ <persistent> extension #106 xlswriter version 1.3.7 ] {
}
}
- - Classes [4] {
+ - Classes [5] {
Class [ <internal:xlswriter> class Vtiful\Kernel\Exception extends Exception implements Throwable ] {
- Constants [0] {
@@ -73,7 +73,7 @@ Extension [ <persistent> extension #106 xlswriter version 1.3.7 ] {
Class [ <internal:xlswriter> class Vtiful\Kernel\Excel ] {
- - Constants [13] {
+ - Constants [53] {
Constant [ public int SKIP_NONE ] { 0 }
Constant [ public int SKIP_EMPTY_ROW ] { 1 }
Constant [ public int SKIP_HIDDEN_ROW ] { 8 }
@@ -83,6 +83,46 @@ Extension [ <persistent> extension #106 xlswriter version 1.3.7 ] {
Constant [ public int GRIDLINES_SHOW_ALL ] { 3 }
Constant [ public int GRIDLINES_SHOW_PRINT ] { 2 }
Constant [ public int GRIDLINES_SHOW_SCREEN ] { 1 }
+ Constant [ public int PAPER_DEFAULT ] { 0 }
+ Constant [ public int PAPER_LETTER ] { 1 }
+ Constant [ public int PAPER_LETTER_SMALL ] { 2 }
+ Constant [ public int PAPER_TABLOID ] { 3 }
+ Constant [ public int PAPER_LEDGER ] { 4 }
+ Constant [ public int PAPER_LEGAL ] { 5 }
+ Constant [ public int PAPER_STATEMENT ] { 6 }
+ Constant [ public int PAPER_EXECUTIVE ] { 7 }
+ Constant [ public int PAPER_A3 ] { 8 }
+ Constant [ public int PAPER_A4 ] { 9 }
+ Constant [ public int PAPER_A4_SMALL ] { 10 }
+ Constant [ public int PAPER_A5 ] { 11 }
+ Constant [ public int PAPER_B4 ] { 12 }
+ Constant [ public int PAPER_B5 ] { 13 }
+ Constant [ public int PAPER_FOLIO ] { 14 }
+ Constant [ public int PAPER_QUARTO ] { 15 }
+ Constant [ public int PAPER_NOTE ] { 18 }
+ Constant [ public int PAPER_ENVELOPE_9 ] { 19 }
+ Constant [ public int PAPER_ENVELOPE_10 ] { 20 }
+ Constant [ public int PAPER_ENVELOPE_11 ] { 21 }
+ Constant [ public int PAPER_ENVELOPE_12 ] { 22 }
+ Constant [ public int PAPER_ENVELOPE_14 ] { 23 }
+ Constant [ public int PAPER_C_SIZE_SHEET ] { 24 }
+ Constant [ public int PAPER_D_SIZE_SHEET ] { 25 }
+ Constant [ public int PAPER_E_SIZE_SHEET ] { 26 }
+ Constant [ public int PAPER_ENVELOPE_DL ] { 27 }
+ Constant [ public int PAPER_ENVELOPE_C3 ] { 28 }
+ Constant [ public int PAPER_ENVELOPE_C4 ] { 29 }
+ Constant [ public int PAPER_ENVELOPE_C5 ] { 30 }
+ Constant [ public int PAPER_ENVELOPE_C6 ] { 31 }
+ Constant [ public int PAPER_ENVELOPE_C65 ] { 32 }
+ Constant [ public int PAPER_ENVELOPE_B4 ] { 33 }
+ Constant [ public int PAPER_ENVELOPE_B5 ] { 34 }
+ Constant [ public int PAPER_ENVELOPE_B6 ] { 35 }
+ Constant [ public int PAPER_ENVELOPE_1 ] { 36 }
+ Constant [ public int PAPER_MONARCH ] { 37 }
+ Constant [ public int PAPER_ENVELOPE_2 ] { 38 }
+ Constant [ public int PAPER_FANFOLD ] { 39 }
+ Constant [ public int PAPER_GERMAN_STD_FANFOLD ] { 40 }
+ Constant [ public int PAPER_GERMAN_LEGAL_FANFOLD ] { 41 }
Constant [ public int TYPE_INT ] { 2 }
Constant [ public int TYPE_DOUBLE ] { 4 }
Constant [ public int TYPE_STRING ] { 1 }
@@ -121,7 +161,7 @@ Extension [ <persistent> extension #106 xlswriter version 1.3.7 ] {
Property [ <default> private $read_row_type ]
}
- - Methods [42] {
+ - Methods [47] {
Method [ <internal:xlswriter, ctor> public method __construct ] {
- Parameters [1] {
@@ -129,6 +169,12 @@ Extension [ <persistent> extension #106 xlswriter version 1.3.7 ] {
}
}
+ Method [ <internal:xlswriter> public method close ] {
+
+ - Parameters [0] {
+ }
+ }
+
Method [ <internal:xlswriter> public method fileName ] {
- Parameters [2] {
@@ -144,6 +190,13 @@ Extension [ <persistent> extension #106 xlswriter version 1.3.7 ] {
}
}
+ Method [ <internal:xlswriter> public method existSheet ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $sheet_name ]
+ }
+ }
+
Method [ <internal:xlswriter> public method checkoutSheet ] {
- Parameters [1] {
@@ -328,6 +381,14 @@ Extension [ <persistent> extension #106 xlswriter version 1.3.7 ] {
}
}
+ Method [ <internal:xlswriter> public method validation ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $range ]
+ Parameter #1 [ <required> $validation_resource ]
+ }
+ }
+
Method [ <internal:xlswriter> public method zoom ] {
- Parameters [1] {
@@ -342,13 +403,30 @@ Extension [ <persistent> extension #106 xlswriter version 1.3.7 ] {
}
}
- Method [ <internal:xlswriter> public method setPrintedPortrait ] {
+ Method [ <internal:xlswriter> public method setPaper ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $paper ]
+ }
+ }
+
+ Method [ <internal:xlswriter> public method setMargins ] {
+
+ - Parameters [4] {
+ Parameter #0 [ <required> $left ]
+ Parameter #1 [ <required> $right ]
+ Parameter #2 [ <required> $top ]
+ Parameter #3 [ <required> $bottom ]
+ }
+ }
+
+ Method [ <internal:xlswriter> public method setPortrait ] {
- Parameters [0] {
}
}
- Method [ <internal:xlswriter> public method setPrintedLandscape ] {
+ Method [ <internal:xlswriter> public method setLandscape ] {
- Parameters [0] {
}
@@ -636,7 +714,7 @@ Extension [ <persistent> extension #106 xlswriter version 1.3.7 ] {
Class [ <internal:xlswriter> class Vtiful\Kernel\Chart ] {
- - Constants [27] {
+ - Constants [29] {
Constant [ public int CHART_BAR ] { 4 }
Constant [ public int CHART_BAR_STACKED ] { 5 }
Constant [ public int CHART_BAR_STACKED_PERCENT ] { 6 }
@@ -648,15 +726,15 @@ Extension [ <persistent> extension #106 xlswriter version 1.3.7 ] {
Constant [ public int CHART_COLUMN_STACKED ] { 8 }
Constant [ public int CHART_COLUMN_STACKED_PERCENT ] { 9 }
Constant [ public int CHART_DOUGHNUT ] { 10 }
- Constant [ public int CHART_PIE ] { 12 }
- Constant [ public int CHART_SCATTER ] { 13 }
- Constant [ public int CHART_SCATTER_STRAIGHT ] { 14 }
- Constant [ public int CHART_SCATTER_STRAIGHT_WITH_MARKERS ] { 15 }
- Constant [ public int CHART_SCATTER_SMOOTH ] { 16 }
- Constant [ public int CHART_SCATTER_SMOOTH_WITH_MARKERS ] { 17 }
- Constant [ public int CHART_RADAR ] { 18 }
- Constant [ public int CHART_RADAR_WITH_MARKERS ] { 19 }
- Constant [ public int CHART_RADAR_FILLED ] { 20 }
+ Constant [ public int CHART_PIE ] { 14 }
+ Constant [ public int CHART_SCATTER ] { 15 }
+ Constant [ public int CHART_SCATTER_STRAIGHT ] { 16 }
+ Constant [ public int CHART_SCATTER_STRAIGHT_WITH_MARKERS ] { 17 }
+ Constant [ public int CHART_SCATTER_SMOOTH ] { 18 }
+ Constant [ public int CHART_SCATTER_SMOOTH_WITH_MARKERS ] { 19 }
+ Constant [ public int CHART_RADAR ] { 20 }
+ Constant [ public int CHART_RADAR_WITH_MARKERS ] { 21 }
+ Constant [ public int CHART_RADAR_FILLED ] { 22 }
Constant [ public int CHART_LEGEND_NONE ] { 0 }
Constant [ public int CHART_LEGEND_RIGHT ] { 1 }
Constant [ public int CHART_LEGEND_LEFT ] { 2 }
@@ -664,6 +742,8 @@ Extension [ <persistent> extension #106 xlswriter version 1.3.7 ] {
Constant [ public int CHART_LEGEND_BOTTOM ] { 4 }
Constant [ public int CHART_LEGEND_OVERLAY_RIGHT ] { 6 }
Constant [ public int CHART_LEGEND_OVERLAY_LEFT ] { 7 }
+ Constant [ public int CHART_LINE_STACKED ] { 12 }
+ Constant [ public int CHART_LINE_STACKED_PERCENT ] { 13 }
}
- Static properties [0] {
@@ -741,6 +821,209 @@ Extension [ <persistent> extension #106 xlswriter version 1.3.7 ] {
}
}
}
+
+ Class [ <internal:xlswriter> class Vtiful\Kernel\Validation ] {
+
+ - Constants [27] {
+ Constant [ public int TYPE_INTEGER ] { 1 }
+ Constant [ public int TYPE_INTEGER_FORMULA ] { 2 }
+ Constant [ public int TYPE_DECIMAL ] { 3 }
+ Constant [ public int TYPE_DECIMAL_FORMULA ] { 4 }
+ Constant [ public int TYPE_LIST ] { 5 }
+ Constant [ public int TYPE_LIST_FORMULA ] { 6 }
+ Constant [ public int TYPE_DATE ] { 7 }
+ Constant [ public int TYPE_DATE_FORMULA ] { 8 }
+ Constant [ public int TYPE_DATE_NUMBER ] { 9 }
+ Constant [ public int TYPE_TIME ] { 10 }
+ Constant [ public int TYPE_TIME_FORMULA ] { 11 }
+ Constant [ public int TYPE_TIME_NUMBER ] { 12 }
+ Constant [ public int TYPE_LENGTH ] { 13 }
+ Constant [ public int TYPE_LENGTH_FORMULA ] { 14 }
+ Constant [ public int TYPE_CUSTOM_FORMULA ] { 15 }
+ Constant [ public int TYPE_ANY ] { 16 }
+ Constant [ public int CRITERIA_BETWEEN ] { 1 }
+ Constant [ public int CRITERIA_NOT_BETWEEN ] { 2 }
+ Constant [ public int CRITERIA_EQUAL_TO ] { 3 }
+ Constant [ public int CRITERIA_NOT_EQUAL_TO ] { 4 }
+ Constant [ public int CRITERIA_GREATER_THAN ] { 5 }
+ Constant [ public int CRITERIA_LESS_THAN ] { 6 }
+ Constant [ public int CRITERIA_GREATER_THAN_OR_EQUAL_TO ] { 7 }
+ Constant [ public int CRITERIA_LESS_THAN_OR_EQUAL_TO ] { 8 }
+ Constant [ public int ERROR_TYPE_STOP ] { 0 }
+ Constant [ public int ERROR_TYPE_WARNING ] { 1 }
+ Constant [ public int ERROR_TYPE_INFORMATION ] { 2 }
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [23] {
+ Method [ <internal:xlswriter, ctor> public method __construct ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:xlswriter> public method validationType ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $type ]
+ }
+ }
+
+ Method [ <internal:xlswriter> public method criteriaType ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $type ]
+ }
+ }
+
+ Method [ <internal:xlswriter> public method ignoreBlank ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $ignore_blank ]
+ }
+ }
+
+ Method [ <internal:xlswriter> public method showInput ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $show_input ]
+ }
+ }
+
+ Method [ <internal:xlswriter> public method showError ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $show_error ]
+ }
+ }
+
+ Method [ <internal:xlswriter> public method errorType ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $error_type ]
+ }
+ }
+
+ Method [ <internal:xlswriter> public method dropdown ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $dropdown ]
+ }
+ }
+
+ Method [ <internal:xlswriter> public method valueNumber ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $value_number ]
+ }
+ }
+
+ Method [ <internal:xlswriter> public method valueFormula ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $value_formula ]
+ }
+ }
+
+ Method [ <internal:xlswriter> public method valueList ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $value_list ]
+ }
+ }
+
+ Method [ <internal:xlswriter> public method valueDatetime ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $timestamp ]
+ }
+ }
+
+ Method [ <internal:xlswriter> public method minimumNumber ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $minimum_number ]
+ }
+ }
+
+ Method [ <internal:xlswriter> public method minimumFormula ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $minimum_formula ]
+ }
+ }
+
+ Method [ <internal:xlswriter> public method minimumDatetime ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $timestamp ]
+ }
+ }
+
+ Method [ <internal:xlswriter> public method maximumNumber ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $maximum_number ]
+ }
+ }
+
+ Method [ <internal:xlswriter> public method maximumFormula ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $maximum_formula ]
+ }
+ }
+
+ Method [ <internal:xlswriter> public method maximumDatetime ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $maximum_datetime ]
+ }
+ }
+
+ Method [ <internal:xlswriter> public method inputTitle ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $input_title ]
+ }
+ }
+
+ Method [ <internal:xlswriter> public method inputMessage ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $input_message ]
+ }
+ }
+
+ Method [ <internal:xlswriter> public method errorTitle ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $error_titile ]
+ }
+ }
+
+ Method [ <internal:xlswriter> public method errorMessage ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $error_message ]
+ }
+ }
+
+ Method [ <internal:xlswriter> public method toResource ] {
+
+ - Parameters [0] {
+ }
+ }
+ }
+ }
}
}
diff --git a/php-pecl-xlswriter.spec b/php-pecl-xlswriter.spec
index c459a0a..d29929e 100644
--- a/php-pecl-xlswriter.spec
+++ b/php-pecl-xlswriter.spec
@@ -1,6 +1,6 @@
# remirepo spec file for php-pecl-xlswriter
#
-# Copyright (c) 2018-2020 Remi Collet
+# Copyright (c) 2018-2021 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
@@ -29,9 +29,9 @@
%global libxlsxio_version 0.2.29
%endif
-Summary: An efficient and fast xlsx file export extension
+Summary: An efficient and fast xlsx file extension
Name: %{?sub_prefix}php-pecl-%{pecl_name}
-Version: 1.3.7
+Version: 1.4.0
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: BSD
URL: https://pecl.php.net/package/%{pecl_name}
@@ -80,17 +80,38 @@ Obsoletes: php74-pecl-%{pecl_name} <= %{version}
%if "%{php_version}" > "8.0"
Obsoletes: php80-pecl-%{pecl_name} <= %{version}
%endif
+%if "%{php_version}" > "8.1"
+Obsoletes: php81-pecl-%{pecl_name} <= %{version}
+%endif
%endif
%description
-An efficient and fast xlsx file export extension for PHP.
-
-- Quickly export xlsx files in php projects.
-- Export xlsx files under fixed memory.
-- Insert a calculation formula in an xlsx file.
-- Insert a local picture in an xlsx file.
-- Merging cells and cell styles.
+xlswriter is a PHP C Extension that can be used to write text, numbers,
+formulas and hyperlinks to multiple worksheets in an Excel 2007+ XLSX file.
+
+Writer
+
+- 100% compatible Excel XLSX files.
+- Full Excel formatting.
+- Merged cells.
+- Defined names.
+- Autofilters.
+- Charts.
+- Data validation and drop down lists.
+- Worksheet PNG/JPEG images.
+- Memory optimization mode for writing large files.
+- Works on Linux, FreeBSD, OpenBSD, OS X, Windows.
+- Compiles for 32 and 64 bit.
+- FreeBSD License.
+- The only dependency is on zlib.
+
+Reader
+
+- Full read data
+- Cursor read data
+- Read by data type
+- Xlsx to csv
Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')%{?scl: as Software Collection (%{scl} by %{?scl_vendor}%{!?scl_vendor:rh})}.
@@ -261,6 +282,9 @@ cd ..
%changelog
+* Mon Jul 19 2021 Remi Collet <remi@remirepo.net> - 1.4.0-1
+- update to 1.4.0
+
* Sat Jan 2 2021 Remi Collet <remi@remirepo.net> - 1.3.7-1
- update to 1.3.7
- drop patch merged upstream