summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-06-17 07:04:45 +0200
committerRemi Collet <remi@remirepo.net>2020-06-17 07:04:45 +0200
commit90ccf56eaaad8573717286706e1c25e95bc5cad1 (patch)
tree00210b6e03c0d2b5dc1745d0ac85d94b31114244
parent7a8b15833487ba83fb8714f89859ca2f57e70f50 (diff)
update to 1.3.6
-rw-r--r--PHPINFO2
-rw-r--r--REFLECTION32
-rw-r--r--php-pecl-xlswriter.spec7
3 files changed, 34 insertions, 7 deletions
diff --git a/PHPINFO b/PHPINFO
index fa6affb..35b2fe5 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,7 +2,7 @@
xlswriter
xlswriter support => enabled
-Version => 1.3.5
+Version => 1.3.6
libxlsxwriter headers version => 0.9.5
libxlsxwriter library version => 0.9.5
libxlsxio headers version => 0.2.26
diff --git a/REFLECTION b/REFLECTION
index 35eeaae..0d446c2 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #101 xlswriter version 1.3.5 ] {
+Extension [ <persistent> extension #102 xlswriter version 1.3.6 ] {
- Classes [4] {
Class [ <internal:xlswriter> class Vtiful\Kernel\Exception extends Exception implements Throwable ] {
@@ -78,7 +78,7 @@ Extension [ <persistent> extension #101 xlswriter version 1.3.5 ] {
- Static properties [0] {
}
- - Static methods [2] {
+ - Static methods [3] {
Method [ <internal:xlswriter> static public method columnIndexFromString ] {
- Parameters [1] {
@@ -92,6 +92,13 @@ Extension [ <persistent> extension #101 xlswriter version 1.3.5 ] {
Parameter #0 [ <required> $index ]
}
}
+
+ Method [ <internal:xlswriter> static public method timestampFromDateDouble ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $index ]
+ }
+ }
}
- Properties [3] {
@@ -100,7 +107,7 @@ Extension [ <persistent> extension #101 xlswriter version 1.3.5 ] {
Property [ <default> private $read_row_type ]
}
- - Methods [34] {
+ - Methods [36] {
Method [ <internal:xlswriter, ctor> public method __construct ] {
- Parameters [1] {
@@ -241,6 +248,21 @@ Extension [ <persistent> extension #101 xlswriter version 1.3.5 ] {
}
}
+ Method [ <internal:xlswriter> public method insertComment ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $row ]
+ Parameter #1 [ <required> $column ]
+ Parameter #2 [ <required> $comment ]
+ }
+ }
+
+ Method [ <internal:xlswriter> public method showComment ] {
+
+ - Parameters [0] {
+ }
+ }
+
Method [ <internal:xlswriter> public method mergeCells ] {
- Parameters [3] {
@@ -552,7 +574,7 @@ Extension [ <persistent> extension #101 xlswriter version 1.3.5 ] {
Class [ <internal:xlswriter> class Vtiful\Kernel\Chart ] {
- - Constants [27] {
+ - Constants [29] {
Constant [ public int CHART_BAR ] { 4 }
Constant [ public int CHART_BAR_STACKED ] { 5 }
Constant [ public int CHART_BAR_STACKED_PERCENT ] { 6 }
@@ -580,6 +602,8 @@ Extension [ <persistent> extension #101 xlswriter version 1.3.5 ] {
Constant [ public int CHART_LEGEND_BOTTOM ] { 4 }
Constant [ public int CHART_LEGEND_OVERLAY_RIGHT ] { 6 }
Constant [ public int CHART_LEGEND_OVERLAY_LEFT ] { 7 }
+ Constant [ public int CHART_LINE_STACKED ] { 12 }
+ Constant [ public int CHART_LINE_STACKED_PERCENT ] { 13 }
}
- Static properties [0] {
diff --git a/php-pecl-xlswriter.spec b/php-pecl-xlswriter.spec
index 74d1eb3..1099b6e 100644
--- a/php-pecl-xlswriter.spec
+++ b/php-pecl-xlswriter.spec
@@ -27,8 +27,8 @@
Summary: An efficient and fast xlsx file export extension
Name: %{?sub_prefix}php-pecl-%{pecl_name}
-Version: 1.3.5
-Release: 2%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Version: 1.3.6
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: BSD
URL: https://pecl.php.net/package/%{pecl_name}
Source0: https://pecl.php.net/get/%{pecl_name}-%{version}.tgz
@@ -251,6 +251,9 @@ cd ..
%changelog
+* Wed Jun 17 2020 Remi Collet <remi@remirepo.net> - 1.3.6-1
+- update to 1.3.6
+
* Mon Jun 1 2020 Remi Collet <remi@remirepo.net> - 1.3.5-2
- build using libxlsxwriter version 0.9.5