summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2019-11-21 15:39:11 +0100
committerRemi Collet <remi@remirepo.net>2019-11-21 15:39:11 +0100
commit2544b6b8169062e66853561e4cd80d0936c5fc0d (patch)
treebc68b5544baf7636c9e178d8af1d51783628dbed
parent2cd20b96dd9d8e67bf684e7eddf49bb148e92b3e (diff)
v1.3.2
-rw-r--r--PHPINFO2
-rw-r--r--REFLECTION34
-rw-r--r--php-pecl-xlswriter.spec7
3 files changed, 37 insertions, 6 deletions
diff --git a/PHPINFO b/PHPINFO
index 1a05be8..219202a 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,7 +2,7 @@
xlswriter
xlswriter support => enabled
-Version => 1.3.1
+Version => 1.3.2
libxlsxwriter headers version => 0.8.8
libxlsxwriter library version => 0.8.8
libxlsxio headers version => 0.2.21
diff --git a/REFLECTION b/REFLECTION
index e5c8eea..a11b38f 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #174 xlswriter version 1.3.1 ] {
+Extension [ <persistent> extension #174 xlswriter version 1.3.2 ] {
- Classes [4] {
Class [ <internal:xlswriter> class Vtiful\Kernel\Exception extends Exception implements Throwable ] {
@@ -60,10 +60,14 @@ Extension [ <persistent> extension #174 xlswriter version 1.3.1 ] {
Class [ <internal:xlswriter> class Vtiful\Kernel\Excel ] {
- - Constants [7] {
+ - Constants [11] {
Constant [ public integer SKIP_NONE ] { 0 }
Constant [ public integer SKIP_EMPTY_ROW ] { 1 }
Constant [ public integer SKIP_EMPTY_CELLS ] { 2 }
+ Constant [ public integer GRIDLINES_HIDE_ALL ] { 0 }
+ Constant [ public integer GRIDLINES_SHOW_ALL ] { 3 }
+ Constant [ public integer GRIDLINES_SHOW_PRINT ] { 2 }
+ Constant [ public integer GRIDLINES_SHOW_SCREEN ] { 1 }
Constant [ public integer TYPE_INT ] { 2 }
Constant [ public integer TYPE_DOUBLE ] { 4 }
Constant [ public integer TYPE_STRING ] { 1 }
@@ -95,7 +99,7 @@ Extension [ <persistent> extension #174 xlswriter version 1.3.1 ] {
Property [ <default> private $read_row_type ]
}
- - Methods [26] {
+ - Methods [30] {
Method [ <internal:xlswriter, ctor> public method __construct ] {
- Parameters [1] {
@@ -255,6 +259,20 @@ Extension [ <persistent> extension #174 xlswriter version 1.3.1 ] {
}
}
+ Method [ <internal:xlswriter> public method zoom ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $scale ]
+ }
+ }
+
+ Method [ <internal:xlswriter> public method gridline ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $option ]
+ }
+ }
+
Method [ <internal:xlswriter> public method openFile ] {
- Parameters [1] {
@@ -269,6 +287,16 @@ Extension [ <persistent> extension #174 xlswriter version 1.3.1 ] {
}
}
+ Method [ <internal:xlswriter> public method putCSV ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $fp ]
+ }
+ }
+
+ Method [ <internal:xlswriter> public method sheetList ] {
+ }
+
Method [ <internal:xlswriter> public method setType ] {
- Parameters [1] {
diff --git a/php-pecl-xlswriter.spec b/php-pecl-xlswriter.spec
index d95c8ce..98abeb0 100644
--- a/php-pecl-xlswriter.spec
+++ b/php-pecl-xlswriter.spec
@@ -27,8 +27,8 @@
Summary: An efficient and fast xlsx file export extension
Name: %{?sub_prefix}php-pecl-%{pecl_name}
-Version: 1.3.1
-Release: 2%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Version: 1.3.2
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: BSD
URL: http://pecl.php.net/package/%{pecl_name}
Source0: http://pecl.php.net/get/%{pecl_name}-%{version}.tgz
@@ -254,6 +254,9 @@ cd ..
%changelog
+* Thu Nov 21 2019 Remi Collet <remi@remirepo.net> - 1.3.2-1
+- update to 1.3.2
+
* Mon Nov 18 2019 Remi Collet <remi@remirepo.net> - 1.3.1-2
- rebuild with libxlsxwriter 0.8.8
- open https://github.com/viest/php-ext-excel-export/pull/199