summaryrefslogtreecommitdiffstats
path: root/php-pecl-xhprof.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-pecl-xhprof.spec')
-rw-r--r--php-pecl-xhprof.spec20
1 files changed, 7 insertions, 13 deletions
diff --git a/php-pecl-xhprof.spec b/php-pecl-xhprof.spec
index 509b0a6..e2a5830 100644
--- a/php-pecl-xhprof.spec
+++ b/php-pecl-xhprof.spec
@@ -25,7 +25,7 @@
%global ini_name 40-%{pecl_name}.ini
Name: %{?sub_prefix}php-pecl-xhprof
-Version: 2.3.0
+Version: 2.3.1
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
Summary: PHP extension for XHProf, a Hierarchical Profiler
@@ -114,7 +114,7 @@ sed -e 's/role="php"/role="src"/' \
-i package.xml
pushd %{pecl_name}-%{version}/extension
-sed -e '/XHPROF_VERSION/s/%{version}-dev/%{version}/' -i php_xhprof.h
+sed -e '/XHPROF_VERSION/s/2.3.0/%{version}/' -i php_xhprof.h
# Sanity check, really often broken
extver=$(sed -n '/#define XHPROF_VERSION/{s/.* "//;s/".*$//;p}' php_xhprof.h)
if test "x${extver}" != "x%{version}"; then
@@ -143,17 +143,8 @@ Alias /xhprof %{_datadir}/xhprof/xhprof_html
<Directory %{_datadir}/xhprof/xhprof_html>
# For security reason, the web interface
# is only allowed from the server
- <IfModule mod_authz_core.c>
- # Apache 2.4
- Require local
- </IfModule>
- <IfModule !mod_authz_core.c>
- # Apache 2.2
- Order Deny,Allow
- Deny from All
- Allow from 127.0.0.1
- Allow from ::1
- </IfModule>
+
+ Require local
</Directory>
EOF
@@ -287,6 +278,9 @@ fi
%changelog
+* Sat May 1 2021 Remi Collet <remi@remirepo.net> - 2.3.1-1
+- update to 2.3.1 (beta)
+
* Thu Apr 1 2021 Remi Collet <remi@remirepo.net> - 2.3.0-1
- update to 2.3.0 (beta)