summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2019-12-06 10:05:42 +0100
committerRemi Collet <remi@remirepo.net>2019-12-06 10:05:42 +0100
commitf7c32c90005e688f99c30ed45ce7cb25f46da758 (patch)
treed848d3080f7a0593412577448de7402ed1e14be4
parentc514b5bc1517aa0d6069b1ca0f3fc5bfa727fb73 (diff)
v2.1.2
-rw-r--r--.gitignore8
-rw-r--r--PHPINFO11
-rw-r--r--REFLECTION17
-rw-r--r--php-pecl-xhprof.spec63
4 files changed, 62 insertions, 37 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 0000000..fc9aa8c
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,8 @@
+clog
+package-*.xml
+*.tgz
+*.tar.gz
+*.tar.xz
+*.tar.xz.asc
+*.src.rpm
+*/*rpm
diff --git a/PHPINFO b/PHPINFO
new file mode 100644
index 0000000..8afe6e0
--- /dev/null
+++ b/PHPINFO
@@ -0,0 +1,11 @@
+
+xhprof
+
+xhprof support => enabled
+Version => 2.1.2
+
+Directive => Local Value => Master Value
+xhprof.output_dir => /tmp => /tmp
+xhprof.collect_additional_info => 0 => 0
+xhprof.sampling_interval => 100000 => 100000
+xhprof.sampling_depth => 0x7fffffff => 0x7fffffff
diff --git a/REFLECTION b/REFLECTION
index 7e402a1..1da8093 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,15 +1,24 @@
-Extension [ <persistent> extension #143 xhprof version 0.9.2 ] {
+Extension [ <persistent> extension #163 xhprof version 2.1.2 ] {
- INI {
Entry [ xhprof.output_dir <ALL> ]
Current = '/tmp'
}
+ Entry [ xhprof.collect_additional_info <ALL> ]
+ Current = '0'
+ }
+ Entry [ xhprof.sampling_interval <ALL> ]
+ Current = '100000'
+ }
+ Entry [ xhprof.sampling_depth <ALL> ]
+ Current = '0x7fffffff'
+ }
}
- Constants [3] {
- Constant [ integer XHPROF_FLAGS_NO_BUILTINS ] { 1 }
- Constant [ integer XHPROF_FLAGS_CPU ] { 2 }
- Constant [ integer XHPROF_FLAGS_MEMORY ] { 4 }
+ Constant [ int XHPROF_FLAGS_NO_BUILTINS ] { 1 }
+ Constant [ int XHPROF_FLAGS_CPU ] { 2 }
+ Constant [ int XHPROF_FLAGS_MEMORY ] { 4 }
}
- Functions {
diff --git a/php-pecl-xhprof.spec b/php-pecl-xhprof.spec
index d4c4249..deb55e2 100644
--- a/php-pecl-xhprof.spec
+++ b/php-pecl-xhprof.spec
@@ -3,7 +3,7 @@
#
# Fedora spec file for php-pecl-xhprof
#
-# Copyright (c) 2012-2017 Remi Collet
+# Copyright (c) 2012-2019 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
@@ -23,15 +23,11 @@
%global pecl_name xhprof
%global with_zts 0%{?__ztsphp:1}
-%if "%{php_version}" < "5.6"
-%global ini_name %{pecl_name}.ini
-%else
%global ini_name 40-%{pecl_name}.ini
-%endif
Name: %{?sub_prefix}php-pecl-xhprof
-Version: 0.9.4
-Release: 7%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Version: 2.1.2
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
Summary: PHP extension for XHProf, a Hierarchical Profiler
Group: Development/Languages
@@ -42,8 +38,7 @@ Source0: http://pecl.php.net/get/%{pecl_name}-%{version}.tgz
# https://bugs.php.net/61262
ExclusiveArch: %{ix86} x86_64
-BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
-BuildRequires: %{?scl_prefix}php-devel >= 5.2.0
+BuildRequires: %{?scl_prefix}php-devel >= 7
BuildRequires: %{?scl_prefix}php-pear
Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
@@ -59,21 +54,17 @@ Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}-%{rele
%if "%{?vendor}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
# Other third party repo stuff
-Obsoletes: php53-pecl-%{pecl_name} <= %{version}
-Obsoletes: php53u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php54-pecl-%{pecl_name} <= %{version}
-Obsoletes: php54w-pecl-%{pecl_name} <= %{version}
-%if "%{php_version}" > "5.5"
-Obsoletes: php55u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php55w-pecl-%{pecl_name} <= %{version}
+%if "%{php_version}" > "7.2"
+Obsoletes: php72u-pecl-%{pecl_name} <= %{version}
+Obsoletes: php72w-pecl-%{pecl_name} <= %{version}
%endif
-%if "%{php_version}" > "5.6"
-Obsoletes: php56u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php56w-pecl-%{pecl_name} <= %{version}
+%if "%{php_version}" > "7.3"
+Obsoletes: php73-pecl-%{pecl_name} <= %{version}
+Obsoletes: php73w-pecl-%{pecl_name} <= %{version}
%endif
-%if "%{php_version}" > "7.0"
-Obsoletes: php70u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php70w-pecl-%{pecl_name} <= %{version}
+%if "%{php_version}" > "7.4"
+Obsoletes: php74-pecl-%{pecl_name} <= %{version}
+Obsoletes: php74w-pecl-%{pecl_name} <= %{version}
%endif
%endif
@@ -98,12 +89,9 @@ Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSIO
%package -n %{?sub_prefix}xhprof
Summary: A Hierarchical Profiler for PHP - Web interface
Group: Development/Tools
-%if 0%{?fedora} > 11 || 0%{?rhel} > 5
BuildArch: noarch
-%endif
Requires: %{name} = %{version}-%{release}
-Requires: %{?scl_prefix}mod_php >= 5.2.0
Requires: %{_root_bindir}/dot
%description -n %{?sub_prefix}xhprof
@@ -140,7 +128,10 @@ extension = xhprof.so
; You can either pass the directory location as an argument to the constructor
; for XHProfRuns_Default() or set xhprof.output_dir ini param.
-xhprof.output_dir = /tmp
+;xhprof.output_dir = /tmp
+;xhprof.collect_additional_info = 0
+;xhprof.sampling_interval = 100000
+;xhprof.sampling_depth = 0x7fffffff
EOF
# Apache configuration file
@@ -165,6 +156,7 @@ Alias /xhprof %{_datadir}/xhprof/xhprof_html
EOF
cd %{pecl_name}-%{version}
+chmod -x extension/*.{c,h}
%if %{with_zts}
# duplicate for ZTS build
@@ -173,6 +165,8 @@ cp -r extension ext-zts
%build
+%{?dtsenable}
+
cd %{pecl_name}-%{version}/extension
%{_bindir}/phpize
%configure \
@@ -189,7 +183,8 @@ make %{?_smp_mflags}
%install
-rm -rf %{buildroot}
+%{?dtsenable}
+
make install -C %{pecl_name}-%{version}/extension INSTALL_ROOT=%{buildroot}
install -D -m 644 %{ini_name} %{buildroot}%{php_inidir}/%{ini_name}
@@ -234,11 +229,7 @@ done
%endif
-%clean
-rm -rf %{buildroot}
-
-
-%if 0%{?fedora} < 24
+%if 0%{?fedora} < 24 && 0%{?rhel} < 8
# when pear installed alone, after us
%triggerin -- %{?scl_prefix}php-pear
if [ -x %{__pecl} ] ; then
@@ -259,7 +250,6 @@ fi
%files
-%defattr(-,root,root,-)
%{?_licensedir:%license %{pecl_name}-%{version}/LICENSE}
%doc %{pecl_docdir}/%{pecl_name}
%exclude %{pecl_docdir}/%{pecl_name}/examples
@@ -285,6 +275,13 @@ fi
%changelog
+* Fri Dec 6 2019 Remi Collet <remi@remirepo.net> - 2.1.2-1
+- update to 2.1.2
+- raise dependency on PHP 7
+
+* Mon Jan 21 2019 Remi Collet <remi@remirepo.net> - 0.9.4-8
+- cleanup for EL-8
+
* Wed Mar 9 2016 Remi Collet <remi@fedoraproject.org> - 0.9.4-7
- adapt for F24