summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-08-04 08:05:00 +0200
committerRemi Collet <remi@remirepo.net>2021-08-04 08:05:00 +0200
commitceaca203ca2527e31304c743d3b03205e818a96e (patch)
tree1c9707ec613404e131a6c0a9f6cbfb4e8a9f4fe0
parente9cf32572fe79e849e99b14b7b88aac4f59cf005 (diff)
update to 2.3.4
drop patch merged upstream
-rw-r--r--PHPINFO2
-rw-r--r--REFLECTION2
-rw-r--r--php-pecl-xhprof.spec10
-rw-r--r--xhprof-php81.patch33
4 files changed, 7 insertions, 40 deletions
diff --git a/PHPINFO b/PHPINFO
index bf7e7d8..363b5fb 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,7 +2,7 @@
xhprof
xhprof support => enabled
-Version => 2.3.3
+Version => 2.3.4
Directive => Local Value => Master Value
xhprof.output_dir => no value => no value
diff --git a/REFLECTION b/REFLECTION
index 47f2ba6..24f0e9f 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #121 xhprof version 2.3.3 ] {
+Extension [ <persistent> extension #122 xhprof version 2.3.4 ] {
- INI {
Entry [ xhprof.output_dir <ALL> ]
diff --git a/php-pecl-xhprof.spec b/php-pecl-xhprof.spec
index b1ae4c6..d87764f 100644
--- a/php-pecl-xhprof.spec
+++ b/php-pecl-xhprof.spec
@@ -25,7 +25,7 @@
%global ini_name 40-%{pecl_name}.ini
Name: %{?sub_prefix}php-pecl-xhprof
-Version: 2.3.3
+Version: 2.3.4
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
Summary: PHP extension for XHProf, a Hierarchical Profiler
@@ -34,8 +34,6 @@ License: ASL 2.0
URL: https://pecl.php.net/package/%{pecl_name}
Source0: https://pecl.php.net/get/%{pecl_name}-%{version}.tgz
-Patch0: %{pecl_name}-php81.patch
-
# https://bugs.php.net/61262
ExclusiveArch: %{ix86} x86_64
@@ -119,8 +117,6 @@ sed -e 's/role="php"/role="src"/' \
-i package.xml
pushd %{pecl_name}-%{version}/extension
-%patch0 -p2 -b .pr61
-
sed -e '/XHPROF_VERSION/s/2.3.0/%{version}/' -i php_xhprof.h
# Sanity check, really often broken
extver=$(sed -n '/#define XHPROF_VERSION/{s/.* "//;s/".*$//;p}' php_xhprof.h)
@@ -285,6 +281,10 @@ fi
%changelog
+* Wed Aug 4 2021 Remi Collet <remi@remirepo.net> - 2.3.4-1
+- update to 2.3.4
+- drop patch merged upstream
+
* Mon Jul 5 2021 Remi Collet <remi@remirepo.net> - 2.3.3-1
- update to 2.3.3
- add patch for PHP 8.1 from
diff --git a/xhprof-php81.patch b/xhprof-php81.patch
deleted file mode 100644
index 9a419b5..0000000
--- a/xhprof-php81.patch
+++ /dev/null
@@ -1,33 +0,0 @@
-From 3eadeb31b8816d930de37a6fe3556451e96755b9 Mon Sep 17 00:00:00 2001
-From: Remi Collet <remi@remirepo.net>
-Date: Mon, 5 Jul 2021 07:24:44 +0200
-Subject: [PATCH] fix for 8.1.0alpha2
-
----
- extension/xhprof.c | 7 ++++++-
- 1 file changed, 6 insertions(+), 1 deletion(-)
-
-diff --git a/extension/xhprof.c b/extension/xhprof.c
-index 7bcc9652..89c577e0 100755
---- a/extension/xhprof.c
-+++ b/extension/xhprof.c
-@@ -1093,7 +1093,12 @@ ZEND_DLEXPORT zend_op_array* hp_compile_file(zend_file_handle *file_handle, int
- zend_string *function_name;
- zend_op_array *op_array;
-
-+#if PHP_VERSION_ID < 80100
- filename = hp_get_base_filename(file_handle->filename);
-+#else
-+ filename = hp_get_base_filename(ZSTR_VAL(file_handle->filename));
-+#endif
-+
- function_name = strpprintf(0, "load::%s", filename);
-
- is_profiling = begin_profiling(function_name, NULL);
-@@ -1481,4 +1486,4 @@ void hp_init_trace_callbacks()
-
- callback = hp_trace_callback_curl_exec;
- register_trace_callback("curl_exec", callback);
--}
-\ No newline at end of file
-+}