summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2013-05-20 09:19:28 +0200
committerRemi Collet <fedora@famillecollet.com>2013-05-20 09:19:28 +0200
commita290f2eac5c794bf3c3362d5d9c996e32d683e1c (patch)
tree699d026ec72ffacf7d1d20653bf260886ab4ab0a
parent0d87517fe9560ff3a5a59429790b6966ab69315f (diff)
php-pecl-xhprof: 0.9.3
-rw-r--r--php-pecl-xhprof.spec26
-rw-r--r--xhprof-php55.patch170
2 files changed, 6 insertions, 190 deletions
diff --git a/php-pecl-xhprof.spec b/php-pecl-xhprof.spec
index b7c4529..01cde76 100644
--- a/php-pecl-xhprof.spec
+++ b/php-pecl-xhprof.spec
@@ -1,25 +1,16 @@
%{!?__pecl: %{expand: %%global __pecl %{_bindir}/pecl}}
%global pecl_name xhprof
-%global gitver b8c76ac5ab
Name: php-pecl-xhprof
-Version: 0.9.2
-Release: 8%{?gitver:.git%{gitver}}%{?dist}.1
+Version: 0.9.3
+Release: 1%{?gitver:.git%{gitver}}%{?dist}.1
Summary: PHP extension for XHProf, a Hierarchical Profiler
Group: Development/Languages
License: ASL 2.0
URL: http://pecl.php.net/package/%{pecl_name}
-%if 0%{?gitver:1}
-# https://github.com/facebook/xhprof/archive/master.tar.gz
-Source0: %{pecl_name}-%{gitver}.tgz
-%else
Source0: http://pecl.php.net/get/%{pecl_name}-%{version}.tgz
-%endif
-
-# https://github.com/facebook/xhprof/pull/15
-Patch1: %{pecl_name}-php55.patch
# https://bugs.php.net/61262
ExclusiveArch: %{ix86} x86_64
@@ -92,10 +83,6 @@ Documentation : %{_datadir}/doc/%{name}-%{version}/docs/index.html
%prep
%setup -c -q
-%if 0%{?gitver:1}
-mv %{pecl_name}-master/package.xml .
-mv %{pecl_name}-master %{pecl_name}-%{version}
-%endif
# Extension configuration file
cat >%{pecl_name}.ini <<EOF
@@ -114,10 +101,7 @@ Alias /xhprof /usr/share/xhprof/xhprof_html
<Directory /usr/share/xhprof/xhprof_html>
<IfModule mod_authz_core.c>
# Apache 2.4
- <RequireAny>
- Require ip 127.0.0.1
- Require ip ::1
- </RequireAny>
+ Require local
</IfModule>
<IfModule !mod_authz_core.c>
# Apache 2.2
@@ -130,7 +114,6 @@ Alias /xhprof /usr/share/xhprof/xhprof_html
EOF
cd %{pecl_name}-%{version}
-%patch1 -p1 -b .php55
# duplicate for ZTS build
cp -r extension ext-zts
@@ -218,6 +201,9 @@ fi
%changelog
+* Mon May 20 2013 Remi Collet <remi@fedoraproject.org> - 0.9.3-1
+- update to 0.9.3
+
* Fri Jan 4 2013 Remi Collet <remi@fedoraproject.org> - 0.9.2-8.gitb8c76ac5ab
- git snapshot + php 5.5 fix
https://github.com/facebook/xhprof/pull/15
diff --git a/xhprof-php55.patch b/xhprof-php55.patch
deleted file mode 100644
index e341443..0000000
--- a/xhprof-php55.patch
+++ /dev/null
@@ -1,170 +0,0 @@
-diff --git a/extension/xhprof.c b/extension/xhprof.c
-index f7e2360..a053ede 100644
---- a/extension/xhprof.c
-+++ b/extension/xhprof.c
-@@ -28,7 +28,7 @@
- #include "php_ini.h"
- #include "ext/standard/info.h"
- #include "php_xhprof.h"
--#include "Zend/zend_extensions.h"
-+#include "zend_extensions.h"
- #include <sys/time.h>
- #include <sys/resource.h>
- #include <stdlib.h>
-@@ -233,12 +233,21 @@ typedef struct hp_global_t {
- /* XHProf global state */
- static hp_global_t hp_globals;
-
-+#if PHP_VERSION_ID < 50500
- /* Pointer to the original execute function */
- static ZEND_DLEXPORT void (*_zend_execute) (zend_op_array *ops TSRMLS_DC);
-
- /* Pointer to the origianl execute_internal function */
- static ZEND_DLEXPORT void (*_zend_execute_internal) (zend_execute_data *data,
- int ret TSRMLS_DC);
-+#else
-+/* Pointer to the original execute function */
-+static void (*_zend_execute_ex) (zend_execute_data *execute_data TSRMLS_DC);
-+
-+/* Pointer to the origianl execute_internal function */
-+static void (*_zend_execute_internal) (zend_execute_data *data,
-+ struct _zend_fcall_info *fci, int ret TSRMLS_DC);
-+#endif
-
- /* Pointer to the original compile function */
- static zend_op_array * (*_zend_compile_file) (zend_file_handle *file_handle,
-@@ -880,8 +889,8 @@ size_t hp_get_function_stack(hp_entry_t *entry,
- * a pointer to one-level directory and basefile name
- * (d/foo.php) in the same string.
- */
--static char *hp_get_base_filename(char *filename) {
-- char *ptr;
-+static const char *hp_get_base_filename(const char *filename) {
-+ const char *ptr;
- int found = 0;
-
- if (!filename)
-@@ -909,7 +918,7 @@ static char *hp_get_base_filename(char *filename) {
- */
- static char *hp_get_function_name(zend_op_array *ops TSRMLS_DC) {
- zend_execute_data *data;
-- char *func = NULL;
-+ const char *func = NULL;
- const char *cls = NULL;
- char *ret = NULL;
- int len;
-@@ -988,7 +997,7 @@ static char *hp_get_function_name(zend_op_array *ops TSRMLS_DC) {
- * you'll see something like "run_init::foo.php" in your reports.
- */
- if (add_filename){
-- char *filename;
-+ const char *filename;
- int len;
- filename = hp_get_base_filename((curr_func->op_array).filename);
- len = strlen("run_init") + strlen(filename) + 3;
-@@ -1629,18 +1638,31 @@ void hp_mode_sampled_endfn_cb(hp_entry_t **entries TSRMLS_DC) {
- *
- * @author hzhao, kannan
- */
-+#if PHP_VERSION_ID < 50500
- ZEND_DLEXPORT void hp_execute (zend_op_array *ops TSRMLS_DC) {
-+#else
-+ZEND_DLEXPORT void hp_execute_ex (zend_execute_data *execute_data TSRMLS_DC) {
-+ zend_op_array *ops = execute_data->op_array;
-+#endif
- char *func = NULL;
- int hp_profile_flag = 1;
-
- func = hp_get_function_name(ops TSRMLS_CC);
- if (!func) {
-+#if PHP_VERSION_ID < 50500
- _zend_execute(ops TSRMLS_CC);
-+#else
-+ _zend_execute_ex(execute_data TSRMLS_CC);
-+#endif
- return;
- }
-
- BEGIN_PROFILING(&hp_globals.entries, func, hp_profile_flag);
-+#if PHP_VERSION_ID < 50500
- _zend_execute(ops TSRMLS_CC);
-+#else
-+ _zend_execute_ex(execute_data TSRMLS_CC);
-+#endif
- if (hp_globals.entries) {
- END_PROFILING(&hp_globals.entries, hp_profile_flag);
- }
-@@ -1649,7 +1671,6 @@ ZEND_DLEXPORT void hp_execute (zend_op_array *ops TSRMLS_DC) {
-
- #undef EX
- #define EX(element) ((execute_data)->element)
--#define EX_T(offset) (*(temp_variable *)((char *) EX(Ts) + offset))
-
- /**
- * Very similar to hp_execute. Proxy for zend_execute_internal().
-@@ -1657,8 +1678,18 @@ ZEND_DLEXPORT void hp_execute (zend_op_array *ops TSRMLS_DC) {
- *
- * @author hzhao, kannan
- */
-+
-+#if PHP_VERSION_ID < 50500
-+#define EX_T(offset) (*(temp_variable *)((char *) EX(Ts) + offset))
-+
- ZEND_DLEXPORT void hp_execute_internal(zend_execute_data *execute_data,
- int ret TSRMLS_DC) {
-+#else
-+#define EX_T(offset) (*EX_TMP_VAR(execute_data, offset))
-+
-+ZEND_DLEXPORT void hp_execute_internal(zend_execute_data *execute_data,
-+ struct _zend_fcall_info *fci, int ret TSRMLS_DC) {
-+#endif
- zend_execute_data *current_data;
- char *func = NULL;
- int hp_profile_flag = 1;
-@@ -1691,7 +1722,11 @@ ZEND_DLEXPORT void hp_execute_internal(zend_execute_data *execute_data,
- #endif
- } else {
- /* call the old override */
-+#if PHP_VERSION_ID < 50500
- _zend_execute_internal(execute_data, ret TSRMLS_CC);
-+#else
-+ _zend_execute_internal(execute_data, fci, ret TSRMLS_CC);
-+#endif
- }
-
- if (func) {
-@@ -1711,7 +1746,7 @@ ZEND_DLEXPORT void hp_execute_internal(zend_execute_data *execute_data,
- ZEND_DLEXPORT zend_op_array* hp_compile_file(zend_file_handle *file_handle,
- int type TSRMLS_DC) {
-
-- char *filename;
-+ const char *filename;
- char *func;
- int len;
- zend_op_array *ret;
-@@ -1783,8 +1818,13 @@ static void hp_begin(long level, long xhprof_flags TSRMLS_DC) {
- zend_compile_string = hp_compile_string;
-
- /* Replace zend_execute with our proxy */
-+#if PHP_VERSION_ID < 50500
- _zend_execute = zend_execute;
- zend_execute = hp_execute;
-+#else
-+ _zend_execute_ex = zend_execute_ex;
-+ zend_execute_ex = hp_execute_ex;
-+#endif
-
- /* Replace zend_execute_internal with our proxy */
- _zend_execute_internal = zend_execute_internal;
-@@ -1855,7 +1895,11 @@ static void hp_stop(TSRMLS_D) {
- }
-
- /* Remove proxies, restore the originals */
-+#if PHP_VERSION_ID < 50500
- zend_execute = _zend_execute;
-+#else
-+ zend_execute_ex = _zend_execute_ex;
-+#endif
- zend_execute_internal = _zend_execute_internal;
- zend_compile_file = _zend_compile_file;
- zend_compile_string = _zend_compile_string;