summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2014-04-17 18:05:45 +0200
committerRemi Collet <fedora@famillecollet.com>2014-04-17 18:05:45 +0200
commit29b8f8f13bef68e37a5328f2bd1132b9321b50e1 (patch)
treeb75241ff38819e55d4d162901e9277f0edc0a913
parent2063485db65a61675050ea807b8c182abb9459fd (diff)
php-pecl: add numerical prefix to extension configuration file (all done !)
-rw-r--r--php-pecl-xhprof.spec20
1 files changed, 14 insertions, 6 deletions
diff --git a/php-pecl-xhprof.spec b/php-pecl-xhprof.spec
index c2fead0..6a511b6 100644
--- a/php-pecl-xhprof.spec
+++ b/php-pecl-xhprof.spec
@@ -15,10 +15,15 @@
%global pecl_name xhprof
%global with_zts 0%{?__ztsphp:1}
+%if "%{php_version}" < "5.6"
+%global ini_name %{pecl_name}.ini
+%else
+%global ini_name 40-%{pecl_name}.ini
+%endif
Name: %{?scl_prefix}php-pecl-xhprof
Version: 0.9.4
-Release: 3%{?gitver:.git%{gitver}}%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
+Release: 4%{?gitver:.git%{gitver}}%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
Summary: PHP extension for XHProf, a Hierarchical Profiler
Group: Development/Languages
@@ -109,7 +114,7 @@ Documentation: %{pecl_docdir}/%{pecl_name}/xhprof_html/docs/index.html
sed -e 's/role="php"/role="src"/' -i package.xml
# Extension configuration file
-cat >%{pecl_name}.ini <<EOF
+cat >%{ini_name} <<EOF
; Enable %{pecl_name} extension module
extension = xhprof.so
@@ -166,11 +171,11 @@ make %{?_smp_mflags}
%install
rm -rf %{buildroot}
make install -C %{pecl_name}-%{version}/extension INSTALL_ROOT=%{buildroot}
-install -D -m 644 %{pecl_name}.ini %{buildroot}%{php_inidir}/%{pecl_name}.ini
+install -D -m 644 %{ini_name} %{buildroot}%{php_inidir}/%{ini_name}
%if %{with_zts}
make install -C %{pecl_name}-%{version}/ext-zts INSTALL_ROOT=%{buildroot}
-install -D -m 644 %{pecl_name}.ini %{buildroot}%{php_ztsinidir}/%{pecl_name}.ini
+install -D -m 644 %{ini_name} %{buildroot}%{php_ztsinidir}/%{ini_name}
%endif
# Install XML package description
@@ -228,13 +233,13 @@ fi
%doc %{pecl_docdir}/%{pecl_name}
%exclude %{pecl_docdir}/%{pecl_name}/examples
%exclude %{pecl_docdir}/%{pecl_name}/xhprof_html
-%config(noreplace) %{php_inidir}/%{pecl_name}.ini
+%config(noreplace) %{php_inidir}/%{ini_name}
%{php_extdir}/%{pecl_name}.so
%{pecl_xmldir}/%{name}.xml
%if %{with_zts}
-%config(noreplace) %{php_ztsinidir}/%{pecl_name}.ini
+%config(noreplace) %{php_ztsinidir}/%{ini_name}
%{php_ztsextdir}/%{pecl_name}.so
%endif
@@ -249,6 +254,9 @@ fi
%changelog
+* Thu Apr 17 2014 Remi Collet <remi@fedoraproject.org> - 0.9.4-4
+- add numerical prefix to extension configuration file (php 5.6)
+
* Wed Mar 19 2014 Remi Collet <rcollet@redhat.com> - 0.9.4-3
- allow SCL build