summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PHPINFO2
-rw-r--r--REFLECTION38
-rw-r--r--php-pecl-xdiff.spec21
3 files changed, 41 insertions, 20 deletions
diff --git a/PHPINFO b/PHPINFO
index 82b78bd..f97f45c 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,5 +2,5 @@
xdiff
xdiff support => enabled
-extension version => 2.1.0
+extension version => 2.1.1
libxdiff version => LibXDiff v0.23 by Davide Libenzi <davide@xmailserver.org>
diff --git a/REFLECTION b/REFLECTION
index 1f5c217..38e8e13 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #120 xdiff version 2.1.0 ] {
+Extension [ <persistent> extension #120 xdiff version 2.1.1 ] {
- Constants [3] {
Constant [ int XDIFF_PATCH_NORMAL ] { 45 }
@@ -27,6 +27,13 @@ Extension [ <persistent> extension #120 xdiff version 2.1.0 ] {
}
- Return [ bool ]
}
+ Function [ <internal:xdiff> function xdiff_string_bdiff ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> string $str1 ]
+ Parameter #1 [ <required> string $str2 ]
+ }
+ }
Function [ <internal:xdiff> function xdiff_string_diff_binary ] {
- Parameters [2] {
@@ -34,6 +41,15 @@ Extension [ <persistent> extension #120 xdiff version 2.1.0 ] {
Parameter #1 [ <required> string $str2 ]
}
}
+ Function [ <internal:xdiff> function xdiff_file_bdiff ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> string $file1 ]
+ Parameter #1 [ <required> string $file2 ]
+ Parameter #2 [ <required> string $dest ]
+ }
+ - Return [ bool ]
+ }
Function [ <internal:xdiff> function xdiff_file_diff_binary ] {
- Parameters [3] {
@@ -92,9 +108,18 @@ Extension [ <persistent> extension #120 xdiff version 2.1.0 ] {
Parameter #0 [ <required> string $file ]
Parameter #1 [ <required> string $patch ]
Parameter #2 [ <optional> int $flags = XDIFF_PATCH_NORMAL ]
- Parameter #3 [ <optional> string &$error = null ]
+ Parameter #3 [ <optional> ?string &$error = null ]
}
}
+ Function [ <internal:xdiff> function xdiff_file_bpatch ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> string $file ]
+ Parameter #1 [ <required> string $patch ]
+ Parameter #2 [ <required> string $dest ]
+ }
+ - Return [ bool ]
+ }
Function [ <internal:xdiff> function xdiff_file_patch_binary ] {
- Parameters [3] {
@@ -104,6 +129,13 @@ Extension [ <persistent> extension #120 xdiff version 2.1.0 ] {
}
- Return [ bool ]
}
+ Function [ <internal:xdiff> function xdiff_string_bpatch ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> string $str ]
+ Parameter #1 [ <required> string $patch ]
+ }
+ }
Function [ <internal:xdiff> function xdiff_string_patch_binary ] {
- Parameters [2] {
@@ -126,7 +158,7 @@ Extension [ <persistent> extension #120 xdiff version 2.1.0 ] {
Parameter #0 [ <required> string $str1 ]
Parameter #1 [ <required> string $str2 ]
Parameter #2 [ <required> string $str3 ]
- Parameter #3 [ <optional> string &$error = null ]
+ Parameter #3 [ <optional> ?string &$error = null ]
}
}
}
diff --git a/php-pecl-xdiff.spec b/php-pecl-xdiff.spec
index 253a881..55d44c2 100644
--- a/php-pecl-xdiff.spec
+++ b/php-pecl-xdiff.spec
@@ -1,6 +1,6 @@
# remirepo spec file for php-pecl-xdiff
#
-# Copyright (c) 2016-2021 Remi Collet
+# Copyright (c) 2016-2022 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
@@ -20,7 +20,7 @@
%global libxdiff_version 0.23
Name: %{?scl_prefix}php-pecl-%{pecl_name}
-Version: 2.1.0
+Version: 2.1.1
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
Summary: File differences/patches
# libxdiff is LGPLv2+, xdiff extension is PHP
@@ -46,20 +46,6 @@ Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
-%if "%{?packager}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
-# Other third party repo stuff
-%if "%{php_version}" > "7.3"
-Obsoletes: php73-pecl-%{pecl_name} <= %{version}
-%endif
-%if "%{php_version}" > "7.4"
-Obsoletes: php74-pecl-%{pecl_name} <= %{version}
-%endif
-%if "%{php_version}" > "8.0"
-Obsoletes: php80-pecl-%{pecl_name} <= %{version}
-%endif
-%endif
-
-
%description
This extension creates and applies patches to both text and binary files.
@@ -211,6 +197,9 @@ REPORT_EXIT_STATUS=1 \
%changelog
+* Tue May 24 2022 Remi Collet <remi@remirepo.net> - 2.1.1-1
+- update to 2.1.1
+
* Tue May 18 2021 Remi Collet <remi@remirepo.net> - 2.1.0-1
- update to 2.1.0