summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-10-12 11:46:08 +0200
committerRemi Collet <fedora@famillecollet.com>2016-10-12 11:46:08 +0200
commit84f13bbeb4edfb35d6ba45528e6d1329c0d357e5 (patch)
treebfcb1b0341dea88fa4a303518eabecb5d8284c3f
php-pecl-xdiff: 1.5.2 (php 5, beta) and 2.0.1 (php 7, stable) - New packages
-rw-r--r--LICENSE68
-rw-r--r--Makefile4
-rw-r--r--REFLECTION62
-rw-r--r--REFLECTION-PHP762
-rw-r--r--config.m443
-rw-r--r--php-pecl-xdiff-php7.spec222
-rw-r--r--php-pecl-xdiff.spec226
7 files changed, 687 insertions, 0 deletions
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 0000000..74c73f9
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,68 @@
+--------------------------------------------------------------------
+ The PHP License, version 3.01
+Copyright (c) 1999 - 2015 The PHP Group. All rights reserved.
+--------------------------------------------------------------------
+
+Redistribution and use in source and binary forms, with or without
+modification, is permitted provided that the following conditions
+are met:
+
+ 1. Redistributions of source code must retain the above copyright
+ notice, this list of conditions and the following disclaimer.
+
+ 2. Redistributions in binary form must reproduce the above copyright
+ notice, this list of conditions and the following disclaimer in
+ the documentation and/or other materials provided with the
+ distribution.
+
+ 3. The name "PHP" must not be used to endorse or promote products
+ derived from this software without prior written permission. For
+ written permission, please contact group@php.net.
+
+ 4. Products derived from this software may not be called "PHP", nor
+ may "PHP" appear in their name, without prior written permission
+ from group@php.net. You may indicate that your software works in
+ conjunction with PHP by saying "Foo for PHP" instead of calling
+ it "PHP Foo" or "phpfoo"
+
+ 5. The PHP Group may publish revised and/or new versions of the
+ license from time to time. Each version will be given a
+ distinguishing version number.
+ Once covered code has been published under a particular version
+ of the license, you may always continue to use it under the terms
+ of that version. You may also choose to use such covered code
+ under the terms of any subsequent version of the license
+ published by the PHP Group. No one other than the PHP Group has
+ the right to modify the terms applicable to covered code created
+ under this License.
+
+ 6. Redistributions of any form whatsoever must retain the following
+ acknowledgment:
+ "This product includes PHP software, freely available from
+ <http://www.php.net/software/>".
+
+THIS SOFTWARE IS PROVIDED BY THE PHP DEVELOPMENT TEAM ``AS IS'' AND
+ANY EXPRESSED OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO,
+THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A
+PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE PHP
+DEVELOPMENT TEAM OR ITS CONTRIBUTORS BE LIABLE FOR ANY DIRECT,
+INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES
+(INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR
+SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
+HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT,
+STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE)
+ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED
+OF THE POSSIBILITY OF SUCH DAMAGE.
+
+--------------------------------------------------------------------
+
+This software consists of voluntary contributions made by many
+individuals on behalf of the PHP Group.
+
+The PHP Group can be contacted via Email at group@php.net.
+
+For more information on the PHP Group and the PHP project,
+please see <http://www.php.net>.
+
+PHP includes the Zend Engine, freely available at
+<http://www.zend.com>.
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..13af741
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,4 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../../common/Makefile
+
diff --git a/REFLECTION b/REFLECTION
new file mode 100644
index 0000000..7994a54
--- /dev/null
+++ b/REFLECTION
@@ -0,0 +1,62 @@
+Extension [ <persistent> extension #70 xdiff version 1.5.2-beta ] {
+
+ - Constants [3] {
+ Constant [ integer XDIFF_PATCH_NORMAL ] { 45 }
+ Constant [ integer XDIFF_PATCH_REVERSE ] { 43 }
+ Constant [ integer XDIFF_PATCH_IGNORESPACE ] { 256 }
+ }
+
+ - Functions {
+ Function [ <internal:xdiff> function xdiff_file_diff ] {
+ }
+ Function [ <internal:xdiff> function xdiff_file_bdiff ] {
+ }
+ Function [ <internal:xdiff> function xdiff_file_patch ] {
+ }
+ Function [ <internal:xdiff> function xdiff_file_bpatch ] {
+ }
+ Function [ <internal:xdiff> function xdiff_file_merge3 ] {
+ }
+ Function [ <internal:xdiff> function xdiff_file_rabdiff ] {
+ }
+ Function [ <internal:xdiff> function xdiff_file_bdiff_size ] {
+ }
+ Function [ <internal:xdiff> function xdiff_string_diff ] {
+ }
+ Function [ <internal:xdiff> function xdiff_string_bdiff ] {
+ }
+ Function [ <internal:xdiff> function xdiff_string_patch ] {
+
+ - Parameters [4] {
+ Parameter #0 [ <required> $param0 ]
+ Parameter #1 [ <required> $param1 ]
+ Parameter #2 [ <required> $param2 ]
+ Parameter #3 [ <required> &$param3 ]
+ }
+ }
+ Function [ <internal:xdiff> function xdiff_string_bpatch ] {
+ }
+ Function [ <internal:xdiff> function xdiff_string_merge3 ] {
+
+ - Parameters [4] {
+ Parameter #0 [ <required> $param0 ]
+ Parameter #1 [ <required> $param1 ]
+ Parameter #2 [ <required> $param2 ]
+ Parameter #3 [ <required> &$param3 ]
+ }
+ }
+ Function [ <internal:xdiff> function xdiff_string_rabdiff ] {
+ }
+ Function [ <internal:xdiff> function xdiff_string_bdiff_size ] {
+ }
+ Function [ <internal:xdiff> function xdiff_file_diff_binary ] {
+ }
+ Function [ <internal:xdiff> function xdiff_file_patch_binary ] {
+ }
+ Function [ <internal:xdiff> function xdiff_string_diff_binary ] {
+ }
+ Function [ <internal:xdiff> function xdiff_string_patch_binary ] {
+ }
+ }
+}
+
diff --git a/REFLECTION-PHP7 b/REFLECTION-PHP7
new file mode 100644
index 0000000..c015236
--- /dev/null
+++ b/REFLECTION-PHP7
@@ -0,0 +1,62 @@
+Extension [ <persistent> extension #133 xdiff version 2.0.1 ] {
+
+ - Constants [3] {
+ Constant [ integer XDIFF_PATCH_NORMAL ] { 45 }
+ Constant [ integer XDIFF_PATCH_REVERSE ] { 43 }
+ Constant [ integer XDIFF_PATCH_IGNORESPACE ] { 256 }
+ }
+
+ - Functions {
+ Function [ <internal:xdiff> function xdiff_file_diff ] {
+ }
+ Function [ <internal:xdiff> function xdiff_file_bdiff ] {
+ }
+ Function [ <internal:xdiff> function xdiff_file_patch ] {
+ }
+ Function [ <internal:xdiff> function xdiff_file_bpatch ] {
+ }
+ Function [ <internal:xdiff> function xdiff_file_merge3 ] {
+ }
+ Function [ <internal:xdiff> function xdiff_file_rabdiff ] {
+ }
+ Function [ <internal:xdiff> function xdiff_file_bdiff_size ] {
+ }
+ Function [ <internal:xdiff> function xdiff_string_diff ] {
+ }
+ Function [ <internal:xdiff> function xdiff_string_bdiff ] {
+ }
+ Function [ <internal:xdiff> function xdiff_string_patch ] {
+
+ - Parameters [4] {
+ Parameter #0 [ <required> $param0 ]
+ Parameter #1 [ <required> $param1 ]
+ Parameter #2 [ <required> $param2 ]
+ Parameter #3 [ <required> &$param3 ]
+ }
+ }
+ Function [ <internal:xdiff> function xdiff_string_bpatch ] {
+ }
+ Function [ <internal:xdiff> function xdiff_string_merge3 ] {
+
+ - Parameters [4] {
+ Parameter #0 [ <required> $param0 ]
+ Parameter #1 [ <required> $param1 ]
+ Parameter #2 [ <required> $param2 ]
+ Parameter #3 [ <required> &$param3 ]
+ }
+ }
+ Function [ <internal:xdiff> function xdiff_string_rabdiff ] {
+ }
+ Function [ <internal:xdiff> function xdiff_string_bdiff_size ] {
+ }
+ Function [ <internal:xdiff> function xdiff_file_diff_binary ] {
+ }
+ Function [ <internal:xdiff> function xdiff_file_patch_binary ] {
+ }
+ Function [ <internal:xdiff> function xdiff_string_diff_binary ] {
+ }
+ Function [ <internal:xdiff> function xdiff_string_patch_binary ] {
+ }
+ }
+}
+
diff --git a/config.m4 b/config.m4
new file mode 100644
index 0000000..5908718
--- /dev/null
+++ b/config.m4
@@ -0,0 +1,43 @@
+dnl config.m4 for extension xdiff
+dnl adapted to use bundled copy of the library
+
+PHP_ARG_WITH(xdiff, for xdiff support,
+[ --with-xdiff Include xdiff support])
+
+
+if test "$PHP_XDIFF" != "no"; then
+
+ dnl Checks for header files.
+ AC_STDC_HEADERS
+ AC_CHECK_HEADERS(stdio.h limits.h)
+
+ dnl Checks for typedefs, structures, and compiler characteristics.
+ AC_C_INLINE
+ AC_C_VOLATILE
+ AC_C_CONST
+ AC_C_BIGENDIAN
+
+ dnl Checks for library functions.
+ AC_CHECK_FUNCS(memset memcmp memchr memcpy strlen malloc free realloc)
+
+ LIBSRC="\
+ libxdiff/xadler32.c \
+ libxdiff/xalloc.c \
+ libxdiff/xbdiff.c \
+ libxdiff/xbpatchi.c \
+ libxdiff/xdiffi.c \
+ libxdiff/xemit.c \
+ libxdiff/xmerge3.c \
+ libxdiff/xmissing.c \
+ libxdiff/xpatchi.c \
+ libxdiff/xprepare.c \
+ libxdiff/xrabdiff.c \
+ libxdiff/xrabply.c \
+ libxdiff/xutils.c \
+ libxdiff/xversion.c \
+ "
+
+ PHP_NEW_EXTENSION(xdiff, xdiff.c $LIBSRC, $ext_shared)
+ PHP_ADD_BUILD_DIR($ext_builddir/libxdiff, 1)
+ PHP_ADD_INCLUDE([$ext_srcdir/libxdiff])
+fi
diff --git a/php-pecl-xdiff-php7.spec b/php-pecl-xdiff-php7.spec
new file mode 100644
index 0000000..1579477
--- /dev/null
+++ b/php-pecl-xdiff-php7.spec
@@ -0,0 +1,222 @@
+# remirepo spec file for php-pecl-xdiff
+#
+# Copyright (c) 2016 Remi Collet
+# License: CC-BY-SA
+# http://creativecommons.org/licenses/by-sa/4.0/
+#
+# Please, preserve the changelog entries
+#
+%if 0%{?scl:1}
+%if "%{scl}" == "rh-php56"
+%global sub_prefix more-php56-
+%else
+%global sub_prefix %{scl_prefix}
+%endif
+%scl_package php-pecl-xdiff
+%endif
+
+%global pecl_name xdiff
+%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
+%global ini_name 40-%{pecl_name}.ini
+
+Name: %{?sub_prefix}php-pecl-%{pecl_name}
+Version: 2.0.1
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Summary: File differences/patches
+Group: Development/Languages
+# libxdiff is LGPLv2+, xdiff extension is PHP
+License: PHP and LGPLv2+
+URL: http://pecl.php.net/package/%{pecl_name}
+Source0: http://pecl.php.net/get/%{pecl_name}-%{version}.tgz
+# bundles the lib, as libxdiff from spot is not compatible
+Source1: http://www.xmailserver.org/libxdiff-0.23.tar.gz
+Source2: config.m4
+
+BuildRequires: %{?scl_prefix}php-devel >= 7
+BuildRequires: %{?scl_prefix}php-pear
+
+Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
+Requires: %{?scl_prefix}php(api) = %{php_core_api}
+%{?_sclreq:Requires: %{?scl_prefix}runtime%{?_sclreq}%{?_isa}}
+
+Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
+Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
+Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
+Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
+%if "%{?scl_prefix}" != "%{?sub_prefix}"
+Provides: %{?scl_prefix}php-pecl-%{pecl_name} = %{version}-%{release}
+Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}-%{release}
+%endif
+
+%if "%{?vendor}" == "Remi Collet" && 0%{!?scl:1}
+# Other third party repo stuff
+Obsoletes: php53-pecl-%{pecl_name} <= %{version}
+Obsoletes: php53u-pecl-%{pecl_name} <= %{version}
+Obsoletes: php54-pecl-%{pecl_name} <= %{version}
+Obsoletes: php54w-pecl-%{pecl_name} <= %{version}
+Obsoletes: php55u-pecl-%{pecl_name} <= %{version}
+Obsoletes: php55w-pecl-%{pecl_name} <= %{version}
+Obsoletes: php56u-pecl-%{pecl_name} <= %{version}
+Obsoletes: php56w-pecl-%{pecl_name} <= %{version}
+Obsoletes: php70u-pecl-%{pecl_name} <= %{version}
+Obsoletes: php70w-pecl-%{pecl_name} <= %{version}
+%if "%{php_version}" > "7.1"
+Obsoletes: php71u-pecl-%{pecl_name} <= %{version}
+Obsoletes: php71w-pecl-%{pecl_name} <= %{version}
+%endif
+%endif
+
+%if 0%{?fedora} < 20 && 0%{?rhel} < 7
+# Filter shared private
+%{?filter_provides_in: %filter_provides_in %{_libdir}/.*\.so$}
+%{?filter_setup}
+%endif
+
+
+%description
+This extension creates and applies patches to both text and binary files.
+
+Documentation: http://php.net/xdiff
+
+Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')%{?scl: as Software Collection (%{scl} by %{?scl_vendor}%{!?scl_vendor:rh})}.
+
+
+%prep
+%setup -q -c -a1
+mv %{pecl_name}-%{version} NTS
+
+# Bundles libxdiff
+mv libxdiff-0.23/xdiff NTS/libxdiff
+cp -p %{SOURCE2} NTS/config.m4
+cp -p libxdiff-0.23/COPYING libxdiff_COPYING
+
+# Don't install/register tests
+sed -e 's/role="test"/role="src"/' \
+ %{?_licensedir:-e '/LICENSE/s/role="doc"/role="src"/' } \
+ -i package.xml
+
+# Sanity check, really often broken
+extver=$(sed -n '/#define PHP_XDIFF_VERSION/{s/.* "//;s/".*$//;p}' NTS/php_xdiff.h)
+if test "x${extver}" != "x%{version}"; then
+ : Error: Upstream extension version is ${extver}, expecting %{version}.
+ exit 1
+fi
+
+cat >%{ini_name} << 'EOF'
+; Enable %{pecl_name} extension module
+extension=%{pecl_name}.so
+EOF
+
+%if %{with_zts}
+# duplicate for ZTS build
+cp -pr NTS ZTS
+%endif
+
+
+%build
+cd NTS
+%{_bindir}/phpize
+%configure --with-php-config=%{_bindir}/php-config
+make %{?_smp_mflags}
+
+%if %{with_zts}
+cd ../ZTS
+%{_bindir}/zts-phpize
+%configure --with-php-config=%{_bindir}/zts-php-config
+make %{?_smp_mflags}
+%endif
+
+
+%install
+make install -C NTS INSTALL_ROOT=%{buildroot}
+
+# Drop in the bit of configuration
+install -D -m 644 %{ini_name} %{buildroot}%{php_inidir}/%{ini_name}
+
+# Install XML package description
+install -D -m 644 package.xml %{buildroot}%{pecl_xmldir}/%{name}.xml
+
+%if %{with_zts}
+make install -C ZTS INSTALL_ROOT=%{buildroot}
+install -D -m 644 %{ini_name} %{buildroot}%{php_ztsinidir}/%{ini_name}
+%endif
+
+# Documentation
+i=libxdiff_COPYING
+%{!?_licensedir:install -Dpm 644 $i %{buildroot}%{pecl_docdir}/%{pecl_name}/$i}
+cd NTS
+for i in $(grep 'role="doc"' ../package.xml | sed -e 's/^.*name="//;s/".*$//')
+do install -Dpm 644 $i %{buildroot}%{pecl_docdir}/%{pecl_name}/$i
+done
+
+
+%if 0%{?fedora} < 24
+# when pear installed alone, after us
+%triggerin -- %{?scl_prefix}php-pear
+if [ -x %{__pecl} ] ; then
+ %{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || :
+fi
+
+# posttrans as pear can be installed after us
+%posttrans
+if [ -x %{__pecl} ] ; then
+ %{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || :
+fi
+
+%postun
+if [ $1 -eq 0 -a -x %{__pecl} ] ; then
+ %{pecl_uninstall} %{pecl_name} >/dev/null || :
+fi
+%endif
+
+
+%check
+: Minimal load test for NTS extension
+%{__php} -n \
+ -d extension=%{buildroot}%{php_extdir}/%{pecl_name}.so \
+ --modules | grep %{pecl_name}
+
+: Upstream test suite for NTS extension
+cd NTS
+TEST_PHP_EXECUTABLE=%{_bindir}/php \
+TEST_PHP_ARGS="-n -d extension=%{buildroot}%{php_extdir}/%{pecl_name}.so" \
+NO_INTERACTION=1 \
+REPORT_EXIT_STATUS=1 \
+%{__php} -n run-tests.php
+
+%if %{with_zts}
+: Minimal load test for ZTS extension
+%{__ztsphp} -n \
+ -d extension=%{buildroot}%{php_ztsextdir}/%{pecl_name}.so \
+ --modules | grep %{pecl_name}
+
+: Upstream test suite for ZTS extension
+cd ../NTS
+TEST_PHP_EXECUTABLE=%{_bindir}/php \
+TEST_PHP_ARGS="-n -d extension=%{buildroot}%{php_ztsextdir}/%{pecl_name}.so" \
+NO_INTERACTION=1 \
+REPORT_EXIT_STATUS=1 \
+%{__ztsphp} -n run-tests.php
+
+%endif
+
+
+%files
+%{?_licensedir:%license NTS/LICENSE}
+%{?_licensedir:%license libxdiff_COPYING}
+%doc %{pecl_docdir}/%{pecl_name}
+%{pecl_xmldir}/%{name}.xml
+
+%config(noreplace) %{php_inidir}/%{ini_name}
+%{php_extdir}/%{pecl_name}.so
+
+%if %{with_zts}
+%config(noreplace) %{php_ztsinidir}/%{ini_name}
+%{php_ztsextdir}/%{pecl_name}.so
+%endif
+
+
+%changelog
+* Wed Oct 12 2016 Remi Collet <remi@fedoraproject.org> - 2.0.1-1
+- initial package, version 2.0.2 with bundled libxdiff 0.23
+
diff --git a/php-pecl-xdiff.spec b/php-pecl-xdiff.spec
new file mode 100644
index 0000000..41d2a16
--- /dev/null
+++ b/php-pecl-xdiff.spec
@@ -0,0 +1,226 @@
+# remirepo spec file for php-pecl-xdiff
+#
+# Copyright (c) 2016 Remi Collet
+# License: CC-BY-SA
+# http://creativecommons.org/licenses/by-sa/4.0/
+#
+# Please, preserve the changelog entries
+#
+%if 0%{?scl:1}
+%global sub_prefix %{scl_prefix}
+%scl_package php-pecl-xdiff
+%endif
+
+%global pecl_name xdiff
+%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
+%global ini_name 40-%{pecl_name}.ini
+
+Name: %{?sub_prefix}php-pecl-%{pecl_name}
+Version: 1.5.2
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Summary: File differences/patches
+Group: Development/Languages
+# libxdiff is LGPLv2+, xdiff extension is PHP
+License: PHP and LGPLv2+
+URL: http://pecl.php.net/package/%{pecl_name}
+Source0: http://pecl.php.net/get/%{pecl_name}-%{version}.tgz
+# bundles the lib, as libxdiff from spot is not compatible
+Source1: http://www.xmailserver.org/libxdiff-0.23.tar.gz
+Source2: config.m4
+# http://git.php.net/?p=pecl/text/xdiff.git;a=blob_plain;f=LICENSE;hb=HEAD
+Source3: LICENSE
+
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
+BuildRequires: %{?scl_prefix}php-devel
+BuildRequires: %{?scl_prefix}php-pear
+
+Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
+Requires: %{?scl_prefix}php(api) = %{php_core_api}
+%{?_sclreq:Requires: %{?scl_prefix}runtime%{?_sclreq}%{?_isa}}
+
+Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
+Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
+Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
+Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
+%if "%{?scl_prefix}" != "%{?sub_prefix}"
+Provides: %{?scl_prefix}php-pecl-%{pecl_name} = %{version}-%{release}
+Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}-%{release}
+%endif
+
+%if "%{?vendor}" == "Remi Collet" && 0%{!?scl:1}
+# Other third party repo stuff
+Obsoletes: php53-pecl-%{pecl_name} <= %{version}
+Obsoletes: php53u-pecl-%{pecl_name} <= %{version}
+Obsoletes: php54-pecl-%{pecl_name} <= %{version}
+Obsoletes: php54w-pecl-%{pecl_name} <= %{version}
+%if "%{php_version}" > "5.5"
+Obsoletes: php55u-pecl-%{pecl_name} <= %{version}
+Obsoletes: php55w-pecl-%{pecl_name} <= %{version}
+%endif
+%if "%{php_version}" > "5.6"
+Obsoletes: php56u-pecl-%{pecl_name} <= %{version}
+Obsoletes: php56w-pecl-%{pecl_name} <= %{version}
+%endif
+%endif
+
+%if 0%{?fedora} < 20 && 0%{?rhel} < 7
+# Filter shared private
+%{?filter_provides_in: %filter_provides_in %{_libdir}/.*\.so$}
+%{?filter_setup}
+%endif
+
+
+%description
+This extension creates and applies patches to both text and binary files.
+
+Documentation: http://php.net/xdiff
+
+Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')%{?scl: as Software Collection (%{scl} by %{?scl_vendor}%{!?scl_vendor:rh})}.
+
+
+%prep
+%setup -q -c -a1
+mv %{pecl_name}-%{version} NTS
+
+# Missing in old version
+cp -p %{SOURCE3} NTS/LICENSE
+
+# Bundles libxdiff
+mv libxdiff-0.23/xdiff NTS/libxdiff
+cp -p %{SOURCE2} NTS/config.m4
+cp -p libxdiff-0.23/COPYING NTS/libxdiff_COPYING
+
+# Don't install/register tests
+sed -e 's/role="test"/role="src"/' \
+ %{?_licensedir:-e '/LICENSE/s/role="doc"/role="src"/' } \
+ -i package.xml
+
+# Sanity check, really often broken
+extver=$(sed -n '/#define PHP_XDIFF_VERSION/{s/.* "//;s/".*$//;p}' NTS/php_xdiff.h)
+if test "x${extver}" != "x%{version}-beta"; then
+ : Error: Upstream extension version is ${extver}, expecting %{version}-beta.
+ exit 1
+fi
+
+cat >%{ini_name} << 'EOF'
+; Enable %{pecl_name} extension module
+extension=%{pecl_name}.so
+EOF
+
+%if %{with_zts}
+# duplicate for ZTS build
+cp -pr NTS ZTS
+%endif
+
+
+%build
+cd NTS
+%{_bindir}/phpize
+%configure --with-php-config=%{_bindir}/php-config
+make %{?_smp_mflags}
+
+%if %{with_zts}
+cd ../ZTS
+%{_bindir}/zts-phpize
+%configure --with-php-config=%{_bindir}/zts-php-config
+make %{?_smp_mflags}
+%endif
+
+
+%install
+rm -rf %{buildroot}
+
+make install -C NTS INSTALL_ROOT=%{buildroot}
+
+# Drop in the bit of configuration
+install -D -m 644 %{ini_name} %{buildroot}%{php_inidir}/%{ini_name}
+
+# Install XML package description
+install -D -m 644 package.xml %{buildroot}%{pecl_xmldir}/%{name}.xml
+
+%if %{with_zts}
+make install -C ZTS INSTALL_ROOT=%{buildroot}
+install -D -m 644 %{ini_name} %{buildroot}%{php_ztsinidir}/%{ini_name}
+%endif
+
+# Documentation
+cd NTS
+for i in %{!?_licensedir:libxdiff_COPYING LICENSE} $(grep 'role="doc"' ../package.xml | sed -e 's/^.*name="//;s/".*$//')
+do install -Dpm 644 $i %{buildroot}%{pecl_docdir}/%{pecl_name}/$i
+done
+
+
+%if 0%{?fedora} < 24
+# when pear installed alone, after us
+%triggerin -- %{?scl_prefix}php-pear
+if [ -x %{__pecl} ] ; then
+ %{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || :
+fi
+
+# posttrans as pear can be installed after us
+%posttrans
+if [ -x %{__pecl} ] ; then
+ %{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || :
+fi
+
+%postun
+if [ $1 -eq 0 -a -x %{__pecl} ] ; then
+ %{pecl_uninstall} %{pecl_name} >/dev/null || :
+fi
+%endif
+
+
+%check
+: Minimal load test for NTS extension
+%{__php} -n \
+ -d extension=%{buildroot}%{php_extdir}/%{pecl_name}.so \
+ --modules | grep %{pecl_name}
+
+: Upstream test suite for NTS extension
+cd NTS
+TEST_PHP_EXECUTABLE=%{_bindir}/php \
+TEST_PHP_ARGS="-n -d extension=%{buildroot}%{php_extdir}/%{pecl_name}.so" \
+NO_INTERACTION=1 \
+REPORT_EXIT_STATUS=1 \
+%{__php} -n run-tests.php
+
+%if %{with_zts}
+: Minimal load test for ZTS extension
+%{__ztsphp} -n \
+ -d extension=%{buildroot}%{php_ztsextdir}/%{pecl_name}.so \
+ --modules | grep %{pecl_name}
+
+: Upstream test suite for ZTS extension
+cd ../NTS
+TEST_PHP_EXECUTABLE=%{_bindir}/php \
+TEST_PHP_ARGS="-n -d extension=%{buildroot}%{php_ztsextdir}/%{pecl_name}.so" \
+NO_INTERACTION=1 \
+REPORT_EXIT_STATUS=1 \
+%{__ztsphp} -n run-tests.php
+
+%endif
+
+
+%clean
+rm -rf %{buildroot}
+
+
+%files
+%defattr(-,root,root,-)
+%{?_licensedir:%license NTS/LICENSE NTS/libxdiff_COPYING}
+%doc %{pecl_docdir}/%{pecl_name}
+%{pecl_xmldir}/%{name}.xml
+
+%config(noreplace) %{php_inidir}/%{ini_name}
+%{php_extdir}/%{pecl_name}.so
+
+%if %{with_zts}
+%config(noreplace) %{php_ztsinidir}/%{ini_name}
+%{php_ztsextdir}/%{pecl_name}.so
+%endif
+
+
+%changelog
+* Wed Oct 12 2016 Remi Collet <remi@fedoraproject.org> - 1.5.2-1
+- initial package, version 1.5.2 (beta) with bundled libxdiff 0.23
+