summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2018-02-17 10:46:19 +0100
committerRemi Collet <remi@remirepo.net>2018-02-17 10:46:19 +0100
commit051e942477ad3c6525e48d23c013bfa51ba1a6e9 (patch)
treeff4acd2007bf4ded07efb9727ecdc57d8e948376
parent36fec1091c370e0719775724e7df1d70dd396688 (diff)
cleanupphp5
-rw-r--r--.gitignore9
-rw-r--r--REFLECTION-PHP762
-rw-r--r--php-pecl-xdiff-php7.spec228
-rw-r--r--php-pecl-xdiff.spec14
4 files changed, 11 insertions, 302 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 0000000..6f69818
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,9 @@
+clog
+package-*.xml
+*.tgz
+*.tar.gz
+*.tar.bz2
+*.tar.xz
+*.tar.xz.asc
+*.src.rpm
+*/*rpm
diff --git a/REFLECTION-PHP7 b/REFLECTION-PHP7
deleted file mode 100644
index c015236..0000000
--- a/REFLECTION-PHP7
+++ /dev/null
@@ -1,62 +0,0 @@
-Extension [ <persistent> extension #133 xdiff version 2.0.1 ] {
-
- - Constants [3] {
- Constant [ integer XDIFF_PATCH_NORMAL ] { 45 }
- Constant [ integer XDIFF_PATCH_REVERSE ] { 43 }
- Constant [ integer XDIFF_PATCH_IGNORESPACE ] { 256 }
- }
-
- - Functions {
- Function [ <internal:xdiff> function xdiff_file_diff ] {
- }
- Function [ <internal:xdiff> function xdiff_file_bdiff ] {
- }
- Function [ <internal:xdiff> function xdiff_file_patch ] {
- }
- Function [ <internal:xdiff> function xdiff_file_bpatch ] {
- }
- Function [ <internal:xdiff> function xdiff_file_merge3 ] {
- }
- Function [ <internal:xdiff> function xdiff_file_rabdiff ] {
- }
- Function [ <internal:xdiff> function xdiff_file_bdiff_size ] {
- }
- Function [ <internal:xdiff> function xdiff_string_diff ] {
- }
- Function [ <internal:xdiff> function xdiff_string_bdiff ] {
- }
- Function [ <internal:xdiff> function xdiff_string_patch ] {
-
- - Parameters [4] {
- Parameter #0 [ <required> $param0 ]
- Parameter #1 [ <required> $param1 ]
- Parameter #2 [ <required> $param2 ]
- Parameter #3 [ <required> &$param3 ]
- }
- }
- Function [ <internal:xdiff> function xdiff_string_bpatch ] {
- }
- Function [ <internal:xdiff> function xdiff_string_merge3 ] {
-
- - Parameters [4] {
- Parameter #0 [ <required> $param0 ]
- Parameter #1 [ <required> $param1 ]
- Parameter #2 [ <required> $param2 ]
- Parameter #3 [ <required> &$param3 ]
- }
- }
- Function [ <internal:xdiff> function xdiff_string_rabdiff ] {
- }
- Function [ <internal:xdiff> function xdiff_string_bdiff_size ] {
- }
- Function [ <internal:xdiff> function xdiff_file_diff_binary ] {
- }
- Function [ <internal:xdiff> function xdiff_file_patch_binary ] {
- }
- Function [ <internal:xdiff> function xdiff_string_diff_binary ] {
- }
- Function [ <internal:xdiff> function xdiff_string_patch_binary ] {
- }
- }
-}
-
diff --git a/php-pecl-xdiff-php7.spec b/php-pecl-xdiff-php7.spec
deleted file mode 100644
index ff2ca26..0000000
--- a/php-pecl-xdiff-php7.spec
+++ /dev/null
@@ -1,228 +0,0 @@
-# remirepo spec file for php-pecl-xdiff
-#
-# Copyright (c) 2016-2017 Remi Collet
-# License: CC-BY-SA
-# http://creativecommons.org/licenses/by-sa/4.0/
-#
-# Please, preserve the changelog entries
-#
-%if 0%{?scl:1}
-%global sub_prefix %{scl_prefix}
-%scl_package php-pecl-xdiff
-%endif
-
-%global pecl_name xdiff
-%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
-%global ini_name 40-%{pecl_name}.ini
-
-Name: %{?sub_prefix}php-pecl-%{pecl_name}
-Version: 2.0.1
-Release: 3%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
-Summary: File differences/patches
-Group: Development/Languages
-# libxdiff is LGPLv2+, xdiff extension is PHP
-License: PHP and LGPLv2+
-URL: http://pecl.php.net/package/%{pecl_name}
-Source0: http://pecl.php.net/get/%{pecl_name}-%{version}.tgz
-# bundles the lib, as libxdiff from spot is not compatible
-Source1: http://www.xmailserver.org/libxdiff-0.23.tar.gz
-Source2: config.m4
-
-BuildRequires: %{?scl_prefix}php-devel >= 7
-BuildRequires: %{?scl_prefix}php-pear
-
-Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
-Requires: %{?scl_prefix}php(api) = %{php_core_api}
-%{?_sclreq:Requires: %{?scl_prefix}runtime%{?_sclreq}%{?_isa}}
-
-Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
-Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
-Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
-Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
-%if "%{?scl_prefix}" != "%{?sub_prefix}"
-Provides: %{?scl_prefix}php-pecl-%{pecl_name} = %{version}-%{release}
-Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}-%{release}
-%endif
-
-%if "%{?vendor}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
-# Other third party repo stuff
-Obsoletes: php53-pecl-%{pecl_name} <= %{version}
-Obsoletes: php53u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php54-pecl-%{pecl_name} <= %{version}
-Obsoletes: php54w-pecl-%{pecl_name} <= %{version}
-Obsoletes: php55u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php55w-pecl-%{pecl_name} <= %{version}
-Obsoletes: php56u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php56w-pecl-%{pecl_name} <= %{version}
-Obsoletes: php70u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php70w-pecl-%{pecl_name} <= %{version}
-%if "%{php_version}" > "7.1"
-Obsoletes: php71u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php71w-pecl-%{pecl_name} <= %{version}
-%endif
-%if "%{php_version}" > "7.2"
-Obsoletes: php72u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php72w-pecl-%{pecl_name} <= %{version}
-%endif
-%endif
-
-%if 0%{?fedora} < 20 && 0%{?rhel} < 7
-# Filter shared private
-%{?filter_provides_in: %filter_provides_in %{_libdir}/.*\.so$}
-%{?filter_setup}
-%endif
-
-
-%description
-This extension creates and applies patches to both text and binary files.
-
-Documentation: http://php.net/xdiff
-
-Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')%{?scl: as Software Collection (%{scl} by %{?scl_vendor}%{!?scl_vendor:rh})}.
-
-
-%prep
-%setup -q -c -a1
-mv %{pecl_name}-%{version} NTS
-
-# Bundles libxdiff
-mv libxdiff-0.23/xdiff NTS/libxdiff
-cp -p %{SOURCE2} NTS/config.m4
-cp -p libxdiff-0.23/COPYING libxdiff_COPYING
-
-# Don't install/register tests
-sed -e 's/role="test"/role="src"/' \
- %{?_licensedir:-e '/LICENSE/s/role="doc"/role="src"/' } \
- -i package.xml
-
-# Sanity check, really often broken
-extver=$(sed -n '/#define PHP_XDIFF_VERSION/{s/.* "//;s/".*$//;p}' NTS/php_xdiff.h)
-if test "x${extver}" != "x%{version}"; then
- : Error: Upstream extension version is ${extver}, expecting %{version}.
- exit 1
-fi
-
-cat >%{ini_name} << 'EOF'
-; Enable %{pecl_name} extension module
-extension=%{pecl_name}.so
-EOF
-
-%if %{with_zts}
-# duplicate for ZTS build
-cp -pr NTS ZTS
-%endif
-
-
-%build
-cd NTS
-%{_bindir}/phpize
-%configure --with-php-config=%{_bindir}/php-config
-make %{?_smp_mflags}
-
-%if %{with_zts}
-cd ../ZTS
-%{_bindir}/zts-phpize
-%configure --with-php-config=%{_bindir}/zts-php-config
-make %{?_smp_mflags}
-%endif
-
-
-%install
-make install -C NTS INSTALL_ROOT=%{buildroot}
-
-# Drop in the bit of configuration
-install -D -m 644 %{ini_name} %{buildroot}%{php_inidir}/%{ini_name}
-
-# Install XML package description
-install -D -m 644 package.xml %{buildroot}%{pecl_xmldir}/%{name}.xml
-
-%if %{with_zts}
-make install -C ZTS INSTALL_ROOT=%{buildroot}
-install -D -m 644 %{ini_name} %{buildroot}%{php_ztsinidir}/%{ini_name}
-%endif
-
-# Documentation
-i=libxdiff_COPYING
-%{!?_licensedir:install -Dpm 644 $i %{buildroot}%{pecl_docdir}/%{pecl_name}/$i}
-cd NTS
-for i in $(grep 'role="doc"' ../package.xml | sed -e 's/^.*name="//;s/".*$//')
-do install -Dpm 644 $i %{buildroot}%{pecl_docdir}/%{pecl_name}/$i
-done
-
-
-%if 0%{?fedora} < 24
-# when pear installed alone, after us
-%triggerin -- %{?scl_prefix}php-pear
-if [ -x %{__pecl} ] ; then
- %{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || :
-fi
-
-# posttrans as pear can be installed after us
-%posttrans
-if [ -x %{__pecl} ] ; then
- %{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || :
-fi
-
-%postun
-if [ $1 -eq 0 -a -x %{__pecl} ] ; then
- %{pecl_uninstall} %{pecl_name} >/dev/null || :
-fi
-%endif
-
-
-%check
-: Minimal load test for NTS extension
-%{__php} -n \
- -d extension=%{buildroot}%{php_extdir}/%{pecl_name}.so \
- --modules | grep %{pecl_name}
-
-: Upstream test suite for NTS extension
-cd NTS
-TEST_PHP_EXECUTABLE=%{_bindir}/php \
-TEST_PHP_ARGS="-n -d extension=%{buildroot}%{php_extdir}/%{pecl_name}.so" \
-NO_INTERACTION=1 \
-REPORT_EXIT_STATUS=1 \
-%{__php} -n run-tests.php
-
-%if %{with_zts}
-: Minimal load test for ZTS extension
-%{__ztsphp} -n \
- -d extension=%{buildroot}%{php_ztsextdir}/%{pecl_name}.so \
- --modules | grep %{pecl_name}
-
-: Upstream test suite for ZTS extension
-cd ../NTS
-TEST_PHP_EXECUTABLE=%{_bindir}/php \
-TEST_PHP_ARGS="-n -d extension=%{buildroot}%{php_ztsextdir}/%{pecl_name}.so" \
-NO_INTERACTION=1 \
-REPORT_EXIT_STATUS=1 \
-%{__ztsphp} -n run-tests.php
-
-%endif
-
-
-%files
-%{?_licensedir:%license NTS/LICENSE}
-%{?_licensedir:%license libxdiff_COPYING}
-%doc %{pecl_docdir}/%{pecl_name}
-%{pecl_xmldir}/%{name}.xml
-
-%config(noreplace) %{php_inidir}/%{ini_name}
-%{php_extdir}/%{pecl_name}.so
-
-%if %{with_zts}
-%config(noreplace) %{php_ztsinidir}/%{ini_name}
-%{php_ztsextdir}/%{pecl_name}.so
-%endif
-
-
-%changelog
-* Tue Jul 18 2017 Remi Collet <remi@remirepo.net> - 2.0.1-3
-- rebuild for PHP 7.2.0beta1 new API
-
-* Thu Dec 1 2016 Remi Collet <remi@fedoraproject.org> - 2.0.1-2
-- rebuild with PHP 7.1.0 GA
-
-* Wed Oct 12 2016 Remi Collet <remi@fedoraproject.org> - 2.0.1-1
-- initial package, version 2.0.2 with bundled libxdiff 0.23
-
diff --git a/php-pecl-xdiff.spec b/php-pecl-xdiff.spec
index 52d5869..cec692a 100644
--- a/php-pecl-xdiff.spec
+++ b/php-pecl-xdiff.spec
@@ -1,6 +1,6 @@
# remirepo spec file for php-pecl-xdiff
#
-# Copyright (c) 2016-2017 Remi Collet
+# Copyright (c) 2016-2018 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
@@ -19,7 +19,6 @@ Name: %{?sub_prefix}php-pecl-%{pecl_name}
Version: 1.5.2
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
Summary: File differences/patches
-Group: Development/Languages
# libxdiff is LGPLv2+, xdiff extension is PHP
License: PHP and LGPLv2+
URL: http://pecl.php.net/package/%{pecl_name}
@@ -30,7 +29,6 @@ Source2: config.m4
# http://git.php.net/?p=pecl/text/xdiff.git;a=blob_plain;f=LICENSE;hb=HEAD
Source3: LICENSE
-BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
BuildRequires: %{?scl_prefix}php-devel
BuildRequires: %{?scl_prefix}php-pear
@@ -128,8 +126,6 @@ make %{?_smp_mflags}
%install
-rm -rf %{buildroot}
-
make install -C NTS INSTALL_ROOT=%{buildroot}
# Drop in the bit of configuration
@@ -150,7 +146,7 @@ do install -Dpm 644 $i %{buildroot}%{pecl_docdir}/%{pecl_name}/$i
done
-%if 0%{?fedora} < 24
+%if 0%{?fedora} < 24 && 0%{?rhel} < 8
# when pear installed alone, after us
%triggerin -- %{?scl_prefix}php-pear
if [ -x %{__pecl} ] ; then
@@ -197,16 +193,10 @@ TEST_PHP_ARGS="-n -d extension=%{buildroot}%{php_ztsextdir}/%{pecl_name}.so" \
NO_INTERACTION=1 \
REPORT_EXIT_STATUS=1 \
%{__ztsphp} -n run-tests.php
-
%endif
-%clean
-rm -rf %{buildroot}
-
-
%files
-%defattr(-,root,root,-)
%{?_licensedir:%license NTS/LICENSE NTS/libxdiff_COPYING}
%doc %{pecl_docdir}/%{pecl_name}
%{pecl_xmldir}/%{name}.xml