summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PHPINFO2
-rw-r--r--REFLECTION2
-rw-r--r--php-pecl-xdebug3.spec14
3 files changed, 11 insertions, 7 deletions
diff --git a/PHPINFO b/PHPINFO
index 57e3699..9bf589f 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -10,7 +10,7 @@ xdebug
 __/ |
 |___/
-Version => 3.0.0-dev
+Version => 3.0.0beta1
Support Xdebug on Patreon, GitHub, or as a business: https://xdebug.org/support
Feature => Enabled/Disabled
diff --git a/REFLECTION b/REFLECTION
index a2b3f99..1aaf20d 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #15 xdebug version 3.0.0-dev ] {
+Extension [ <persistent> extension #15 xdebug version 3.0.0beta1 ] {
- INI {
Entry [ xdebug.mode <SYSTEM> ]
diff --git a/php-pecl-xdebug3.spec b/php-pecl-xdebug3.spec
index 3827c96..e223c98 100644
--- a/php-pecl-xdebug3.spec
+++ b/php-pecl-xdebug3.spec
@@ -19,13 +19,13 @@
%global pecl_name xdebug
%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
-%global gh_commit a5b668e29143716b73b6b649a6ab95489286d8f4
+%global gh_commit e3158f5b7bd84b4e9a18eb170d512416557de803
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
-%global gh_date 20201011
+#global gh_date 20201011
%global with_tests 0%{!?_without_tests:1}
%global upstream_version 3.0.0
-#global upstream_prever beta2
-%global upstream_lower DEV
+%global upstream_prever beta1
+%global upstream_lower beta1
# XDebug should be loaded after opcache
%global ini_name 15-%{pecl_name}.ini
@@ -73,7 +73,7 @@ Provides: %{?scl_prefix}php-pecl-%{pecl_name} = %{version}-%{relea
Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}-%{release}
%else
# A single version can be installed
-Conflicts: %{?scl_prefix}php-pecl-%{pecl_name} < 5
+Conflicts: %{?scl_prefix}php-pecl-%{pecl_name} < 3
%endif
%if "%{?packager}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
@@ -305,8 +305,12 @@ fi
%changelog
+* Thu Oct 15 2020 Remi Collet <remi@remirepo.net> - 3.0.0~beta1-1
+- update to 3.0.0beta1
+
* Tue Oct 13 2020 Remi Collet <remi@remirepo.net> - 3.0.0~DEV-1.20201011
- update to 3.0.0-dev
+- rename to php-pecl-xdebug3 for new API
- debugclient dropped upstream
- raise dependency on PHP 7.2